Genghis

Genghis Class Library

Genghis Namespace

Namespace hierarchy

Classes

Class | Description
CommandLineParser |
CommandLineParser.CurrentDir |
CommandLineParser.FlagUsageAttribute |
CommandLineParser.MemberInfoUsage |
CommandLineParser.NoUsageAttribute |
CommandLineParser.ParserUsageAttribute |
CommandLineParser.UsageAttribute |
CommandLineParser.UsageException |
CommandLineParser.ValueUsageAttribute |
PathList | A strongly-typed collection of unique case-insensitive System.String as paths. Originally generated by Chris Sells CollectionGen, modified for internal use, and for case insensitivity
PathResolver | Class responsible for resolving single paths, or a list of paths via a PathList
PathResolverEventArgs | Class that contains data relevant to the PathResolvedEventHandler delegate
Preferences | Provides a way to persist user preferences.
ResolvedPathList | A hashtable of a given path, and its resolved path, or string.Empty if it couldn't be resolved Originally generated by Chris Sells CollectionGen, then modified for internal scope
ResolvedPathListEnumerator |

Interfaces

Interface | Description
IPathResolver | The interface that a class must support to be a PathResolver
IPublicDictionary |
IResolvedPathList | Describes the public interface for a read-only PathList collection
PathList.IPathListEnumerator | Supports type-safe iteration over a PathList.

Delegates

Delegate | Description
PathResolvedEventHandler | The delegate corresponding to the OnPathResolved event

Enumerations

Enumeration | Description
CommandLineParser.ImageSubsystem |
PathResolveTypeEnum | An enumeration specifying what type of path to generate from the given path

Copyright (C) 2002 The Genghis Group


CommandLineParser Class

For a list of all members of this type, see CommandLineParser Members.

System.Object
CommandLineParser

[Visual Basic]
Public Class CommandLineParser
[C#]
public class CommandLineParser

Requirements

Namespace: Genghis Namespace

Assembly: Genghis.dll

See Also

CommandLineParser Members | Genghis Namespace


CommandLineParser Members

Public Static (Shared) Methods

GetImageSubsystem
GetModuleName
IsConsole

Public Instance Constructors

CommandLineParser Constructor

Public Instance Fields

help
version

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetUsage | Overloaded.
Parse |
ParseAndContinue |
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Fields

members

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLogo |
GetMembers |
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

CommandLineParser Class | Genghis Namespace


CommandLineParser Constructor

[Visual Basic]
Public Sub New()
[C#]
public CommandLineParser();

See Also

CommandLineParser Class | CommandLineParser Members | Genghis Namespace


CommandLineParser Fields

The fields of the CommandLineParser class are listed below. For a complete list of CommandLineParser class members, see the CommandLineParser Members topic.

Public Instance Fields

help
version

Protected Instance Fields

members

See Also

CommandLineParser Class | Genghis Namespace


CommandLineParser.help Field

[Visual Basic]
Public help As Boolean
[C#]
public bool help;

See Also

CommandLineParser Class | CommandLineParser Members | Genghis Namespace


CommandLineParser.members Field

[Visual Basic]
Protected members As Genghis.CommandLineParser.MemberInfoUsage()
[C#]
protected MemberInfoUsage[] members;

See Also

CommandLineParser Class | CommandLineParser Members | Genghis Namespace


CommandLineParser.version Field

[Visual Basic]
Public version As Boolean
[C#]
public bool version;

See Also

CommandLineParser Class | CommandLineParser Members | Genghis Namespace


CommandLineParser Methods

The methods of the CommandLineParser class are listed below. For a complete list of CommandLineParser class members, see the CommandLineParser Members topic.

Public Static (Shared) Methods

GetImageSubsystem
GetModuleName
IsConsole

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetUsage | Overloaded.
Parse |
ParseAndContinue |
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLogo |
GetMembers |
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

CommandLineParser Class | Genghis Namespace


CommandLineParser.GetImageSubsystem Method

[Visual Basic]
Public Shared Function GetImageSubsystem( _
   ByVal filename As String _
) As Genghis.CommandLineParser.ImageSubsystem
[C#]
public static ImageSubsystem GetImageSubsystem(
   string filename
);

See Also

CommandLineParser Class | CommandLineParser Members | Genghis Namespace


CommandLineParser.GetLogo Method

[Visual Basic]
Overridable Protected Function GetLogo() As String
[C#]
protected virtual string GetLogo();

See Also

CommandLineParser Class | CommandLineParser Members | Genghis Namespace


CommandLineParser.GetMembers Method

[Visual Basic]
Protected Function GetMembers() As Genghis.CommandLineParser.MemberInfoUsage()
[C#]
protected MemberInfoUsage[] GetMembers();

See Also

CommandLineParser Class | CommandLineParser Members | Genghis Namespace


CommandLineParser.GetModuleName Method

[Visual Basic]
Public Shared Function GetModuleName() As String
[C#]
public static string GetModuleName();

See Also

CommandLineParser Class | CommandLineParser Members | Genghis Namespace


GetUsage Method

Genghis Class Library

CommandLineParser.GetUsage

Overload List

public string GetUsage();

public string GetUsage(string);

See Also

CommandLineParser Class | CommandLineParser Members | Genghis Namespace


CommandLineParser.GetUsage Method ()

[Visual Basic]
Overloads Public Function GetUsage() As String
[C#]
public string GetUsage();

See Also

CommandLineParser Class | CommandLineParser Members | Genghis Namespace | CommandLineParser.GetUsage Overload List


CommandLineParser.GetUsage Method (String)

[Visual Basic]
Overloads Public Function GetUsage( _
   ByVal err As String _
) As String
[C#]
public string GetUsage(
   string err
);

See Also

CommandLineParser Class | CommandLineParser Members | Genghis Namespace | CommandLineParser.GetUsage Overload List


CommandLineParser.IsConsole Method

[Visual Basic]
Public Shared Function IsConsole() As Boolean
[C#]
public static bool IsConsole();

See Also

CommandLineParser Class | CommandLineParser Members | Genghis Namespace


CommandLineParser.Parse Method

[Visual Basic]
Overloads Public Sub Parse( _
   ByVal commandLine As String _
)
[C#]
public void Parse(
   string commandLine
);

See Also

CommandLineParser Class | CommandLineParser Members | Genghis Namespace


CommandLineParser.ParseAndContinue Method

[Visual Basic]
Public Function ParseAndContinue( _
   ByVal args As String() _
) As Boolean
[C#]
public bool ParseAndContinue(
   string[] args
);

See Also

CommandLineParser Class | CommandLineParser Members | Genghis Namespace


CommandLineParser.CurrentDir Class

For a list of all members of this type, see CommandLineParser.CurrentDir Members.

System.Object
CommandLineParser.CurrentDir

[Visual Basic]
Protected Class CommandLineParser.CurrentDir
   Implements IDisposable
[C#]
protected class CommandLineParser.CurrentDir : IDisposable

Requirements

Namespace: Genghis Namespace

Assembly: Genghis.dll

See Also

CommandLineParser.CurrentDir Members | Genghis Namespace


CommandLineParser.CurrentDir Members

Public Instance Constructors

CommandLineParser.CurrentDir Constructor

Public Instance Methods

Dispose |
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

CommandLineParser.CurrentDir Class | Genghis Namespace


CommandLineParser.CurrentDir Constructor

[Visual Basic]
Public Sub New( _
   ByVal newDir As String _
)
[C#]
public CommandLineParser.CurrentDir(
   string newDir
);

See Also

CommandLineParser.CurrentDir Class | CommandLineParser.CurrentDir Members | Genghis Namespace


CommandLineParser.CurrentDir Methods

The methods of the CommandLineParser.CurrentDir class are listed below. For a complete list of CommandLineParser.CurrentDir class members, see the CommandLineParser.CurrentDir Members topic.

Public Instance Methods

Dispose |
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

CommandLineParser.CurrentDir Class | Genghis Namespace


CommandLineParser.CurrentDir.Dispose Method

[Visual Basic]
NotOverridable Public Sub Dispose()
[C#]
public final void Dispose();

See Also

CommandLineParser.CurrentDir Class | CommandLineParser.CurrentDir Members | Genghis Namespace


CommandLineParser.FlagUsageAttribute Class

For a list of all members of this type, see CommandLineParser.FlagUsageAttribute Members.

System.Object
Attribute
UsageAttribute
CommandLineParser.FlagUsageAttribute

[Visual Basic]
Public Class CommandLineParser.FlagUsageAttribute
   Inherits UsageAttribute
[C#]
public class CommandLineParser.FlagUsageAttribute : UsageAttribute

Requirements

Namespace: Genghis Namespace

Assembly: Genghis.dll

See Also

CommandLineParser.FlagUsageAttribute Members | Genghis Namespace


CommandLineParser.FlagUsageAttribute Members

Public Instance Constructors

CommandLineParser.FlagUsageAttribute Constructor

Public Instance Fields

AlternateName1
AlternateName2
Description
IgnoreCase
MatchPosition
Name
Optional
ValueName

Public Instance Properties

TypeId (inherited from System.Attribute) Select the method name to go to the Microsoft documentation.

Public Instance Methods

Equals (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsDefaultAttribute (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
Match (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
Matches | See the third party documentation for more information.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Fields

found

Protected Instance Properties

Flag See the third party documentation for more information.

Protected Instance Methods

ConsumeValueHelper | See the third party documentation for more information.
Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLongUsageHelper | See the third party documentation for more information.
GetShortUsageHelper | See the third party documentation for more information.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
ReadFromString | See the third party documentation for more information.

Protected Internal Instance Properties

ExpectsValue |
IsFound | See the third party documentation for more information.

Protected Internal Instance Methods

ConsumeValue
GetLongUsage
GetShortUsage

See Also

CommandLineParser.FlagUsageAttribute Class | Genghis Namespace


CommandLineParser.FlagUsageAttribute Constructor

[Visual Basic]
Public Sub New( _
   ByVal description As String _
)
[C#]
public CommandLineParser.FlagUsageAttribute(
   string description
);

See Also

CommandLineParser.FlagUsageAttribute Class | CommandLineParser.FlagUsageAttribute Members | Genghis Namespace


CommandLineParser.FlagUsageAttribute Fields

The fields of the CommandLineParser.FlagUsageAttribute class are listed below. For a complete list of CommandLineParser.FlagUsageAttribute class members, see the CommandLineParser.FlagUsageAttribute Members topic.

Public Instance Fields

AlternateName1
AlternateName2
Description
IgnoreCase
MatchPosition
Name
Optional
ValueName

Protected Instance Fields

found

See Also

CommandLineParser.FlagUsageAttribute Class | Genghis Namespace


CommandLineParser.FlagUsageAttribute.AlternateName1 Field

[Visual Basic]
Public AlternateName1 As String
[C#]
public string AlternateName1;

See Also

CommandLineParser.FlagUsageAttribute Class | CommandLineParser.FlagUsageAttribute Members | Genghis Namespace


CommandLineParser.FlagUsageAttribute.AlternateName2 Field

[Visual Basic]
Public AlternateName2 As String
[C#]
public string AlternateName2;

See Also

CommandLineParser.FlagUsageAttribute Class | CommandLineParser.FlagUsageAttribute Members | Genghis Namespace


CommandLineParser.FlagUsageAttribute.Description Field

[Visual Basic]
Public Description As String
[C#]
public string Description;

See Also

CommandLineParser.FlagUsageAttribute Class | CommandLineParser.FlagUsageAttribute Members | Genghis Namespace


CommandLineParser.FlagUsageAttribute.found Field

[Visual Basic]
Protected found As Boolean
[C#]
protected bool found;

See Also

CommandLineParser.FlagUsageAttribute Class | CommandLineParser.FlagUsageAttribute Members | Genghis Namespace


CommandLineParser.FlagUsageAttribute.IgnoreCase Field

[Visual Basic]
Public IgnoreCase As Boolean
[C#]
public bool IgnoreCase;

See Also

CommandLineParser.FlagUsageAttribute Class | CommandLineParser.FlagUsageAttribute Members | Genghis Namespace


CommandLineParser.FlagUsageAttribute.MatchPosition Field

[Visual Basic]
Public MatchPosition As Boolean
[C#]
public bool MatchPosition;

See Also

CommandLineParser.FlagUsageAttribute Class | CommandLineParser.FlagUsageAttribute Members | Genghis Namespace


CommandLineParser.FlagUsageAttribute.Name Field

[Visual Basic]
Public Name As String
[C#]
public string Name;

See Also

CommandLineParser.FlagUsageAttribute Class | CommandLineParser.FlagUsageAttribute Members | Genghis Namespace


CommandLineParser.FlagUsageAttribute.Optional Field

[Visual Basic]
Public Optional As Boolean
[C#]
public bool Optional;

See Also

CommandLineParser.FlagUsageAttribute Class | CommandLineParser.FlagUsageAttribute Members | Genghis Namespace


CommandLineParser.FlagUsageAttribute.ValueName Field

[Visual Basic]
Public ValueName As String
[C#]
public string ValueName;

See Also

CommandLineParser.FlagUsageAttribute Class | CommandLineParser.FlagUsageAttribute Members | Genghis Namespace


CommandLineParser.FlagUsageAttribute Properties

The properties of the CommandLineParser.FlagUsageAttribute class are listed below. For a complete list of CommandLineParser.FlagUsageAttribute class members, see the CommandLineParser.FlagUsageAttribute Members topic.

Public Instance Properties

TypeId (inherited from System.Attribute) Select the method name to go to the Microsoft documentation.

Protected Instance Properties

Flag See the third party documentation for more information.

Protected Internal Instance Properties

ExpectsValue |
IsFound | See the third party documentation for more information.

See Also

CommandLineParser.FlagUsageAttribute Class | Genghis Namespace


CommandLineParser.FlagUsageAttribute.ExpectsValue Property

[Visual Basic]
Overrides Protected Friend ReadOnly Property ExpectsValue As Boolean
[C#]
protected internal bool ExpectsValue {override get;}

See Also

CommandLineParser.FlagUsageAttribute Class | CommandLineParser.FlagUsageAttribute Members | Genghis Namespace


CommandLineParser.FlagUsageAttribute Methods

The methods of the CommandLineParser.FlagUsageAttribute class are listed below. For a complete list of CommandLineParser.FlagUsageAttribute class members, see the CommandLineParser.FlagUsageAttribute Members topic.

Public Instance Methods

Equals (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsDefaultAttribute (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
Match (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
Matches | See the third party documentation for more information.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

ConsumeValueHelper | See the third party documentation for more information.
Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLongUsageHelper | See the third party documentation for more information.
GetShortUsageHelper | See the third party documentation for more information.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
ReadFromString | See the third party documentation for more information.

Protected Internal Instance Methods

ConsumeValue
GetLongUsage
GetShortUsage

See Also

CommandLineParser.FlagUsageAttribute Class | Genghis Namespace


CommandLineParser.FlagUsageAttribute.ConsumeValue Method

[Visual Basic]
Overrides Protected Friend Sub ConsumeValue( _
   ByVal s As String, _
   ByVal container As Object, _
   ByVal info As System.Reflection.MemberInfo _
)
[C#]
protected internal override void ConsumeValue(
   string s,
   object container,
   MemberInfo info
);

See Also

CommandLineParser.FlagUsageAttribute Class | CommandLineParser.FlagUsageAttribute Members | Genghis Namespace


CommandLineParser.FlagUsageAttribute.GetLongUsage Method

[Visual Basic]
Overrides Protected Friend Function GetLongUsage( _
   ByVal prefix As String, _
   ByVal defaultName As String _
) As String
[C#]
protected internal override string GetLongUsage(
   string prefix,
   string defaultName
);

See Also

CommandLineParser.FlagUsageAttribute Class | CommandLineParser.FlagUsageAttribute Members | Genghis Namespace


CommandLineParser.FlagUsageAttribute.GetShortUsage Method

[Visual Basic]
Overrides Protected Friend Function GetShortUsage( _
   ByVal prefix As String, _
   ByVal defaultName As String _
) As String
[C#]
protected internal override string GetShortUsage(
   string prefix,
   string defaultName
);

See Also

CommandLineParser.FlagUsageAttribute Class | CommandLineParser.FlagUsageAttribute Members | Genghis Namespace


CommandLineParser.ImageSubsystem Enumeration

[Visual Basic]
Public Enum CommandLineParser.ImageSubsystem
[C#]
public enum CommandLineParser.ImageSubsystem

Members

Member Name | Description
Native |
GUI |
CUI |

Requirements

Namespace: Genghis Namespace

Assembly: Genghis.dll

See Also

Genghis Namespace


CommandLineParser.MemberInfoUsage Class

For a list of all members of this type, see CommandLineParser.MemberInfoUsage Members.

System.Object
CommandLineParser.MemberInfoUsage

[Visual Basic]
Protected Class CommandLineParser.MemberInfoUsage
[C#]
protected class CommandLineParser.MemberInfoUsage

Requirements

Namespace: Genghis Namespace

Assembly: Genghis.dll

See Also

CommandLineParser.MemberInfoUsage Members | Genghis Namespace


CommandLineParser.MemberInfoUsage Members

Public Instance Constructors

CommandLineParser.MemberInfoUsage Constructor

Public Instance Fields

info
usage

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

CommandLineParser.MemberInfoUsage Class | Genghis Namespace


CommandLineParser.MemberInfoUsage Constructor

[Visual Basic]
Public Sub New( _
   ByVal info As System.Reflection.MemberInfo, _
   ByVal usage As Genghis.CommandLineParser.UsageAttribute _
)
[C#]
public CommandLineParser.MemberInfoUsage(
   MemberInfo info,
   UsageAttribute usage
);

See Also

CommandLineParser.MemberInfoUsage Class | CommandLineParser.MemberInfoUsage Members | Genghis Namespace


CommandLineParser.MemberInfoUsage Fields

The fields of the CommandLineParser.MemberInfoUsage class are listed below. For a complete list of CommandLineParser.MemberInfoUsage class members, see the CommandLineParser.MemberInfoUsage Members topic.

Public Instance Fields

info
usage

See Also

CommandLineParser.MemberInfoUsage Class | Genghis Namespace


CommandLineParser.MemberInfoUsage.info Field

[Visual Basic]
Public info As System.Reflection.MemberInfo
[C#]
public MemberInfo info;

See Also

CommandLineParser.MemberInfoUsage Class | CommandLineParser.MemberInfoUsage Members | Genghis Namespace


CommandLineParser.MemberInfoUsage.usage Field

[Visual Basic]
Public usage As Genghis.CommandLineParser.UsageAttribute
[C#]
public UsageAttribute usage;

See Also

CommandLineParser.MemberInfoUsage Class | CommandLineParser.MemberInfoUsage Members | Genghis Namespace


CommandLineParser.NoUsageAttribute Class

For a list of all members of this type, see CommandLineParser.NoUsageAttribute Members.

System.Object
Attribute
UsageAttribute
CommandLineParser.NoUsageAttribute

[Visual Basic]
Public Class CommandLineParser.NoUsageAttribute
   Inherits UsageAttribute
[C#]
public class CommandLineParser.NoUsageAttribute : UsageAttribute

Requirements

Namespace: Genghis Namespace

Assembly: Genghis.dll

See Also

CommandLineParser.NoUsageAttribute Members | Genghis Namespace


CommandLineParser.NoUsageAttribute Members

Public Instance Constructors

CommandLineParser.NoUsageAttribute Constructor

Public Instance Fields

AlternateName1
AlternateName2
Description
IgnoreCase
MatchPosition
Name
Optional
ValueName

Public Instance Properties

TypeId (inherited from System.Attribute) Select the method name to go to the Microsoft documentation.

Public Instance Methods

Equals (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsDefaultAttribute (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
Match (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
Matches | See the third party documentation for more information.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Fields

found

Protected Instance Properties

Flag See the third party documentation for more information.

Protected Instance Methods

ConsumeValueHelper | See the third party documentation for more information.
Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLongUsageHelper | See the third party documentation for more information.
GetShortUsageHelper | See the third party documentation for more information.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
ReadFromString | See the third party documentation for more information.

Protected Internal Instance Properties

ExpectsValue |
IsFound | See the third party documentation for more information.

Protected Internal Instance Methods

ConsumeValue
GetLongUsage
GetShortUsage

See Also

CommandLineParser.NoUsageAttribute Class | Genghis Namespace


CommandLineParser.NoUsageAttribute Constructor

[Visual Basic]
Public Sub New()
[C#]
public CommandLineParser.NoUsageAttribute();

See Also

CommandLineParser.NoUsageAttribute Class | CommandLineParser.NoUsageAttribute Members | Genghis Namespace


CommandLineParser.NoUsageAttribute Fields

The fields of the CommandLineParser.NoUsageAttribute class are listed below. For a complete list of CommandLineParser.NoUsageAttribute class members, see the CommandLineParser.NoUsageAttribute Members topic.

Public Instance Fields

AlternateName1
AlternateName2
Description
IgnoreCase
MatchPosition
Name
Optional
ValueName

Protected Instance Fields

found

See Also

CommandLineParser.NoUsageAttribute Class | Genghis Namespace


CommandLineParser.NoUsageAttribute.AlternateName1 Field

[Visual Basic]
Public AlternateName1 As String
[C#]
public string AlternateName1;

See Also

CommandLineParser.NoUsageAttribute Class | CommandLineParser.NoUsageAttribute Members | Genghis Namespace


CommandLineParser.NoUsageAttribute.AlternateName2 Field

[Visual Basic]
Public AlternateName2 As String
[C#]
public string AlternateName2;

See Also

CommandLineParser.NoUsageAttribute Class | CommandLineParser.NoUsageAttribute Members | Genghis Namespace


CommandLineParser.NoUsageAttribute.Description Field

[Visual Basic]
Public Description As String
[C#]
public string Description;

See Also

CommandLineParser.NoUsageAttribute Class | CommandLineParser.NoUsageAttribute Members | Genghis Namespace


CommandLineParser.NoUsageAttribute.found Field

[Visual Basic]
Protected found As Boolean
[C#]
protected bool found;

See Also

CommandLineParser.NoUsageAttribute Class | CommandLineParser.NoUsageAttribute Members | Genghis Namespace


CommandLineParser.NoUsageAttribute.IgnoreCase Field

[Visual Basic]
Public IgnoreCase As Boolean
[C#]
public bool IgnoreCase;

See Also

CommandLineParser.NoUsageAttribute Class | CommandLineParser.NoUsageAttribute Members | Genghis Namespace


CommandLineParser.NoUsageAttribute.MatchPosition Field

[Visual Basic]
Public MatchPosition As Boolean
[C#]
public bool MatchPosition;

See Also

CommandLineParser.NoUsageAttribute Class | CommandLineParser.NoUsageAttribute Members | Genghis Namespace


CommandLineParser.NoUsageAttribute.Name Field

[Visual Basic]
Public Name As String
[C#]
public string Name;

See Also

CommandLineParser.NoUsageAttribute Class | CommandLineParser.NoUsageAttribute Members | Genghis Namespace


CommandLineParser.NoUsageAttribute.Optional Field

[Visual Basic]
Public Optional As Boolean
[C#]
public bool Optional;

See Also

CommandLineParser.NoUsageAttribute Class | CommandLineParser.NoUsageAttribute Members | Genghis Namespace


CommandLineParser.NoUsageAttribute.ValueName Field

[Visual Basic]
Public ValueName As String
[C#]
public string ValueName;

See Also

CommandLineParser.NoUsageAttribute Class | CommandLineParser.NoUsageAttribute Members | Genghis Namespace


CommandLineParser.NoUsageAttribute Properties

The properties of the CommandLineParser.NoUsageAttribute class are listed below. For a complete list of CommandLineParser.NoUsageAttribute class members, see the CommandLineParser.NoUsageAttribute Members topic.

Public Instance Properties

TypeId (inherited from System.Attribute) Select the method name to go to the Microsoft documentation.

Protected Instance Properties

Flag See the third party documentation for more information.

Protected Internal Instance Properties

ExpectsValue |
IsFound | See the third party documentation for more information.

See Also

CommandLineParser.NoUsageAttribute Class | Genghis Namespace


CommandLineParser.NoUsageAttribute.ExpectsValue Property

[Visual Basic]
Overrides Protected Friend ReadOnly Property ExpectsValue As Boolean
[C#]
protected internal bool ExpectsValue {override get;}

See Also

CommandLineParser.NoUsageAttribute Class | CommandLineParser.NoUsageAttribute Members | Genghis Namespace


CommandLineParser.NoUsageAttribute Methods

The methods of the CommandLineParser.NoUsageAttribute class are listed below. For a complete list of CommandLineParser.NoUsageAttribute class members, see the CommandLineParser.NoUsageAttribute Members topic.

Public Instance Methods

Equals (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsDefaultAttribute (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
Match (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
Matches | See the third party documentation for more information.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

ConsumeValueHelper | See the third party documentation for more information.
Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLongUsageHelper | See the third party documentation for more information.
GetShortUsageHelper | See the third party documentation for more information.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
ReadFromString | See the third party documentation for more information.

Protected Internal Instance Methods

ConsumeValue
GetLongUsage
GetShortUsage

See Also

CommandLineParser.NoUsageAttribute Class | Genghis Namespace


CommandLineParser.NoUsageAttribute.ConsumeValue Method

[Visual Basic]
Overrides Protected Friend Sub ConsumeValue( _
   ByVal s As String, _
   ByVal container As Object, _
   ByVal info As System.Reflection.MemberInfo _
)
[C#]
protected internal override void ConsumeValue(
   string s,
   object container,
   MemberInfo info
);

See Also

CommandLineParser.NoUsageAttribute Class | CommandLineParser.NoUsageAttribute Members | Genghis Namespace


CommandLineParser.NoUsageAttribute.GetLongUsage Method

[Visual Basic]
Overrides Protected Friend Function GetLongUsage( _
   ByVal prefix As String, _
   ByVal defaultName As String _
) As String
[C#]
protected internal override string GetLongUsage(
   string prefix,
   string defaultName
);

See Also

CommandLineParser.NoUsageAttribute Class | CommandLineParser.NoUsageAttribute Members | Genghis Namespace


CommandLineParser.NoUsageAttribute.GetShortUsage Method

[Visual Basic]
Overrides Protected Friend Function GetShortUsage( _
   ByVal prefix As String, _
   ByVal defaultName As String _
) As String
[C#]
protected internal override string GetShortUsage(
   string prefix,
   string defaultName
);

See Also

CommandLineParser.NoUsageAttribute Class | CommandLineParser.NoUsageAttribute Members | Genghis Namespace


CommandLineParser.ParserUsageAttribute Class

For a list of all members of this type, see CommandLineParser.ParserUsageAttribute Members.

System.Object
Attribute
CommandLineParser.ParserUsageAttribute

[Visual Basic]
Public Class CommandLineParser.ParserUsageAttribute
   Inherits Attribute
[C#]
public class CommandLineParser.ParserUsageAttribute : Attribute

Requirements

Namespace: Genghis Namespace

Assembly: Genghis.dll

See Also

CommandLineParser.ParserUsageAttribute Members | Genghis Namespace


CommandLineParser.ParserUsageAttribute Members

Public Instance Constructors

CommandLineParser.ParserUsageAttribute Constructor

Public Instance Fields

AllowArgumentFile
Description
PreferredPrefix

Public Instance Properties

TypeId (inherited from System.Attribute) Select the method name to go to the Microsoft documentation.

Public Instance Methods

Equals (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsDefaultAttribute (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
Match (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

CommandLineParser.ParserUsageAttribute Class | Genghis Namespace


CommandLineParser.ParserUsageAttribute Constructor

[Visual Basic]
Public Sub New( _
   ByVal description As String _
)
[C#]
public CommandLineParser.ParserUsageAttribute(
   string description
);

See Also

CommandLineParser.ParserUsageAttribute Class | CommandLineParser.ParserUsageAttribute Members | Genghis Namespace


CommandLineParser.ParserUsageAttribute Fields

The fields of the CommandLineParser.ParserUsageAttribute class are listed below. For a complete list of CommandLineParser.ParserUsageAttribute class members, see the CommandLineParser.ParserUsageAttribute Members topic.

Public Instance Fields

AllowArgumentFile
Description
PreferredPrefix

See Also

CommandLineParser.ParserUsageAttribute Class | Genghis Namespace


CommandLineParser.ParserUsageAttribute.AllowArgumentFile Field

[Visual Basic]
Public AllowArgumentFile As Boolean
[C#]
public bool AllowArgumentFile;

See Also

CommandLineParser.ParserUsageAttribute Class | CommandLineParser.ParserUsageAttribute Members | Genghis Namespace


CommandLineParser.ParserUsageAttribute.Description Field

[Visual Basic]
Public Description As String
[C#]
public string Description;

See Also

CommandLineParser.ParserUsageAttribute Class | CommandLineParser.ParserUsageAttribute Members | Genghis Namespace


CommandLineParser.ParserUsageAttribute.PreferredPrefix Field

[Visual Basic]
Public PreferredPrefix As String
[C#]
public string PreferredPrefix;

See Also

CommandLineParser.ParserUsageAttribute Class | CommandLineParser.ParserUsageAttribute Members | Genghis Namespace


CommandLineParser.UsageAttribute Class

For a list of all members of this type, see CommandLineParser.UsageAttribute Members.

System.Object
Attribute
CommandLineParser.UsageAttribute

[Visual Basic]
MustInherit Public Class CommandLineParser.UsageAttribute
   Inherits Attribute
[C#]
public abstract class CommandLineParser.UsageAttribute : Attribute

Requirements

Namespace: Genghis Namespace

Assembly: Genghis.dll

See Also

CommandLineParser.UsageAttribute Members | Genghis Namespace


CommandLineParser.UsageAttribute Members

Public Instance Constructors

CommandLineParser.UsageAttribute Constructor

Public Instance Fields

AlternateName1
AlternateName2
Description
IgnoreCase
MatchPosition
Name
Optional
ValueName

Public Instance Properties

TypeId (inherited from System.Attribute) Select the method name to go to the Microsoft documentation.

Public Instance Methods

Equals (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsDefaultAttribute (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
Match (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
Matches |
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Fields

found

Protected Instance Properties

Flag

Protected Instance Methods

ConsumeValueHelper |
Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLongUsageHelper |
GetShortUsageHelper |
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
ReadFromString |

Protected Internal Instance Properties

ExpectsValue
IsFound

Protected Internal Instance Methods

ConsumeValue
GetLongUsage
GetShortUsage

See Also

CommandLineParser.UsageAttribute Class | Genghis Namespace


CommandLineParser.UsageAttribute Constructor

[Visual Basic]
Public Sub New( _
   ByVal description As String _
)
[C#]
public CommandLineParser.UsageAttribute(
   string description
);

See Also

CommandLineParser.UsageAttribute Class | CommandLineParser.UsageAttribute Members | Genghis Namespace


CommandLineParser.UsageAttribute Fields

The fields of the CommandLineParser.UsageAttribute class are listed below. For a complete list of CommandLineParser.UsageAttribute class members, see the CommandLineParser.UsageAttribute Members topic.

Public Instance Fields

AlternateName1
AlternateName2
Description
IgnoreCase
MatchPosition
Name
Optional
ValueName

Protected Instance Fields

found

See Also

CommandLineParser.UsageAttribute Class | Genghis Namespace


CommandLineParser.UsageAttribute.AlternateName1 Field

[Visual Basic]
Public AlternateName1 As String
[C#]
public string AlternateName1;

See Also

CommandLineParser.UsageAttribute Class | CommandLineParser.UsageAttribute Members | Genghis Namespace


CommandLineParser.UsageAttribute.AlternateName2 Field

[Visual Basic]
Public AlternateName2 As String
[C#]
public string AlternateName2;

See Also

CommandLineParser.UsageAttribute Class | CommandLineParser.UsageAttribute Members | Genghis Namespace


CommandLineParser.UsageAttribute.Description Field

[Visual Basic]
Public Description As String
[C#]
public string Description;

See Also

CommandLineParser.UsageAttribute Class | CommandLineParser.UsageAttribute Members | Genghis Namespace


CommandLineParser.UsageAttribute.found Field

[Visual Basic]
Protected found As Boolean
[C#]
protected bool found;

See Also

CommandLineParser.UsageAttribute Class | CommandLineParser.UsageAttribute Members | Genghis Namespace


CommandLineParser.UsageAttribute.IgnoreCase Field

[Visual Basic]
Public IgnoreCase As Boolean
[C#]
public bool IgnoreCase;

See Also

CommandLineParser.UsageAttribute Class | CommandLineParser.UsageAttribute Members | Genghis Namespace


CommandLineParser.UsageAttribute.MatchPosition Field

[Visual Basic]
Public MatchPosition As Boolean
[C#]
public bool MatchPosition;

See Also

CommandLineParser.UsageAttribute Class | CommandLineParser.UsageAttribute Members | Genghis Namespace


CommandLineParser.UsageAttribute.Name Field

[Visual Basic]
Public Name As String
[C#]
public string Name;

See Also

CommandLineParser.UsageAttribute Class | CommandLineParser.UsageAttribute Members | Genghis Namespace


CommandLineParser.UsageAttribute.Optional Field

[Visual Basic]
Public Optional As Boolean
[C#]
public bool Optional;

See Also

CommandLineParser.UsageAttribute Class | CommandLineParser.UsageAttribute Members | Genghis Namespace


CommandLineParser.UsageAttribute.ValueName Field

[Visual Basic]
Public ValueName As String
[C#]
public string ValueName;

See Also

CommandLineParser.UsageAttribute Class | CommandLineParser.UsageAttribute Members | Genghis Namespace


CommandLineParser.UsageAttribute Properties

The properties of the CommandLineParser.UsageAttribute class are listed below. For a complete list of CommandLineParser.UsageAttribute class members, see the CommandLineParser.UsageAttribute Members topic.

Public Instance Properties

TypeId (inherited from System.Attribute) Select the method name to go to the Microsoft documentation.

Protected Instance Properties

Flag

Protected Internal Instance Properties

ExpectsValue
IsFound

See Also

CommandLineParser.UsageAttribute Class | Genghis Namespace


CommandLineParser.UsageAttribute.ExpectsValue Property

[Visual Basic]
MustOverride Protected Friend ReadOnly Property ExpectsValue As Boolean
[C#]
protected internal bool ExpectsValue {abstract get;}

See Also

CommandLineParser.UsageAttribute Class | CommandLineParser.UsageAttribute Members | Genghis Namespace


CommandLineParser.UsageAttribute.Flag Property

[Visual Basic]
Protected ReadOnly Property Flag As Boolean
[C#]
protected bool Flag {get;}

See Also

CommandLineParser.UsageAttribute Class | CommandLineParser.UsageAttribute Members | Genghis Namespace


CommandLineParser.UsageAttribute.IsFound Property

[Visual Basic]
Overridable Protected Friend ReadOnly Property IsFound As Boolean
[C#]
protected internal bool IsFound {virtual get;}

See Also

CommandLineParser.UsageAttribute Class | CommandLineParser.UsageAttribute Members | Genghis Namespace


CommandLineParser.UsageAttribute Methods

The methods of the CommandLineParser.UsageAttribute class are listed below. For a complete list of CommandLineParser.UsageAttribute class members, see the CommandLineParser.UsageAttribute Members topic.

Public Instance Methods

Equals (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsDefaultAttribute (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
Match (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
Matches |
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

ConsumeValueHelper |
Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLongUsageHelper |
GetShortUsageHelper |
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
ReadFromString |

Protected Internal Instance Methods

ConsumeValue
GetLongUsage
GetShortUsage

See Also

CommandLineParser.UsageAttribute Class | Genghis Namespace


CommandLineParser.UsageAttribute.ConsumeValue Method

[Visual Basic]
MustOverride Protected Friend Sub ConsumeValue( _
   ByVal s As String, _
   ByVal container As Object, _
   ByVal info As System.Reflection.MemberInfo _
)
[C#]
protected internal abstract void ConsumeValue(
   string s,
   object container,
   MemberInfo info
);

See Also

CommandLineParser.UsageAttribute Class | CommandLineParser.UsageAttribute Members | Genghis Namespace


CommandLineParser.UsageAttribute.ConsumeValueHelper Method

[Visual Basic]
Protected Sub ConsumeValueHelper( _
   ByVal s As String, _
   ByVal container As Object, _
   ByVal info As System.Reflection.MemberInfo _
)
[C#]
protected void ConsumeValueHelper(
   string s,
   object container,
   MemberInfo info
);

See Also

CommandLineParser.UsageAttribute Class | CommandLineParser.UsageAttribute Members | Genghis Namespace


CommandLineParser.UsageAttribute.GetLongUsage Method

[Visual Basic]
MustOverride Protected Friend Function GetLongUsage( _
   ByVal prefix As String, _
   ByVal defaultName As String _
) As String
[C#]
protected internal abstract string GetLongUsage(
   string prefix,
   string defaultName
);

See Also

CommandLineParser.UsageAttribute Class | CommandLineParser.UsageAttribute Members | Genghis Namespace


CommandLineParser.UsageAttribute.GetLongUsageHelper Method

[Visual Basic]
Protected Function GetLongUsageHelper( _
   ByVal prefix As String, _
   ByVal defaultName As String, _
   ByVal valueName As String _
) As String
[C#]
protected string GetLongUsageHelper(
   string prefix,
   string defaultName,
   string valueName
);

See Also

CommandLineParser.UsageAttribute Class | CommandLineParser.UsageAttribute Members | Genghis Namespace


CommandLineParser.UsageAttribute.GetShortUsage Method

[Visual Basic]
MustOverride Protected Friend Function GetShortUsage( _
   ByVal prefix As String, _
   ByVal defaultName As String _
) As String
[C#]
protected internal abstract string GetShortUsage(
   string prefix,
   string defaultName
);

See Also

CommandLineParser.UsageAttribute Class | CommandLineParser.UsageAttribute Members | Genghis Namespace


CommandLineParser.UsageAttribute.GetShortUsageHelper Method

[Visual Basic]
Protected Function GetShortUsageHelper( _
   ByVal prefix As String, _
   ByVal defaultName As String, _
   ByVal valueName As String _
) As String
[C#]
protected string GetShortUsageHelper(
   string prefix,
   string defaultName,
   string valueName
);

See Also

CommandLineParser.UsageAttribute Class | CommandLineParser.UsageAttribute Members | Genghis Namespace


CommandLineParser.UsageAttribute.Matches Method

[Visual Basic]
Public Function Matches( _
   ByVal name As String, _
   ByVal defaultName As String _
) As Boolean
[C#]
public bool Matches(
   string name,
   string defaultName
);

See Also

CommandLineParser.UsageAttribute Class | CommandLineParser.UsageAttribute Members | Genghis Namespace


CommandLineParser.UsageAttribute.ReadFromString Method

[Visual Basic]
Protected Function ReadFromString( _
   ByVal s As String, _
   ByVal type As System.Type _
) As Object
[C#]
protected object ReadFromString(
   string s,
   Type type
);

See Also

CommandLineParser.UsageAttribute Class | CommandLineParser.UsageAttribute Members | Genghis Namespace


CommandLineParser.UsageException Class

For a list of all members of this type, see CommandLineParser.UsageException Members.

System.Object
Exception
ApplicationException
CommandLineParser.UsageException

[Visual Basic]
Public Class CommandLineParser.UsageException
   Inherits ApplicationException
   Implements ISerializable
[C#]
public class CommandLineParser.UsageException : ApplicationException, ISerializable

Requirements

Namespace: Genghis Namespace

Assembly: Genghis.dll

See Also

CommandLineParser.UsageException Members | Genghis Namespace


CommandLineParser.UsageException Members

Public Instance Constructors

CommandLineParser.UsageException Constructor

Public Instance Properties

Argument |
HelpLink (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
InnerException (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
Message |
Source (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
StackTrace (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
TargetSite (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetBaseException (inherited from Exception) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetObjectData (inherited from Exception) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Exception) | Select the method name to go to the Microsoft documentation.

Protected Instance Fields

arg

Protected Instance Properties

HResult (inherited from System.Exception) Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

CommandLineParser.UsageException Class | Genghis Namespace


CommandLineParser.UsageException Constructor

[Visual Basic]
Public Sub New( _
   ByVal arg As String, _
   ByVal error As String _
)
[C#]
public CommandLineParser.UsageException(
   string arg,
   string error
);

See Also

CommandLineParser.UsageException Class | CommandLineParser.UsageException Members | Genghis Namespace


CommandLineParser.UsageException Fields

The fields of the CommandLineParser.UsageException class are listed below. For a complete list of CommandLineParser.UsageException class members, see the CommandLineParser.UsageException Members topic.

Protected Instance Fields

arg

See Also

CommandLineParser.UsageException Class | Genghis Namespace


CommandLineParser.UsageException.arg Field

[Visual Basic]
Protected arg As String
[C#]
protected string arg;

See Also

CommandLineParser.UsageException Class | CommandLineParser.UsageException Members | Genghis Namespace


CommandLineParser.UsageException Properties

The properties of the CommandLineParser.UsageException class are listed below. For a complete list of CommandLineParser.UsageException class members, see the CommandLineParser.UsageException Members topic.

Public Instance Properties

Argument |
HelpLink (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
InnerException (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
Message |
Source (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
StackTrace (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
TargetSite (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

HResult (inherited from System.Exception) Select the method name to go to the Microsoft documentation.

See Also

CommandLineParser.UsageException Class | Genghis Namespace


CommandLineParser.UsageException.Argument Property

[Visual Basic]
Public ReadOnly Property Argument As String
[C#]
public string Argument {get;}

See Also

CommandLineParser.UsageException Class | CommandLineParser.UsageException Members | Genghis Namespace


CommandLineParser.UsageException.Message Property

[Visual Basic]
Overrides Public ReadOnly Property Message As String
[C#]
public string Message {override get;}

See Also

CommandLineParser.UsageException Class | CommandLineParser.UsageException Members | Genghis Namespace


CommandLineParser.ValueUsageAttribute Class

For a list of all members of this type, see CommandLineParser.ValueUsageAttribute Members.

System.Object
Attribute
UsageAttribute
CommandLineParser.ValueUsageAttribute

[Visual Basic]
Public Class CommandLineParser.ValueUsageAttribute
   Inherits UsageAttribute
[C#]
public class CommandLineParser.ValueUsageAttribute : UsageAttribute

Requirements

Namespace: Genghis Namespace

Assembly: Genghis.dll

See Also

CommandLineParser.ValueUsageAttribute Members | Genghis Namespace


CommandLineParser.ValueUsageAttribute Members

Public Instance Constructors

CommandLineParser.ValueUsageAttribute Constructor

Public Instance Fields

AlternateName1
AlternateName2
Description
IgnoreCase
MatchPosition
Name
Optional
ValueName

Public Instance Properties

TypeId (inherited from System.Attribute) Select the method name to go to the Microsoft documentation.

Public Instance Methods

Equals (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsDefaultAttribute (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
Match (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
Matches | See the third party documentation for more information.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Fields

found

Protected Instance Properties

Flag See the third party documentation for more information.

Protected Instance Methods

ConsumeValueHelper | See the third party documentation for more information.
Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLongUsageHelper | See the third party documentation for more information.
GetShortUsageHelper | See the third party documentation for more information.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
ReadFromString | See the third party documentation for more information.

Protected Internal Instance Properties

ExpectsValue |
IsFound | See the third party documentation for more information.

Protected Internal Instance Methods

ConsumeValue
GetLongUsage
GetShortUsage

See Also

CommandLineParser.ValueUsageAttribute Class | Genghis Namespace


CommandLineParser.ValueUsageAttribute Constructor

[Visual Basic]
Public Sub New( _
   ByVal description As String _
)
[C#]
public CommandLineParser.ValueUsageAttribute(
   string description
);

See Also

CommandLineParser.ValueUsageAttribute Class | CommandLineParser.ValueUsageAttribute Members | Genghis Namespace


CommandLineParser.ValueUsageAttribute Fields

The fields of the CommandLineParser.ValueUsageAttribute class are listed below. For a complete list of CommandLineParser.ValueUsageAttribute class members, see the CommandLineParser.ValueUsageAttribute Members topic.

Public Instance Fields

AlternateName1
AlternateName2
Description
IgnoreCase
MatchPosition
Name
Optional
ValueName

Protected Instance Fields

found

See Also

CommandLineParser.ValueUsageAttribute Class | Genghis Namespace


CommandLineParser.ValueUsageAttribute.AlternateName1 Field

[Visual Basic]
Public AlternateName1 As String
[C#]
public string AlternateName1;

See Also

CommandLineParser.ValueUsageAttribute Class | CommandLineParser.ValueUsageAttribute Members | Genghis Namespace


CommandLineParser.ValueUsageAttribute.AlternateName2 Field

[Visual Basic]
Public AlternateName2 As String
[C#]
public string AlternateName2;

See Also

CommandLineParser.ValueUsageAttribute Class | CommandLineParser.ValueUsageAttribute Members | Genghis Namespace


CommandLineParser.ValueUsageAttribute.Description Field

[Visual Basic]
Public Description As String
[C#]
public string Description;

See Also

CommandLineParser.ValueUsageAttribute Class | CommandLineParser.ValueUsageAttribute Members | Genghis Namespace


CommandLineParser.ValueUsageAttribute.found Field

[Visual Basic]
Protected found As Boolean
[C#]
protected bool found;

See Also

CommandLineParser.ValueUsageAttribute Class | CommandLineParser.ValueUsageAttribute Members | Genghis Namespace


CommandLineParser.ValueUsageAttribute.IgnoreCase Field

[Visual Basic]
Public IgnoreCase As Boolean
[C#]
public bool IgnoreCase;

See Also

CommandLineParser.ValueUsageAttribute Class | CommandLineParser.ValueUsageAttribute Members | Genghis Namespace


CommandLineParser.ValueUsageAttribute.MatchPosition Field

[Visual Basic]
Public MatchPosition As Boolean
[C#]
public bool MatchPosition;

See Also

CommandLineParser.ValueUsageAttribute Class | CommandLineParser.ValueUsageAttribute Members | Genghis Namespace


CommandLineParser.ValueUsageAttribute.Name Field

[Visual Basic]
Public Name As String
[C#]
public string Name;

See Also

CommandLineParser.ValueUsageAttribute Class | CommandLineParser.ValueUsageAttribute Members | Genghis Namespace


CommandLineParser.ValueUsageAttribute.Optional Field

[Visual Basic]
Public Optional As Boolean
[C#]
public bool Optional;

See Also

CommandLineParser.ValueUsageAttribute Class | CommandLineParser.ValueUsageAttribute Members | Genghis Namespace


CommandLineParser.ValueUsageAttribute.ValueName Field

[Visual Basic]
Public ValueName As String
[C#]
public string ValueName;

See Also

CommandLineParser.ValueUsageAttribute Class | CommandLineParser.ValueUsageAttribute Members | Genghis Namespace


CommandLineParser.ValueUsageAttribute Properties

The properties of the CommandLineParser.ValueUsageAttribute class are listed below. For a complete list of CommandLineParser.ValueUsageAttribute class members, see the CommandLineParser.ValueUsageAttribute Members topic.

Public Instance Properties

TypeId (inherited from System.Attribute) Select the method name to go to the Microsoft documentation.

Protected Instance Properties

Flag See the third party documentation for more information.

Protected Internal Instance Properties

ExpectsValue |
IsFound | See the third party documentation for more information.

See Also

CommandLineParser.ValueUsageAttribute Class | Genghis Namespace


CommandLineParser.ValueUsageAttribute.ExpectsValue Property

[Visual Basic]
Overrides Protected Friend ReadOnly Property ExpectsValue As Boolean
[C#]
protected internal bool ExpectsValue {override get;}

See Also

CommandLineParser.ValueUsageAttribute Class | CommandLineParser.ValueUsageAttribute Members | Genghis Namespace


CommandLineParser.ValueUsageAttribute Methods

The methods of the CommandLineParser.ValueUsageAttribute class are listed below. For a complete list of CommandLineParser.ValueUsageAttribute class members, see the CommandLineParser.ValueUsageAttribute Members topic.

Public Instance Methods

Equals (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsDefaultAttribute (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
Match (inherited from Attribute) | Select the method name to go to the Microsoft documentation.
Matches | See the third party documentation for more information.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

ConsumeValueHelper | See the third party documentation for more information.
Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLongUsageHelper | See the third party documentation for more information.
GetShortUsageHelper | See the third party documentation for more information.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
ReadFromString | See the third party documentation for more information.

Protected Internal Instance Methods

ConsumeValue
GetLongUsage
GetShortUsage

See Also

CommandLineParser.ValueUsageAttribute Class | Genghis Namespace


CommandLineParser.ValueUsageAttribute.ConsumeValue Method

[Visual Basic]
Overrides Protected Friend Sub ConsumeValue( _
   ByVal s As String, _
   ByVal container As Object, _
   ByVal info As System.Reflection.MemberInfo _
)
[C#]
protected internal override void ConsumeValue(
   string s,
   object container,
   MemberInfo info
);

See Also

CommandLineParser.ValueUsageAttribute Class | CommandLineParser.ValueUsageAttribute Members | Genghis Namespace


CommandLineParser.ValueUsageAttribute.GetLongUsage Method

[Visual Basic]
Overrides Protected Friend Function GetLongUsage( _
   ByVal prefix As String, _
   ByVal defaultName As String _
) As String
[C#]
protected internal override string GetLongUsage(
   string prefix,
   string defaultName
);

See Also

CommandLineParser.ValueUsageAttribute Class | CommandLineParser.ValueUsageAttribute Members | Genghis Namespace


CommandLineParser.ValueUsageAttribute.GetShortUsage Method

[Visual Basic]
Overrides Protected Friend Function GetShortUsage( _
   ByVal prefix As String, _
   ByVal defaultName As String _
) As String
[C#]
protected internal override string GetShortUsage(
   string prefix,
   string defaultName
);

See Also

CommandLineParser.ValueUsageAttribute Class | CommandLineParser.ValueUsageAttribute Members | Genghis Namespace


IPathResolver Interface

The interface that a class must support to be a PathResolver

For a list of all members of this type, see IPathResolver Members.

[Visual Basic]
Public Interface IPathResolver
[C#]
public interface IPathResolver

Requirements

Namespace: Genghis Namespace

Assembly: Genghis.dll

See Also

IPathResolver Members | Genghis Namespace


IPathResolver Members

Public Instance Methods

ResolvePath | Resolve a single path to the destination type specified by ResolutionType
ResolvePathList | Resolve multiples path specified in a PathList to the destination type specified by ResolutionType

See Also

IPathResolver Interface | Genghis Namespace


IPathResolver Methods

The methods of the IPathResolver class are listed below. For a complete list of IPathResolver class members, see the IPathResolver Members topic.

Public Instance Methods

ResolvePath | Resolve a single path to the destination type specified by ResolutionType
ResolvePathList | Resolve multiples path specified in a PathList to the destination type specified by ResolutionType

See Also

IPathResolver Interface | Genghis Namespace


IPathResolver.ResolvePath Method

Resolve a single path to the destination type specified by ResolutionType

[Visual Basic]
Function ResolvePath( _
   ByVal Path As String, _
   ByVal ResolutionType As Genghis.PathResolveTypeEnum _
) As String
[C#]
string ResolvePath(
   string Path,
   PathResolveTypeEnum ResolutionType
);

Parameters

Path
A System.String representing the original path
ResolutionType
A PathResolveTypeEnum resolution type

Return Value

The resolved path if a resolution was possible. Otherwise, returns System.String.Empty

See Also

IPathResolver Interface | IPathResolver Members | Genghis Namespace


IPathResolver.ResolvePathList Method

Resolve multiples path specified in a PathList to the destination type specified by ResolutionType

[Visual Basic]
Function ResolvePathList( _
   ByVal PathList As Genghis.PathList, _
   ByVal ResolutionType As Genghis.PathResolveTypeEnum _
) As Genghis.IResolvedPathList
[C#]
IResolvedPathList ResolvePathList(
   PathList PathList,
   PathResolveTypeEnum ResolutionType
);

Parameters

PathList
A PathList containing a list of unique paths
ResolutionType
A PathResolveTypeEnum resolution type

Return Value

A IResolvedPathList hashtable-style read-only collection of original paths as keys, and their corresponding resolutions as values. A resolved value is System.String.Empty if no resolution was possible.

See Also

IPathResolver Interface | IPathResolver Members | Genghis Namespace


IPublicDictionary Interface

For a list of all members of this type, see IPublicDictionary Members.

[Visual Basic]
Public Interface IPublicDictionary
[C#]
public interface IPublicDictionary

Requirements

Namespace: Genghis Namespace

Assembly: Genghis.dll

See Also

IPublicDictionary Members | Genghis Namespace


IPublicDictionary Members

Public Instance Properties

IsFixedSize
IsReadOnly
Item
Keys
Values

Public Instance Methods

Contains
GetEnumerator

See Also

IPublicDictionary Interface | Genghis Namespace


IPublicDictionary Properties

The properties of the IPublicDictionary class are listed below. For a complete list of IPublicDictionary class members, see the IPublicDictionary Members topic.

Public Instance Properties

IsFixedSize
IsReadOnly
Item
Keys
Values

See Also

IPublicDictionary Interface | Genghis Namespace


IPublicDictionary.IsFixedSize Property

[Visual Basic]
Property IsFixedSize As Boolean
[C#]
bool IsFixedSize {get;}

See Also

IPublicDictionary Interface | IPublicDictionary Members | Genghis Namespace


IPublicDictionary.IsReadOnly Property

[Visual Basic]
Property IsReadOnly As Boolean
[C#]
bool IsReadOnly {get;}

See Also

IPublicDictionary Interface | IPublicDictionary Members | Genghis Namespace


IPublicDictionary.Item Property

[Visual Basic]
Property Item( _
   ByVal key As Object _
) As Object
[C#]
object this[
   object key
] {get;}

See Also

IPublicDictionary Interface | IPublicDictionary Members | Genghis Namespace


IPublicDictionary.Keys Property

[Visual Basic]
Property Keys As System.Collections.ICollection
[C#]
System.Collections.ICollection Keys {get;}

See Also

IPublicDictionary Interface | IPublicDictionary Members | Genghis Namespace


IPublicDictionary.Values Property

[Visual Basic]
Property Values As System.Collections.ICollection
[C#]
System.Collections.ICollection Values {get;}

See Also

IPublicDictionary Interface | IPublicDictionary Members | Genghis Namespace


IPublicDictionary Methods

The methods of the IPublicDictionary class are listed below. For a complete list of IPublicDictionary class members, see the IPublicDictionary Members topic.

Public Instance Methods

Contains
GetEnumerator

See Also

IPublicDictionary Interface | Genghis Namespace


IPublicDictionary.Contains Method

[Visual Basic]
Function Contains( _
   ByVal key As Object _
) As Boolean
[C#]
bool Contains(
   object key
);

See Also

IPublicDictionary Interface | IPublicDictionary Members | Genghis Namespace


IPublicDictionary.GetEnumerator Method

[Visual Basic]
Function GetEnumerator() As System.Collections.IDictionaryEnumerator
[C#]
IDictionaryEnumerator GetEnumerator();

See Also

IPublicDictionary Interface | IPublicDictionary Members | Genghis Namespace


IResolvedPathList Interface

Describes the public interface for a read-only PathList collection

For a list of all members of this type, see IResolvedPathList Members.

[Visual Basic]
Public Interface IResolvedPathList
   Implements IPublicDictionary
[C#]
public interface IResolvedPathList : IPublicDictionary

Requirements

Namespace: Genghis Namespace

Assembly: Genghis.dll

See Also

IResolvedPathList Members | Genghis Namespace


IResolvedPathList Members

Public Instance Properties

Item Overloaded.

Public Instance Methods

Contains

See Also

IResolvedPathList Interface | Genghis Namespace


IResolvedPathList Properties

The properties of the IResolvedPathList class are listed below. For a complete list of IResolvedPathList class members, see the IResolvedPathList Members topic.

Public Instance Properties

Item Overloaded.

See Also

IResolvedPathList Interface | Genghis Namespace


Item Property

Genghis Class Library

IResolvedPathList.Item

Overload List

string this[long] {get;}

string this[string] {get;}

See Also

IResolvedPathList Interface | IResolvedPathList Members | Genghis Namespace


IResolvedPathList.Item Property

[Visual Basic]
Property Item( _
   ByVal index As Long _
) As String
[C#]
string this[
   long index
] {get;}

See Also

IResolvedPathList Interface | IResolvedPathList Members | Genghis Namespace | IResolvedPathList.Item Overload List


IResolvedPathList.Item Property

[Visual Basic]
Property Item( _
   ByVal key As String _
) As String
[C#]
string this[
   string key
] {get;}

See Also

IResolvedPathList Interface | IResolvedPathList Members | Genghis Namespace | IResolvedPathList.Item Overload List


IResolvedPathList Methods

The methods of the IResolvedPathList class are listed below. For a complete list of IResolvedPathList class members, see the IResolvedPathList Members topic.

Public Instance Methods

Contains

See Also

IResolvedPathList Interface | Genghis Namespace


IResolvedPathList.Contains Method

[Visual Basic]
Function Contains( _
   ByVal key As String _
) As Boolean
[C#]
bool Contains(
   string key
);

See Also

IResolvedPathList Interface | IResolvedPathList Members | Genghis Namespace


PathList Class

A strongly-typed collection of unique case-insensitive System.String as paths. Originally generated by Chris Sells CollectionGen, modified for internal use, and for case insensitivity

For a list of all members of this type, see PathList Members.

System.Object
PathList

[Visual Basic]
Public Class PathList
   Implements IList, ICollection, IEnumerable, ICloneable
[C#]
public class PathList : IList, ICollection, IEnumerable, ICloneable

Requirements

Namespace: Genghis Namespace

Assembly: Genghis.dll

See Also

PathList Members | Genghis Namespace


PathList Members

Public Static (Shared) Methods

ReadOnly | Creates a read-only wrapper for a PathList instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a PathList instance.

Public Instance Constructors

PathList Overloaded. Initialize a new instance of the PathList class.

Public Instance Properties

Capacity | Gets or sets the number of elements the PathList can contain.
Count | Gets the number of elements actually contained in the PathList.
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the System.String at the specified index.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

AddRange | Overloaded. Adds the elements of a System.String array to the current PathList.
Clear | Removes all elements from the PathList.
Clone | Creates a shallow copy of the PathList.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
RemoveAt | Overloaded. Removes the element at the specified index of the PathList.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

IList.Add | Overloaded.
IList.Contains | Overloaded.
ICollection.CopyTo | Overloaded.
IEnumerable.GetEnumerator | Overloaded.
IList.IndexOf | Overloaded.
IList.Insert | Overloaded.
IList.Remove | Overloaded.

See Also

PathList Class | Genghis Namespace


PathList Constructor

Genghis Class Library

PathList

Initializes a new instance of the PathList class that is empty and has the default initial capacity.

Overload List

Initializes a new instance of the PathList class that is empty and has the default initial capacity.

public PathList();

Initializes a new instance of the PathList class that has the specified initial capacity.

public PathList(int);

Initializes a new instance of the PathList class that contains elements copied from the specified PathList.

public PathList(PathList);

Initializes a new instance of the PathList class that contains elements copied from the specified System.String array.

public PathList(string[]);

See Also

PathList Class | PathList Members | Genghis Namespace


PathList Constructor ()

Initializes a new instance of the PathList class that is empty and has the default initial capacity.

[Visual Basic]
Overloads Public Sub New()
[C#]
public PathList();

See Also

PathList Class | PathList Members | Genghis Namespace | PathList Constructor Overload List


PathList Constructor (Int32)

Initializes a new instance of the PathList class that has the specified initial capacity.

[Visual Basic]
Overloads Public Sub New( _
   ByVal capacity As Integer _
)
[C#]
public PathList(
   int capacity
);

Parameters

capacity
The number of elements that the new PathList is initially capable of storing.

See Also

PathList Class | PathList Members | Genghis Namespace | PathList Constructor Overload List


PathList Constructor (PathList)

Initializes a new instance of the PathList class that contains elements copied from the specified PathList.

[Visual Basic]
Overloads Public Sub New( _
   ByVal c As Genghis.PathList _
)
[C#]
public PathList(
   PathList c
);

Parameters

c
The PathList whose elements are copied to the new collection.

See Also

PathList Class | PathList Members | Genghis Namespace | PathList Constructor Overload List


PathList Constructor (String[])

Initializes a new instance of the PathList class that contains elements copied from the specified System.String array.

[Visual Basic]
Overloads Public Sub New( _
   ByVal a As String() _
)
[C#]
public PathList(
   string[] a
);

Parameters

a
The System.String array whose elements are copied to the new list.

See Also

PathList Class | PathList Members | Genghis Namespace | PathList Constructor Overload List


PathList Properties

The properties of the PathList class are listed below. For a complete list of PathList class members, see the PathList Members topic.

Public Instance Properties

Capacity | Gets or sets the number of elements the PathList can contain.
Count | Gets the number of elements actually contained in the PathList.
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the System.String at the specified index.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

PathList Class | Genghis Namespace


PathList.Capacity Property

Gets or sets the number of elements the PathList can contain.

[Visual Basic]
Overridable Public Property Capacity As Integer
[C#]
public int Capacity {virtual get; virtual set;}

See Also

PathList Class | PathList Members | Genghis Namespace


PathList.Count Property

Gets the number of elements actually contained in the PathList.

[Visual Basic]
Overridable Public ReadOnly Property Count As Integer
[C#]
public int Count {virtual get;}

See Also

PathList Class | PathList Members | Genghis Namespace


PathList.IsFixedSize Property

Gets a value indicating whether the collection has a fixed size.

[Visual Basic]
Overridable Public ReadOnly Property IsFixedSize As Boolean
[C#]
public bool IsFixedSize {virtual get;}

Property Value

true if the collection has a fixed size; otherwise, false. The default is false

See Also

PathList Class | PathList Members | Genghis Namespace


PathList.IsReadOnly Property

gets a value indicating whether the IList is read-only.

[Visual Basic]
Overridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {virtual get;}

Property Value

true if the collection is read-only; otherwise, false. The default is false

See Also

PathList Class | PathList Members | Genghis Namespace


PathList.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

[Visual Basic]
Overridable Public ReadOnly Property IsSynchronized As Boolean
[C#]
public bool IsSynchronized {virtual get;}

See Also

PathList Class | PathList Members | Genghis Namespace


PathList.Item Property

Gets or sets the System.String at the specified index.

[Visual Basic]
Overridable Public Default Property Item( _
   ByVal index As Integer _
) As String
[C#]
public string this[
   int index
] {virtual get; virtual set;}

Parameters

index
The zero-based index of the element to get or set.

Remarks

Will not set the path at the current index with the passed in string value if that path is already found elsewhere in the collection.

Exceptions

Exception Type | Condition
System.ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

PathList Class | PathList Members | Genghis Namespace


PathList.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

[Visual Basic]
Overridable Public ReadOnly Property SyncRoot As Object
[C#]
public object SyncRoot {virtual get;}

See Also

PathList Class | PathList Members | Genghis Namespace


PathList Methods

The methods of the PathList class are listed below. For a complete list of PathList class members, see the PathList Members topic.

Public Static (Shared) Methods

ReadOnly | Creates a read-only wrapper for a PathList instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a PathList instance.

Public Instance Methods

AddRange | Overloaded. Adds the elements of a System.String array to the current PathList.
Clear | Removes all elements from the PathList.
Clone | Creates a shallow copy of the PathList.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
RemoveAt | Overloaded. Removes the element at the specified index of the PathList.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

IList.Add | Overloaded.
IList.Contains | Overloaded.
ICollection.CopyTo | Overloaded.
IEnumerable.GetEnumerator | Overloaded.
IList.IndexOf | Overloaded.
IList.Insert | Overloaded.
IList.Remove | Overloaded.

See Also

PathList Class | Genghis Namespace


PathList.Add Method (String)

Adds a System.String to the end of the PathList.

[Visual Basic]
Overridable Public Function Add( _
   ByVal item As String _
) As Integer
[C#]
public virtual int Add(
   string item
);

Parameters

item
The System.String to be added to the end of the PathList.

Return Value

The index at which the value has been added.

Remarks

Will not add item as a new path if that path is already found elsewhere in the collection.

See Also

PathList Class | PathList Members | Genghis Namespace | PathList.Add Overload List


AddRange Method

Genghis Class Library

PathList.AddRange

Adds the elements of another PathList to the current PathList.

Overload List

Adds the elements of a System.String array to the current PathList.

public virtual int AddRange(string[]);

Adds the elements of another PathList to the current PathList.

public virtual int AddRange(PathList);

See Also

PathList Class | PathList Members | Genghis Namespace


PathList.AddRange Method (PathList)

Adds the elements of another PathList to the current PathList.

[Visual Basic]
Overridable Overloads Public Function AddRange( _
   ByVal x As Genghis.PathList _
) As Integer
[C#]
public virtual int AddRange(
   PathList x
);

Parameters

x
The PathList whose elements should be added to the end of the current PathList.

Return Value

The new Count of the PathList.

See Also

PathList Class | PathList Members | Genghis Namespace | PathList.AddRange Overload List


PathList.AddRange Method (String[])

Adds the elements of a System.String array to the current PathList.

[Visual Basic]
Overridable Overloads Public Function AddRange( _
   ByVal x As String() _
) As Integer
[C#]
public virtual int AddRange(
   string[] x
);

Parameters

x
The System.String array whose elements should be added to the end of the PathList.

Return Value

The new Count of the PathList.

Remarks

Checks each path string one at a time against the existing collection. Will not add item as a new path if that path is already found elsewhere in the collection.

See Also

PathList Class | PathList Members | Genghis Namespace | PathList.AddRange Overload List


PathList.Clear Method

Removes all elements from the PathList.

[Visual Basic]
Overridable Public Sub Clear()
[C#]
public virtual void Clear();

See Also

PathList Class | PathList Members | Genghis Namespace


PathList.Clone Method

Creates a shallow copy of the PathList.

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();

See Also

PathList Class | PathList Members | Genghis Namespace


PathList.Contains Method (String)

Determines whether a given System.String is in the PathList.

[Visual Basic]
Overridable Public Function Contains( _
   ByVal item As String _
) As Boolean
[C#]
public virtual bool Contains(
   string item
);

Parameters

item
The System.String to check for.

Return Value

true if item is found in the PathList; otherwise, false.

See Also

PathList Class | PathList Members | Genghis Namespace | PathList.Contains Overload List


CopyTo Method

Genghis Class Library

PathList.CopyTo

Copies the entire PathList to a one-dimensional string array.

Overload List

private final void CopyTo(Array,int);

Copies the entire PathList to a one-dimensional System.String array, starting at the specified index of the target array.

public virtual void CopyTo(string[],int);

Copies the entire PathList to a one-dimensional string array.

public virtual void CopyTo(string[]);

See Also

PathList Class | PathList Members | Genghis Namespace


PathList.CopyTo Method (String[])

Copies the entire PathList to a one-dimensional string array.

[Visual Basic]
Overridable Overloads Public Sub CopyTo( _
   ByVal array As String() _
)
[C#]
public virtual void CopyTo(
   string[] array
);

Parameters

array
The one-dimensional System.String array to copy to.

See Also

PathList Class | PathList Members | Genghis Namespace | PathList.CopyTo Overload List


PathList.CopyTo Method (String[], Int32)

Copies the entire PathList to a one-dimensional System.String array, starting at the specified index of the target array.

[Visual Basic]
Overridable Overloads Public Sub CopyTo( _
   ByVal array As String(), _
   ByVal start As Integer _
)
[C#]
public virtual void CopyTo(
   string[] array,
   int start
);

Parameters

array
The one-dimensional System.String array to copy to.
start
The zero-based index in array at which copying begins.

See Also

PathList Class | PathList Members | Genghis Namespace | PathList.CopyTo Overload List


PathList.GetEnumerator Method ()

Returns an enumerator that can iterate through the PathList.

[Visual Basic]
Overridable Public Function GetEnumerator() As Genghis.PathList.IPathListEnumerator
[C#]
public virtual IPathListEnumerator GetEnumerator();

Return Value

An Genghis.PathList.Enumerator for the entire PathList.

See Also

PathList Class | PathList Members | Genghis Namespace | PathList.GetEnumerator Overload List


PathList.IndexOf Method (String)

Returns the zero-based index of the first occurrence of a System.String in the PathList.

[Visual Basic]
Overridable Public Function IndexOf( _
   ByVal item As String _
) As Integer
[C#]
public virtual int IndexOf(
   string item
);

Parameters

item
The System.String to locate in the PathList.

Return Value

The zero-based index of the first occurrence of item in the entire PathList, if found; otherwise, -1.

See Also

PathList Class | PathList Members | Genghis Namespace | PathList.IndexOf Overload List


PathList.Insert Method (Int32, String)

Inserts an element into the PathList at the specified index.

[Visual Basic]
Overridable Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As String _
)
[C#]
public virtual void Insert(
   int index,
   string item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The System.String to insert.

Remarks

Will not add item as a new path if that path is already found elsewhere in the collection.

Exceptions

Exception Type | Condition
System.ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

PathList Class | PathList Members | Genghis Namespace | PathList.Insert Overload List


PathList.ReadOnly Method

Creates a read-only wrapper for a PathList instance.

[Visual Basic]
Public Shared Function ReadOnly( _
   ByVal list As Genghis.PathList _
) As Genghis.PathList
[C#]
public static PathList ReadOnly(
   PathList list
);

Return Value

An PathList wrapper that is read-only.

See Also

PathList Class | PathList Members | Genghis Namespace


PathList.Remove Method (String)

Removes the first occurrence of a specific System.String from the PathList.

[Visual Basic]
Overridable Public Sub Remove( _
   ByVal item As String _
)
[C#]
public virtual void Remove(
   string item
);

Parameters

item
The System.String to remove from the PathList.

Exceptions

Exception Type | Condition
System.ArgumentException | The specified System.String was not found in the PathList.

See Also

PathList Class | PathList Members | Genghis Namespace | PathList.Remove Overload List


PathList.RemoveAt Method (Int32)

Removes the element at the specified index of the PathList.

[Visual Basic]
Overridable Public Sub RemoveAt( _
   ByVal index As Integer _
)
[C#]
public virtual void RemoveAt(
   int index
);

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception Type | Condition
System.ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

PathList Class | PathList Members | Genghis Namespace | PathList.RemoveAt Overload List


PathList.Synchronized Method

Creates a synchronized (thread-safe) wrapper for a PathList instance.

[Visual Basic]
Public Shared Function Synchronized( _
   ByVal list As Genghis.PathList _
) As Genghis.PathList
[C#]
public static PathList Synchronized(
   PathList list
);

Return Value

An PathList wrapper that is synchronized (thread-safe).

See Also

PathList Class | PathList Members | Genghis Namespace


PathList.CopyTo Method (Array, Int32)

[Visual Basic]
Sub CopyTo( _
   ByVal array As System.Array, _
   ByVal start As Integer _
) Implements ICollection.CopyTo
[C#]
void ICollection.CopyTo(
   Array array,
   int start
);

See Also

PathList Class | PathList Members | Genghis Namespace | PathList.CopyTo Overload List


PathList.GetEnumerator Method ()

[Visual Basic]
Function GetEnumerator() As System.Collections.IEnumerator Implements IEnumerable.GetEnumerator
[C#]
IEnumerator IEnumerable.GetEnumerator();

See Also

PathList Class | PathList Members | Genghis Namespace | PathList.GetEnumerator Overload List


PathList.Add Method (Object)

[Visual Basic]
Function Add( _
   ByVal x As Object _
) As Integer Implements IList.Add
[C#]
int IList.Add(
   object x
);

See Also

PathList Class | PathList Members | Genghis Namespace | PathList.Add Overload List


PathList.Contains Method (Object)

[Visual Basic]
Function Contains( _
   ByVal x As Object _
) As Boolean Implements IList.Contains
[C#]
bool IList.Contains(
   object x
);

See Also

PathList Class | PathList Members | Genghis Namespace | PathList.Contains Overload List


PathList.IndexOf Method (Object)

[Visual Basic]
Function IndexOf( _
   ByVal x As Object _
) As Integer Implements IList.IndexOf
[C#]
int IList.IndexOf(
   object x
);

See Also

PathList Class | PathList Members | Genghis Namespace | PathList.IndexOf Overload List


PathList.Insert Method (Int32, Object)

[Visual Basic]
Sub Insert( _
   ByVal pos As Integer, _
   ByVal x As Object _
) Implements IList.Insert
[C#]
void IList.Insert(
   int pos,
   object x
);

See Also

PathList Class | PathList Members | Genghis Namespace | PathList.Insert Overload List


PathList.Remove Method (Object)

[Visual Basic]
Sub Remove( _
   ByVal x As Object _
) Implements IList.Remove
[C#]
void IList.Remove(
   object x
);

See Also

PathList Class | PathList Members | Genghis Namespace | PathList.Remove Overload List


PathList.RemoveAt Method (Int32)

[Visual Basic]
Sub RemoveAt( _
   ByVal pos As Integer _
) Implements IList.RemoveAt
[C#]
void IList.RemoveAt(
   int pos
);

See Also

PathList Class | PathList Members | Genghis Namespace | PathList.RemoveAt Overload List


PathList.TrimToSize Method

Sets the capacity to the actual number of elements.

[Visual Basic]
Overridable Public Sub TrimToSize()
[C#]
public virtual void TrimToSize();

See Also

PathList Class | PathList Members | Genghis Namespace


PathList.IPathListEnumerator Interface

Supports type-safe iteration over a PathList.

For a list of all members of this type, see PathList.IPathListEnumerator Members.

[Visual Basic]
Public Interface PathList.IPathListEnumerator
[C#]
public interface PathList.IPathListEnumerator

Requirements

Namespace: Genghis Namespace

Assembly: Genghis.dll

See Also

PathList.IPathListEnumerator Members | Genghis Namespace


PathList.IPathListEnumerator Members

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

PathList.IPathListEnumerator Interface | Genghis Namespace


PathList.IPathListEnumerator Properties

The properties of the PathList.IPathListEnumerator class are listed below. For a complete list of PathList.IPathListEnumerator class members, see the PathList.IPathListEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

PathList.IPathListEnumerator Interface | Genghis Namespace


PathList.IPathListEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Property Current As String
[C#]
string Current {get;}

See Also

PathList.IPathListEnumerator Interface | PathList.IPathListEnumerator Members | Genghis Namespace


PathList.IPathListEnumerator Methods

The methods of the PathList.IPathListEnumerator class are listed below. For a complete list of PathList.IPathListEnumerator class members, see the PathList.IPathListEnumerator Members topic.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

PathList.IPathListEnumerator Interface | Genghis Namespace


PathList.IPathListEnumerator.MoveNext Method

Advances the enumerator to the next element in the collection.

[Visual Basic]
Function MoveNext() As Boolean
[C#]
bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Exceptions

Exception Type | Condition
System.InvalidOperationException | The collection was modified after the enumerator was created.

See Also

PathList.IPathListEnumerator Interface | PathList.IPathListEnumerator Members | Genghis Namespace


PathList.IPathListEnumerator.Reset Method

Sets the enumerator to its initial position, before the first element in the collection.

[Visual Basic]
Sub Reset()
[C#]
void Reset();

See Also

PathList.IPathListEnumerator Interface | PathList.IPathListEnumerator Members | Genghis Namespace


PathResolvedEventHandler Delegate

The delegate corresponding to the OnPathResolved event

[Visual Basic]
Public Delegate Sub PathResolvedEventHandler( _
   ByVal sender As Object, _
   ByVal e As Genghis.PathResolverEventArgs _
)
[C#]
public delegate void PathResolvedEventHandler(
   object sender,
   PathResolverEventArgs e
);

Requirements

Namespace: Genghis Namespace

Assembly: Genghis.dll

See Also

Genghis Namespace


PathResolver Class

Class responsible for resolving single paths, or a list of paths via a PathList

For a list of all members of this type, see PathResolver Members.

System.Object
PathResolver

[Visual Basic]
Public Class PathResolver
   Implements IPathResolver
[C#]
public class PathResolver : IPathResolver

Requirements

Namespace: Genghis Namespace

Assembly: Genghis.dll

See Also

PathResolver Members | Genghis Namespace


PathResolver Members

Public Instance Constructors

PathResolver Constructor Initializes a new instace of PathResolver

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ResolvePath | Resolve a single path to the destination type specified by ResolutionType
ResolvePathList | Resolve multiples path specified in a PathList to the destination type specified by ResolutionType
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Public Instance Events

PathResolved Occurrs any time a path has been resolved

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
OnPathResolved | Occurrs any time a path has been resolved

See Also

PathResolver Class | Genghis Namespace


PathResolver Constructor

Initializes a new instace of PathResolver

[Visual Basic]
Public Sub New()
[C#]
public PathResolver();

Remarks

Allocates an internal instance of the Shares class, in addition to an internal instance of the Maps class which will be used for path resolution

See Also

PathResolver Class | PathResolver Members | Genghis Namespace


PathResolver Methods

The methods of the PathResolver class are listed below. For a complete list of PathResolver class members, see the PathResolver Members topic.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ResolvePath | Resolve a single path to the destination type specified by ResolutionType
ResolvePathList | Resolve multiples path specified in a PathList to the destination type specified by ResolutionType
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
OnPathResolved | Occurrs any time a path has been resolved

See Also

PathResolver Class | Genghis Namespace


PathResolver.OnPathResolved Method

Occurrs any time a path has been resolved

[Visual Basic]
Protected Sub OnPathResolved( _
   ByVal sender As Object, _
   ByVal e As Genghis.PathResolverEventArgs _
)
[C#]
protected void OnPathResolved(
   object sender,
   PathResolverEventArgs e
);

Parameters

sender
A System.Object representing the originator of the event
e
A System.EventArgs representing additional data relevant to the event

See Also

PathResolver Class | PathResolver Members | Genghis Namespace


PathResolver.ResolvePath Method

Resolve a single path to the destination type specified by ResolutionType

[Visual Basic]
NotOverridable Public Function ResolvePath( _
   ByVal Path As String, _
   ByVal ResolutionType As Genghis.PathResolveTypeEnum _
) As String
[C#]
public final string ResolvePath(
   string Path,
   PathResolveTypeEnum ResolutionType
);

Parameters

Path
A System.String representing the original path
ResolutionType
A PathResolveTypeEnum resolution type

Return Value

The resolved path if a resolution was possible. Otherwise, returns System.String.Empty

See Also

PathResolver Class | PathResolver Members | Genghis Namespace


PathResolver.ResolvePathList Method

Resolve multiples path specified in a PathList to the destination type specified by ResolutionType

[Visual Basic]
NotOverridable Public Function ResolvePathList( _
   ByVal PathList As Genghis.PathList, _
   ByVal ResolutionType As Genghis.PathResolveTypeEnum _
) As Genghis.IResolvedPathList
[C#]
public final IResolvedPathList ResolvePathList(
   PathList PathList,
   PathResolveTypeEnum ResolutionType
);

Parameters

PathList
A PathList containing a list of unique paths
ResolutionType
A PathResolveTypeEnum resolution type

Return Value

A IResolvedPathList hashtable-style read-only collection of original paths as keys, and their corresponding resolutions as values. A resolved value is System.String.Empty if no resolution was possible.

See Also

PathResolver Class | PathResolver Members | Genghis Namespace


PathResolver Events

The events of the PathResolver class are listed below. For a complete list of PathResolver class members, see the PathResolver Members topic.

Public Instance Events

PathResolved Occurrs any time a path has been resolved

See Also

PathResolver Class | Genghis Namespace


PathResolver.PathResolved Event

Occurrs any time a path has been resolved

[Visual Basic]
Public PathResolved As Genghis.PathResolvedEventHandler
[C#]
public PathResolvedEventHandler PathResolved;

Event Data

The event handler receives a PathResolverEventArgs containing data related to the PathResolved event. The following PathResolverEventArgs properties provide information specific to this event.

Property | Description
CurrentIndex | Returns the index within the original PathList passed to the PathResolver
Path | Returns the current path within the original PathList passed to the PathResolver
ResolutionType | The PathResolveTypeEnum type of operation being performed on the current path
ResolvedPath | Returns the resolution of the current path within the original PathList passed to the PathResolver
Total | Returns the total number of paths in the original PathList passed to the PathResolver

See Also

PathResolver Class | PathResolver Members | Genghis Namespace


PathResolverEventArgs Class

Class that contains data relevant to the PathResolvedEventHandler delegate

For a list of all members of this type, see PathResolverEventArgs Members.

System.Object
EventArgs
PathResolverEventArgs

[Visual Basic]
Public Class PathResolverEventArgs
   Inherits EventArgs
[C#]
public class PathResolverEventArgs : EventArgs

Remarks

This class provides statistical information and other data about the last path resolution operation

Requirements

Namespace: Genghis Namespace

Assembly: Genghis.dll

See Also

PathResolverEventArgs Members | Genghis Namespace


PathResolverEventArgs Members

Public Instance Constructors

PathResolverEventArgs Constructor The constructor used to create an instance of the PathResolverEventArgs class

Public Instance Properties

CurrentIndex | Returns the index within the original PathList passed to the PathResolver
Path | Returns the current path within the original PathList passed to the PathResolver
ResolutionType | The PathResolveTypeEnum type of operation being performed on the current path
ResolvedPath | Returns the resolution of the current path within the original PathList passed to the PathResolver
Total | Returns the total number of paths in the original PathList passed to the PathResolver

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

PathResolverEventArgs Class | Genghis Namespace


PathResolverEventArgs Constructor

The constructor used to create an instance of the PathResolverEventArgs class

[Visual Basic]
Public Sub New( _
   ByVal currentIndex As Integer, _
   ByVal total As Integer, _
   ByVal path As String, _
   ByVal resolvedPath As String, _
   ByVal pathResolveTypeEnum As Genghis.PathResolveTypeEnum _
)
[C#]
public PathResolverEventArgs(
   int currentIndex,
   int total,
   string path,
   string resolvedPath,
   PathResolveTypeEnum pathResolveTypeEnum
);

Parameters

currentIndex
The index of the current item within the original PathList passed to the PathResolver
total
The total number of paths in the original PathList passed to the PathResolver
path
The current path within the original PathList passed to the PathResolver
resolvedPath
The resolution of the current path within the original PathList passed to the PathResolver
pathResolveTypeEnum
The PathResolveTypeEnum type of operation being performed on the current path

See Also

PathResolverEventArgs Class | PathResolverEventArgs Members | Genghis Namespace


PathResolverEventArgs Properties

The properties of the PathResolverEventArgs class are listed below. For a complete list of PathResolverEventArgs class members, see the PathResolverEventArgs Members topic.

Public Instance Properties

CurrentIndex | Returns the index within the original PathList passed to the PathResolver
Path | Returns the current path within the original PathList passed to the PathResolver
ResolutionType | The PathResolveTypeEnum type of operation being performed on the current path
ResolvedPath | Returns the resolution of the current path within the original PathList passed to the PathResolver
Total | Returns the total number of paths in the original PathList passed to the PathResolver

See Also

PathResolverEventArgs Class | Genghis Namespace


PathResolverEventArgs.CurrentIndex Property

Returns the index within the original PathList passed to the PathResolver

[Visual Basic]
Public ReadOnly Property CurrentIndex As Integer
[C#]
public int CurrentIndex {get;}

See Also

PathResolverEventArgs Class | PathResolverEventArgs Members | Genghis Namespace


PathResolverEventArgs.Path Property

Returns the current path within the original PathList passed to the PathResolver

[Visual Basic]
Public ReadOnly Property Path As String
[C#]
public string Path {get;}

See Also

PathResolverEventArgs Class | PathResolverEventArgs Members | Genghis Namespace


PathResolverEventArgs.ResolutionType Property

The PathResolveTypeEnum type of operation being performed on the current path

[Visual Basic]
Public ReadOnly Property ResolutionType As Genghis.PathResolveTypeEnum
[C#]
public PathResolveTypeEnum ResolutionType {get;}

See Also

PathResolverEventArgs Class | PathResolverEventArgs Members | Genghis Namespace


PathResolverEventArgs.ResolvedPath Property

Returns the resolution of the current path within the original PathList passed to the PathResolver

[Visual Basic]
Public ReadOnly Property ResolvedPath As String
[C#]
public string ResolvedPath {get;}

See Also

PathResolverEventArgs Class | PathResolverEventArgs Members | Genghis Namespace


PathResolverEventArgs.Total Property

Returns the total number of paths in the original PathList passed to the PathResolver

[Visual Basic]
Public ReadOnly Property Total As Integer
[C#]
public int Total {get;}

See Also

PathResolverEventArgs Class | PathResolverEventArgs Members | Genghis Namespace


PathResolveTypeEnum Enumeration

An enumeration specifying what type of path to generate from the given path

[Visual Basic]
Public Enum PathResolveTypeEnum
[C#]
public enum PathResolveTypeEnum

Members

Member Name | Description
UNC | Generate a UNC style path from the given path
Local | Generate a local style path from the given path

Requirements

Namespace: Genghis Namespace

Assembly: Genghis.dll

See Also

Genghis Namespace


Preferences Class

Provides a way to persist user preferences.

For a list of all members of this type, see Preferences Members.

System.Object
Preferences

[Visual Basic]
MustInherit Public Class Preferences
   Implements IDisposable
[C#]
public abstract class Preferences : IDisposable

Remarks

By default, this class uses Isolated Storage to provide provide portable and safe persistance.
It is envisioned that in the future, alternate backing stores will be available (the registry would be an obvious one).

Example

Here's an example of how to persist the persist the personal details of a user (for registration purposes, perhaps).

            Preferences prefWriter = Preferences.GetUserNode("Personal Details");
            prefWriter.SetProperty("Name", "Joe Bloggs");
            prefWriter.SetProperty("Age", 56);
            prefWriter.Close();
And here's an example of how to read these properties back in.
            Preferences prefReader = Preferences.GetUserNode("Personal Details");
            string name = prefReader.GetString("Name", "Anonymous");
            int age = prefReader.GetInt32("Age", 0);
            prefReader.Close();

Requirements

Namespace: Genghis Namespace

Assembly: Genghis.dll

See Also

Preferences Members | Genghis Namespace


Preferences Members

Public Static (Shared) Methods

GetUserNode | Overloaded. Constructs a per-user preferences object from a class.
GetUserRoot | Constructs a preferences object at the root of the per-user settings.

Public Instance Properties

Path

Public Instance Methods

Close | Disposes of any resources.
Dispose |
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
Flush | Flushes any outstanding property data to disk.
GetBoolean |
GetDouble |
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetInt32 |
GetInt64 |
GetProperty | Overloaded. Gets a property
GetSingle |
GetString |
GetSubnode | Opens a new subnode to store settings under.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
SetProperty | Sets a property
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Constructors

Preferences Overloaded. Initialize a new instance of the Preferences class.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

Preferences Class | Genghis Namespace


Preferences Constructor

Genghis Class Library

Preferences

Constructs a preferences writer at the root.

Overload List

Constructs a preferences writer at the root.

protected Preferences();

Constructs a preferences writer with a path.

protected Preferences(string);

See Also

Preferences Class | Preferences Members | Genghis Namespace


Preferences Constructor ()

Constructs a preferences writer at the root.

[Visual Basic]
Overloads Protected Sub New()
[C#]
protected Preferences();

See Also

Preferences Class | Preferences Members | Genghis Namespace | Preferences Constructor Overload List


Preferences Constructor (String)

Constructs a preferences writer with a path.

[Visual Basic]
Overloads Protected Sub New( _
   ByVal path As String _
)
[C#]
protected Preferences(
   string path
);

Parameters

path
The path under which the preferences will be saved.

See Also

Preferences Class | Preferences Members | Genghis Namespace | Preferences Constructor Overload List


Preferences Properties

The properties of the Preferences class are listed below. For a complete list of Preferences class members, see the Preferences Members topic.

Public Instance Properties

Path

See Also

Preferences Class | Genghis Namespace


Preferences.Path Property

[Visual Basic]
Public ReadOnly Property Path As String
[C#]
public string Path {get;}

See Also

Preferences Class | Preferences Members | Genghis Namespace


Preferences Methods

The methods of the Preferences class are listed below. For a complete list of Preferences class members, see the Preferences Members topic.

Public Static (Shared) Methods

GetUserNode | Overloaded. Constructs a per-user preferences object from a class.
GetUserRoot | Constructs a preferences object at the root of the per-user settings.

Public Instance Methods

Close | Disposes of any resources.
Dispose |
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
Flush | Flushes any outstanding property data to disk.
GetBoolean |
GetDouble |
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetInt32 |
GetInt64 |
GetProperty | Overloaded. Gets a property
GetSingle |
GetString |
GetSubnode | Opens a new subnode to store settings under.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
SetProperty | Sets a property
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

Preferences Class | Genghis Namespace


Preferences.Close Method

Disposes of any resources.

[Visual Basic]
Public Sub Close()
[C#]
public void Close();

Remarks

Equivalent to calling Dispose().

See Also

Preferences Class | Preferences Members | Genghis Namespace


Preferences.Dispose Method

[Visual Basic]
Overridable Public Sub Dispose()
[C#]
public virtual void Dispose();

See Also

Preferences Class | Preferences Members | Genghis Namespace


Preferences.Flush Method

Flushes any outstanding property data to disk.

[Visual Basic]
MustOverride Public Sub Flush()
[C#]
public abstract void Flush();

See Also

Preferences Class | Preferences Members | Genghis Namespace


Preferences.GetBoolean Method

[Visual Basic]
Public Function GetBoolean( _
   ByVal name As String, _
   ByVal defaultValue As Boolean _
) As Boolean
[C#]
public bool GetBoolean(
   string name,
   bool defaultValue
);

See Also

Preferences Class | Preferences Members | Genghis Namespace


Preferences.GetDouble Method

[Visual Basic]
Public Function GetDouble( _
   ByVal name As String, _
   ByVal defaultValue As Double _
) As Double
[C#]
public double GetDouble(
   string name,
   double defaultValue
);

See Also

Preferences Class | Preferences Members | Genghis Namespace


Preferences.GetInt32 Method

[Visual Basic]
Public Function GetInt32( _
   ByVal name As String, _
   ByVal defaultValue As Integer _
) As Integer
[C#]
public int GetInt32(
   string name,
   int defaultValue
);

See Also

Preferences Class | Preferences Members | Genghis Namespace


Preferences.GetInt64 Method

[Visual Basic]
Public Function GetInt64( _
   ByVal name As String, _
   ByVal defaultValue As Long _
) As Double
[C#]
public double GetInt64(
   string name,
   long defaultValue
);

See Also

Preferences Class | Preferences Members | Genghis Namespace


GetProperty Method

Genghis Class Library

Preferences.GetProperty

Gets a property

Overload List

Gets a property

public abstract object GetProperty(string,object,Type);

Gets a property

public object GetProperty(string,object);

See Also

Preferences Class | Preferences Members | Genghis Namespace


Preferences.GetProperty Method (String, Object)

Gets a property

[Visual Basic]
Overloads Public Function GetProperty( _
   ByVal name As String, _
   ByVal defaultValue As Object _
) As Object
[C#]
public object GetProperty(
   string name,
   object defaultValue
);

Parameters

name
The property name.
Use slash (/) to logically separate groups of settings.
defaultValue
The default property value. If no previous property exists, or the preferences store is unavailable, this value will be returned.

Return Value

Returns the property value (with the same type as defaultValue).

Remarks

The return type is converted to the same type as the defaultValue argument before it is returned. Therefore, this must be a type supported by the System.Convert class. The supported types are: Boolean, Char, SByte, Byte, Int16, Int32, Int64, UInt16, UInt32, UInt64, Single, Double, Decimal, DateTime and String.

See Also

Preferences Class | Preferences Members | Genghis Namespace | Preferences.GetProperty Overload List


Preferences.GetProperty Method (String, Object, Type)

Gets a property

[Visual Basic]
MustOverride Overloads Public Function GetProperty( _
   ByVal path As String, _
   ByVal defaultValue As Object, _
   ByVal returnType As System.Type _
) As Object
[C#]
public abstract object GetProperty(
   string path,
   object defaultValue,
   Type returnType
);

Parameters

path
defaultValue
The default property value. If no previous property exists, or the preferences store is unavailable, this value will be returned.
returnType
The return type. This must be a type supported by the System.Convert class. The supported types are: Boolean, Char, SByte, Byte, Int16, Int32, Int64, UInt16, UInt32, UInt64, Single, Double, Decimal, DateTime and String.

Return Value

Returns the property value (with the same type as returnType).

See Also

Preferences Class | Preferences Members | Genghis Namespace | Preferences.GetProperty Overload List


Preferences.GetSingle Method

[Visual Basic]
Public Function GetSingle( _
   ByVal name As String, _
   ByVal defaultValue As Single _
) As Single
[C#]
public float GetSingle(
   string name,
   float defaultValue
);

See Also

Preferences Class | Preferences Members | Genghis Namespace


Preferences.GetString Method

[Visual Basic]
Public Function GetString( _
   ByVal name As String, _
   ByVal defaultValue As String _
) As String
[C#]
public string GetString(
   string name,
   string defaultValue
);

See Also

Preferences Class | Preferences Members | Genghis Namespace


Preferences.GetSubnode Method

Opens a new subnode to store settings under.

[Visual Basic]
Overridable Public Function GetSubnode( _
   ByVal subpath As String _
) As Genghis.Preferences
[C#]
public virtual Preferences GetSubnode(
   string subpath
);

Parameters

subpath

Remarks

The subnode is created if it doesn't already exist.

See Also

Preferences Class | Preferences Members | Genghis Namespace


GetUserNode Method

Genghis Class Library

Preferences.GetUserNode

Constructs a per-user preferences object from a path.

Overload List

Constructs a per-user preferences object from a class.

public static Preferences GetUserNode(Type);

Constructs a per-user preferences object from a path.

public static Preferences GetUserNode(string);

See Also

Preferences Class | Preferences Members | Genghis Namespace


Preferences.GetUserNode Method (String)

Constructs a per-user preferences object from a path.

[Visual Basic]
Overloads Public Shared Function GetUserNode( _
   ByVal path As String _
) As Genghis.Preferences
[C#]
public static Preferences GetUserNode(
   string path
);

Parameters

path
Represents the path the preferences are stored under. Equivalent to a directory path or a registry key path.
Important Note: The seperator character is slash ('/') NOT backslash ('\').

Remarks

The path of the root node is "".

See Also

Preferences Class | Preferences Members | Genghis Namespace | Preferences.GetUserNode Overload List


Preferences.GetUserNode Method (Type)

Constructs a per-user preferences object from a class.

[Visual Basic]
Overloads Public Shared Function GetUserNode( _
   ByVal type As System.Type _
) As Genghis.Preferences
[C#]
public static Preferences GetUserNode(
   Type type
);

Parameters

type

See Also

Preferences Class | Preferences Members | Genghis Namespace | Preferences.GetUserNode Overload List


Preferences.GetUserRoot Method

Constructs a preferences object at the root of the per-user settings.

[Visual Basic]
Public Shared Function GetUserRoot() As Genghis.Preferences
[C#]
public static Preferences GetUserRoot();

See Also

Preferences Class | Preferences Members | Genghis Namespace


Preferences.SetProperty Method

Sets a property

[Visual Basic]
MustOverride Public Sub SetProperty( _
   ByVal name As String, _
   ByVal value As Object _
)
[C#]
public abstract void SetProperty(
   string name,
   object value
);

Parameters

name
The property name.
Use slash (/) to logically separate groups of settings.
value
The property value.

Remarks

Currently, the value parameter must be a type supported by the System.Convert class. The supported types are: Boolean, Char, SByte, Byte, Int16, Int32, Int64, UInt16, UInt32, UInt64, Single, Double, Decimal, DateTime and String.

See Also

Preferences Class | Preferences Members | Genghis Namespace


ResolvedPathList Class

A hashtable of a given path, and its resolved path, or string.Empty if it couldn't be resolved Originally generated by Chris Sells CollectionGen, then modified for internal scope

For a list of all members of this type, see ResolvedPathList Members.

System.Object
ResolvedPathList

[Visual Basic]
Public Class ResolvedPathList
   Implements IResolvedPathList, IPublicDictionary, IPrivateResolvedPathList, IPrivateDictionary, ICollection, IEnumerable, ICloneable
[C#]
public class ResolvedPathList : IResolvedPathList, IPublicDictionary, IPrivateResolvedPathList, IPrivateDictionary, ICollection, IEnumerable, ICloneable

Requirements

Namespace: Genghis Namespace

Assembly: Genghis.dll

See Also

ResolvedPathList Members | Genghis Namespace


ResolvedPathList Members

Public Static (Shared) Methods

Synchronized

Public Instance Properties

Count
IsSynchronized
Keys
SyncRoot
Values

Public Instance Methods

ContainsKey |
ContainsValue |
CopyTo |
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetEnumerator | Overloaded.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Fields

innerHash

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

IPrivateDictionary.Add | Overloaded.
IPrivateDictionary.Clear | Overloaded.
ICloneable.Clone | Overloaded.
IPublicDictionary.Contains | Overloaded.
IPrivateDictionary.Remove | Overloaded.

See Also

ResolvedPathList Class | Genghis Namespace


ResolvedPathList Fields

The fields of the ResolvedPathList class are listed below. For a complete list of ResolvedPathList class members, see the ResolvedPathList Members topic.

Protected Instance Fields

innerHash

See Also

ResolvedPathList Class | Genghis Namespace


ResolvedPathList.innerHash Field

[Visual Basic]
Protected innerHash As System.Collections.Hashtable
[C#]
protected Hashtable innerHash;

See Also

ResolvedPathList Class | ResolvedPathList Members | Genghis Namespace


ResolvedPathList Properties

The properties of the ResolvedPathList class are listed below. For a complete list of ResolvedPathList class members, see the ResolvedPathList Members topic.

Public Instance Properties

Count
IsSynchronized
Keys
SyncRoot
Values

See Also

ResolvedPathList Class | Genghis Namespace


ResolvedPathList.Count Property

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer
[C#]
public int Count {final get;}

See Also

ResolvedPathList Class | ResolvedPathList Members | Genghis Namespace


ResolvedPathList.IsSynchronized Property

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean
[C#]
public bool IsSynchronized {final get;}

See Also

ResolvedPathList Class | ResolvedPathList Members | Genghis Namespace


ResolvedPathList.Keys Property

[Visual Basic]
NotOverridable Public ReadOnly Property Keys As System.Collections.ICollection
[C#]
public System.Collections.ICollection Keys {final get;}

See Also

ResolvedPathList Class | ResolvedPathList Members | Genghis Namespace


ResolvedPathList.SyncRoot Property

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object
[C#]
public object SyncRoot {final get;}

See Also

ResolvedPathList Class | ResolvedPathList Members | Genghis Namespace


ResolvedPathList.Values Property

[Visual Basic]
NotOverridable Public ReadOnly Property Values As System.Collections.ICollection
[C#]
public System.Collections.ICollection Values {final get;}

See Also

ResolvedPathList Class | ResolvedPathList Members | Genghis Namespace


ResolvedPathList Methods

The methods of the ResolvedPathList class are listed below. For a complete list of ResolvedPathList class members, see the ResolvedPathList Members topic.

Public Static (Shared) Methods

Synchronized

Public Instance Methods

ContainsKey |
ContainsValue |
CopyTo |
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetEnumerator | Overloaded.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

IPrivateDictionary.Add | Overloaded.
IPrivateDictionary.Clear | Overloaded.
ICloneable.Clone | Overloaded.
IPublicDictionary.Contains | Overloaded.
IPrivateDictionary.Remove | Overloaded.

See Also

ResolvedPathList Class | Genghis Namespace


ResolvedPathList.Clone Method ()

[Visual Basic]
Public Function Clone() As Genghis.ResolvedPathList
[C#]
public ResolvedPathList Clone();

See Also

ResolvedPathList Class | ResolvedPathList Members | Genghis Namespace | ResolvedPathList.Clone Overload List


ResolvedPathList.ContainsKey Method

[Visual Basic]
Public Function ContainsKey( _
   ByVal key As String _
) As Boolean
[C#]
public bool ContainsKey(
   string key
);

See Also

ResolvedPathList Class | ResolvedPathList Members | Genghis Namespace


ResolvedPathList.ContainsValue Method

[Visual Basic]
Public Function ContainsValue( _
   ByVal value As String _
) As Boolean
[C#]
public bool ContainsValue(
   string value
);

See Also

ResolvedPathList Class | ResolvedPathList Members | Genghis Namespace


ResolvedPathList.CopyTo Method

[Visual Basic]
NotOverridable Public Sub CopyTo( _
   ByVal array As System.Array, _
   ByVal index As Integer _
)
[C#]
public final void CopyTo(
   Array array,
   int index
);

See Also

ResolvedPathList Class | ResolvedPathList Members | Genghis Namespace


ResolvedPathList.Add Method (Object, Object)

[Visual Basic]
Sub Add( _
   ByVal key As Object, _
   ByVal value As Object _
) Implements IPrivateDictionary.Add
[C#]
void IPrivateDictionary.Add(
   object key,
   object value
);

See Also

ResolvedPathList Class | ResolvedPathList Members | Genghis Namespace | ResolvedPathList.Add Overload List


ResolvedPathList.Clear Method ()

[Visual Basic]
Sub Clear() Implements IPrivateDictionary.Clear
[C#]
void IPrivateDictionary.Clear();

See Also

ResolvedPathList Class | ResolvedPathList Members | Genghis Namespace | ResolvedPathList.Clear Overload List


ResolvedPathList.Remove Method (Object)

[Visual Basic]
Sub Remove( _
   ByVal key As Object _
) Implements IPrivateDictionary.Remove
[C#]
void IPrivateDictionary.Remove(
   object key
);

See Also

ResolvedPathList Class | ResolvedPathList Members | Genghis Namespace | ResolvedPathList.Remove Overload List


ResolvedPathList.Add Method (String, String)

[Visual Basic]
Sub Add( _
   ByVal key As String, _
   ByVal value As String _
) Implements IPrivateResolvedPathList.Add
[C#]
void IPrivateResolvedPathList.Add(
   string key,
   string value
);

See Also

ResolvedPathList Class | ResolvedPathList Members | Genghis Namespace | ResolvedPathList.Add Overload List


ResolvedPathList.Clear Method ()

[Visual Basic]
Sub Clear() Implements IPrivateResolvedPathList.Clear
[C#]
void IPrivateResolvedPathList.Clear();

See Also

ResolvedPathList Class | ResolvedPathList Members | Genghis Namespace | ResolvedPathList.Clear Overload List


ResolvedPathList.Remove Method (String)

[Visual Basic]
Sub Remove( _
   ByVal key As String _
) Implements IPrivateResolvedPathList.Remove
[C#]
void IPrivateResolvedPathList.Remove(
   string key
);

See Also

ResolvedPathList Class | ResolvedPathList Members | Genghis Namespace | ResolvedPathList.Remove Overload List


Contains Method

Genghis Class Library

ResolvedPathList.Contains

Overload List

private final bool Contains(object);

private final bool Contains(string);

See Also

ResolvedPathList Class | ResolvedPathList Members | Genghis Namespace


ResolvedPathList.Contains Method (Object)

[Visual Basic]
Function Contains( _
   ByVal key As Object _
) As Boolean Implements IPublicDictionary.Contains
[C#]
bool IPublicDictionary.Contains(
   object key
);

See Also

ResolvedPathList Class | ResolvedPathList Members | Genghis Namespace | ResolvedPathList.Contains Overload List


ResolvedPathList.Contains Method (String)

[Visual Basic]
Function Contains( _
   ByVal key As String _
) As Boolean Implements IResolvedPathList.Contains
[C#]
bool IResolvedPathList.Contains(
   string key
);

See Also

ResolvedPathList Class | ResolvedPathList Members | Genghis Namespace | ResolvedPathList.Contains Overload List


ResolvedPathList.GetEnumerator Method ()

[Visual Basic]
NotOverridable Public Function GetEnumerator() As System.Collections.IDictionaryEnumerator
[C#]
public final IDictionaryEnumerator GetEnumerator();

See Also

ResolvedPathList Class | ResolvedPathList Members | Genghis Namespace | ResolvedPathList.GetEnumerator Overload List


ResolvedPathList.Synchronized Method

[Visual Basic]
Public Shared Function Synchronized( _
   ByVal nonSync As Genghis.ResolvedPathList _
) As Genghis.ResolvedPathList
[C#]
public static ResolvedPathList Synchronized(
   ResolvedPathList nonSync
);

See Also

ResolvedPathList Class | ResolvedPathList Members | Genghis Namespace


ResolvedPathList.GetEnumerator Method ()

[Visual Basic]
Function GetEnumerator() As System.Collections.IEnumerator Implements IEnumerable.GetEnumerator
[C#]
IEnumerator IEnumerable.GetEnumerator();

See Also

ResolvedPathList Class | ResolvedPathList Members | Genghis Namespace | ResolvedPathList.GetEnumerator Overload List


ResolvedPathList.Clone Method ()

[Visual Basic]
Function Clone() As Object Implements ICloneable.Clone
[C#]
object ICloneable.Clone();

See Also

ResolvedPathList Class | ResolvedPathList Members | Genghis Namespace | ResolvedPathList.Clone Overload List


ResolvedPathListEnumerator Class

For a list of all members of this type, see ResolvedPathListEnumerator Members.

System.Object
ResolvedPathListEnumerator

[Visual Basic]
Public Class ResolvedPathListEnumerator
   Implements IDictionaryEnumerator, IEnumerator
[C#]
public class ResolvedPathListEnumerator : IDictionaryEnumerator, IEnumerator

Requirements

Namespace: Genghis Namespace

Assembly: Genghis.dll

See Also

ResolvedPathListEnumerator Members | Genghis Namespace


ResolvedPathListEnumerator Members

Public Instance Properties

Current
Entry
Key
Value

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
MoveNext |
Reset |
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

ResolvedPathListEnumerator Class | Genghis Namespace


ResolvedPathListEnumerator Properties

The properties of the ResolvedPathListEnumerator class are listed below. For a complete list of ResolvedPathListEnumerator class members, see the ResolvedPathListEnumerator Members topic.

Public Instance Properties

Current
Entry
Key
Value

See Also

ResolvedPathListEnumerator Class | Genghis Namespace


ResolvedPathListEnumerator.Current Property

[Visual Basic]
NotOverridable Public ReadOnly Property Current As Object
[C#]
public object Current {final get;}

See Also

ResolvedPathListEnumerator Class | ResolvedPathListEnumerator Members | Genghis Namespace


ResolvedPathListEnumerator.Entry Property

[Visual Basic]
NotOverridable Public ReadOnly Property Entry As System.Collections.DictionaryEntry
[C#]
public System.Collections.DictionaryEntry Entry {final get;}

See Also

ResolvedPathListEnumerator Class | ResolvedPathListEnumerator Members | Genghis Namespace


ResolvedPathListEnumerator.Key Property

[Visual Basic]
Public ReadOnly Property Key As String
[C#]
public string Key {get;}

See Also

ResolvedPathListEnumerator Class | ResolvedPathListEnumerator Members | Genghis Namespace


ResolvedPathListEnumerator.Value Property

[Visual Basic]
Public ReadOnly Property Value As String
[C#]
public string Value {get;}

See Also

ResolvedPathListEnumerator Class | ResolvedPathListEnumerator Members | Genghis Namespace


ResolvedPathListEnumerator Methods

The methods of the ResolvedPathListEnumerator class are listed below. For a complete list of ResolvedPathListEnumerator class members, see the ResolvedPathListEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
MoveNext |
Reset |
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

ResolvedPathListEnumerator Class | Genghis Namespace


ResolvedPathListEnumerator.MoveNext Method

[Visual Basic]
NotOverridable Public Function MoveNext() As Boolean
[C#]
public final bool MoveNext();

See Also

ResolvedPathListEnumerator Class | ResolvedPathListEnumerator Members | Genghis Namespace


ResolvedPathListEnumerator.Reset Method

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

ResolvedPathListEnumerator Class | ResolvedPathListEnumerator Members | Genghis Namespace


Genghis.Diagnostics

Genghis Class Library

Genghis.Diagnostics Namespace

Namespace hierarchy

Classes

Class Description
TraceEx TraceEx is an extension to the Trace class, supporting individuell TraceSwitches for each assembly and a customizable formatstring to specify the output format.

All settings are configurable in the app.config of the application.

TraceFormat in appSettings:

Format | Descriptions
{T} | timestamp
{A} | name of calling assembly
{M} | name of calling method
{m} | trace message
\n | CRLF
\t | Tag

Example: {T}:{A}::{M}\n{m}


TraceEx Class

TraceEx is an extension to the Trace class, supporting individuell TraceSwitches for each assembly and a customizable formatstring to specify the output format.

All settings are configurable in the app.config of the application.

TraceFormat in appSettings:

Format | Descriptions
{T} | timestamp
{A} | name of calling assembly
{M} | name of calling method
{m} | trace message
\n | CRLF
\t | Tag

Example: {T}:{A}::{M}\n{m}

For a list of all members of this type, see TraceEx Members.

System.Object
TraceEx

[Visual Basic]
Public Class TraceEx
[C#]
public class TraceEx

Requirements

Namespace: Genghis.Diagnostics Namespace

Assembly: Genghis.dll

See Also

TraceEx Members | Genghis.Diagnostics Namespace


TraceEx Members

Public Static (Shared) Methods

Assert Checks for a condition and writes a message to the trace listeners in the Listeners collection if the condition is false.
Note The message is only written if the TraceLevel for the calling module is set to TraceLevel.Error or higher.
Write | Overloaded. Writes a category name and message to the trace listeners in the Listeners collection.
WriteError | Overloaded. Writes a category name and message to the trace listeners in the Listeners collection if the TraceLevel for the calling module is set to TraceLevel.Error or higher.
WriteException Writes a textual representation of the gives exception to the trace listeners in the Listeners collection.
Note The message is only written if the TraceLevel for the calling module is set to TraceLevel.Error or higher.
WriteInfo | Overloaded. Writes a category name and message to the trace listeners in the Listeners collection if the TraceLevel for the calling module is set to TraceLevel.Info or higher.
WriteVerbose | Overloaded. Writes a category name and message to the trace listeners in the Listeners collection if the TraceLevel for the calling module is set to TraceLevel.Verbose.
WriteWarning | Overloaded. Writes a category name and message to the trace listeners in the Listeners collection if the TraceLevel for the calling module is set to TraceLevel.Warning or higher.

Public Instance Constructors

TraceEx Constructor

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

TraceEx Class | Genghis.Diagnostics Namespace


TraceEx Constructor

[Visual Basic]
Public Sub New()
[C#]
public TraceEx();

See Also

TraceEx Class | TraceEx Members | Genghis.Diagnostics Namespace


TraceEx Methods

The methods of the TraceEx class are listed below. For a complete list of TraceEx class members, see the TraceEx Members topic.

Public Static (Shared) Methods

Assert Checks for a condition and writes a message to the trace listeners in the Listeners collection if the condition is false.
Note The message is only written if the TraceLevel for the calling module is set to TraceLevel.Error or higher.
Write | Overloaded. Writes a category name and message to the trace listeners in the Listeners collection.
WriteError | Overloaded. Writes a category name and message to the trace listeners in the Listeners collection if the TraceLevel for the calling module is set to TraceLevel.Error or higher.
WriteException Writes a textual representation of the gives exception to the trace listeners in the Listeners collection.
Note The message is only written if the TraceLevel for the calling module is set to TraceLevel.Error or higher.
WriteInfo | Overloaded. Writes a category name and message to the trace listeners in the Listeners collection if the TraceLevel for the calling module is set to TraceLevel.Info or higher.
WriteVerbose | Overloaded. Writes a category name and message to the trace listeners in the Listeners collection if the TraceLevel for the calling module is set to TraceLevel.Verbose.
WriteWarning | Overloaded. Writes a category name and message to the trace listeners in the Listeners collection if the TraceLevel for the calling module is set to TraceLevel.Warning or higher.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

TraceEx Class | Genghis.Diagnostics Namespace


TraceEx.Assert Method

Checks for a condition and writes a message to the trace listeners in the Listeners collection if the condition is false.

Note The message is only written if the TraceLevel for the calling module is set to TraceLevel.Error or higher.

[Visual Basic]
Public Shared Sub Assert( _
   ByVal condition As Boolean, _
   ByVal message As String _
)
[C#]
public static void Assert(
   bool condition,
   string message
);

Parameters

condition
<b>true</b> to prevent a message being written; otherwise, <b>false</b>.
message
A message to write

See Also

TraceEx Class | TraceEx Members | Genghis.Diagnostics Namespace


Write Method

Genghis Class Library

TraceEx.Write

Writes a message to the trace listeners in the Listeners collection.

Overload List

Writes a category name and message to the trace listeners in the Listeners collection.

public static void Write(string,string);

Writes a message to the trace listeners in the Listeners collection.

public static void Write(string);

See Also

TraceEx Class | TraceEx Members | Genghis.Diagnostics Namespace


TraceEx.Write Method (String)

Writes a message to the trace listeners in the Listeners collection.

[Visual Basic]
Overloads Public Shared Sub Write( _
   ByVal message As String _
)
[C#]
public static void Write(
   string message
);

Parameters

message
A message to write

See Also

TraceEx Class | TraceEx Members | Genghis.Diagnostics Namespace | TraceEx.Write Overload List


TraceEx.Write Method (String, String)

Writes a category name and message to the trace listeners in the Listeners collection.

[Visual Basic]
Overloads Public Shared Sub Write( _
   ByVal message As String, _
   ByVal category As String _
)
[C#]
public static void Write(
   string message,
   string category
);

Parameters

message
A message to write
category
A category to write

See Also

TraceEx Class | TraceEx Members | Genghis.Diagnostics Namespace | TraceEx.Write Overload List


WriteError Method

Genghis Class Library

TraceEx.WriteError

Writes a message to the trace listeners in the Listeners collection if the TraceLevel for the calling module is set to TraceLevel.Error or higher.

Overload List

Writes a category name and message to the trace listeners in the Listeners collection if the TraceLevel for the calling module is set to TraceLevel.Error or higher.

public static void WriteError(string,string);

Writes a message to the trace listeners in the Listeners collection if the TraceLevel for the calling module is set to TraceLevel.Error or higher.

public static void WriteError(string);

See Also

TraceEx Class | TraceEx Members | Genghis.Diagnostics Namespace


TraceEx.WriteError Method (String)

Writes a message to the trace listeners in the Listeners collection if the TraceLevel for the calling module is set to TraceLevel.Error or higher.

[Visual Basic]
Overloads Public Shared Sub WriteError( _
   ByVal message As String _
)
[C#]
public static void WriteError(
   string message
);

Parameters

message
A message to write

See Also

TraceEx Class | TraceEx Members | Genghis.Diagnostics Namespace | TraceEx.WriteError Overload List


TraceEx.WriteError Method (String, String)

Writes a category name and message to the trace listeners in the Listeners collection if the TraceLevel for the calling module is set to TraceLevel.Error or higher.

[Visual Basic]
Overloads Public Shared Sub WriteError( _
   ByVal message As String, _
   ByVal category As String _
)
[C#]
public static void WriteError(
   string message,
   string category
);

Parameters

message
A message to write
category
A category to write

See Also

TraceEx Class | TraceEx Members | Genghis.Diagnostics Namespace | TraceEx.WriteError Overload List


TraceEx.WriteException Method

Writes a textual representation of the gives exception to the trace listeners in the Listeners collection.

Note The message is only written if the TraceLevel for the calling module is set to TraceLevel.Error or higher.

[Visual Basic]
Public Shared Sub WriteException( _
   ByVal e As System.Exception _
)
[C#]
public static void WriteException(
   Exception e
);

Parameters

e
Exception being thrown

See Also

TraceEx Class | TraceEx Members | Genghis.Diagnostics Namespace


WriteInfo Method

Genghis Class Library

TraceEx.WriteInfo

Writes a message to the trace listeners in the Listeners collection if the TraceLevel for the calling module is set to TraceLevel.Info or higher.

Overload List

Writes a category name and message to the trace listeners in the Listeners collection if the TraceLevel for the calling module is set to TraceLevel.Info or higher.

public static void WriteInfo(string,string);

Writes a message to the trace listeners in the Listeners collection if the TraceLevel for the calling module is set to TraceLevel.Info or higher.

public static void WriteInfo(string);

See Also

TraceEx Class | TraceEx Members | Genghis.Diagnostics Namespace


TraceEx.WriteInfo Method (String)

Writes a message to the trace listeners in the Listeners collection if the TraceLevel for the calling module is set to TraceLevel.Info or higher.

[Visual Basic]
Overloads Public Shared Sub WriteInfo( _
   ByVal message As String _
)
[C#]
public static void WriteInfo(
   string message
);

Parameters

message
A message to write

See Also

TraceEx Class | TraceEx Members | Genghis.Diagnostics Namespace | TraceEx.WriteInfo Overload List


TraceEx.WriteInfo Method (String, String)

Writes a category name and message to the trace listeners in the Listeners collection if the TraceLevel for the calling module is set to TraceLevel.Info or higher.

[Visual Basic]
Overloads Public Shared Sub WriteInfo( _
   ByVal message As String, _
   ByVal category As String _
)
[C#]
public static void WriteInfo(
   string message,
   string category
);

Parameters

message
A message to write
category
A category to write

See Also

TraceEx Class | TraceEx Members | Genghis.Diagnostics Namespace | TraceEx.WriteInfo Overload List


WriteVerbose Method

Genghis Class Library

TraceEx.WriteVerbose

Writes a message to the trace listeners in the Listeners collection if the TraceLevel for the calling module is set to TraceLevel.Verbose.

Overload List

Writes a category name and message to the trace listeners in the Listeners collection if the TraceLevel for the calling module is set to TraceLevel.Verbose.

public static void WriteVerbose(string,string);

Writes a message to the trace listeners in the Listeners collection if the TraceLevel for the calling module is set to TraceLevel.Verbose.

public static void WriteVerbose(string);

See Also

TraceEx Class | TraceEx Members | Genghis.Diagnostics Namespace


TraceEx.WriteVerbose Method (String)

Writes a message to the trace listeners in the Listeners collection if the TraceLevel for the calling module is set to TraceLevel.Verbose.

[Visual Basic]
Overloads Public Shared Sub WriteVerbose( _
   ByVal message As String _
)
[C#]
public static void WriteVerbose(
   string message
);

Parameters

message
A message to write

See Also

TraceEx Class | TraceEx Members | Genghis.Diagnostics Namespace | TraceEx.WriteVerbose Overload List


TraceEx.WriteVerbose Method (String, String)

Writes a category name and message to the trace listeners in the Listeners collection if the TraceLevel for the calling module is set to TraceLevel.Verbose.

[Visual Basic]
Overloads Public Shared Sub WriteVerbose( _
   ByVal message As String, _
   ByVal category As String _
)
[C#]
public static void WriteVerbose(
   string message,
   string category
);

Parameters

message
A message to write
category
A category to write

See Also

TraceEx Class | TraceEx Members | Genghis.Diagnostics Namespace | TraceEx.WriteVerbose Overload List


WriteWarning Method

Genghis Class Library

TraceEx.WriteWarning

Writes a message to the trace listeners in the Listeners collection if the TraceLevel for the calling module is set to TraceLevel.Warning or higher.

Overload List

Writes a category name and message to the trace listeners in the Listeners collection if the TraceLevel for the calling module is set to TraceLevel.Warning or higher.

public static void WriteWarning(string,string);

Writes a message to the trace listeners in the Listeners collection if the TraceLevel for the calling module is set to TraceLevel.Warning or higher.

public static void WriteWarning(string);

See Also

TraceEx Class | TraceEx Members | Genghis.Diagnostics Namespace


TraceEx.WriteWarning Method (String)

Writes a message to the trace listeners in the Listeners collection if the TraceLevel for the calling module is set to TraceLevel.Warning or higher.

[Visual Basic]
Overloads Public Shared Sub WriteWarning( _
   ByVal message As String _
)
[C#]
public static void WriteWarning(
   string message
);

Parameters

message
A message to write

See Also

TraceEx Class | TraceEx Members | Genghis.Diagnostics Namespace | TraceEx.WriteWarning Overload List


TraceEx.WriteWarning Method (String, String)

Writes a category name and message to the trace listeners in the Listeners collection if the TraceLevel for the calling module is set to TraceLevel.Warning or higher.

[Visual Basic]
Overloads Public Shared Sub WriteWarning( _
   ByVal message As String, _
   ByVal category As String _
)
[C#]
public static void WriteWarning(
   string message,
   string category
);

Parameters

message
A message to write
category
A category to write

See Also

TraceEx Class | TraceEx Members | Genghis.Diagnostics Namespace | TraceEx.WriteWarning Overload List


Genghis.Web

Genghis Class Library

Genghis.Web Namespace

Namespace hierarchy

Classes

Class | Description
WebCommandLineHelper |


WebCommandLineHelper Class

For a list of all members of this type, see WebCommandLineHelper Members.

System.Object
WebCommandLineHelper

[Visual Basic]
Public Class WebCommandLineHelper
[C#]
public class WebCommandLineHelper

Requirements

Namespace: Genghis.Web Namespace

Assembly: Genghis.dll

See Also

WebCommandLineHelper Members | Genghis.Web Namespace


WebCommandLineHelper Members

Public Static (Shared) Properties

LaunchedFromUrl

Public Static (Shared) Methods

CommandLineArgs
Empty

Public Instance Constructors

WebCommandLineHelper Constructor

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

WebCommandLineHelper Class | Genghis.Web Namespace


WebCommandLineHelper Constructor

[Visual Basic]
Public Sub New()
[C#]
public WebCommandLineHelper();

See Also

WebCommandLineHelper Class | WebCommandLineHelper Members | Genghis.Web Namespace


WebCommandLineHelper Properties

The properties of the WebCommandLineHelper class are listed below. For a complete list of WebCommandLineHelper class members, see the WebCommandLineHelper Members topic.

Public Static (Shared) Properties

LaunchedFromUrl

See Also

WebCommandLineHelper Class | Genghis.Web Namespace


WebCommandLineHelper.LaunchedFromUrl Property

[Visual Basic]
Public Shared ReadOnly Property LaunchedFromUrl As Boolean
[C#]
public static bool LaunchedFromUrl {get;}

See Also

WebCommandLineHelper Class | WebCommandLineHelper Members | Genghis.Web Namespace


WebCommandLineHelper Methods

The methods of the WebCommandLineHelper class are listed below. For a complete list of WebCommandLineHelper class members, see the WebCommandLineHelper Members topic.

Public Static (Shared) Methods

CommandLineArgs
Empty

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

WebCommandLineHelper Class | Genghis.Web Namespace


WebCommandLineHelper.CommandLineArgs Method

[Visual Basic]
Public Shared Function CommandLineArgs( _
   ByVal argsFromMain As String() _
) As String()
[C#]
public static string[] CommandLineArgs(
   string[] argsFromMain
);

See Also

WebCommandLineHelper Class | WebCommandLineHelper Members | Genghis.Web Namespace


WebCommandLineHelper.Empty Method

[Visual Basic]
Public Shared Function Empty( _
   ByVal s As String _
) As Boolean
[C#]
public static bool Empty(
   string s
);

See Also

WebCommandLineHelper Class | WebCommandLineHelper Members | Genghis.Web Namespace


Genghis.Win32

Genghis Class Library

Genghis.Win32 Namespace

Namespace hierarchy

Classes

Class | Description
MappedDriveMap | A hashtable collection of mapped drive letters as keys, and their corresponding UNC paths as values Originally generated by Chris Sells CollectionGen, then modified for internal scope
MappedDriveMapEnumerator |
MappedDrives | Used to load a list of mapped drives from the registry Provides an event handler to notify clients that the mapped drives have been changed
NetworkConnection.ManagementSystemProperties |
NetworkConnection.NetworkConnectionCollection |
NetworkConnection.NetworkConnectionCollection.NetworkConnectionEnumerator |
NetworkConnection.WMIValueTypeConverter |
Share.ManagementSystemProperties |
Share.ShareCollection |
Share.ShareCollection.ShareEnumerator |
Share.WMIValueTypeConverter |
ShareMap | A hashmap collection of share names as keys, and their corresponding local paths as values Originally generated by Chris Sells CollectionGen, then modified for internal scope
ShareMapEnumerator |
SystemShares | Used to load a list of shares from the registry Provides an event handler to notify clients that the shares have been changed

Interfaces

Interface | Description
Win32NetworkConnectionList.IWin32NetworkConnectionListEnumerator | Supports type-safe iteration over a Genghis.Win32.Win32NetworkConnectionList.
Win32ShareList.IWin32ShareListEnumerator | Supports type-safe iteration over a Genghis.Win32.Win32ShareList.

Delegates

Delegate | Description
MappedDrivesChangedEventHandler | The delegate corresponding to the OnMappedDrivesChanged event
SystemSharesSharesChangedEventHandler | The delegate corresponding to the OnSharesChanged event

Enumerations

Enumeration | Description
NetworkConnection.AccessMaskValues |
Share.AccessMaskValues |
Share.TypeValues |


MappedDriveMap Class

A hashtable collection of mapped drive letters as keys, and their corresponding UNC paths as values Originally generated by Chris Sells CollectionGen, then modified for internal scope

For a list of all members of this type, see MappedDriveMap Members.

System.Object
MappedDriveMap

[Visual Basic]
Public Class MappedDriveMap
   Implements IDictionary, ICollection, IEnumerable, ICloneable
[C#]
public class MappedDriveMap : IDictionary, ICollection, IEnumerable, ICloneable

Requirements

Namespace: Genghis.Win32 Namespace

Assembly: Genghis.dll

See Also

MappedDriveMap Members | Genghis.Win32 Namespace


MappedDriveMap Members

Public Static (Shared) Methods

Synchronized

Public Instance Properties

Count
IsFixedSize
IsReadOnly
IsSynchronized
Item
Keys
SyncRoot
Values

Public Instance Methods

Clear |
ContainsKey |
ContainsValue |
CopyTo |
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetEnumerator | Overloaded.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Fields

innerHash

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

IDictionary.Add | Overloaded.
ICloneable.Clone | Overloaded.
IDictionary.Contains | Overloaded.
IDictionary.Remove | Overloaded.

See Also

MappedDriveMap Class | Genghis.Win32 Namespace


MappedDriveMap Fields

The fields of the MappedDriveMap class are listed below. For a complete list of MappedDriveMap class members, see the MappedDriveMap Members topic.

Protected Instance Fields

innerHash

See Also

MappedDriveMap Class | Genghis.Win32 Namespace


MappedDriveMap.innerHash Field

[Visual Basic]
Protected innerHash As System.Collections.Hashtable
[C#]
protected Hashtable innerHash;

See Also

MappedDriveMap Class | MappedDriveMap Members | Genghis.Win32 Namespace


MappedDriveMap Properties

The properties of the MappedDriveMap class are listed below. For a complete list of MappedDriveMap class members, see the MappedDriveMap Members topic.

Public Instance Properties

Count
IsFixedSize
IsReadOnly
IsSynchronized
Item
Keys
SyncRoot
Values

See Also

MappedDriveMap Class | Genghis.Win32 Namespace


MappedDriveMap.Count Property

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer
[C#]
public int Count {final get;}

See Also

MappedDriveMap Class | MappedDriveMap Members | Genghis.Win32 Namespace


MappedDriveMap.IsFixedSize Property

[Visual Basic]
NotOverridable Public ReadOnly Property IsFixedSize As Boolean
[C#]
public bool IsFixedSize {final get;}

See Also

MappedDriveMap Class | MappedDriveMap Members | Genghis.Win32 Namespace


MappedDriveMap.IsReadOnly Property

[Visual Basic]
NotOverridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {final get;}

See Also

MappedDriveMap Class | MappedDriveMap Members | Genghis.Win32 Namespace


MappedDriveMap.IsSynchronized Property

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean
[C#]
public bool IsSynchronized {final get;}

See Also

MappedDriveMap Class | MappedDriveMap Members | Genghis.Win32 Namespace


MappedDriveMap.Item Property

[Visual Basic]
Public Default Property Item( _
   ByVal key As String _
) As String
[C#]
public string this[
   string key
] {get; set;}

See Also

MappedDriveMap Class | MappedDriveMap Members | Genghis.Win32 Namespace


MappedDriveMap.Keys Property

[Visual Basic]
NotOverridable Public ReadOnly Property Keys As System.Collections.ICollection
[C#]
public System.Collections.ICollection Keys {final get;}

See Also

MappedDriveMap Class | MappedDriveMap Members | Genghis.Win32 Namespace


MappedDriveMap.SyncRoot Property

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object
[C#]
public object SyncRoot {final get;}

See Also

MappedDriveMap Class | MappedDriveMap Members | Genghis.Win32 Namespace


MappedDriveMap.Values Property

[Visual Basic]
NotOverridable Public ReadOnly Property Values As System.Collections.ICollection
[C#]
public System.Collections.ICollection Values {final get;}

See Also

MappedDriveMap Class | MappedDriveMap Members | Genghis.Win32 Namespace


MappedDriveMap Methods

The methods of the MappedDriveMap class are listed below. For a complete list of MappedDriveMap class members, see the MappedDriveMap Members topic.

Public Static (Shared) Methods

Synchronized

Public Instance Methods

Clear |
ContainsKey |
ContainsValue |
CopyTo |
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetEnumerator | Overloaded.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

IDictionary.Add | Overloaded.
ICloneable.Clone | Overloaded.
IDictionary.Contains | Overloaded.
IDictionary.Remove | Overloaded.

See Also

MappedDriveMap Class | Genghis.Win32 Namespace


MappedDriveMap.Add Method (String, String)

[Visual Basic]
Public Sub Add( _
   ByVal key As String, _
   ByVal value As String _
)
[C#]
public void Add(
   string key,
   string value
);

See Also

MappedDriveMap Class | MappedDriveMap Members | Genghis.Win32 Namespace | MappedDriveMap.Add Overload List


MappedDriveMap.Clear Method

[Visual Basic]
NotOverridable Public Sub Clear()
[C#]
public final void Clear();

See Also

MappedDriveMap Class | MappedDriveMap Members | Genghis.Win32 Namespace


MappedDriveMap.Clone Method ()

[Visual Basic]
Public Function Clone() As Genghis.Win32.MappedDriveMap
[C#]
public MappedDriveMap Clone();

See Also

MappedDriveMap Class | MappedDriveMap Members | Genghis.Win32 Namespace | MappedDriveMap.Clone Overload List


MappedDriveMap.Contains Method (String)

[Visual Basic]
Public Function Contains( _
   ByVal key As String _
) As Boolean
[C#]
public bool Contains(
   string key
);

See Also

MappedDriveMap Class | MappedDriveMap Members | Genghis.Win32 Namespace | MappedDriveMap.Contains Overload List


MappedDriveMap.ContainsKey Method

[Visual Basic]
Public Function ContainsKey( _
   ByVal key As String _
) As Boolean
[C#]
public bool ContainsKey(
   string key
);

See Also

MappedDriveMap Class | MappedDriveMap Members | Genghis.Win32 Namespace


MappedDriveMap.ContainsValue Method

[Visual Basic]
Public Function ContainsValue( _
   ByVal value As String _
) As Boolean
[C#]
public bool ContainsValue(
   string value
);

See Also

MappedDriveMap Class | MappedDriveMap Members | Genghis.Win32 Namespace


MappedDriveMap.CopyTo Method

[Visual Basic]
NotOverridable Public Sub CopyTo( _
   ByVal array As System.Array, _
   ByVal index As Integer _
)
[C#]
public final void CopyTo(
   Array array,
   int index
);

See Also

MappedDriveMap Class | MappedDriveMap Members | Genghis.Win32 Namespace


MappedDriveMap.GetEnumerator Method ()

[Visual Basic]
NotOverridable Public Function GetEnumerator() As System.Collections.IDictionaryEnumerator
[C#]
public final IDictionaryEnumerator GetEnumerator();

See Also

MappedDriveMap Class | MappedDriveMap Members | Genghis.Win32 Namespace | MappedDriveMap.GetEnumerator Overload List


MappedDriveMap.Remove Method (String)

[Visual Basic]
Public Sub Remove( _
   ByVal key As String _
)
[C#]
public void Remove(
   string key
);

See Also

MappedDriveMap Class | MappedDriveMap Members | Genghis.Win32 Namespace | MappedDriveMap.Remove Overload List


MappedDriveMap.Synchronized Method

[Visual Basic]
Public Shared Function Synchronized( _
   ByVal nonSync As Genghis.Win32.MappedDriveMap _
) As Genghis.Win32.MappedDriveMap
[C#]
public static MappedDriveMap Synchronized(
   MappedDriveMap nonSync
);

See Also

MappedDriveMap Class | MappedDriveMap Members | Genghis.Win32 Namespace


MappedDriveMap.Add Method (Object, Object)

[Visual Basic]
Sub Add( _
   ByVal key As Object, _
   ByVal value As Object _
) Implements IDictionary.Add
[C#]
void IDictionary.Add(
   object key,
   object value
);

See Also

MappedDriveMap Class | MappedDriveMap Members | Genghis.Win32 Namespace | MappedDriveMap.Add Overload List


MappedDriveMap.Contains Method (Object)

[Visual Basic]
Function Contains( _
   ByVal key As Object _
) As Boolean Implements IDictionary.Contains
[C#]
bool IDictionary.Contains(
   object key
);

See Also

MappedDriveMap Class | MappedDriveMap Members | Genghis.Win32 Namespace | MappedDriveMap.Contains Overload List


MappedDriveMap.Remove Method (Object)

[Visual Basic]
Sub Remove( _
   ByVal key As Object _
) Implements IDictionary.Remove
[C#]
void IDictionary.Remove(
   object key
);

See Also

MappedDriveMap Class | MappedDriveMap Members | Genghis.Win32 Namespace | MappedDriveMap.Remove Overload List


MappedDriveMap.GetEnumerator Method ()

[Visual Basic]
Function GetEnumerator() As System.Collections.IEnumerator Implements IEnumerable.GetEnumerator
[C#]
IEnumerator IEnumerable.GetEnumerator();

See Also

MappedDriveMap Class | MappedDriveMap Members | Genghis.Win32 Namespace | MappedDriveMap.GetEnumerator Overload List


MappedDriveMap.Clone Method ()

[Visual Basic]
Function Clone() As Object Implements ICloneable.Clone
[C#]
object ICloneable.Clone();

See Also

MappedDriveMap Class | MappedDriveMap Members | Genghis.Win32 Namespace | MappedDriveMap.Clone Overload List


MappedDriveMapEnumerator Class

For a list of all members of this type, see MappedDriveMapEnumerator Members.

System.Object
MappedDriveMapEnumerator

[Visual Basic]
Public Class MappedDriveMapEnumerator
   Implements IDictionaryEnumerator, IEnumerator
[C#]
public class MappedDriveMapEnumerator : IDictionaryEnumerator, IEnumerator

Requirements

Namespace: Genghis.Win32 Namespace

Assembly: Genghis.dll

See Also

MappedDriveMapEnumerator Members | Genghis.Win32 Namespace


MappedDriveMapEnumerator Members

Public Instance Properties

Current
Entry
Key
Value

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
MoveNext |
Reset |
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

MappedDriveMapEnumerator Class | Genghis.Win32 Namespace


MappedDriveMapEnumerator Properties

The properties of the MappedDriveMapEnumerator class are listed below. For a complete list of MappedDriveMapEnumerator class members, see the MappedDriveMapEnumerator Members topic.

Public Instance Properties

Current
Entry
Key
Value

See Also

MappedDriveMapEnumerator Class | Genghis.Win32 Namespace


MappedDriveMapEnumerator.Current Property

[Visual Basic]
NotOverridable Public ReadOnly Property Current As Object
[C#]
public object Current {final get;}

See Also

MappedDriveMapEnumerator Class | MappedDriveMapEnumerator Members | Genghis.Win32 Namespace


MappedDriveMapEnumerator.Entry Property

[Visual Basic]
NotOverridable Public ReadOnly Property Entry As System.Collections.DictionaryEntry
[C#]
public System.Collections.DictionaryEntry Entry {final get;}

See Also

MappedDriveMapEnumerator Class | MappedDriveMapEnumerator Members | Genghis.Win32 Namespace


MappedDriveMapEnumerator.Key Property

[Visual Basic]
Public ReadOnly Property Key As String
[C#]
public string Key {get;}

See Also

MappedDriveMapEnumerator Class | MappedDriveMapEnumerator Members | Genghis.Win32 Namespace


MappedDriveMapEnumerator.Value Property

[Visual Basic]
Public ReadOnly Property Value As String
[C#]
public string Value {get;}

See Also

MappedDriveMapEnumerator Class | MappedDriveMapEnumerator Members | Genghis.Win32 Namespace


MappedDriveMapEnumerator Methods

The methods of the MappedDriveMapEnumerator class are listed below. For a complete list of MappedDriveMapEnumerator class members, see the MappedDriveMapEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
MoveNext |
Reset |
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

MappedDriveMapEnumerator Class | Genghis.Win32 Namespace


MappedDriveMapEnumerator.MoveNext Method

[Visual Basic]
NotOverridable Public Function MoveNext() As Boolean
[C#]
public final bool MoveNext();

See Also

MappedDriveMapEnumerator Class | MappedDriveMapEnumerator Members | Genghis.Win32 Namespace


MappedDriveMapEnumerator.Reset Method

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

MappedDriveMapEnumerator Class | MappedDriveMapEnumerator Members | Genghis.Win32 Namespace


MappedDrives Class

Used to load a list of mapped drives from the registry Provides an event handler to notify clients that the mapped drives have been changed

For a list of all members of this type, see MappedDrives Members.

System.Object
MappedDrives

[Visual Basic]
Public Class MappedDrives
[C#]
public class MappedDrives

Requirements

Namespace: Genghis.Win32 Namespace

Assembly: Genghis.dll

See Also

MappedDrives Members | Genghis.Win32 Namespace


MappedDrives Members

Public Static (Shared) Properties

Maps Retreives a MappedDriveMap copy representing all the currently mapped drives

Public Static (Shared) Events

MappedDrivesChanged Occurrs any time the mapped drives have been changed

Protected Static (Shared) Methods

OnEventArrived | Occurs any time we receive a notification about mapped drives changing from the WMI event handler
OnMappedDrivesChanged | Occurrs any time the system mapped drives have been changed

Public Instance Methods

Dispose | Overrides IDisposable.Dispose - terminates our WMI event watcher
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize |
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

MappedDrives Class | Genghis.Win32 Namespace


MappedDrives Properties

The properties of the MappedDrives class are listed below. For a complete list of MappedDrives class members, see the MappedDrives Members topic.

Public Static (Shared) Properties

Maps Retreives a MappedDriveMap copy representing all the currently mapped drives

See Also

MappedDrives Class | Genghis.Win32 Namespace


MappedDrives.Maps Property

Retreives a MappedDriveMap copy representing all the currently mapped drives

[Visual Basic]
Public Shared ReadOnly Property Maps As Genghis.Win32.MappedDriveMap
[C#]
public static MappedDriveMap Maps {get;}

Remarks

The key to the MappedDriveMap is the local drive letter expressed like X:\, and the value is the remote UNC path expressed like \\Server\share\file.ext

See Also

MappedDrives Class | MappedDrives Members | Genghis.Win32 Namespace


MappedDrives Methods

The methods of the MappedDrives class are listed below. For a complete list of MappedDrives class members, see the MappedDrives Members topic.

Protected Static (Shared) Methods

OnEventArrived | Occurs any time we receive a notification about mapped drives changing from the WMI event handler
OnMappedDrivesChanged | Occurrs any time the system mapped drives have been changed

Public Instance Methods

Dispose | Overrides IDisposable.Dispose - terminates our WMI event watcher
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize |
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

MappedDrives Class | Genghis.Win32 Namespace


MappedDrives.Dispose Method

Overrides IDisposable.Dispose - terminates our WMI event watcher

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();

See Also

MappedDrives Class | MappedDrives Members | Genghis.Win32 Namespace


MappedDrives.Finalize Method

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();

See Also

MappedDrives Class | MappedDrives Members | Genghis.Win32 Namespace


MappedDrives.OnEventArrived Method

Occurs any time we receive a notification about mapped drives changing from the WMI event handler

[Visual Basic]
Protected Shared Sub OnEventArrived( _
   ByVal sender As Object, _
   ByVal e As System.Management.EventArrivedEventArgs _
)
[C#]
protected static void OnEventArrived(
   object sender,
   EventArrivedEventArgs e
);

Parameters

sender
>A System.Object representing the originator of the event
e
A System.EventArgs representing additional data relevant to the event

See Also

MappedDrives Class | MappedDrives Members | Genghis.Win32 Namespace


MappedDrives.OnMappedDrivesChanged Method

Occurrs any time the system mapped drives have been changed

[Visual Basic]
Protected Shared Sub OnMappedDrivesChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
)
[C#]
protected static void OnMappedDrivesChanged(
   object sender,
   EventArgs e
);

Parameters

sender
A System.Object representing the originator of the event
e
A System.EventArgs representing additional data relevant to the event

See Also

MappedDrives Class | MappedDrives Members | Genghis.Win32 Namespace


MappedDrives Events

The events of the MappedDrives class are listed below. For a complete list of MappedDrives class members, see the MappedDrives Members topic.

Public Static (Shared) Events

MappedDrivesChanged Occurrs any time the mapped drives have been changed

See Also

MappedDrives Class | Genghis.Win32 Namespace


MappedDrives.MappedDrivesChanged Event

Occurrs any time the mapped drives have been changed

[Visual Basic]
Public Shared MappedDrivesChanged As Genghis.Win32.MappedDrivesChangedEventHandler
[C#]
public static MappedDrivesChangedEventHandler MappedDrivesChanged;

See Also

MappedDrives Class | MappedDrives Members | Genghis.Win32 Namespace


MappedDrivesChangedEventHandler Delegate

The delegate corresponding to the OnMappedDrivesChanged event

[Visual Basic]
Public Delegate Sub MappedDrivesChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
)
[C#]
public delegate void MappedDrivesChangedEventHandler(
   object sender,
   EventArgs e
);

Requirements

Namespace: Genghis.Win32 Namespace

Assembly: Genghis.dll

See Also

Genghis.Win32 Namespace


NetworkConnection.AccessMaskValues Enumeration

[Visual Basic]
Public Enum NetworkConnection.AccessMaskValues
[C#]
public enum NetworkConnection.AccessMaskValues

Members

Member Name | Description
FILE_READ_DATA_file_or_FILE_LIST_DIRECTORY_directory_ |
FILE_WRITE_DATA_file_or_FILE_ADD_FILE_directory_ |
FILE_APPEND_DATA_file_or_FILE_ADD_SUBDIRECTORY_directory_ |
FILE_READ_EA |
FILE_WRITE_EA |
FILE_EXECUTE_file_or_FILE_TRAVERSE_directory_ |
FILE_DELETE_CHILD_directory_ |
FILE_READ_ATTRIBUTES |
FILE_WRITE_ATTRIBUTES |
DELETE |
READ_CONTROL |
WRITE_DAC |
WRITE_OWNER |
SYNCHRONIZE |

Requirements

Namespace: Genghis.Win32 Namespace

Assembly: Genghis.dll

See Also

Genghis.Win32 Namespace


NetworkConnection.ManagementSystemProperties Class

For a list of all members of this type, see NetworkConnection.ManagementSystemProperties Members.

System.Object
NetworkConnection.ManagementSystemProperties

[Visual Basic]
Public Class NetworkConnection.ManagementSystemProperties
[C#]
public class NetworkConnection.ManagementSystemProperties

Requirements

Namespace: Genghis.Win32 Namespace

Assembly: Genghis.dll

See Also

NetworkConnection.ManagementSystemProperties Members | Genghis.Win32 Namespace


NetworkConnection.ManagementSystemProperties Members

Public Instance Constructors

NetworkConnection.ManagementSystemProperties Constructor

Public Instance Properties

CLASS
DERIVATION
DYNASTY
GENUS
NAMESPACE
PATH
PROPERTY_COUNT
RELPATH
SERVER
SUPERCLASS

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

NetworkConnection.ManagementSystemProperties Class | Genghis.Win32 Namespace


NetworkConnection.ManagementSystemProperties Constructor

[Visual Basic]
Public Sub New( _
   ByVal ManagedObject As System.Management.ManagementBaseObject _
)
[C#]
public NetworkConnection.ManagementSystemProperties(
   ManagementBaseObject ManagedObject
);

See Also

NetworkConnection.ManagementSystemProperties Class | NetworkConnection.ManagementSystemProperties Members | Genghis.Win32 Namespace


NetworkConnection.ManagementSystemProperties Properties

The properties of the NetworkConnection.ManagementSystemProperties class are listed below. For a complete list of NetworkConnection.ManagementSystemProperties class members, see the NetworkConnection.ManagementSystemProperties Members topic.

Public Instance Properties

CLASS
DERIVATION
DYNASTY
GENUS
NAMESPACE
PATH
PROPERTY_COUNT
RELPATH
SERVER
SUPERCLASS

See Also

NetworkConnection.ManagementSystemProperties Class | Genghis.Win32 Namespace


NetworkConnection.ManagementSystemProperties.CLASS Property

[Visual Basic]
Public ReadOnly Property CLASS As String
[C#]
public string CLASS {get;}

See Also

NetworkConnection.ManagementSystemProperties Class | NetworkConnection.ManagementSystemProperties Members | Genghis.Win32 Namespace


NetworkConnection.ManagementSystemProperties.DERIVATION Property

[Visual Basic]
Public ReadOnly Property DERIVATION As String()
[C#]
public string[] DERIVATION {get;}

See Also

NetworkConnection.ManagementSystemProperties Class | NetworkConnection.ManagementSystemProperties Members | Genghis.Win32 Namespace


NetworkConnection.ManagementSystemProperties.DYNASTY Property

[Visual Basic]
Public ReadOnly Property DYNASTY As String
[C#]
public string DYNASTY {get;}

See Also

NetworkConnection.ManagementSystemProperties Class | NetworkConnection.ManagementSystemProperties Members | Genghis.Win32 Namespace


NetworkConnection.ManagementSystemProperties.GENUS Property

[Visual Basic]
Public ReadOnly Property GENUS As Integer
[C#]
public int GENUS {get;}

See Also

NetworkConnection.ManagementSystemProperties Class | NetworkConnection.ManagementSystemProperties Members | Genghis.Win32 Namespace


NetworkConnection.ManagementSystemProperties.NAMESPACE Property

[Visual Basic]
Public ReadOnly Property NAMESPACE As String
[C#]
public string NAMESPACE {get;}

See Also

NetworkConnection.ManagementSystemProperties Class | NetworkConnection.ManagementSystemProperties Members | Genghis.Win32 Namespace


NetworkConnection.ManagementSystemProperties.PATH Property

[Visual Basic]
Public ReadOnly Property PATH As String
[C#]
public string PATH {get;}

See Also

NetworkConnection.ManagementSystemProperties Class | NetworkConnection.ManagementSystemProperties Members | Genghis.Win32 Namespace


NetworkConnection.ManagementSystemProperties.PROPERTY_COUNT Property

[Visual Basic]
Public ReadOnly Property PROPERTY_COUNT As Integer
[C#]
public int PROPERTY_COUNT {get;}

See Also

NetworkConnection.ManagementSystemProperties Class | NetworkConnection.ManagementSystemProperties Members | Genghis.Win32 Namespace


NetworkConnection.ManagementSystemProperties.RELPATH Property

[Visual Basic]
Public ReadOnly Property RELPATH As String
[C#]
public string RELPATH {get;}

See Also

NetworkConnection.ManagementSystemProperties Class | NetworkConnection.ManagementSystemProperties Members | Genghis.Win32 Namespace


NetworkConnection.ManagementSystemProperties.SERVER Property

[Visual Basic]
Public ReadOnly Property SERVER As String
[C#]
public string SERVER {get;}

See Also

NetworkConnection.ManagementSystemProperties Class | NetworkConnection.ManagementSystemProperties Members | Genghis.Win32 Namespace


NetworkConnection.ManagementSystemProperties.SUPERCLASS Property

[Visual Basic]
Public ReadOnly Property SUPERCLASS As String
[C#]
public string SUPERCLASS {get;}

See Also

NetworkConnection.ManagementSystemProperties Class | NetworkConnection.ManagementSystemProperties Members | Genghis.Win32 Namespace


NetworkConnection.NetworkConnectionCollection Class

For a list of all members of this type, see NetworkConnection.NetworkConnectionCollection Members.

System.Object
NetworkConnection.NetworkConnectionCollection

[Visual Basic]
Public Class NetworkConnection.NetworkConnectionCollection
   Implements ICollection, IEnumerable
[C#]
public class NetworkConnection.NetworkConnectionCollection : ICollection, IEnumerable

Requirements

Namespace: Genghis.Win32 Namespace

Assembly: Genghis.dll

See Also

NetworkConnection.NetworkConnectionCollection Members | Genghis.Win32 Namespace


NetworkConnection.NetworkConnectionCollection Members

Public Instance Constructors

NetworkConnection.NetworkConnectionCollection Constructor

Public Instance Properties

Count
IsSynchronized
SyncRoot

Public Instance Methods

CopyTo |
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetEnumerator |
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

NetworkConnection.NetworkConnectionCollection Class | Genghis.Win32 Namespace


NetworkConnection.NetworkConnectionCollection Constructor

[Visual Basic]
Public Sub New( _
   ByVal objCollection As System.Management.ManagementObjectCollection _
)
[C#]
public NetworkConnection.NetworkConnectionCollection(
   ManagementObjectCollection objCollection
);

See Also

NetworkConnection.NetworkConnectionCollection Class | NetworkConnection.NetworkConnectionCollection Members | Genghis.Win32 Namespace


NetworkConnection.NetworkConnectionCollection Properties

The properties of the NetworkConnection.NetworkConnectionCollection class are listed below. For a complete list of NetworkConnection.NetworkConnectionCollection class members, see the NetworkConnection.NetworkConnectionCollection Members topic.

Public Instance Properties

Count
IsSynchronized
SyncRoot

See Also

NetworkConnection.NetworkConnectionCollection Class | Genghis.Win32 Namespace


NetworkConnection.NetworkConnectionCollection.Count Property

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer
[C#]
public int Count {final get;}

See Also

NetworkConnection.NetworkConnectionCollection Class | NetworkConnection.NetworkConnectionCollection Members | Genghis.Win32 Namespace


NetworkConnection.NetworkConnectionCollection.IsSynchronized Property

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean
[C#]
public bool IsSynchronized {final get;}

See Also

NetworkConnection.NetworkConnectionCollection Class | NetworkConnection.NetworkConnectionCollection Members | Genghis.Win32 Namespace


NetworkConnection.NetworkConnectionCollection.SyncRoot Property

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object
[C#]
public object SyncRoot {final get;}

See Also

NetworkConnection.NetworkConnectionCollection Class | NetworkConnection.NetworkConnectionCollection Members | Genghis.Win32 Namespace


NetworkConnection.NetworkConnectionCollection Methods

The methods of the NetworkConnection.NetworkConnectionCollection class are listed below. For a complete list of NetworkConnection.NetworkConnectionCollection class members, see the NetworkConnection.NetworkConnectionCollection Members topic.

Public Instance Methods

CopyTo |
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetEnumerator |
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

NetworkConnection.NetworkConnectionCollection Class | Genghis.Win32 Namespace


NetworkConnection.NetworkConnectionCollection.CopyTo Method

[Visual Basic]
NotOverridable Public Sub CopyTo( _
   ByVal array As System.Array, _
   ByVal index As Integer _
)
[C#]
public final void CopyTo(
   Array array,
   int index
);

See Also

NetworkConnection.NetworkConnectionCollection Class | NetworkConnection.NetworkConnectionCollection Members | Genghis.Win32 Namespace


NetworkConnection.NetworkConnectionCollection.GetEnumerator Method

[Visual Basic]
NotOverridable Public Function GetEnumerator() As System.Collections.IEnumerator
[C#]
public final IEnumerator GetEnumerator();

See Also

NetworkConnection.NetworkConnectionCollection Class | NetworkConnection.NetworkConnectionCollection Members | Genghis.Win32 Namespace


NetworkConnection.NetworkConnectionCollection.NetworkConnectionEnumerator Class

For a list of all members of this type, see NetworkConnection.NetworkConnectionCollection.NetworkConnectionEnumerator Members.

System.Object
NetworkConnection.NetworkConnectionCollection.NetworkConnectionEnumerator

[Visual Basic]
Public Class NetworkConnection.NetworkConnectionCollection.NetworkConnectionEnumerator
   Implements IEnumerator
[C#]
public class NetworkConnection.NetworkConnectionCollection.NetworkConnectionEnumerator : IEnumerator

Requirements

Namespace: Genghis.Win32 Namespace

Assembly: Genghis.dll

See Also

NetworkConnection.NetworkConnectionCollection.NetworkConnectionEnumerator Members | Genghis.Win32 Namespace


NetworkConnection.NetworkConnectionCollection.NetworkConnectionEnumerator Members

Public Instance Constructors

NetworkConnection.NetworkConnectionCollection.NetworkConnectionEnumerator Constructor

Public Instance Properties

Current

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
MoveNext |
Reset |
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

NetworkConnection.NetworkConnectionCollection.NetworkConnectionEnumerator Class | Genghis.Win32 Namespace


NetworkConnection.NetworkConnectionCollection.NetworkConnectionEnumerator Constructor

[Visual Basic]
Public Sub New( _
   ByVal objEnum As System.Management.ManagementObjectCollection.ManagementObjectEnumerator _
)
[C#]
public NetworkConnection.NetworkConnectionCollection.NetworkConnectionEnumerator(
   ManagementObjectEnumerator objEnum
);

See Also

NetworkConnection.NetworkConnectionCollection.NetworkConnectionEnumerator Class | NetworkConnection.NetworkConnectionCollection.NetworkConnectionEnumerator Members | Genghis.Win32 Namespace


NetworkConnection.NetworkConnectionCollection.NetworkConnectionEnumerator Properties

The properties of the NetworkConnection.NetworkConnectionCollection.NetworkConnectionEnumerator class are listed below. For a complete list of NetworkConnection.NetworkConnectionCollection.NetworkConnectionEnumerator class members, see the NetworkConnection.NetworkConnectionCollection.NetworkConnectionEnumerator Members topic.

Public Instance Properties

Current

See Also

NetworkConnection.NetworkConnectionCollection.NetworkConnectionEnumerator Class | Genghis.Win32 Namespace


NetworkConnection.NetworkConnectionCollection.NetworkConnectionEnumerator.Current Property

[Visual Basic]
NotOverridable Public ReadOnly Property Current As Object
[C#]
public object Current {final get;}

See Also

NetworkConnection.NetworkConnectionCollection.NetworkConnectionEnumerator Class | NetworkConnection.NetworkConnectionCollection.NetworkConnectionEnumerator Members | Genghis.Win32 Namespace


NetworkConnection.NetworkConnectionCollection.NetworkConnectionEnumerator Methods

The methods of the NetworkConnection.NetworkConnectionCollection.NetworkConnectionEnumerator class are listed below. For a complete list of NetworkConnection.NetworkConnectionCollection.NetworkConnectionEnumerator class members, see the NetworkConnection.NetworkConnectionCollection.NetworkConnectionEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
MoveNext |
Reset |
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

NetworkConnection.NetworkConnectionCollection.NetworkConnectionEnumerator Class | Genghis.Win32 Namespace


NetworkConnection.NetworkConnectionCollection.NetworkConnectionEnumerator.MoveNext Method

[Visual Basic]
NotOverridable Public Function MoveNext() As Boolean
[C#]
public final bool MoveNext();

See Also

NetworkConnection.NetworkConnectionCollection.NetworkConnectionEnumerator Class | NetworkConnection.NetworkConnectionCollection.NetworkConnectionEnumerator Members | Genghis.Win32 Namespace


NetworkConnection.NetworkConnectionCollection.NetworkConnectionEnumerator.Reset Method

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

NetworkConnection.NetworkConnectionCollection.NetworkConnectionEnumerator Class | NetworkConnection.NetworkConnectionCollection.NetworkConnectionEnumerator Members | Genghis.Win32 Namespace


NetworkConnection.WMIValueTypeConverter Class

For a list of all members of this type, see NetworkConnection.WMIValueTypeConverter Members.

System.Object
TypeConverter
NetworkConnection.WMIValueTypeConverter

[Visual Basic]
Public Class NetworkConnection.WMIValueTypeConverter
   Inherits TypeConverter
[C#]
public class NetworkConnection.WMIValueTypeConverter : TypeConverter

Requirements

Namespace: Genghis.Win32 Namespace

Assembly: Genghis.dll

See Also

NetworkConnection.WMIValueTypeConverter Members | Genghis.Win32 Namespace


NetworkConnection.WMIValueTypeConverter Members

Public Instance Constructors

NetworkConnection.WMIValueTypeConverter Constructor

Public Instance Methods

CanConvertFrom | Overloaded.
CanConvertFrom (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
CanConvertTo | Overloaded.
CanConvertTo (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFrom | Overloaded.
ConvertFrom (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFromInvariantString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFromInvariantString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFromString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFromString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFromString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertTo | Overloaded.
ConvertTo (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertToInvariantString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertToInvariantString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertToString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertToString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertToString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
CreateInstance | Overloaded.
CreateInstance (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetCreateInstanceSupported | Overloaded.
GetCreateInstanceSupported (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetProperties | Overloaded.
GetProperties (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetProperties (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetPropertiesSupported | Overloaded.
GetPropertiesSupported (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetStandardValues | Overloaded.
GetStandardValues (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesExclusive (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetStandardValuesSupported | Overloaded.
GetStandardValuesSupported (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsValid (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
IsValid (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetConvertFromException (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetConvertToException (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
SortProperties (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.

See Also

NetworkConnection.WMIValueTypeConverter Class | Genghis.Win32 Namespace


NetworkConnection.WMIValueTypeConverter Constructor

[Visual Basic]
Public Sub New( _
   ByVal baseType As System.Type _
)
[C#]
public NetworkConnection.WMIValueTypeConverter(
   Type baseType
);

See Also

NetworkConnection.WMIValueTypeConverter Class | NetworkConnection.WMIValueTypeConverter Members | Genghis.Win32 Namespace


NetworkConnection.WMIValueTypeConverter Methods

The methods of the NetworkConnection.WMIValueTypeConverter class are listed below. For a complete list of NetworkConnection.WMIValueTypeConverter class members, see the NetworkConnection.WMIValueTypeConverter Members topic.

Public Instance Methods

CanConvertFrom | Overloaded.
CanConvertFrom (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
CanConvertTo | Overloaded.
CanConvertTo (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFrom | Overloaded.
ConvertFrom (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFromInvariantString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFromInvariantString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFromString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFromString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFromString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertTo | Overloaded.
ConvertTo (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertToInvariantString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertToInvariantString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertToString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertToString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertToString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
CreateInstance | Overloaded.
CreateInstance (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetCreateInstanceSupported | Overloaded.
GetCreateInstanceSupported (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetProperties | Overloaded.
GetProperties (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetProperties (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetPropertiesSupported | Overloaded.
GetPropertiesSupported (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetStandardValues | Overloaded.
GetStandardValues (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesExclusive (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetStandardValuesSupported | Overloaded.
GetStandardValuesSupported (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsValid (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
IsValid (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetConvertFromException (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetConvertToException (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
SortProperties (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.

See Also

NetworkConnection.WMIValueTypeConverter Class | Genghis.Win32 Namespace


NetworkConnection.WMIValueTypeConverter.CanConvertFrom Method (ITypeDescriptorContext, Type)

[Visual Basic]
Overrides Overloads Public Function CanConvertFrom( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal srcType As System.Type _
) As Boolean
[C#]
public override bool CanConvertFrom(
   ITypeDescriptorContext context,
   Type srcType
);

See Also

NetworkConnection.WMIValueTypeConverter Class | NetworkConnection.WMIValueTypeConverter Members | Genghis.Win32 Namespace | NetworkConnection.WMIValueTypeConverter.CanConvertFrom Overload List


NetworkConnection.WMIValueTypeConverter.CanConvertTo Method (ITypeDescriptorContext, Type)

[Visual Basic]
Overrides Overloads Public Function CanConvertTo( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal destinationType As System.Type _
) As Boolean
[C#]
public override bool CanConvertTo(
   ITypeDescriptorContext context,
   Type destinationType
);

See Also

NetworkConnection.WMIValueTypeConverter Class | NetworkConnection.WMIValueTypeConverter Members | Genghis.Win32 Namespace | NetworkConnection.WMIValueTypeConverter.CanConvertTo Overload List


NetworkConnection.WMIValueTypeConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

[Visual Basic]
Overrides Overloads Public Function ConvertFrom( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal culture As System.Globalization.CultureInfo, _
   ByVal value As Object _
) As Object
[C#]
public override object ConvertFrom(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value
);

See Also

NetworkConnection.WMIValueTypeConverter Class | NetworkConnection.WMIValueTypeConverter Members | Genghis.Win32 Namespace | NetworkConnection.WMIValueTypeConverter.ConvertFrom Overload List


NetworkConnection.WMIValueTypeConverter.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

[Visual Basic]
Overrides Overloads Public Function ConvertTo( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal culture As System.Globalization.CultureInfo, _
   ByVal value As Object, _
   ByVal destinationType As System.Type _
) As Object
[C#]
public override object ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value,
   Type destinationType
);

See Also

NetworkConnection.WMIValueTypeConverter Class | NetworkConnection.WMIValueTypeConverter Members | Genghis.Win32 Namespace | NetworkConnection.WMIValueTypeConverter.ConvertTo Overload List


NetworkConnection.WMIValueTypeConverter.CreateInstance Method (ITypeDescriptorContext, IDictionary)

[Visual Basic]
Overrides Overloads Public Function CreateInstance( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal dictionary As System.Collections.IDictionary _
) As Object
[C#]
public override object CreateInstance(
   ITypeDescriptorContext context,
   IDictionary dictionary
);

See Also

NetworkConnection.WMIValueTypeConverter Class | NetworkConnection.WMIValueTypeConverter Members | Genghis.Win32 Namespace | NetworkConnection.WMIValueTypeConverter.CreateInstance Overload List


NetworkConnection.WMIValueTypeConverter.GetCreateInstanceSupported Method (ITypeDescriptorContext)

[Visual Basic]
Overrides Overloads Public Function GetCreateInstanceSupported( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext _
) As Boolean
[C#]
public override bool GetCreateInstanceSupported(
   ITypeDescriptorContext context
);

See Also

NetworkConnection.WMIValueTypeConverter Class | NetworkConnection.WMIValueTypeConverter Members | Genghis.Win32 Namespace | NetworkConnection.WMIValueTypeConverter.GetCreateInstanceSupported Overload List


NetworkConnection.WMIValueTypeConverter.GetProperties Method (ITypeDescriptorContext, Object, Attribute[])

[Visual Basic]
Overrides Overloads Public Function GetProperties( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal attributeVar As System.Attribute() _
) As System.ComponentModel.PropertyDescriptorCollection
[C#]
public override PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object value,
   Attribute[] attributeVar
);

See Also

NetworkConnection.WMIValueTypeConverter Class | NetworkConnection.WMIValueTypeConverter Members | Genghis.Win32 Namespace | NetworkConnection.WMIValueTypeConverter.GetProperties Overload List


NetworkConnection.WMIValueTypeConverter.GetPropertiesSupported Method (ITypeDescriptorContext)

[Visual Basic]
Overrides Overloads Public Function GetPropertiesSupported( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext _
) As Boolean
[C#]
public override bool GetPropertiesSupported(
   ITypeDescriptorContext context
);

See Also

NetworkConnection.WMIValueTypeConverter Class | NetworkConnection.WMIValueTypeConverter Members | Genghis.Win32 Namespace | NetworkConnection.WMIValueTypeConverter.GetPropertiesSupported Overload List


NetworkConnection.WMIValueTypeConverter.GetStandardValues Method (ITypeDescriptorContext)

[Visual Basic]
Overrides Overloads Public Function GetStandardValues( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext _
) As System.ComponentModel.TypeConverter.StandardValuesCollection
[C#]
public override StandardValuesCollection GetStandardValues(
   ITypeDescriptorContext context
);

See Also

NetworkConnection.WMIValueTypeConverter Class | NetworkConnection.WMIValueTypeConverter Members | Genghis.Win32 Namespace | NetworkConnection.WMIValueTypeConverter.GetStandardValues Overload List


NetworkConnection.WMIValueTypeConverter.GetStandardValuesExclusive Method (ITypeDescriptorContext)

[Visual Basic]
Overrides Overloads Public Function GetStandardValuesExclusive( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext _
) As Boolean
[C#]
public override bool GetStandardValuesExclusive(
   ITypeDescriptorContext context
);

See Also

NetworkConnection.WMIValueTypeConverter Class | NetworkConnection.WMIValueTypeConverter Members | Genghis.Win32 Namespace | NetworkConnection.WMIValueTypeConverter.GetStandardValuesExclusive Overload List


NetworkConnection.WMIValueTypeConverter.GetStandardValuesSupported Method (ITypeDescriptorContext)

[Visual Basic]
Overrides Overloads Public Function GetStandardValuesSupported( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext _
) As Boolean
[C#]
public override bool GetStandardValuesSupported(
   ITypeDescriptorContext context
);

See Also

NetworkConnection.WMIValueTypeConverter Class | NetworkConnection.WMIValueTypeConverter Members | Genghis.Win32 Namespace | NetworkConnection.WMIValueTypeConverter.GetStandardValuesSupported Overload List


Share.AccessMaskValues Enumeration

[Visual Basic]
Public Enum Share.AccessMaskValues
[C#]
public enum Share.AccessMaskValues

Members

Member Name | Description
FILE_LIST_DIRECTORY |
FILE_ADD_FILE |
FILE_ADD_SUBDIRECTORY |
FILE_READ_EA |
FILE_WRITE_EA |
FILE_TRAVERSE |
FILE_DELETE_CHILD |
FILE_READ_ATTRIBUTES |
FILE_WRITE_ATTRIBUTES |
DELETE |
READ_CONTROL |
WRITE_DAC |
WRITE_OWNER |
SYNCHRONIZE |

Requirements

Namespace: Genghis.Win32 Namespace

Assembly: Genghis.dll

See Also

Genghis.Win32 Namespace


Share.ManagementSystemProperties Class

For a list of all members of this type, see Share.ManagementSystemProperties Members.

System.Object
Share.ManagementSystemProperties

[Visual Basic]
Public Class Share.ManagementSystemProperties
[C#]
public class Share.ManagementSystemProperties

Requirements

Namespace: Genghis.Win32 Namespace

Assembly: Genghis.dll

See Also

Share.ManagementSystemProperties Members | Genghis.Win32 Namespace


Share.ManagementSystemProperties Members

Public Instance Constructors

Share.ManagementSystemProperties Constructor

Public Instance Properties

CLASS
DERIVATION
DYNASTY
GENUS
NAMESPACE
PATH
PROPERTY_COUNT
RELPATH
SERVER
SUPERCLASS

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

Share.ManagementSystemProperties Class | Genghis.Win32 Namespace


Share.ManagementSystemProperties Constructor

[Visual Basic]
Public Sub New( _
   ByVal ManagedObject As System.Management.ManagementBaseObject _
)
[C#]
public Share.ManagementSystemProperties(
   ManagementBaseObject ManagedObject
);

See Also

Share.ManagementSystemProperties Class | Share.ManagementSystemProperties Members | Genghis.Win32 Namespace


Share.ManagementSystemProperties Properties

The properties of the Share.ManagementSystemProperties class are listed below. For a complete list of Share.ManagementSystemProperties class members, see the Share.ManagementSystemProperties Members topic.

Public Instance Properties

CLASS
DERIVATION
DYNASTY
GENUS
NAMESPACE
PATH
PROPERTY_COUNT
RELPATH
SERVER
SUPERCLASS

See Also

Share.ManagementSystemProperties Class | Genghis.Win32 Namespace


Share.ManagementSystemProperties.CLASS Property

[Visual Basic]
Public ReadOnly Property CLASS As String
[C#]
public string CLASS {get;}

See Also

Share.ManagementSystemProperties Class | Share.ManagementSystemProperties Members | Genghis.Win32 Namespace


Share.ManagementSystemProperties.DERIVATION Property

[Visual Basic]
Public ReadOnly Property DERIVATION As String()
[C#]
public string[] DERIVATION {get;}

See Also

Share.ManagementSystemProperties Class | Share.ManagementSystemProperties Members | Genghis.Win32 Namespace


Share.ManagementSystemProperties.DYNASTY Property

[Visual Basic]
Public ReadOnly Property DYNASTY As String
[C#]
public string DYNASTY {get;}

See Also

Share.ManagementSystemProperties Class | Share.ManagementSystemProperties Members | Genghis.Win32 Namespace


Share.ManagementSystemProperties.GENUS Property

[Visual Basic]
Public ReadOnly Property GENUS As Integer
[C#]
public int GENUS {get;}

See Also

Share.ManagementSystemProperties Class | Share.ManagementSystemProperties Members | Genghis.Win32 Namespace


Share.ManagementSystemProperties.NAMESPACE Property

[Visual Basic]
Public ReadOnly Property NAMESPACE As String
[C#]
public string NAMESPACE {get;}

See Also

Share.ManagementSystemProperties Class | Share.ManagementSystemProperties Members | Genghis.Win32 Namespace


Share.ManagementSystemProperties.PATH Property

[Visual Basic]
Public ReadOnly Property PATH As String
[C#]
public string PATH {get;}

See Also

Share.ManagementSystemProperties Class | Share.ManagementSystemProperties Members | Genghis.Win32 Namespace


Share.ManagementSystemProperties.PROPERTY_COUNT Property

[Visual Basic]
Public ReadOnly Property PROPERTY_COUNT As Integer
[C#]
public int PROPERTY_COUNT {get;}

See Also

Share.ManagementSystemProperties Class | Share.ManagementSystemProperties Members | Genghis.Win32 Namespace


Share.ManagementSystemProperties.RELPATH Property

[Visual Basic]
Public ReadOnly Property RELPATH As String
[C#]
public string RELPATH {get;}

See Also

Share.ManagementSystemProperties Class | Share.ManagementSystemProperties Members | Genghis.Win32 Namespace


Share.ManagementSystemProperties.SERVER Property

[Visual Basic]
Public ReadOnly Property SERVER As String
[C#]
public string SERVER {get;}

See Also

Share.ManagementSystemProperties Class | Share.ManagementSystemProperties Members | Genghis.Win32 Namespace


Share.ManagementSystemProperties.SUPERCLASS Property

[Visual Basic]
Public ReadOnly Property SUPERCLASS As String
[C#]
public string SUPERCLASS {get;}

See Also

Share.ManagementSystemProperties Class | Share.ManagementSystemProperties Members | Genghis.Win32 Namespace


Share.ShareCollection Class

For a list of all members of this type, see Share.ShareCollection Members.

System.Object
Share.ShareCollection

[Visual Basic]
Public Class Share.ShareCollection
   Implements ICollection, IEnumerable
[C#]
public class Share.ShareCollection : ICollection, IEnumerable

Requirements

Namespace: Genghis.Win32 Namespace

Assembly: Genghis.dll

See Also

Share.ShareCollection Members | Genghis.Win32 Namespace


Share.ShareCollection Members

Public Instance Constructors

Share.ShareCollection Constructor

Public Instance Properties

Count
IsSynchronized
SyncRoot

Public Instance Methods

CopyTo |
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetEnumerator |
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

Share.ShareCollection Class | Genghis.Win32 Namespace


Share.ShareCollection Constructor

[Visual Basic]
Public Sub New( _
   ByVal objCollection As System.Management.ManagementObjectCollection _
)
[C#]
public Share.ShareCollection(
   ManagementObjectCollection objCollection
);

See Also

Share.ShareCollection Class | Share.ShareCollection Members | Genghis.Win32 Namespace


Share.ShareCollection Properties

The properties of the Share.ShareCollection class are listed below. For a complete list of Share.ShareCollection class members, see the Share.ShareCollection Members topic.

Public Instance Properties

Count
IsSynchronized
SyncRoot

See Also

Share.ShareCollection Class | Genghis.Win32 Namespace


Share.ShareCollection.Count Property

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer
[C#]
public int Count {final get;}

See Also

Share.ShareCollection Class | Share.ShareCollection Members | Genghis.Win32 Namespace


Share.ShareCollection.IsSynchronized Property

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean
[C#]
public bool IsSynchronized {final get;}

See Also

Share.ShareCollection Class | Share.ShareCollection Members | Genghis.Win32 Namespace


Share.ShareCollection.SyncRoot Property

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object
[C#]
public object SyncRoot {final get;}

See Also

Share.ShareCollection Class | Share.ShareCollection Members | Genghis.Win32 Namespace


Share.ShareCollection Methods

The methods of the Share.ShareCollection class are listed below. For a complete list of Share.ShareCollection class members, see the Share.ShareCollection Members topic.

Public Instance Methods

CopyTo |
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetEnumerator |
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

Share.ShareCollection Class | Genghis.Win32 Namespace


Share.ShareCollection.CopyTo Method

[Visual Basic]
NotOverridable Public Sub CopyTo( _
   ByVal array As System.Array, _
   ByVal index As Integer _
)
[C#]
public final void CopyTo(
   Array array,
   int index
);

See Also

Share.ShareCollection Class | Share.ShareCollection Members | Genghis.Win32 Namespace


Share.ShareCollection.GetEnumerator Method

[Visual Basic]
NotOverridable Public Function GetEnumerator() As System.Collections.IEnumerator
[C#]
public final IEnumerator GetEnumerator();

See Also

Share.ShareCollection Class | Share.ShareCollection Members | Genghis.Win32 Namespace


Share.ShareCollection.ShareEnumerator Class

For a list of all members of this type, see Share.ShareCollection.ShareEnumerator Members.

System.Object
Share.ShareCollection.ShareEnumerator

[Visual Basic]
Public Class Share.ShareCollection.ShareEnumerator
   Implements IEnumerator
[C#]
public class Share.ShareCollection.ShareEnumerator : IEnumerator

Requirements

Namespace: Genghis.Win32 Namespace

Assembly: Genghis.dll

See Also

Share.ShareCollection.ShareEnumerator Members | Genghis.Win32 Namespace


Share.ShareCollection.ShareEnumerator Members

Public Instance Constructors

Share.ShareCollection.ShareEnumerator Constructor

Public Instance Properties

Current

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
MoveNext |
Reset |
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

Share.ShareCollection.ShareEnumerator Class | Genghis.Win32 Namespace


Share.ShareCollection.ShareEnumerator Constructor

[Visual Basic]
Public Sub New( _
   ByVal objEnum As System.Management.ManagementObjectCollection.ManagementObjectEnumerator _
)
[C#]
public Share.ShareCollection.ShareEnumerator(
   ManagementObjectEnumerator objEnum
);

See Also

Share.ShareCollection.ShareEnumerator Class | Share.ShareCollection.ShareEnumerator Members | Genghis.Win32 Namespace


Share.ShareCollection.ShareEnumerator Properties

The properties of the Share.ShareCollection.ShareEnumerator class are listed below. For a complete list of Share.ShareCollection.ShareEnumerator class members, see the Share.ShareCollection.ShareEnumerator Members topic.

Public Instance Properties

Current

See Also

Share.ShareCollection.ShareEnumerator Class | Genghis.Win32 Namespace


Share.ShareCollection.ShareEnumerator.Current Property

[Visual Basic]
NotOverridable Public ReadOnly Property Current As Object
[C#]
public object Current {final get;}

See Also

Share.ShareCollection.ShareEnumerator Class | Share.ShareCollection.ShareEnumerator Members | Genghis.Win32 Namespace


Share.ShareCollection.ShareEnumerator Methods

The methods of the Share.ShareCollection.ShareEnumerator class are listed below. For a complete list of Share.ShareCollection.ShareEnumerator class members, see the Share.ShareCollection.ShareEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
MoveNext |
Reset |
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

Share.ShareCollection.ShareEnumerator Class | Genghis.Win32 Namespace


Share.ShareCollection.ShareEnumerator.MoveNext Method

[Visual Basic]
NotOverridable Public Function MoveNext() As Boolean
[C#]
public final bool MoveNext();

See Also

Share.ShareCollection.ShareEnumerator Class | Share.ShareCollection.ShareEnumerator Members | Genghis.Win32 Namespace


Share.ShareCollection.ShareEnumerator.Reset Method

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

Share.ShareCollection.ShareEnumerator Class | Share.ShareCollection.ShareEnumerator Members | Genghis.Win32 Namespace


Share.TypeValues Enumeration

[Visual Basic]
Public Enum Share.TypeValues
[C#]
public enum Share.TypeValues

Members

Member Name | Description
Disk_Drive |
Print_Queue |
Device |
IPC |
Disk_Drive_Admin |
Print_Queue_Admin |
Device_Admin |
IPC_Admin |

Requirements

Namespace: Genghis.Win32 Namespace

Assembly: Genghis.dll

See Also

Genghis.Win32 Namespace


Share.WMIValueTypeConverter Class

For a list of all members of this type, see Share.WMIValueTypeConverter Members.

System.Object
TypeConverter
Share.WMIValueTypeConverter

[Visual Basic]
Public Class Share.WMIValueTypeConverter
   Inherits TypeConverter
[C#]
public class Share.WMIValueTypeConverter : TypeConverter

Requirements

Namespace: Genghis.Win32 Namespace

Assembly: Genghis.dll

See Also

Share.WMIValueTypeConverter Members | Genghis.Win32 Namespace


Share.WMIValueTypeConverter Members

Public Instance Constructors

Share.WMIValueTypeConverter Constructor

Public Instance Methods

CanConvertFrom | Overloaded.
CanConvertFrom (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
CanConvertTo | Overloaded.
CanConvertTo (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFrom | Overloaded.
ConvertFrom (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFromInvariantString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFromInvariantString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFromString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFromString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFromString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertTo | Overloaded.
ConvertTo (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertToInvariantString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertToInvariantString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertToString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertToString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertToString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
CreateInstance | Overloaded.
CreateInstance (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetCreateInstanceSupported | Overloaded.
GetCreateInstanceSupported (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetProperties | Overloaded.
GetProperties (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetProperties (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetPropertiesSupported | Overloaded.
GetPropertiesSupported (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetStandardValues | Overloaded.
GetStandardValues (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesExclusive (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetStandardValuesSupported | Overloaded.
GetStandardValuesSupported (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsValid (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
IsValid (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetConvertFromException (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetConvertToException (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
SortProperties (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.

See Also

Share.WMIValueTypeConverter Class | Genghis.Win32 Namespace


Share.WMIValueTypeConverter Constructor

[Visual Basic]
Public Sub New( _
   ByVal baseType As System.Type _
)
[C#]
public Share.WMIValueTypeConverter(
   Type baseType
);

See Also

Share.WMIValueTypeConverter Class | Share.WMIValueTypeConverter Members | Genghis.Win32 Namespace


Share.WMIValueTypeConverter Methods

The methods of the Share.WMIValueTypeConverter class are listed below. For a complete list of Share.WMIValueTypeConverter class members, see the Share.WMIValueTypeConverter Members topic.

Public Instance Methods

CanConvertFrom | Overloaded.
CanConvertFrom (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
CanConvertTo | Overloaded.
CanConvertTo (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFrom | Overloaded.
ConvertFrom (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFromInvariantString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFromInvariantString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFromString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFromString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFromString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertTo | Overloaded.
ConvertTo (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertToInvariantString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertToInvariantString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertToString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertToString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertToString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
CreateInstance | Overloaded.
CreateInstance (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetCreateInstanceSupported | Overloaded.
GetCreateInstanceSupported (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetProperties | Overloaded.
GetProperties (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetProperties (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetPropertiesSupported | Overloaded.
GetPropertiesSupported (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetStandardValues | Overloaded.
GetStandardValues (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesExclusive (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetStandardValuesSupported | Overloaded.
GetStandardValuesSupported (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsValid (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
IsValid (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetConvertFromException (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetConvertToException (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
SortProperties (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.

See Also

Share.WMIValueTypeConverter Class | Genghis.Win32 Namespace


Share.WMIValueTypeConverter.CanConvertFrom Method (ITypeDescriptorContext, Type)

[Visual Basic]
Overrides Overloads Public Function CanConvertFrom( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal srcType As System.Type _
) As Boolean
[C#]
public override bool CanConvertFrom(
   ITypeDescriptorContext context,
   Type srcType
);

See Also

Share.WMIValueTypeConverter Class | Share.WMIValueTypeConverter Members | Genghis.Win32 Namespace | Share.WMIValueTypeConverter.CanConvertFrom Overload List


Share.WMIValueTypeConverter.CanConvertTo Method (ITypeDescriptorContext, Type)

[Visual Basic]
Overrides Overloads Public Function CanConvertTo( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal destinationType As System.Type _
) As Boolean
[C#]
public override bool CanConvertTo(
   ITypeDescriptorContext context,
   Type destinationType
);

See Also

Share.WMIValueTypeConverter Class | Share.WMIValueTypeConverter Members | Genghis.Win32 Namespace | Share.WMIValueTypeConverter.CanConvertTo Overload List


Share.WMIValueTypeConverter.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

[Visual Basic]
Overrides Overloads Public Function ConvertFrom( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal culture As System.Globalization.CultureInfo, _
   ByVal value As Object _
) As Object
[C#]
public override object ConvertFrom(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value
);

See Also

Share.WMIValueTypeConverter Class | Share.WMIValueTypeConverter Members | Genghis.Win32 Namespace | Share.WMIValueTypeConverter.ConvertFrom Overload List


Share.WMIValueTypeConverter.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

[Visual Basic]
Overrides Overloads Public Function ConvertTo( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal culture As System.Globalization.CultureInfo, _
   ByVal value As Object, _
   ByVal destinationType As System.Type _
) As Object
[C#]
public override object ConvertTo(
   ITypeDescriptorContext context,
   CultureInfo culture,
   object value,
   Type destinationType
);

See Also

Share.WMIValueTypeConverter Class | Share.WMIValueTypeConverter Members | Genghis.Win32 Namespace | Share.WMIValueTypeConverter.ConvertTo Overload List


Share.WMIValueTypeConverter.CreateInstance Method (ITypeDescriptorContext, IDictionary)

[Visual Basic]
Overrides Overloads Public Function CreateInstance( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal dictionary As System.Collections.IDictionary _
) As Object
[C#]
public override object CreateInstance(
   ITypeDescriptorContext context,
   IDictionary dictionary
);

See Also

Share.WMIValueTypeConverter Class | Share.WMIValueTypeConverter Members | Genghis.Win32 Namespace | Share.WMIValueTypeConverter.CreateInstance Overload List


Share.WMIValueTypeConverter.GetCreateInstanceSupported Method (ITypeDescriptorContext)

[Visual Basic]
Overrides Overloads Public Function GetCreateInstanceSupported( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext _
) As Boolean
[C#]
public override bool GetCreateInstanceSupported(
   ITypeDescriptorContext context
);

See Also

Share.WMIValueTypeConverter Class | Share.WMIValueTypeConverter Members | Genghis.Win32 Namespace | Share.WMIValueTypeConverter.GetCreateInstanceSupported Overload List


Share.WMIValueTypeConverter.GetProperties Method (ITypeDescriptorContext, Object, Attribute[])

[Visual Basic]
Overrides Overloads Public Function GetProperties( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal value As Object, _
   ByVal attributeVar As System.Attribute() _
) As System.ComponentModel.PropertyDescriptorCollection
[C#]
public override PropertyDescriptorCollection GetProperties(
   ITypeDescriptorContext context,
   object value,
   Attribute[] attributeVar
);

See Also

Share.WMIValueTypeConverter Class | Share.WMIValueTypeConverter Members | Genghis.Win32 Namespace | Share.WMIValueTypeConverter.GetProperties Overload List


Share.WMIValueTypeConverter.GetPropertiesSupported Method (ITypeDescriptorContext)

[Visual Basic]
Overrides Overloads Public Function GetPropertiesSupported( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext _
) As Boolean
[C#]
public override bool GetPropertiesSupported(
   ITypeDescriptorContext context
);

See Also

Share.WMIValueTypeConverter Class | Share.WMIValueTypeConverter Members | Genghis.Win32 Namespace | Share.WMIValueTypeConverter.GetPropertiesSupported Overload List


Share.WMIValueTypeConverter.GetStandardValues Method (ITypeDescriptorContext)

[Visual Basic]
Overrides Overloads Public Function GetStandardValues( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext _
) As System.ComponentModel.TypeConverter.StandardValuesCollection
[C#]
public override StandardValuesCollection GetStandardValues(
   ITypeDescriptorContext context
);

See Also

Share.WMIValueTypeConverter Class | Share.WMIValueTypeConverter Members | Genghis.Win32 Namespace | Share.WMIValueTypeConverter.GetStandardValues Overload List


Share.WMIValueTypeConverter.GetStandardValuesExclusive Method (ITypeDescriptorContext)

[Visual Basic]
Overrides Overloads Public Function GetStandardValuesExclusive( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext _
) As Boolean
[C#]
public override bool GetStandardValuesExclusive(
   ITypeDescriptorContext context
);

See Also

Share.WMIValueTypeConverter Class | Share.WMIValueTypeConverter Members | Genghis.Win32 Namespace | Share.WMIValueTypeConverter.GetStandardValuesExclusive Overload List


Share.WMIValueTypeConverter.GetStandardValuesSupported Method (ITypeDescriptorContext)

[Visual Basic]
Overrides Overloads Public Function GetStandardValuesSupported( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext _
) As Boolean
[C#]
public override bool GetStandardValuesSupported(
   ITypeDescriptorContext context
);

See Also

Share.WMIValueTypeConverter Class | Share.WMIValueTypeConverter Members | Genghis.Win32 Namespace | Share.WMIValueTypeConverter.GetStandardValuesSupported Overload List


ShareMap Class

A hashmap collection of share names as keys, and their corresponding local paths as values Originally generated by Chris Sells CollectionGen, then modified for internal scope

For a list of all members of this type, see ShareMap Members.

System.Object
ShareMap

[Visual Basic]
Public Class ShareMap
   Implements IDictionary, ICollection, IEnumerable, ICloneable
[C#]
public class ShareMap : IDictionary, ICollection, IEnumerable, ICloneable

Requirements

Namespace: Genghis.Win32 Namespace

Assembly: Genghis.dll

See Also

ShareMap Members | Genghis.Win32 Namespace


ShareMap Members

Public Static (Shared) Methods

Synchronized

Public Instance Properties

Count
IsFixedSize
IsReadOnly
IsSynchronized
Item
Keys
SyncRoot
Values

Public Instance Methods

Clear |
ContainsKey |
ContainsValue |
CopyTo |
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetEnumerator | Overloaded.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Fields

innerHash

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

IDictionary.Add | Overloaded.
ICloneable.Clone | Overloaded.
IDictionary.Contains | Overloaded.
IDictionary.Remove | Overloaded.

See Also

ShareMap Class | Genghis.Win32 Namespace


ShareMap Fields

The fields of the ShareMap class are listed below. For a complete list of ShareMap class members, see the ShareMap Members topic.

Protected Instance Fields

innerHash

See Also

ShareMap Class | Genghis.Win32 Namespace


ShareMap.innerHash Field

[Visual Basic]
Protected innerHash As System.Collections.Hashtable
[C#]
protected Hashtable innerHash;

See Also

ShareMap Class | ShareMap Members | Genghis.Win32 Namespace


ShareMap Properties

The properties of the ShareMap class are listed below. For a complete list of ShareMap class members, see the ShareMap Members topic.

Public Instance Properties

Count
IsFixedSize
IsReadOnly
IsSynchronized
Item
Keys
SyncRoot
Values

See Also

ShareMap Class | Genghis.Win32 Namespace


ShareMap.Count Property

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer
[C#]
public int Count {final get;}

See Also

ShareMap Class | ShareMap Members | Genghis.Win32 Namespace


ShareMap.IsFixedSize Property

[Visual Basic]
NotOverridable Public ReadOnly Property IsFixedSize As Boolean
[C#]
public bool IsFixedSize {final get;}

See Also

ShareMap Class | ShareMap Members | Genghis.Win32 Namespace


ShareMap.IsReadOnly Property

[Visual Basic]
NotOverridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {final get;}

See Also

ShareMap Class | ShareMap Members | Genghis.Win32 Namespace


ShareMap.IsSynchronized Property

[Visual Basic]
NotOverridable Public ReadOnly Property IsSynchronized As Boolean
[C#]
public bool IsSynchronized {final get;}

See Also

ShareMap Class | ShareMap Members | Genghis.Win32 Namespace


ShareMap.Item Property

[Visual Basic]
Public Default Property Item( _
   ByVal key As String _
) As String
[C#]
public string this[
   string key
] {get; set;}

See Also

ShareMap Class | ShareMap Members | Genghis.Win32 Namespace


ShareMap.Keys Property

[Visual Basic]
NotOverridable Public ReadOnly Property Keys As System.Collections.ICollection
[C#]
public System.Collections.ICollection Keys {final get;}

See Also

ShareMap Class | ShareMap Members | Genghis.Win32 Namespace


ShareMap.SyncRoot Property

[Visual Basic]
NotOverridable Public ReadOnly Property SyncRoot As Object
[C#]
public object SyncRoot {final get;}

See Also

ShareMap Class | ShareMap Members | Genghis.Win32 Namespace


ShareMap.Values Property

[Visual Basic]
NotOverridable Public ReadOnly Property Values As System.Collections.ICollection
[C#]
public System.Collections.ICollection Values {final get;}

See Also

ShareMap Class | ShareMap Members | Genghis.Win32 Namespace


ShareMap Methods

The methods of the ShareMap class are listed below. For a complete list of ShareMap class members, see the ShareMap Members topic.

Public Static (Shared) Methods

Synchronized

Public Instance Methods

Clear |
ContainsKey |
ContainsValue |
CopyTo |
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetEnumerator | Overloaded.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

IDictionary.Add | Overloaded.
ICloneable.Clone | Overloaded.
IDictionary.Contains | Overloaded.
IDictionary.Remove | Overloaded.

See Also

ShareMap Class | Genghis.Win32 Namespace


ShareMap.Add Method (String, String)

[Visual Basic]
Public Sub Add( _
   ByVal key As String, _
   ByVal value As String _
)
[C#]
public void Add(
   string key,
   string value
);

See Also

ShareMap Class | ShareMap Members | Genghis.Win32 Namespace | ShareMap.Add Overload List


ShareMap.Clear Method

[Visual Basic]
NotOverridable Public Sub Clear()
[C#]
public final void Clear();

See Also

ShareMap Class | ShareMap Members | Genghis.Win32 Namespace


ShareMap.Clone Method ()

[Visual Basic]
Public Function Clone() As Genghis.Win32.ShareMap
[C#]
public ShareMap Clone();

See Also

ShareMap Class | ShareMap Members | Genghis.Win32 Namespace | ShareMap.Clone Overload List


ShareMap.Contains Method (String)

[Visual Basic]
Public Function Contains( _
   ByVal key As String _
) As Boolean
[C#]
public bool Contains(
   string key
);

See Also

ShareMap Class | ShareMap Members | Genghis.Win32 Namespace | ShareMap.Contains Overload List


ShareMap.ContainsKey Method

[Visual Basic]
Public Function ContainsKey( _
   ByVal key As String _
) As Boolean
[C#]
public bool ContainsKey(
   string key
);

See Also

ShareMap Class | ShareMap Members | Genghis.Win32 Namespace


ShareMap.ContainsValue Method

[Visual Basic]
Public Function ContainsValue( _
   ByVal value As String _
) As Boolean
[C#]
public bool ContainsValue(
   string value
);

See Also

ShareMap Class | ShareMap Members | Genghis.Win32 Namespace


ShareMap.CopyTo Method

[Visual Basic]
NotOverridable Public Sub CopyTo( _
   ByVal array As System.Array, _
   ByVal index As Integer _
)
[C#]
public final void CopyTo(
   Array array,
   int index
);

See Also

ShareMap Class | ShareMap Members | Genghis.Win32 Namespace


ShareMap.GetEnumerator Method ()

[Visual Basic]
NotOverridable Public Function GetEnumerator() As System.Collections.IDictionaryEnumerator
[C#]
public final IDictionaryEnumerator GetEnumerator();

See Also

ShareMap Class | ShareMap Members | Genghis.Win32 Namespace | ShareMap.GetEnumerator Overload List


ShareMap.Remove Method (String)

[Visual Basic]
Public Sub Remove( _
   ByVal key As String _
)
[C#]
public void Remove(
   string key
);

See Also

ShareMap Class | ShareMap Members | Genghis.Win32 Namespace | ShareMap.Remove Overload List


ShareMap.Synchronized Method

[Visual Basic]
Public Shared Function Synchronized( _
   ByVal nonSync As Genghis.Win32.ShareMap _
) As Genghis.Win32.ShareMap
[C#]
public static ShareMap Synchronized(
   ShareMap nonSync
);

See Also

ShareMap Class | ShareMap Members | Genghis.Win32 Namespace


ShareMap.Add Method (Object, Object)

[Visual Basic]
Sub Add( _
   ByVal key As Object, _
   ByVal value As Object _
) Implements IDictionary.Add
[C#]
void IDictionary.Add(
   object key,
   object value
);

See Also

ShareMap Class | ShareMap Members | Genghis.Win32 Namespace | ShareMap.Add Overload List


ShareMap.Contains Method (Object)

[Visual Basic]
Function Contains( _
   ByVal key As Object _
) As Boolean Implements IDictionary.Contains
[C#]
bool IDictionary.Contains(
   object key
);

See Also

ShareMap Class | ShareMap Members | Genghis.Win32 Namespace | ShareMap.Contains Overload List


ShareMap.Remove Method (Object)

[Visual Basic]
Sub Remove( _
   ByVal key As Object _
) Implements IDictionary.Remove
[C#]
void IDictionary.Remove(
   object key
);

See Also

ShareMap Class | ShareMap Members | Genghis.Win32 Namespace | ShareMap.Remove Overload List


ShareMap.GetEnumerator Method ()

[Visual Basic]
Function GetEnumerator() As System.Collections.IEnumerator Implements IEnumerable.GetEnumerator
[C#]
IEnumerator IEnumerable.GetEnumerator();

See Also

ShareMap Class | ShareMap Members | Genghis.Win32 Namespace | ShareMap.GetEnumerator Overload List


ShareMap.Clone Method ()

[Visual Basic]
Function Clone() As Object Implements ICloneable.Clone
[C#]
object ICloneable.Clone();

See Also

ShareMap Class | ShareMap Members | Genghis.Win32 Namespace | ShareMap.Clone Overload List


ShareMapEnumerator Class

For a list of all members of this type, see ShareMapEnumerator Members.

System.Object
ShareMapEnumerator

[Visual Basic]
Public Class ShareMapEnumerator
   Implements IDictionaryEnumerator, IEnumerator
[C#]
public class ShareMapEnumerator : IDictionaryEnumerator, IEnumerator

Requirements

Namespace: Genghis.Win32 Namespace

Assembly: Genghis.dll

See Also

ShareMapEnumerator Members | Genghis.Win32 Namespace


ShareMapEnumerator Members

Public Instance Properties

Current
Entry
Key
Value

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
MoveNext |
Reset |
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

ShareMapEnumerator Class | Genghis.Win32 Namespace


ShareMapEnumerator Properties

The properties of the ShareMapEnumerator class are listed below. For a complete list of ShareMapEnumerator class members, see the ShareMapEnumerator Members topic.

Public Instance Properties

Current
Entry
Key
Value

See Also

ShareMapEnumerator Class | Genghis.Win32 Namespace


ShareMapEnumerator.Current Property

[Visual Basic]
NotOverridable Public ReadOnly Property Current As Object
[C#]
public object Current {final get;}

See Also

ShareMapEnumerator Class | ShareMapEnumerator Members | Genghis.Win32 Namespace


ShareMapEnumerator.Entry Property

[Visual Basic]
NotOverridable Public ReadOnly Property Entry As System.Collections.DictionaryEntry
[C#]
public System.Collections.DictionaryEntry Entry {final get;}

See Also

ShareMapEnumerator Class | ShareMapEnumerator Members | Genghis.Win32 Namespace


ShareMapEnumerator.Key Property

[Visual Basic]
Public ReadOnly Property Key As String
[C#]
public string Key {get;}

See Also

ShareMapEnumerator Class | ShareMapEnumerator Members | Genghis.Win32 Namespace


ShareMapEnumerator.Value Property

[Visual Basic]
Public ReadOnly Property Value As String
[C#]
public string Value {get;}

See Also

ShareMapEnumerator Class | ShareMapEnumerator Members | Genghis.Win32 Namespace


ShareMapEnumerator Methods

The methods of the ShareMapEnumerator class are listed below. For a complete list of ShareMapEnumerator class members, see the ShareMapEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
MoveNext |
Reset |
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

ShareMapEnumerator Class | Genghis.Win32 Namespace


ShareMapEnumerator.MoveNext Method

[Visual Basic]
NotOverridable Public Function MoveNext() As Boolean
[C#]
public final bool MoveNext();

See Also

ShareMapEnumerator Class | ShareMapEnumerator Members | Genghis.Win32 Namespace


ShareMapEnumerator.Reset Method

[Visual Basic]
NotOverridable Public Sub Reset()
[C#]
public final void Reset();

See Also

ShareMapEnumerator Class | ShareMapEnumerator Members | Genghis.Win32 Namespace


SystemShares Class

Used to load a list of shares from the registry Provides an event handler to notify clients that the shares have been changed

For a list of all members of this type, see SystemShares Members.

System.Object
SystemShares

[Visual Basic]
Public Class SystemShares
   Implements IDisposable
[C#]
public class SystemShares : IDisposable

Requirements

Namespace: Genghis.Win32 Namespace

Assembly: Genghis.dll

See Also

SystemShares Members | Genghis.Win32 Namespace


SystemShares Members

Public Static (Shared) Properties

Shares Returns a ShareMap copy representing all current system shares

Public Static (Shared) Events

SharesChanged Occurrs any time the system shares have been changed

Protected Static (Shared) Methods

OnEventArrived | Occurs any time we receive a notification about mapped drives changing from the WMI event handler
OnSharesChanged | Occurrs any time the system shares have been changed

Public Instance Methods

Dispose | Overrides IDisposable.Dispose - terminates our WMI event watcher
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize |
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

SystemShares Class | Genghis.Win32 Namespace


SystemShares Properties

The properties of the SystemShares class are listed below. For a complete list of SystemShares class members, see the SystemShares Members topic.

Public Static (Shared) Properties

Shares Returns a ShareMap copy representing all current system shares

See Also

SystemShares Class | Genghis.Win32 Namespace


SystemShares.Shares Property

Returns a ShareMap copy representing all current system shares

[Visual Basic]
Public Shared ReadOnly Property Shares As Genghis.Win32.ShareMap
[C#]
public static ShareMap Shares {get;}

Remarks

The key to the ShareMap is the sharename, and the value is the local path expressed as c:\path\file.ext. To create a UNC style path from the sharename, prepend the computer name like : \\Computer\Share

See Also

SystemShares Class | SystemShares Members | Genghis.Win32 Namespace


SystemShares Methods

The methods of the SystemShares class are listed below. For a complete list of SystemShares class members, see the SystemShares Members topic.

Protected Static (Shared) Methods

OnEventArrived | Occurs any time we receive a notification about mapped drives changing from the WMI event handler
OnSharesChanged | Occurrs any time the system shares have been changed

Public Instance Methods

Dispose | Overrides IDisposable.Dispose - terminates our WMI event watcher
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize |
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

SystemShares Class | Genghis.Win32 Namespace


SystemShares.Dispose Method

Overrides IDisposable.Dispose - terminates our WMI event watcher

[Visual Basic]
NotOverridable Public Sub Dispose()
[C#]
public final void Dispose();

See Also

SystemShares Class | SystemShares Members | Genghis.Win32 Namespace


SystemShares.Finalize Method

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();

See Also

SystemShares Class | SystemShares Members | Genghis.Win32 Namespace


SystemShares.OnEventArrived Method

Occurs any time we receive a notification about mapped drives changing from the WMI event handler

[Visual Basic]
Protected Shared Sub OnEventArrived( _
   ByVal sender As Object, _
   ByVal e As System.Management.EventArrivedEventArgs _
)
[C#]
protected static void OnEventArrived(
   object sender,
   EventArrivedEventArgs e
);

Parameters

sender
>A System.Object representing the originator of the event
e
A System.EventArgs representing additional data relevant to the event

See Also

SystemShares Class | SystemShares Members | Genghis.Win32 Namespace


SystemShares.OnSharesChanged Method

Occurrs any time the system shares have been changed

[Visual Basic]
Protected Shared Sub OnSharesChanged( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
)
[C#]
protected static void OnSharesChanged(
   object sender,
   EventArgs e
);

Parameters

sender
A System.Object representing the originator of the event
e
A System.EventArgs representing additional data relevant to the event

See Also

SystemShares Class | SystemShares Members | Genghis.Win32 Namespace


SystemShares Events

The events of the SystemShares class are listed below. For a complete list of SystemShares class members, see the SystemShares Members topic.

Public Static (Shared) Events

SharesChanged Occurrs any time the system shares have been changed

See Also

SystemShares Class | Genghis.Win32 Namespace


SystemShares.SharesChanged Event

Occurrs any time the system shares have been changed

[Visual Basic]
Public Shared SharesChanged As Genghis.Win32.SystemSharesSharesChangedEventHandler
[C#]
public static SystemSharesSharesChangedEventHandler SharesChanged;

See Also

SystemShares Class | SystemShares Members | Genghis.Win32 Namespace


SystemSharesSharesChangedEventHandler Delegate

The delegate corresponding to the OnSharesChanged event

[Visual Basic]
Public Delegate Sub SystemSharesSharesChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
)
[C#]
public delegate void SystemSharesSharesChangedEventHandler(
   object sender,
   EventArgs e
);

Requirements

Namespace: Genghis.Win32 Namespace

Assembly: Genghis.dll

See Also

Genghis.Win32 Namespace


Win32NetworkConnectionList.IWin32NetworkConnectionListEnumerator Interface

Supports type-safe iteration over a Genghis.Win32.Win32NetworkConnectionList.

For a list of all members of this type, see Win32NetworkConnectionList.IWin32NetworkConnectionListEnumerator Members.

[Visual Basic]
Public Interface Win32NetworkConnectionList.IWin32NetworkConnectionListEnumerator
[C#]
public interface Win32NetworkConnectionList.IWin32NetworkConnectionListEnumerator

Requirements

Namespace: Genghis.Win32 Namespace

Assembly: Genghis.dll

See Also

Win32NetworkConnectionList.IWin32NetworkConnectionListEnumerator Members | Genghis.Win32 Namespace


Win32NetworkConnectionList.IWin32NetworkConnectionListEnumerator Members

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

Win32NetworkConnectionList.IWin32NetworkConnectionListEnumerator Interface | Genghis.Win32 Namespace


Win32NetworkConnectionList.IWin32NetworkConnectionListEnumerator Properties

The properties of the Win32NetworkConnectionList.IWin32NetworkConnectionListEnumerator class are listed below. For a complete list of Win32NetworkConnectionList.IWin32NetworkConnectionListEnumerator class members, see the Win32NetworkConnectionList.IWin32NetworkConnectionListEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

Win32NetworkConnectionList.IWin32NetworkConnectionListEnumerator Interface | Genghis.Win32 Namespace


Win32NetworkConnectionList.IWin32NetworkConnectionListEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Property Current As Genghis.Win32.NetworkConnection
[C#]
NetworkConnection Current {get;}

See Also

Win32NetworkConnectionList.IWin32NetworkConnectionListEnumerator Interface | Win32NetworkConnectionList.IWin32NetworkConnectionListEnumerator Members | Genghis.Win32 Namespace


Win32NetworkConnectionList.IWin32NetworkConnectionListEnumerator Methods

The methods of the Win32NetworkConnectionList.IWin32NetworkConnectionListEnumerator class are listed below. For a complete list of Win32NetworkConnectionList.IWin32NetworkConnectionListEnumerator class members, see the Win32NetworkConnectionList.IWin32NetworkConnectionListEnumerator Members topic.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

Win32NetworkConnectionList.IWin32NetworkConnectionListEnumerator Interface | Genghis.Win32 Namespace


Win32NetworkConnectionList.IWin32NetworkConnectionListEnumerator.MoveNext Method

Advances the enumerator to the next element in the collection.

[Visual Basic]
Function MoveNext() As Boolean
[C#]
bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Exceptions

Exception Type | Condition
System.InvalidOperationException | The collection was modified after the enumerator was created.

See Also

Win32NetworkConnectionList.IWin32NetworkConnectionListEnumerator Interface | Win32NetworkConnectionList.IWin32NetworkConnectionListEnumerator Members | Genghis.Win32 Namespace


Win32NetworkConnectionList.IWin32NetworkConnectionListEnumerator.Reset Method

Sets the enumerator to its initial position, before the first element in the collection.

[Visual Basic]
Sub Reset()
[C#]
void Reset();

See Also

Win32NetworkConnectionList.IWin32NetworkConnectionListEnumerator Interface | Win32NetworkConnectionList.IWin32NetworkConnectionListEnumerator Members | Genghis.Win32 Namespace


Win32ShareList.IWin32ShareListEnumerator Interface

Supports type-safe iteration over a Genghis.Win32.Win32ShareList.

For a list of all members of this type, see Win32ShareList.IWin32ShareListEnumerator Members.

[Visual Basic]
Public Interface Win32ShareList.IWin32ShareListEnumerator
[C#]
public interface Win32ShareList.IWin32ShareListEnumerator

Requirements

Namespace: Genghis.Win32 Namespace

Assembly: Genghis.dll

See Also

Win32ShareList.IWin32ShareListEnumerator Members | Genghis.Win32 Namespace


Win32ShareList.IWin32ShareListEnumerator Members

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

Win32ShareList.IWin32ShareListEnumerator Interface | Genghis.Win32 Namespace


Win32ShareList.IWin32ShareListEnumerator Properties

The properties of the Win32ShareList.IWin32ShareListEnumerator class are listed below. For a complete list of Win32ShareList.IWin32ShareListEnumerator class members, see the Win32ShareList.IWin32ShareListEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

Win32ShareList.IWin32ShareListEnumerator Interface | Genghis.Win32 Namespace


Win32ShareList.IWin32ShareListEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Property Current As Genghis.Win32.Share
[C#]
Share Current {get;}

See Also

Win32ShareList.IWin32ShareListEnumerator Interface | Win32ShareList.IWin32ShareListEnumerator Members | Genghis.Win32 Namespace


Win32ShareList.IWin32ShareListEnumerator Methods

The methods of the Win32ShareList.IWin32ShareListEnumerator class are listed below. For a complete list of Win32ShareList.IWin32ShareListEnumerator class members, see the Win32ShareList.IWin32ShareListEnumerator Members topic.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

Win32ShareList.IWin32ShareListEnumerator Interface | Genghis.Win32 Namespace


Win32ShareList.IWin32ShareListEnumerator.MoveNext Method

Advances the enumerator to the next element in the collection.

[Visual Basic]
Function MoveNext() As Boolean
[C#]
bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Exceptions

Exception Type | Condition
System.InvalidOperationException | The collection was modified after the enumerator was created.

See Also

Win32ShareList.IWin32ShareListEnumerator Interface | Win32ShareList.IWin32ShareListEnumerator Members | Genghis.Win32 Namespace


Win32ShareList.IWin32ShareListEnumerator.Reset Method

Sets the enumerator to its initial position, before the first element in the collection.

[Visual Basic]
Sub Reset()
[C#]
void Reset();

See Also

Win32ShareList.IWin32ShareListEnumerator Interface | Win32ShareList.IWin32ShareListEnumerator Members | Genghis.Win32 Namespace


Genghis.Windows.Forms

Genghis Class Library

Genghis.Windows.Forms Namespace

Namespace hierarchy

Classes

Class | Description
BaseCompareValidator | Serves as the abstract base class for validation controls requiring type-specific validation, formatting, comparison and conversion.
BaseValidator | Serves as the abstract base class for validation controls.
BaseValidatorCollection | A strongly-typed collection of BaseValidator objects.
CompareValidator | Compares the value entered by the user into an input control with the value entered into another input control or a constant value.
CompletionCombo | Combo Box that does that neat auto-completion trick
ContainerStatusBar | A substitute for the System.Windows.Forms.ContainerStatusBar that allows any control to be hosted in a status bar panel.
ContainerStatusBar.StatusBarPanelCollection | Typed collection of ContainerStatusBarpanels.
ContainerStatusBarPanel | A modified ContainerStatusBarPanel that adds support for a hosted Control
CursorChanger | A class to change the cursor for the current window. Upon Disposal, the class will return the original cursor.
CustomStateTreeView | A treeview that allows a custom image list for the check state.
FileDocument |
FindReplaceDialog | FindReplace dialog component for .NET
FindReplaceDialog.FindReplace |
FolderNameDialog | Summary description for ImageCombo.
FormValidator | Performs validation on the form.
FormValidatorCollection | A strongly-typed collection of FormValidator objects.
HandleCollector | Summary description for GenghisHandleCollector.
HandleCollector.RegisteredHandleType | Describes a handle type that has been registered with the handle collector. Helps to ensure type-safe use of add and remove with only registered types.
HandleTypeNotRegisteredException | Represents an exception that can be thrown by the HandleCollector, when a type is used that has not been registered first
HeaderGroupBox | A simple header-only GroupBox. Supports Right-To-Left reading, and should (I hope) look pretty much like the real thing.
ImageCombo | Summary description for ImageCombo.
ListViewSorter | ListViewSorter sorts a listview in reportview style.
MRU |
MRUMenuItem |
MRUStringCollection.MRUStringCollectionEnumerator |
RangeValidator | Checks whether the value of an input control is within a specified range of values.
RegularExpressionValidator | Validates whether the value of an associated input control matches the pattern specified by a regular expression.
RequiredFieldValidator | Makes the associated input control a required field.
ScreenSaver | The main screensaver window -- big, black, borderless, and topmost. The window closes itself on keystrokes and (optionally) mouse movement.
ValidationControlConverter | Provides a type converter to convert object references to and from other representations.
WindowSerializer | A class to automatically serialize/deserialize the state of a form.
WindowsFormsNotInitializedException | Represents an exception that can be thrown by the HandleCollector, when registering handle types has been attempted before windows forms has initiated, and registered it's own types
WizardPage | A User Control that provides a base class to derive from to create standard looking wizard pages. It supports a top pane that contains a title and description of a page.
WizardSheet | Frame to hold WizardPages for a Wizard-like User Interface.

Interfaces

Interface | Description
BaseValidatorCollection.IBaseValidatorCollectionEnumerator | Supports type-safe iteration over a BaseValidatorCollection.
FormValidatorCollection.IFormValidatorCollectionEnumerator | Supports type-safe iteration over a FormValidatorCollection.

Delegates

Delegate | Description
ChangedEventHandler |
HandleChangeEventHandler | Represents the method prototype a delegate must conform to sink events when handles are added or removed from the HandleCollector
onMRUClick |
WindowSerializerDelegate |

Enumerations

Enumeration | Description
FindReplaceDialog.FindDirection |
FindReplaceDialog.FindReplaceDialogType |
FolderNameDialog.FolderNameFolder |
FolderNameDialog.FolderNameStyles |
ListViewCompareType |
MRUStyle |
ValidationCompareOperator | Specifies the validation comparison operators used by the CompareValidator control.
ValidationDataType | Specifies the validation data types used by the CompareValidator and RangeValidator controls.


BaseCompareValidator Class

Serves as the abstract base class for validation controls requiring type-specific validation, formatting, comparison and conversion.

For a list of all members of this type, see BaseCompareValidator Members.

System.Object
MarshalByRefObject
Component
BaseValidator
BaseCompareValidator

[Visual Basic]
MustInherit Public Class BaseCompareValidator
   Inherits BaseValidator
   Implements IComponent, IDisposable, ISupportInitialize
[C#]
public abstract class BaseCompareValidator : BaseValidator, IComponent, IDisposable, ISupportInitialize

Remarks

The BaseCompareValidator class provides the core implementation for compare-style validation controls, including both the RangeValidator and CompareValidator.

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

BaseCompareValidator Members | Genghis.Windows.Forms Namespace


BaseCompareValidator Members

Public Instance Properties

Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ControlToValidate (inherited from BaseValidator) | Gets or sets the input control to validate.
ErrorMessage (inherited from BaseValidator) | Gets or sets the text for the error message.
HostingForm (inherited from BaseValidator) | Gets or sets the component's hosting form.
Icon (inherited from BaseValidator) | Gets or sets the Icon that is displayed next to a control when an error description string has been set for the control.
IconAlignment (inherited from BaseValidator) | Gets or sets the location where the error icon should be placed in relation to the control.
IconPadding (inherited from BaseValidator) | Gets or sets the amount of extra space to leave between the specified control and the error icon.
IsValid (inherited from BaseValidator) | Gets a value that indicates whether the associated input control passes validation.
Site (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Type | Gets or sets what type-checking will be applied to the validation.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Component) | Select the method name to go to the Microsoft documentation.
Validate (inherited from BaseValidator) | Performs validation on the associated input control and updates the IsValid property.

Protected Instance Constructors

BaseCompareValidator Constructor

Protected Instance Properties

DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
TypeConverter | Gets a TypeConverter capable of performing conversions to and from the type, specified by ValidationDataType.

Protected Instance Methods

CanConvert | Returns a value indicating whether the string value can be converted to the type specified by Type.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
EvaluateIsValid (inherited from BaseValidator) | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
Format | Returns a formatted string.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

ISupportInitialize.BeginInit (inherited from BaseValidator)
ISupportInitialize.EndInit (inherited from BaseValidator)

See Also

BaseCompareValidator Class | Genghis.Windows.Forms Namespace


BaseCompareValidator Constructor

[Visual Basic]
Protected Sub New()
[C#]
protected BaseCompareValidator();

See Also

BaseCompareValidator Class | BaseCompareValidator Members | Genghis.Windows.Forms Namespace


BaseCompareValidator Properties

The properties of the BaseCompareValidator class are listed below. For a complete list of BaseCompareValidator class members, see the BaseCompareValidator Members topic.

Public Instance Properties

Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ControlToValidate (inherited from BaseValidator) | Gets or sets the input control to validate.
ErrorMessage (inherited from BaseValidator) | Gets or sets the text for the error message.
HostingForm (inherited from BaseValidator) | Gets or sets the component's hosting form.
Icon (inherited from BaseValidator) | Gets or sets the Icon that is displayed next to a control when an error description string has been set for the control.
IconAlignment (inherited from BaseValidator) | Gets or sets the location where the error icon should be placed in relation to the control.
IconPadding (inherited from BaseValidator) | Gets or sets the amount of extra space to leave between the specified control and the error icon.
IsValid (inherited from BaseValidator) | Gets a value that indicates whether the associated input control passes validation.
Site (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Type | Gets or sets what type-checking will be applied to the validation.

Protected Instance Properties

DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
TypeConverter | Gets a TypeConverter capable of performing conversions to and from the type, specified by ValidationDataType.

See Also

BaseCompareValidator Class | Genghis.Windows.Forms Namespace


BaseCompareValidator.Type Property

Gets or sets what type-checking will be applied to the validation.

[Visual Basic]
Public Property Type As Genghis.Windows.Forms.ValidationDataType
[C#]
public ValidationDataType Type {get; set;}

Property Value

What type-checking will be applied to the validation, default is ValidationDataType.String.

See Also

BaseCompareValidator Class | BaseCompareValidator Members | Genghis.Windows.Forms Namespace


BaseCompareValidator.TypeConverter Property

Gets a TypeConverter capable of performing conversions to and from the type, specified by ValidationDataType.

[Visual Basic]
Protected ReadOnly Property TypeConverter As System.ComponentModel.TypeConverter
[C#]
protected System.ComponentModel.TypeConverter TypeConverter {get;}

Property Value

A TypeConverter capable of performing conversions to and from the type, specified by ValidationDataType.

See Also

BaseCompareValidator Class | BaseCompareValidator Members | Genghis.Windows.Forms Namespace


BaseCompareValidator Methods

The methods of the BaseCompareValidator class are listed below. For a complete list of BaseCompareValidator class members, see the BaseCompareValidator Members topic.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Component) | Select the method name to go to the Microsoft documentation.
Validate (inherited from BaseValidator) | Performs validation on the associated input control and updates the IsValid property.

Protected Instance Methods

CanConvert | Returns a value indicating whether the string value can be converted to the type specified by Type.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
EvaluateIsValid (inherited from BaseValidator) | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
Format | Returns a formatted string.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

ISupportInitialize.BeginInit (inherited from BaseValidator)
ISupportInitialize.EndInit (inherited from BaseValidator)

See Also

BaseCompareValidator Class | Genghis.Windows.Forms Namespace


BaseCompareValidator.CanConvert Method

Returns a value indicating whether the string value can be converted to the type specified by Type.

[Visual Basic]
Protected Function CanConvert( _
   ByVal value As String _
) As Boolean
[C#]
protected bool CanConvert(
   string value
);

Parameters

value
String value being tested.

Return Value

true if value can be converted, false otherwise.

See Also

BaseCompareValidator Class | BaseCompareValidator Members | Genghis.Windows.Forms Namespace


BaseCompareValidator.Format Method

Returns a formatted string.

[Visual Basic]
Protected Function Format( _
   ByVal value As String _
) As String
[C#]
protected string Format(
   string value
);

Parameters

value
String value of Typeto be formatted prior to conversion to an internal System type representation.

Return Value

true if value can be converted, false otherwise.

Remarks

Format is used to clean a string from any unnecessary UI artifacts before converting it from the type specified by Type to the specified Systemtype. For example, a Currency type is internally converted to System.Decimal. From a UI point of view, it is perfectly valid to include $ and . characters in a Currency field on a UI, but such a field cannot be converted to System.Decimal. Format is used to strip any characters that won't make the conversion from UI Type to internal System type.

The following table shows what ValidationDataTypes are converted to what internal System types.

ValidationDataType | System Type
Currency | System.Decimal
Date | System.DateTime
Double | System.Double
Integer | System.Int32
String | System.String

See Also

BaseCompareValidator Class | BaseCompareValidator Members | Genghis.Windows.Forms Namespace


BaseValidator Class

Serves as the abstract base class for validation controls.

For a list of all members of this type, see BaseValidator Members.

System.Object
MarshalByRefObject
Component
BaseValidator

[Visual Basic]
MustInherit Public Class BaseValidator
   Inherits Component
   Implements IComponent, IDisposable, ISupportInitialize
[C#]
public abstract class BaseValidator : Component, IComponent, IDisposable, ISupportInitialize

Remarks

The BaseValidator class provides the core implementation for all validation controls. Validation occurs when the associated control issues a Validating event, which the base validator registers itself with with the ControlToValidate property is set.

The BaseValidator also registers itself with FormValidator if it successfully initializes, which is determined by whether the ControlToValidate property has been set.

Note No validation occurs until the first time a ControlToValidate has been altered from it's initial value.

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

BaseValidator Members | Genghis.Windows.Forms Namespace


BaseValidator Members

Public Instance Properties

Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ControlToValidate | Gets or sets the input control to validate.
ErrorMessage | Gets or sets the text for the error message.
HostingForm | Gets or sets the component's hosting form.
Icon | Gets or sets the Icon that is displayed next to a control when an error description string has been set for the control.
IconAlignment | Gets or sets the location where the error icon should be placed in relation to the control.
IconPadding | Gets or sets the amount of extra space to leave between the specified control and the error icon.
IsValid | Gets a value that indicates whether the associated input control passes validation.
Site (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Component) | Select the method name to go to the Microsoft documentation.
Validate | Performs validation on the associated input control and updates the IsValid property.

Protected Instance Constructors

BaseValidator Constructor

Protected Instance Properties

DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
EvaluateIsValid | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

ISupportInitialize.BeginInit
ISupportInitialize.EndInit

See Also

BaseValidator Class | Genghis.Windows.Forms Namespace


BaseValidator Constructor

[Visual Basic]
Protected Sub New()
[C#]
protected BaseValidator();

See Also

BaseValidator Class | BaseValidator Members | Genghis.Windows.Forms Namespace


BaseValidator Properties

The properties of the BaseValidator class are listed below. For a complete list of BaseValidator class members, see the BaseValidator Members topic.

Public Instance Properties

Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ControlToValidate | Gets or sets the input control to validate.
ErrorMessage | Gets or sets the text for the error message.
HostingForm | Gets or sets the component's hosting form.
Icon | Gets or sets the Icon that is displayed next to a control when an error description string has been set for the control.
IconAlignment | Gets or sets the location where the error icon should be placed in relation to the control.
IconPadding | Gets or sets the amount of extra space to leave between the specified control and the error icon.
IsValid | Gets a value that indicates whether the associated input control passes validation.
Site (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.

See Also

BaseValidator Class | Genghis.Windows.Forms Namespace


BaseValidator.ControlToValidate Property

Gets or sets the input control to validate.

[Visual Basic]
Public Property ControlToValidate As System.Windows.Forms.Control
[C#]
public System.Windows.Forms.Control ControlToValidate {get; set;}

Property Value

The input control to validate. The default value is null.

See Also

BaseValidator Class | BaseValidator Members | Genghis.Windows.Forms Namespace


BaseValidator.ErrorMessage Property

Gets or sets the text for the error message.

[Visual Basic]
Public Property ErrorMessage As String
[C#]
public string ErrorMessage {get; set;}

Property Value

The error message displayed when validation fails. The default value is String.Empty.

See Also

BaseValidator Class | BaseValidator Members | Genghis.Windows.Forms Namespace


BaseValidator.HostingForm Property

Gets or sets the component's hosting form.

[Visual Basic]
Public Property HostingForm As System.Windows.Forms.Form
[C#]
public System.Windows.Forms.Form HostingForm {get; set;}

Property Value

The component's hosting form. The default value is null.

See Also

BaseValidator Class | BaseValidator Members | Genghis.Windows.Forms Namespace


BaseValidator.Icon Property

Gets or sets the Icon that is displayed next to a control when an error description string has been set for the control.

[Visual Basic]
Public Property Icon As System.Drawing.Icon
[C#]
public System.Drawing.Icon Icon {get; set;}

Property Value

The Icon that is displayed next to a control when an error description string has been set for the control.

See Also

BaseValidator Class | BaseValidator Members | Genghis.Windows.Forms Namespace


BaseValidator.IconAlignment Property

Gets or sets the location where the error icon should be placed in relation to the control.

[Visual Basic]
Public Property IconAlignment As System.Windows.Forms.ErrorIconAlignment
[C#]
public System.Windows.Forms.ErrorIconAlignment IconAlignment {get; set;}

Property Value

The location where the error icon should be placed in relation to the control.

See Also

BaseValidator Class | BaseValidator Members | Genghis.Windows.Forms Namespace


BaseValidator.IconPadding Property

Gets or sets the amount of extra space to leave between the specified control and the error icon.

[Visual Basic]
Public Property IconPadding As Integer
[C#]
public int IconPadding {get; set;}

Property Value

The amount of extra space to leave between the specified control and the error icon.

See Also

BaseValidator Class | BaseValidator Members | Genghis.Windows.Forms Namespace


BaseValidator.IsValid Property

Gets a value that indicates whether the associated input control passes validation.

[Visual Basic]
Public ReadOnly Property IsValid As Boolean
[C#]
public bool IsValid {get;}

Property Value

true if the associated input control passes validation, false otherwise.

See Also

BaseValidator Class | BaseValidator Members | Genghis.Windows.Forms Namespace


BaseValidator Methods

The methods of the BaseValidator class are listed below. For a complete list of BaseValidator class members, see the BaseValidator Members topic.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Component) | Select the method name to go to the Microsoft documentation.
Validate | Performs validation on the associated input control and updates the IsValid property.

Protected Instance Methods

Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
EvaluateIsValid | When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

ISupportInitialize.BeginInit
ISupportInitialize.EndInit

See Also

BaseValidator Class | Genghis.Windows.Forms Namespace


BaseValidator.EvaluateIsValid Method

When overridden in a derived class, this method contains the code to determine whether the value in the input control is valid.

[Visual Basic]
MustOverride Protected Function EvaluateIsValid() As Boolean
[C#]
protected abstract bool EvaluateIsValid();

See Also

BaseValidator Class | BaseValidator Members | Genghis.Windows.Forms Namespace


BaseValidator.BeginInit Method

[Visual Basic]
Sub BeginInit() Implements ISupportInitialize.BeginInit
[C#]
void ISupportInitialize.BeginInit();

See Also

BaseValidator Class | BaseValidator Members | Genghis.Windows.Forms Namespace


BaseValidator.EndInit Method

[Visual Basic]
Sub EndInit() Implements ISupportInitialize.EndInit
[C#]
void ISupportInitialize.EndInit();

See Also

BaseValidator Class | BaseValidator Members | Genghis.Windows.Forms Namespace


BaseValidator.Validate Method

Performs validation on the associated input control and updates the IsValid property.

[Visual Basic]
Public Sub Validate()
[C#]
public void Validate();

See Also

BaseValidator Class | BaseValidator Members | Genghis.Windows.Forms Namespace


BaseValidatorCollection Class

A strongly-typed collection of BaseValidator objects.

For a list of all members of this type, see BaseValidatorCollection Members.

System.Object
BaseValidatorCollection

[Visual Basic]
Public Class BaseValidatorCollection
   Implements IList, ICollection, IEnumerable, ICloneable
[C#]
public class BaseValidatorCollection : IList, ICollection, IEnumerable, ICloneable

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

BaseValidatorCollection Members | Genghis.Windows.Forms Namespace


BaseValidatorCollection Members

Public Static (Shared) Methods

ReadOnly | Creates a read-only wrapper for a BaseValidatorCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a BaseValidatorCollection instance.

Public Instance Constructors

BaseValidatorCollection Overloaded. Initialize a new instance of the BaseValidatorCollection class.

Public Instance Properties

Capacity | Gets or sets the number of elements the BaseValidatorCollection can contain.
Count | Gets the number of elements actually contained in the BaseValidatorCollection.
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the BaseValidator at the specified index.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

AddRange | Overloaded. Adds the elements of a BaseValidator array to the current BaseValidatorCollection.
Clear | Removes all elements from the BaseValidatorCollection.
Clone | Creates a shallow copy of the BaseValidatorCollection.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
RemoveAt | Overloaded. Removes the element at the specified index of the BaseValidatorCollection.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

IList.Add | Overloaded.
IList.Contains | Overloaded.
ICollection.CopyTo | Overloaded.
IEnumerable.GetEnumerator | Overloaded.
IList.IndexOf | Overloaded.
IList.Insert | Overloaded.
IList.Remove | Overloaded.

See Also

BaseValidatorCollection Class | Genghis.Windows.Forms Namespace


BaseValidatorCollection Constructor

Genghis Class Library

BaseValidatorCollection

Initializes a new instance of the BaseValidatorCollection class that is empty and has the default initial capacity.

Overload List

Initializes a new instance of the BaseValidatorCollection class that is empty and has the default initial capacity.

public BaseValidatorCollection();

Initializes a new instance of the BaseValidatorCollection class that has the specified initial capacity.

public BaseValidatorCollection(int);

Initializes a new instance of the BaseValidatorCollection class that contains elements copied from the specified BaseValidatorCollection.

public BaseValidatorCollection(BaseValidatorCollection);

Initializes a new instance of the BaseValidatorCollection class that contains elements copied from the specified BaseValidator array.

public BaseValidatorCollection(BaseValidator[]);

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace


BaseValidatorCollection Constructor ()

Initializes a new instance of the BaseValidatorCollection class that is empty and has the default initial capacity.

[Visual Basic]
Overloads Public Sub New()
[C#]
public BaseValidatorCollection();

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace | BaseValidatorCollection Constructor Overload List


BaseValidatorCollection Constructor (Int32)

Initializes a new instance of the BaseValidatorCollection class that has the specified initial capacity.

[Visual Basic]
Overloads Public Sub New( _
   ByVal capacity As Integer _
)
[C#]
public BaseValidatorCollection(
   int capacity
);

Parameters

capacity
The number of elements that the new BaseValidatorCollection is initially capable of storing.

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace | BaseValidatorCollection Constructor Overload List


BaseValidatorCollection Constructor (BaseValidatorCollection)

Initializes a new instance of the BaseValidatorCollection class that contains elements copied from the specified BaseValidatorCollection.

[Visual Basic]
Overloads Public Sub New( _
   ByVal c As Genghis.Windows.Forms.BaseValidatorCollection _
)
[C#]
public BaseValidatorCollection(
   BaseValidatorCollection c
);

Parameters

c
The BaseValidatorCollection whose elements are copied to the new collection.

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace | BaseValidatorCollection Constructor Overload List


BaseValidatorCollection Constructor (BaseValidator[])

Initializes a new instance of the BaseValidatorCollection class that contains elements copied from the specified BaseValidator array.

[Visual Basic]
Overloads Public Sub New( _
   ByVal a As Genghis.Windows.Forms.BaseValidator() _
)
[C#]
public BaseValidatorCollection(
   BaseValidator[] a
);

Parameters

a
The BaseValidator array whose elements are copied to the new list.

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace | BaseValidatorCollection Constructor Overload List


BaseValidatorCollection Properties

The properties of the BaseValidatorCollection class are listed below. For a complete list of BaseValidatorCollection class members, see the BaseValidatorCollection Members topic.

Public Instance Properties

Capacity | Gets or sets the number of elements the BaseValidatorCollection can contain.
Count | Gets the number of elements actually contained in the BaseValidatorCollection.
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the BaseValidator at the specified index.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

BaseValidatorCollection Class | Genghis.Windows.Forms Namespace


BaseValidatorCollection.Capacity Property

Gets or sets the number of elements the BaseValidatorCollection can contain.

[Visual Basic]
Overridable Public Property Capacity As Integer
[C#]
public int Capacity {virtual get; virtual set;}

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace


BaseValidatorCollection.Count Property

Gets the number of elements actually contained in the BaseValidatorCollection.

[Visual Basic]
Overridable Public ReadOnly Property Count As Integer
[C#]
public int Count {virtual get;}

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace


BaseValidatorCollection.IsFixedSize Property

Gets a value indicating whether the collection has a fixed size.

[Visual Basic]
Overridable Public ReadOnly Property IsFixedSize As Boolean
[C#]
public bool IsFixedSize {virtual get;}

Property Value

true if the collection has a fixed size; otherwise, false. The default is false

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace


BaseValidatorCollection.IsReadOnly Property

gets a value indicating whether the IList is read-only.

[Visual Basic]
Overridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {virtual get;}

Property Value

true if the collection is read-only; otherwise, false. The default is false

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace


BaseValidatorCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

[Visual Basic]
Overridable Public ReadOnly Property IsSynchronized As Boolean
[C#]
public bool IsSynchronized {virtual get;}

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace


BaseValidatorCollection.Item Property

Gets or sets the BaseValidator at the specified index.

[Visual Basic]
Overridable Public Default Property Item( _
   ByVal index As Integer _
) As Genghis.Windows.Forms.BaseValidator
[C#]
public BaseValidator this[
   int index
] {virtual get; virtual set;}

Parameters

index
The zero-based index of the element to get or set.

Exceptions

Exception Type | Condition
System.ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace


BaseValidatorCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

[Visual Basic]
Overridable Public ReadOnly Property SyncRoot As Object
[C#]
public object SyncRoot {virtual get;}

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace


BaseValidatorCollection Methods

The methods of the BaseValidatorCollection class are listed below. For a complete list of BaseValidatorCollection class members, see the BaseValidatorCollection Members topic.

Public Static (Shared) Methods

ReadOnly | Creates a read-only wrapper for a BaseValidatorCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a BaseValidatorCollection instance.

Public Instance Methods

AddRange | Overloaded. Adds the elements of a BaseValidator array to the current BaseValidatorCollection.
Clear | Removes all elements from the BaseValidatorCollection.
Clone | Creates a shallow copy of the BaseValidatorCollection.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
RemoveAt | Overloaded. Removes the element at the specified index of the BaseValidatorCollection.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

IList.Add | Overloaded.
IList.Contains | Overloaded.
ICollection.CopyTo | Overloaded.
IEnumerable.GetEnumerator | Overloaded.
IList.IndexOf | Overloaded.
IList.Insert | Overloaded.
IList.Remove | Overloaded.

See Also

BaseValidatorCollection Class | Genghis.Windows.Forms Namespace


BaseValidatorCollection.Add Method (BaseValidator)

Adds a BaseValidator to the end of the BaseValidatorCollection.

[Visual Basic]
Overridable Public Function Add( _
   ByVal item As Genghis.Windows.Forms.BaseValidator _
) As Integer
[C#]
public virtual int Add(
   BaseValidator item
);

Parameters

item
The BaseValidator to be added to the end of the BaseValidatorCollection.

Return Value

The index at which the value has been added.

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace | BaseValidatorCollection.Add Overload List


AddRange Method

Genghis Class Library

BaseValidatorCollection.AddRange

Adds the elements of a BaseValidator array to the current BaseValidatorCollection.

Overload List

Adds the elements of a BaseValidator array to the current BaseValidatorCollection.

public virtual int AddRange(BaseValidator[]);

Adds the elements of another BaseValidatorCollection to the current BaseValidatorCollection.

public virtual int AddRange(BaseValidatorCollection);

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace


BaseValidatorCollection.AddRange Method (BaseValidator[])

Adds the elements of a BaseValidator array to the current BaseValidatorCollection.

[Visual Basic]
Overridable Overloads Public Function AddRange( _
   ByVal x As Genghis.Windows.Forms.BaseValidator() _
) As Integer
[C#]
public virtual int AddRange(
   BaseValidator[] x
);

Parameters

x
The BaseValidator array whose elements should be added to the end of the BaseValidatorCollection.

Return Value

The new Count of the BaseValidatorCollection.

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace | BaseValidatorCollection.AddRange Overload List


BaseValidatorCollection.AddRange Method (BaseValidatorCollection)

Adds the elements of another BaseValidatorCollection to the current BaseValidatorCollection.

[Visual Basic]
Overridable Overloads Public Function AddRange( _
   ByVal x As Genghis.Windows.Forms.BaseValidatorCollection _
) As Integer
[C#]
public virtual int AddRange(
   BaseValidatorCollection x
);

Parameters

x
The BaseValidatorCollection whose elements should be added to the end of the current BaseValidatorCollection.

Return Value

The new Count of the BaseValidatorCollection.

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace | BaseValidatorCollection.AddRange Overload List


BaseValidatorCollection.Clear Method

Removes all elements from the BaseValidatorCollection.

[Visual Basic]
Overridable Public Sub Clear()
[C#]
public virtual void Clear();

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace


BaseValidatorCollection.Clone Method

Creates a shallow copy of the BaseValidatorCollection.

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace


BaseValidatorCollection.Contains Method (BaseValidator)

Determines whether a given BaseValidator is in the BaseValidatorCollection.

[Visual Basic]
Overridable Public Function Contains( _
   ByVal item As Genghis.Windows.Forms.BaseValidator _
) As Boolean
[C#]
public virtual bool Contains(
   BaseValidator item
);

Parameters

item
The BaseValidator to check for.

Return Value

true if item is found in the BaseValidatorCollection; otherwise, false.

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace | BaseValidatorCollection.Contains Overload List


CopyTo Method

Genghis Class Library

BaseValidatorCollection.CopyTo

Copies the entire BaseValidatorCollection to a one-dimensional string array.

Overload List

private final void CopyTo(Array,int);

Copies the entire BaseValidatorCollection to a one-dimensional BaseValidator array, starting at the specified index of the target array.

public virtual void CopyTo(BaseValidator[],int);

Copies the entire BaseValidatorCollection to a one-dimensional string array.

public virtual void CopyTo(BaseValidator[]);

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace


BaseValidatorCollection.CopyTo Method (BaseValidator[])

Copies the entire BaseValidatorCollection to a one-dimensional string array.

[Visual Basic]
Overridable Overloads Public Sub CopyTo( _
   ByVal array As Genghis.Windows.Forms.BaseValidator() _
)
[C#]
public virtual void CopyTo(
   BaseValidator[] array
);

Parameters

array
The one-dimensional BaseValidator array to copy to.

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace | BaseValidatorCollection.CopyTo Overload List


BaseValidatorCollection.CopyTo Method (BaseValidator[], Int32)

Copies the entire BaseValidatorCollection to a one-dimensional BaseValidator array, starting at the specified index of the target array.

[Visual Basic]
Overridable Overloads Public Sub CopyTo( _
   ByVal array As Genghis.Windows.Forms.BaseValidator(), _
   ByVal start As Integer _
)
[C#]
public virtual void CopyTo(
   BaseValidator[] array,
   int start
);

Parameters

array
The one-dimensional BaseValidator array to copy to.
start
The zero-based index in array at which copying begins.

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace | BaseValidatorCollection.CopyTo Overload List


BaseValidatorCollection.GetEnumerator Method ()

Returns an enumerator that can iterate through the BaseValidatorCollection.

[Visual Basic]
Overridable Public Function GetEnumerator() As Genghis.Windows.Forms.BaseValidatorCollection.IBaseValidatorCollectionEnumerator
[C#]
public virtual IBaseValidatorCollectionEnumerator GetEnumerator();

Return Value

An Genghis.Windows.Forms.BaseValidatorCollection.Enumerator for the entire BaseValidatorCollection.

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace | BaseValidatorCollection.GetEnumerator Overload List


BaseValidatorCollection.IndexOf Method (BaseValidator)

Returns the zero-based index of the first occurrence of a BaseValidator in the BaseValidatorCollection.

[Visual Basic]
Overridable Public Function IndexOf( _
   ByVal item As Genghis.Windows.Forms.BaseValidator _
) As Integer
[C#]
public virtual int IndexOf(
   BaseValidator item
);

Parameters

item
The BaseValidator to locate in the BaseValidatorCollection.

Return Value

The zero-based index of the first occurrence of item in the entire BaseValidatorCollection, if found; otherwise, -1.

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace | BaseValidatorCollection.IndexOf Overload List


BaseValidatorCollection.Insert Method (Int32, BaseValidator)

Inserts an element into the BaseValidatorCollection at the specified index.

[Visual Basic]
Overridable Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As Genghis.Windows.Forms.BaseValidator _
)
[C#]
public virtual void Insert(
   int index,
   BaseValidator item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The BaseValidator to insert.

Exceptions

Exception Type | Condition
System.ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace | BaseValidatorCollection.Insert Overload List


BaseValidatorCollection.ReadOnly Method

Creates a read-only wrapper for a BaseValidatorCollection instance.

[Visual Basic]
Public Shared Function ReadOnly( _
   ByVal list As Genghis.Windows.Forms.BaseValidatorCollection _
) As Genghis.Windows.Forms.BaseValidatorCollection
[C#]
public static BaseValidatorCollection ReadOnly(
   BaseValidatorCollection list
);

Return Value

An BaseValidatorCollection wrapper that is read-only.

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace


BaseValidatorCollection.Remove Method (BaseValidator)

Removes the first occurrence of a specific BaseValidator from the BaseValidatorCollection.

[Visual Basic]
Overridable Public Sub Remove( _
   ByVal item As Genghis.Windows.Forms.BaseValidator _
)
[C#]
public virtual void Remove(
   BaseValidator item
);

Parameters

item
The BaseValidator to remove from the BaseValidatorCollection.

Exceptions

Exception Type | Condition
System.ArgumentException | The specified BaseValidator was not found in the BaseValidatorCollection.

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace | BaseValidatorCollection.Remove Overload List


BaseValidatorCollection.RemoveAt Method (Int32)

Removes the element at the specified index of the BaseValidatorCollection.

[Visual Basic]
Overridable Public Sub RemoveAt( _
   ByVal index As Integer _
)
[C#]
public virtual void RemoveAt(
   int index
);

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception Type | Condition
System.ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace | BaseValidatorCollection.RemoveAt Overload List


BaseValidatorCollection.Synchronized Method

Creates a synchronized (thread-safe) wrapper for a BaseValidatorCollection instance.

[Visual Basic]
Public Shared Function Synchronized( _
   ByVal list As Genghis.Windows.Forms.BaseValidatorCollection _
) As Genghis.Windows.Forms.BaseValidatorCollection
[C#]
public static BaseValidatorCollection Synchronized(
   BaseValidatorCollection list
);

Return Value

An BaseValidatorCollection wrapper that is synchronized (thread-safe).

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace


BaseValidatorCollection.CopyTo Method (Array, Int32)

[Visual Basic]
Sub CopyTo( _
   ByVal array As System.Array, _
   ByVal start As Integer _
) Implements ICollection.CopyTo
[C#]
void ICollection.CopyTo(
   Array array,
   int start
);

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace | BaseValidatorCollection.CopyTo Overload List


BaseValidatorCollection.GetEnumerator Method ()

[Visual Basic]
Function GetEnumerator() As System.Collections.IEnumerator Implements IEnumerable.GetEnumerator
[C#]
IEnumerator IEnumerable.GetEnumerator();

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace | BaseValidatorCollection.GetEnumerator Overload List


BaseValidatorCollection.Add Method (Object)

[Visual Basic]
Function Add( _
   ByVal x As Object _
) As Integer Implements IList.Add
[C#]
int IList.Add(
   object x
);

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace | BaseValidatorCollection.Add Overload List


BaseValidatorCollection.Contains Method (Object)

[Visual Basic]
Function Contains( _
   ByVal x As Object _
) As Boolean Implements IList.Contains
[C#]
bool IList.Contains(
   object x
);

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace | BaseValidatorCollection.Contains Overload List


BaseValidatorCollection.IndexOf Method (Object)

[Visual Basic]
Function IndexOf( _
   ByVal x As Object _
) As Integer Implements IList.IndexOf
[C#]
int IList.IndexOf(
   object x
);

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace | BaseValidatorCollection.IndexOf Overload List


BaseValidatorCollection.Insert Method (Int32, Object)

[Visual Basic]
Sub Insert( _
   ByVal pos As Integer, _
   ByVal x As Object _
) Implements IList.Insert
[C#]
void IList.Insert(
   int pos,
   object x
);

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace | BaseValidatorCollection.Insert Overload List


BaseValidatorCollection.Remove Method (Object)

[Visual Basic]
Sub Remove( _
   ByVal x As Object _
) Implements IList.Remove
[C#]
void IList.Remove(
   object x
);

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace | BaseValidatorCollection.Remove Overload List


BaseValidatorCollection.RemoveAt Method (Int32)

[Visual Basic]
Sub RemoveAt( _
   ByVal pos As Integer _
) Implements IList.RemoveAt
[C#]
void IList.RemoveAt(
   int pos
);

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace | BaseValidatorCollection.RemoveAt Overload List


BaseValidatorCollection.TrimToSize Method

Sets the capacity to the actual number of elements.

[Visual Basic]
Overridable Public Sub TrimToSize()
[C#]
public virtual void TrimToSize();

See Also

BaseValidatorCollection Class | BaseValidatorCollection Members | Genghis.Windows.Forms Namespace


BaseValidatorCollection.IBaseValidatorCollectionEnumerator Interface

Supports type-safe iteration over a BaseValidatorCollection.

For a list of all members of this type, see BaseValidatorCollection.IBaseValidatorCollectionEnumerator Members.

[Visual Basic]
Public Interface BaseValidatorCollection.IBaseValidatorCollectionEnumerator
[C#]
public interface BaseValidatorCollection.IBaseValidatorCollectionEnumerator

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

BaseValidatorCollection.IBaseValidatorCollectionEnumerator Members | Genghis.Windows.Forms Namespace


BaseValidatorCollection.IBaseValidatorCollectionEnumerator Members

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

BaseValidatorCollection.IBaseValidatorCollectionEnumerator Interface | Genghis.Windows.Forms Namespace


BaseValidatorCollection.IBaseValidatorCollectionEnumerator Properties

The properties of the BaseValidatorCollection.IBaseValidatorCollectionEnumerator class are listed below. For a complete list of BaseValidatorCollection.IBaseValidatorCollectionEnumerator class members, see the BaseValidatorCollection.IBaseValidatorCollectionEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

BaseValidatorCollection.IBaseValidatorCollectionEnumerator Interface | Genghis.Windows.Forms Namespace


BaseValidatorCollection.IBaseValidatorCollectionEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Property Current As Genghis.Windows.Forms.BaseValidator
[C#]
BaseValidator Current {get;}

See Also

BaseValidatorCollection.IBaseValidatorCollectionEnumerator Interface | BaseValidatorCollection.IBaseValidatorCollectionEnumerator Members | Genghis.Windows.Forms Namespace


BaseValidatorCollection.IBaseValidatorCollectionEnumerator Methods

The methods of the BaseValidatorCollection.IBaseValidatorCollectionEnumerator class are listed below. For a complete list of BaseValidatorCollection.IBaseValidatorCollectionEnumerator class members, see the BaseValidatorCollection.IBaseValidatorCollectionEnumerator Members topic.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

BaseValidatorCollection.IBaseValidatorCollectionEnumerator Interface | Genghis.Windows.Forms Namespace


BaseValidatorCollection.IBaseValidatorCollectionEnumerator.MoveNext Method

Advances the enumerator to the next element in the collection.

[Visual Basic]
Function MoveNext() As Boolean
[C#]
bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Exceptions

Exception Type | Condition
System.InvalidOperationException | The collection was modified after the enumerator was created.

See Also

BaseValidatorCollection.IBaseValidatorCollectionEnumerator Interface | BaseValidatorCollection.IBaseValidatorCollectionEnumerator Members | Genghis.Windows.Forms Namespace


BaseValidatorCollection.IBaseValidatorCollectionEnumerator.Reset Method

Sets the enumerator to its initial position, before the first element in the collection.

[Visual Basic]
Sub Reset()
[C#]
void Reset();

See Also

BaseValidatorCollection.IBaseValidatorCollectionEnumerator Interface | BaseValidatorCollection.IBaseValidatorCollectionEnumerator Members | Genghis.Windows.Forms Namespace


CompareValidator Class

Compares the value entered by the user into an input control with the value entered into another input control or a constant value.

For a list of all members of this type, see CompareValidator Members.

System.Object
MarshalByRefObject
Component
BaseValidator
BaseCompareValidator
CompareValidator

[Visual Basic]
Public Class CompareValidator
   Inherits BaseCompareValidator
   Implements IComponent, IDisposable, ISupportInitialize
[C#]
public class CompareValidator : BaseCompareValidator, IComponent, IDisposable, ISupportInitialize

Remarks

The CompareValidator compares the input control's value with a value specified by another control (ControlToCompare) or a constant value (ValueToCompare). Either ControlToCompare or ValueToCompare must be provided and, if both are, ControlToCompare is compared against.

Note If the input control's value does not match the type specified by BaseCompareValidator.Type the validation fails.

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

CompareValidator Members | Genghis.Windows.Forms Namespace


CompareValidator Members

Public Instance Constructors

CompareValidator Constructor

Public Instance Properties

Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ControlToCompare | Gets or sets the control to compare the input control's value against.
ControlToValidate (inherited from BaseValidator) | Gets or sets the input control to validate.
ErrorMessage (inherited from BaseValidator) | Gets or sets the text for the error message.
HostingForm (inherited from BaseValidator) | Gets or sets the component's hosting form.
Icon (inherited from BaseValidator) | Gets or sets the Icon that is displayed next to a control when an error description string has been set for the control.
IconAlignment (inherited from BaseValidator) | Gets or sets the location where the error icon should be placed in relation to the control.
IconPadding (inherited from BaseValidator) | Gets or sets the amount of extra space to leave between the specified control and the error icon.
IsValid (inherited from BaseValidator) | Gets a value that indicates whether the associated input control passes validation.
Operator | Gets or sets the type of comparison being performed.
Required | Gets or sets whether this control is required.
Site (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Type (inherited from BaseCompareValidator) | Gets or sets what type-checking will be applied to the validation.
ValueToCompare | Gets or sets the value to compare the input control's value against.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Component) | Select the method name to go to the Microsoft documentation.
Validate (inherited from BaseValidator) | Performs validation on the associated input control and updates the IsValid property.

Protected Instance Properties

DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
TypeConverter (inherited from BaseCompareValidator) | Gets a TypeConverter capable of performing conversions to and from the type, specified by ValidationDataType.

Protected Instance Methods

CanConvert (inherited from BaseCompareValidator) | Returns a value indicating whether the string value can be converted to the type specified by Type.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
EvaluateIsValid | This member overrides BaseValidator.EvaluateIsValid.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
Format (inherited from BaseCompareValidator) | Returns a formatted string.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

ISupportInitialize.BeginInit (inherited from BaseValidator)
ISupportInitialize.EndInit (inherited from BaseValidator)

See Also

CompareValidator Class | Genghis.Windows.Forms Namespace


CompareValidator Constructor

[Visual Basic]
Public Sub New()
[C#]
public CompareValidator();

See Also

CompareValidator Class | CompareValidator Members | Genghis.Windows.Forms Namespace


CompareValidator Properties

The properties of the CompareValidator class are listed below. For a complete list of CompareValidator class members, see the CompareValidator Members topic.

Public Instance Properties

Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ControlToCompare | Gets or sets the control to compare the input control's value against.
ControlToValidate (inherited from BaseValidator) | Gets or sets the input control to validate.
ErrorMessage (inherited from BaseValidator) | Gets or sets the text for the error message.
HostingForm (inherited from BaseValidator) | Gets or sets the component's hosting form.
Icon (inherited from BaseValidator) | Gets or sets the Icon that is displayed next to a control when an error description string has been set for the control.
IconAlignment (inherited from BaseValidator) | Gets or sets the location where the error icon should be placed in relation to the control.
IconPadding (inherited from BaseValidator) | Gets or sets the amount of extra space to leave between the specified control and the error icon.
IsValid (inherited from BaseValidator) | Gets a value that indicates whether the associated input control passes validation.
Operator | Gets or sets the type of comparison being performed.
Required | Gets or sets whether this control is required.
Site (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Type (inherited from BaseCompareValidator) | Gets or sets what type-checking will be applied to the validation.
ValueToCompare | Gets or sets the value to compare the input control's value against.

Protected Instance Properties

DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
TypeConverter (inherited from BaseCompareValidator) | Gets a TypeConverter capable of performing conversions to and from the type, specified by ValidationDataType.

See Also

CompareValidator Class | Genghis.Windows.Forms Namespace


CompareValidator.ControlToCompare Property

Gets or sets the control to compare the input control's value against.

[Visual Basic]
Public Property ControlToCompare As System.Windows.Forms.Control
[C#]
public System.Windows.Forms.Control ControlToCompare {get; set;}

Property Value

The control to compare the input control's value against.

See Also

CompareValidator Class | CompareValidator Members | Genghis.Windows.Forms Namespace


CompareValidator.Operator Property

Gets or sets the type of comparison being performed.

[Visual Basic]
Public Property Operator As Genghis.Windows.Forms.ValidationCompareOperator
[C#]
public ValidationCompareOperator Operator {get; set;}

Property Value

The type of comparison being performed.

See Also

CompareValidator Class | CompareValidator Members | Genghis.Windows.Forms Namespace


CompareValidator.Required Property

Gets or sets whether this control is required.

[Visual Basic]
Public Property Required As Boolean
[C#]
public bool Required {get; set;}

Property Value

true if this control is required; otherwise, false.

See Also

CompareValidator Class | CompareValidator Members | Genghis.Windows.Forms Namespace


CompareValidator.ValueToCompare Property

Gets or sets the value to compare the input control's value against.

[Visual Basic]
Public Property ValueToCompare As String
[C#]
public string ValueToCompare {get; set;}

Property Value

The value to compare the input control's value against.

See Also

CompareValidator Class | CompareValidator Members | Genghis.Windows.Forms Namespace


CompareValidator Methods

The methods of the CompareValidator class are listed below. For a complete list of CompareValidator class members, see the CompareValidator Members topic.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Component) | Select the method name to go to the Microsoft documentation.
Validate (inherited from BaseValidator) | Performs validation on the associated input control and updates the IsValid property.

Protected Instance Methods

CanConvert (inherited from BaseCompareValidator) | Returns a value indicating whether the string value can be converted to the type specified by Type.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
EvaluateIsValid | This member overrides BaseValidator.EvaluateIsValid.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
Format (inherited from BaseCompareValidator) | Returns a formatted string.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

ISupportInitialize.BeginInit (inherited from BaseValidator)
ISupportInitialize.EndInit (inherited from BaseValidator)

See Also

CompareValidator Class | Genghis.Windows.Forms Namespace


CompareValidator.EvaluateIsValid Method

This member overrides BaseValidator.EvaluateIsValid.

[Visual Basic]
Overrides Protected Function EvaluateIsValid() As Boolean
[C#]
protected override bool EvaluateIsValid();

See Also

CompareValidator Class | CompareValidator Members | Genghis.Windows.Forms Namespace


CompletionCombo Class

Combo Box that does that neat auto-completion trick

For a list of all members of this type, see CompletionCombo Members.

System.Object
MarshalByRefObject
Component
Control
ListControl
ComboBox
CompletionCombo

[Visual Basic]
Public Class CompletionCombo
   Inherits ComboBox
   Implements IComponent, IDisposable, IOleControl, IOleObject, IOleInPlaceObject, IOleInPlaceActiveObject, IOleWindow, IViewObject, IViewObject2, IPersist, IPersistStreamInit, IPersistPropertyBag, IPersistStorage, IQuickActivate, ISynchronizeInvoke, IWin32Window
[C#]
public class CompletionCombo : ComboBox, IComponent, IDisposable, IOleControl, IOleObject, IOleInPlaceObject, IOleInPlaceActiveObject, IOleWindow, IViewObject, IViewObject2, IPersist, IPersistStreamInit, IPersistPropertyBag, IPersistStorage, IQuickActivate, ISynchronizeInvoke, IWin32Window

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

CompletionCombo Members | Genghis.Windows.Forms Namespace


CompletionCombo Members

Public Instance Constructors

CompletionCombo Constructor

Public Instance Properties

AccessibilityObject (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleDefaultActionDescription (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleDescription (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleRole (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AllowDrop (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Anchor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
BackColor (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
BackgroundImage (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
BindingContext (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Bottom (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Bounds (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CanFocus (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CanSelect (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Capture (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CausesValidation (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ClientRectangle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ClientSize (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CompanyName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ContainsFocus (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ContextMenu (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Controls (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Created (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Cursor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DataBindings (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DataSource (inherited from System.Windows.Forms.ListControl) | Select the method name to go to the Microsoft documentation.
DisplayMember (inherited from System.Windows.Forms.ListControl) | Select the method name to go to the Microsoft documentation.
DisplayRectangle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Disposing (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Dock (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DrawMode (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
DropDownStyle (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
DropDownWidth (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
DroppedDown (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
Enabled (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Focused (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
Font (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ForeColor (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
Handle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
HasChildren (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Height (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ImeMode (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IntegralHeight (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
InvokeRequired (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsAccessible (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsDisposed (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsHandleCreated (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ItemHeight (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
Items (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
Left (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Location (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
MaxDropDownItems (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
MaxLength (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
Name (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Parent (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
PreferredHeight (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
ProductName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ProductVersion (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RecreatingHandle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Region (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Right (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RightToLeft (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
SelectedIndex (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
SelectedItem (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
SelectedText (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
SelectedValue (inherited from System.Windows.Forms.ListControl) | Select the method name to go to the Microsoft documentation.
SelectionLength (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
SelectionStart (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
Site (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Size (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Sorted (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
TabIndex (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TabStop (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Tag (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Text (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
Top (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TopLevelControl (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ValueMember (inherited from System.Windows.Forms.ListControl) | Select the method name to go to the Microsoft documentation.
Visible (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Width (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
WindowTarget (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.

Public Instance Methods

BeginInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
BeginInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
BeginUpdate (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
BringToFront (inherited from Control) | Select the method name to go to the Microsoft documentation.
Contains (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateGraphics (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
DoDragDrop (inherited from Control) | Select the method name to go to the Microsoft documentation.
EndInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
EndUpdate (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
FindForm (inherited from Control) | Select the method name to go to the Microsoft documentation.
FindString (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
FindString (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
FindStringExact (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
FindStringExact (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
Focus (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetChildAtPoint (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetContainerControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetItemHeight (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
GetItemText (inherited from ListControl) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetNextControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
Hide (inherited from Control) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
PerformLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
PerformLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
PointToClient (inherited from Control) | Select the method name to go to the Microsoft documentation.
PointToScreen (inherited from Control) | Select the method name to go to the Microsoft documentation.
PreProcessMessage (inherited from Control) | Select the method name to go to the Microsoft documentation.
RectangleToClient (inherited from Control) | Select the method name to go to the Microsoft documentation.
RectangleToScreen (inherited from Control) | Select the method name to go to the Microsoft documentation.
Refresh (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetBackColor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetBindings (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetCursor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetFont (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetForeColor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetImeMode (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetRightToLeft (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetText (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResumeLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResumeLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
Scale (inherited from Control) | Select the method name to go to the Microsoft documentation.
Scale (inherited from Control) | Select the method name to go to the Microsoft documentation.
Select (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
Select (inherited from Control) | Select the method name to go to the Microsoft documentation.
SelectAll (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
SelectNextControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
SendToBack (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
Show (inherited from Control) | Select the method name to go to the Microsoft documentation.
SuspendLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
ToString (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
Update (inherited from Control) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

CreateParams (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
DataManager (inherited from System.Windows.Forms.ListControl) | Select the method name to go to the Microsoft documentation.
DefaultImeMode (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DefaultSize (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
FontHeight (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RenderRightToLeft (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ResizeRedraw (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowFocusCues (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowKeyboardCues (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Select the method name to go to the Microsoft documentation.
AddItemsCore (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
CreateAccessibilityInstance (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateControlsInstance (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
DefWndProc (inherited from Control) | Select the method name to go to the Microsoft documentation.
DestroyHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
FilterItemOnProperty (inherited from ListControl) | Select the method name to go to the Microsoft documentation.
FilterItemOnProperty (inherited from ListControl) | Select the method name to go to the Microsoft documentation.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetStyle (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetTopLevel (inherited from Control) | Select the method name to go to the Microsoft documentation.
InitLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeGotFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeLostFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeOnClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokePaint (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokePaintBackground (inherited from Control) | Select the method name to go to the Microsoft documentation.
IsInputChar (inherited from Control) | Select the method name to go to the Microsoft documentation.
IsInputKey (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
NotifyInvalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBackColorChanged (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnBackgroundImageChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBindingContextChanged (inherited from ListControl) | Select the method name to go to the Microsoft documentation.
OnCausesValidationChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnChangeUICues (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnContextMenuChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnControlAdded (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnControlRemoved (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnCreateControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnCursorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDataSourceChanged (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnDisplayMemberChanged (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnDockChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDoubleClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragDrop (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragOver (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDrawItem (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnDropDown (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnDropDownStyleChanged (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnEnabledChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnFontChanged (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnForeColorChanged (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnGiveFeedback (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnGotFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnHandleCreated (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnHandleDestroyed (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnHelpRequested (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnImeModeChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnInvalidated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnKeyDown |
OnKeyPress (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnKeyUp (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLocationChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLostFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMeasureItem (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnMouseDown (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseHover (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseMove (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseUp (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseWheel (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMove (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnNotifyMessage (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnPaint (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnPaintBackground (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBackColorChanged (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnParentBackgroundImageChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBindingContextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentEnabledChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentFontChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentForeColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentRightToLeftChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentVisibleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnQueryContinueDrag (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnResize (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnRightToLeftChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnSelectedIndexChanged (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnSelectedItemChanged (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnSelectedValueChanged (inherited from ListControl) | Select the method name to go to the Microsoft documentation.
OnSelectionChangeCommitted (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnSizeChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnStyleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnSystemColorsChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTabIndexChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTabStopChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTextChanged |
OnValidated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnValidating (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnValueMemberChanged (inherited from ListControl) | Select the method name to go to the Microsoft documentation.
OnVisibleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessCmdKey (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessDialogChar (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessDialogKey (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessKeyEventArgs (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessKeyPreview (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessMnemonic (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseDragEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseKeyEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseMouseEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaisePaintEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RecreateHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
RefreshItem (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
ResetMouseEventArgs (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateContent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateHorizontal (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateLeftRight (inherited from Control) | Select the method name to go to the Microsoft documentation.
ScaleCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
Select (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetBoundsCore (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
SetClientSizeCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetItemCore (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
SetItemsCore (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
SetStyle (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetTopLevel (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetVisibleCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateStyles (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateZOrder (inherited from Control) | Select the method name to go to the Microsoft documentation.
WndProc (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

UnsafeNativeMethods+IOleObject.Advise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Close (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleWindow.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.DoVerb (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Draw (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Draw (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.EnableModeless (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.EnumAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.EnumVerbs (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Freeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Freeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.FreezeEvents (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.GetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersist.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetClientSite (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetClipboardData (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetColorSet (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.GetColorSet (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.GetContentExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.GetControlInfo (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetMiscStatus (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetMoniker (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.GetSizeMax (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetUserClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetUserType (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleWindow.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.HandsOffStorage (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.InitFromData (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.InPlaceDeactivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.IsDirty (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.IsDirty (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.IsUpToDate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.OleUpdate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.OnAmbientPropertyChange (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.OnDocWindowActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.OnFrameWindowActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.OnMnemonic (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.QuickActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.ReactivateAndUndo (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.ResizeBorder (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.SaveCompleted (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.SetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.SetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetClientSite (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetColorScheme (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.SetContentExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetHostNames (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetMoniker (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.SetObjectRects (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.TranslateAccelerator (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.UIDeactivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Unadvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Unfreeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Unfreeze (inherited from Control) | Select the method name to go to the Microsoft documentation.

See Also

CompletionCombo Class | Genghis.Windows.Forms Namespace


CompletionCombo Constructor

[Visual Basic]
Public Sub New()
[C#]
public CompletionCombo();

See Also

CompletionCombo Class | CompletionCombo Members | Genghis.Windows.Forms Namespace


CompletionCombo Methods

The methods of the CompletionCombo class are listed below. For a complete list of CompletionCombo class members, see the CompletionCombo Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
BeginInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
BeginUpdate (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
BringToFront (inherited from Control) | Select the method name to go to the Microsoft documentation.
Contains (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateGraphics (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
DoDragDrop (inherited from Control) | Select the method name to go to the Microsoft documentation.
EndInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
EndUpdate (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
FindForm (inherited from Control) | Select the method name to go to the Microsoft documentation.
FindString (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
FindString (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
FindStringExact (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
FindStringExact (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
Focus (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetChildAtPoint (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetContainerControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetItemHeight (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
GetItemText (inherited from ListControl) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetNextControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
Hide (inherited from Control) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
PerformLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
PerformLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
PointToClient (inherited from Control) | Select the method name to go to the Microsoft documentation.
PointToScreen (inherited from Control) | Select the method name to go to the Microsoft documentation.
PreProcessMessage (inherited from Control) | Select the method name to go to the Microsoft documentation.
RectangleToClient (inherited from Control) | Select the method name to go to the Microsoft documentation.
RectangleToScreen (inherited from Control) | Select the method name to go to the Microsoft documentation.
Refresh (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetBackColor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetBindings (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetCursor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetFont (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetForeColor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetImeMode (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetRightToLeft (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetText (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResumeLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResumeLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
Scale (inherited from Control) | Select the method name to go to the Microsoft documentation.
Scale (inherited from Control) | Select the method name to go to the Microsoft documentation.
Select (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
Select (inherited from Control) | Select the method name to go to the Microsoft documentation.
SelectAll (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
SelectNextControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
SendToBack (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
Show (inherited from Control) | Select the method name to go to the Microsoft documentation.
SuspendLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
ToString (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
Update (inherited from Control) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Select the method name to go to the Microsoft documentation.
AddItemsCore (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
CreateAccessibilityInstance (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateControlsInstance (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
DefWndProc (inherited from Control) | Select the method name to go to the Microsoft documentation.
DestroyHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
FilterItemOnProperty (inherited from ListControl) | Select the method name to go to the Microsoft documentation.
FilterItemOnProperty (inherited from ListControl) | Select the method name to go to the Microsoft documentation.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetStyle (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetTopLevel (inherited from Control) | Select the method name to go to the Microsoft documentation.
InitLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeGotFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeLostFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeOnClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokePaint (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokePaintBackground (inherited from Control) | Select the method name to go to the Microsoft documentation.
IsInputChar (inherited from Control) | Select the method name to go to the Microsoft documentation.
IsInputKey (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
NotifyInvalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBackColorChanged (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnBackgroundImageChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBindingContextChanged (inherited from ListControl) | Select the method name to go to the Microsoft documentation.
OnCausesValidationChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnChangeUICues (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnContextMenuChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnControlAdded (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnControlRemoved (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnCreateControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnCursorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDataSourceChanged (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnDisplayMemberChanged (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnDockChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDoubleClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragDrop (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragOver (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDrawItem (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnDropDown (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnDropDownStyleChanged (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnEnabledChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnFontChanged (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnForeColorChanged (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnGiveFeedback (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnGotFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnHandleCreated (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnHandleDestroyed (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnHelpRequested (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnImeModeChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnInvalidated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnKeyDown |
OnKeyPress (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnKeyUp (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLocationChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLostFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMeasureItem (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnMouseDown (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseHover (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseMove (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseUp (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseWheel (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMove (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnNotifyMessage (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnPaint (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnPaintBackground (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBackColorChanged (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnParentBackgroundImageChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBindingContextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentEnabledChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentFontChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentForeColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentRightToLeftChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentVisibleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnQueryContinueDrag (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnResize (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnRightToLeftChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnSelectedIndexChanged (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnSelectedItemChanged (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnSelectedValueChanged (inherited from ListControl) | Select the method name to go to the Microsoft documentation.
OnSelectionChangeCommitted (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnSizeChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnStyleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnSystemColorsChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTabIndexChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTabStopChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTextChanged |
OnValidated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnValidating (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnValueMemberChanged (inherited from ListControl) | Select the method name to go to the Microsoft documentation.
OnVisibleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessCmdKey (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessDialogChar (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessDialogKey (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessKeyEventArgs (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessKeyPreview (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessMnemonic (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseDragEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseKeyEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseMouseEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaisePaintEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RecreateHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
RefreshItem (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
ResetMouseEventArgs (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateContent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateHorizontal (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateLeftRight (inherited from Control) | Select the method name to go to the Microsoft documentation.
ScaleCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
Select (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetBoundsCore (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
SetClientSizeCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetItemCore (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
SetItemsCore (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
SetStyle (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetTopLevel (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetVisibleCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateStyles (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateZOrder (inherited from Control) | Select the method name to go to the Microsoft documentation.
WndProc (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

UnsafeNativeMethods+IOleObject.Advise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Close (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleWindow.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.DoVerb (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Draw (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Draw (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.EnableModeless (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.EnumAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.EnumVerbs (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Freeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Freeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.FreezeEvents (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.GetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersist.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetClientSite (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetClipboardData (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetColorSet (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.GetColorSet (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.GetContentExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.GetControlInfo (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetMiscStatus (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetMoniker (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.GetSizeMax (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetUserClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetUserType (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleWindow.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.HandsOffStorage (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.InitFromData (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.InPlaceDeactivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.IsDirty (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.IsDirty (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.IsUpToDate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.OleUpdate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.OnAmbientPropertyChange (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.OnDocWindowActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.OnFrameWindowActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.OnMnemonic (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.QuickActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.ReactivateAndUndo (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.ResizeBorder (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.SaveCompleted (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.SetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.SetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetClientSite (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetColorScheme (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.SetContentExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetHostNames (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetMoniker (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.SetObjectRects (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.TranslateAccelerator (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.UIDeactivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Unadvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Unfreeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Unfreeze (inherited from Control) | Select the method name to go to the Microsoft documentation.

See Also

CompletionCombo Class | Genghis.Windows.Forms Namespace


CompletionCombo.OnKeyDown Method

[Visual Basic]
Overrides Protected Sub OnKeyDown( _
   ByVal args As System.Windows.Forms.KeyEventArgs _
)
[C#]
protected override void OnKeyDown(
   KeyEventArgs args
);

See Also

CompletionCombo Class | CompletionCombo Members | Genghis.Windows.Forms Namespace


CompletionCombo.OnTextChanged Method

[Visual Basic]
Overrides Protected Sub OnTextChanged( _
   ByVal args As System.EventArgs _
)
[C#]
protected override void OnTextChanged(
   EventArgs args
);

See Also

CompletionCombo Class | CompletionCombo Members | Genghis.Windows.Forms Namespace


ContainerStatusBar Class

A substitute for the System.Windows.Forms.ContainerStatusBar that allows any control to be hosted in a status bar panel.

For a list of all members of this type, see ContainerStatusBar Members.

System.Object
MarshalByRefObject
Component
Control
StatusBar
ContainerStatusBar

[Visual Basic]
Public Class ContainerStatusBar
   Inherits StatusBar
   Implements IComponent, IDisposable, IOleControl, IOleObject, IOleInPlaceObject, IOleInPlaceActiveObject, IOleWindow, IViewObject, IViewObject2, IPersist, IPersistStreamInit, IPersistPropertyBag, IPersistStorage, IQuickActivate, ISynchronizeInvoke, IWin32Window
[C#]
public class ContainerStatusBar : StatusBar, IComponent, IDisposable, IOleControl, IOleObject, IOleInPlaceObject, IOleInPlaceActiveObject, IOleWindow, IViewObject, IViewObject2, IPersist, IPersistStreamInit, IPersistPropertyBag, IPersistStorage, IQuickActivate, ISynchronizeInvoke, IWin32Window

Remarks

Provides full designer support for adding and customizing panels. To use: Add the Genghis.Windows.Forms.ContainerStatusBar to your toolbox. From the toolbox, add the ContainerStatusBar to your form and use as a normal ContainerStatusBar. To host a control, the control must be a child of the status bar. It can then be set as the value for the HostedControl property on one of the status bar's panels.

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

ContainerStatusBar Members | Genghis.Windows.Forms Namespace


ContainerStatusBar Members

Public Instance Constructors

ContainerStatusBar Constructor

Public Instance Properties

AccessibilityObject (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleDefaultActionDescription (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleDescription (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleRole (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AllowDrop (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Anchor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
BackColor (inherited from System.Windows.Forms.StatusBar) | Select the method name to go to the Microsoft documentation.
BackgroundImage (inherited from System.Windows.Forms.StatusBar) | Select the method name to go to the Microsoft documentation.
BindingContext (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Bottom (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Bounds (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CanFocus (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CanSelect (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Capture (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CausesValidation (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ClientRectangle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ClientSize (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CompanyName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ContainsFocus (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ContextMenu (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Controls (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Created (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Cursor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DataBindings (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DisplayRectangle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Disposing (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Dock (inherited from System.Windows.Forms.StatusBar) | Select the method name to go to the Microsoft documentation.
Enabled (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Focused (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Font (inherited from System.Windows.Forms.StatusBar) | Select the method name to go to the Microsoft documentation.
ForeColor (inherited from System.Windows.Forms.StatusBar) | Select the method name to go to the Microsoft documentation.
Handle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
HasChildren (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Height (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ImeMode (inherited from System.Windows.Forms.StatusBar) | Select the method name to go to the Microsoft documentation.
InvokeRequired (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsAccessible (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsDisposed (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsHandleCreated (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Left (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Location (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Name (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Panels | Overloaded. Typed collection of ContainerStatusBarpanels
Panels (inherited from System.Windows.Forms.StatusBar) | Select the method name to go to the Microsoft documentation.
Parent (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ProductName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ProductVersion (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RecreatingHandle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Region (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Right (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RightToLeft (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowPanels (inherited from System.Windows.Forms.StatusBar) | Select the method name to go to the Microsoft documentation.
Site (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Size (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
SizingGrip (inherited from System.Windows.Forms.StatusBar) | Select the method name to go to the Microsoft documentation.
TabIndex (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TabStop (inherited from System.Windows.Forms.StatusBar) | Select the method name to go to the Microsoft documentation.
Tag (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Text (inherited from System.Windows.Forms.StatusBar) | Select the method name to go to the Microsoft documentation.
Top (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TopLevelControl (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Visible (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Width (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
WindowTarget (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.

Public Instance Methods

BeginInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
BeginInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
BringToFront (inherited from Control) | Select the method name to go to the Microsoft documentation.
Contains (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateGraphics (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
DoDragDrop (inherited from Control) | Select the method name to go to the Microsoft documentation.
EndInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
FindForm (inherited from Control) | Select the method name to go to the Microsoft documentation.
Focus (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetChildAtPoint (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetContainerControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHostingPanel | Examines the exisitng panels hosted by the ContainerStatusBar to determine if any of them already host the control. Used in design mode to ensure that a control is not placed on more than one panel.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetNextControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetPanelAtPoint | Determines the ContainerStatusBarPanel that is under the point
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
Hide (inherited from Control) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
PerformLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
PerformLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
PointToClient (inherited from Control) | Select the method name to go to the Microsoft documentation.
PointToScreen (inherited from Control) | Select the method name to go to the Microsoft documentation.
PreProcessMessage (inherited from Control) | Select the method name to go to the Microsoft documentation.
RectangleToClient (inherited from Control) | Select the method name to go to the Microsoft documentation.
RectangleToScreen (inherited from Control) | Select the method name to go to the Microsoft documentation.
Refresh (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetBackColor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetBindings (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetCursor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetFont (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetForeColor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetImeMode (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetRightToLeft (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetText (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResumeLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResumeLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
Scale (inherited from Control) | Select the method name to go to the Microsoft documentation.
Scale (inherited from Control) | Select the method name to go to the Microsoft documentation.
Select (inherited from Control) | Select the method name to go to the Microsoft documentation.
SelectNextControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
SendToBack (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
Show (inherited from Control) | Select the method name to go to the Microsoft documentation.
SuspendLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
ToString (inherited from StatusBar) | Select the method name to go to the Microsoft documentation.
Update (inherited from Control) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

CreateParams (inherited from System.Windows.Forms.StatusBar) | Select the method name to go to the Microsoft documentation.
DefaultImeMode (inherited from System.Windows.Forms.StatusBar) | Select the method name to go to the Microsoft documentation.
DefaultSize (inherited from System.Windows.Forms.StatusBar) | Select the method name to go to the Microsoft documentation.
DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
FontHeight (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RenderRightToLeft (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ResizeRedraw (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowFocusCues (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowKeyboardCues (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateAccessibilityInstance (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateControlsInstance (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateHandle (inherited from StatusBar) | Select the method name to go to the Microsoft documentation.
DefWndProc (inherited from Control) | Select the method name to go to the Microsoft documentation.
DestroyHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from StatusBar) | Select the method name to go to the Microsoft documentation.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetStyle (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetTopLevel (inherited from Control) | Select the method name to go to the Microsoft documentation.
InitLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeGotFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeLostFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeOnClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokePaint (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokePaintBackground (inherited from Control) | Select the method name to go to the Microsoft documentation.
IsInputChar (inherited from Control) | Select the method name to go to the Microsoft documentation.
IsInputKey (inherited from Control) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
NotifyInvalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBackColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBackgroundImageChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBindingContextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnCausesValidationChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnChangeUICues (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnContextMenuChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnControlAdded (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnControlRemoved | Override standard processing of removing child controls from the ContainerStatusBar. Ensures that no panels host the control that has been removed.
OnCreateControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnCursorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDockChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDoubleClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragDrop (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragOver (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDrawItem | Handles drawing of ContainerStatusBarpanles with a value for their NestedControl Property.
OnEnabledChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnFontChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnForeColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnGiveFeedback (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnGotFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnHandleCreated (inherited from StatusBar) | Select the method name to go to the Microsoft documentation.
OnHandleDestroyed (inherited from StatusBar) | Select the method name to go to the Microsoft documentation.
OnHelpRequested (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnImeModeChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnInvalidated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnKeyDown (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnKeyPress (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnKeyUp (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLayout (inherited from StatusBar) | Select the method name to go to the Microsoft documentation.
OnLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLocationChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLostFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseDown (inherited from StatusBar) | Select the method name to go to the Microsoft documentation.
OnMouseEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseHover (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseMove (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseUp (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseWheel (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMove (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnNotifyMessage (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnPaint (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnPaintBackground (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnPanelClick (inherited from StatusBar) | Select the method name to go to the Microsoft documentation.
OnParentBackColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBackgroundImageChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBindingContextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentEnabledChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentFontChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentForeColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentRightToLeftChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentVisibleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnQueryContinueDrag (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnResize (inherited from StatusBar) | Select the method name to go to the Microsoft documentation.
OnRightToLeftChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnSizeChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnStyleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnSystemColorsChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTabIndexChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTabStopChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnValidated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnValidating (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnVisibleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessCmdKey (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessDialogChar (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessDialogKey (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessKeyEventArgs (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessKeyPreview (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessMnemonic (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseDragEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseKeyEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseMouseEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaisePaintEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RecreateHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetMouseEventArgs (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateContent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateHorizontal (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateLeftRight (inherited from Control) | Select the method name to go to the Microsoft documentation.
ScaleCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
Select (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetBoundsCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetClientSizeCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetStyle (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetTopLevel (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetVisibleCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateStyles (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateZOrder (inherited from Control) | Select the method name to go to the Microsoft documentation.
WndProc (inherited from StatusBar) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

UnsafeNativeMethods+IOleObject.Advise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Close (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleWindow.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.DoVerb (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Draw (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Draw (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.EnableModeless (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.EnumAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.EnumVerbs (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Freeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Freeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.FreezeEvents (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.GetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersist.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetClientSite (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetClipboardData (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetColorSet (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.GetColorSet (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.GetContentExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.GetControlInfo (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetMiscStatus (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetMoniker (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.GetSizeMax (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetUserClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetUserType (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleWindow.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.HandsOffStorage (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.InitFromData (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.InPlaceDeactivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.IsDirty (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.IsDirty (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.IsUpToDate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.OleUpdate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.OnAmbientPropertyChange (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.OnDocWindowActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.OnFrameWindowActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.OnMnemonic (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.QuickActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.ReactivateAndUndo (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.ResizeBorder (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.SaveCompleted (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.SetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.SetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetClientSite (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetColorScheme (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.SetContentExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetHostNames (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetMoniker (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.SetObjectRects (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.TranslateAccelerator (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.UIDeactivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Unadvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Unfreeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Unfreeze (inherited from Control) | Select the method name to go to the Microsoft documentation.

See Also

ContainerStatusBar Class | Genghis.Windows.Forms Namespace


ContainerStatusBar Constructor

[Visual Basic]
Public Sub New()
[C#]
public ContainerStatusBar();

See Also

ContainerStatusBar Class | ContainerStatusBar Members | Genghis.Windows.Forms Namespace


ContainerStatusBar Properties

The properties of the ContainerStatusBar class are listed below. For a complete list of ContainerStatusBar class members, see the ContainerStatusBar Members topic.

Public Instance Properties

AccessibilityObject (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleDefaultActionDescription (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleDescription (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleRole (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AllowDrop (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Anchor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
BackColor (inherited from System.Windows.Forms.StatusBar) | Select the method name to go to the Microsoft documentation.
BackgroundImage (inherited from System.Windows.Forms.StatusBar) | Select the method name to go to the Microsoft documentation.
BindingContext (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Bottom (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Bounds (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CanFocus (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CanSelect (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Capture (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CausesValidation (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ClientRectangle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ClientSize (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CompanyName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ContainsFocus (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ContextMenu (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Controls (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Created (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Cursor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DataBindings (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DisplayRectangle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Disposing (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Dock (inherited from System.Windows.Forms.StatusBar) | Select the method name to go to the Microsoft documentation.
Enabled (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Focused (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Font (inherited from System.Windows.Forms.StatusBar) | Select the method name to go to the Microsoft documentation.
ForeColor (inherited from System.Windows.Forms.StatusBar) | Select the method name to go to the Microsoft documentation.
Handle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
HasChildren (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Height (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ImeMode (inherited from System.Windows.Forms.StatusBar) | Select the method name to go to the Microsoft documentation.
InvokeRequired (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsAccessible (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsDisposed (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsHandleCreated (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Left (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Location (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Name (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Panels | Overloaded. Typed collection of ContainerStatusBarpanels
Panels (inherited from System.Windows.Forms.StatusBar) | Select the method name to go to the Microsoft documentation.
Parent (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ProductName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ProductVersion (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RecreatingHandle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Region (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Right (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RightToLeft (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowPanels (inherited from System.Windows.Forms.StatusBar) | Select the method name to go to the Microsoft documentation.
Site (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Size (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
SizingGrip (inherited from System.Windows.Forms.StatusBar) | Select the method name to go to the Microsoft documentation.
TabIndex (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TabStop (inherited from System.Windows.Forms.StatusBar) | Select the method name to go to the Microsoft documentation.
Tag (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Text (inherited from System.Windows.Forms.StatusBar) | Select the method name to go to the Microsoft documentation.
Top (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TopLevelControl (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Visible (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Width (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
WindowTarget (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

CreateParams (inherited from System.Windows.Forms.StatusBar) | Select the method name to go to the Microsoft documentation.
DefaultImeMode (inherited from System.Windows.Forms.StatusBar) | Select the method name to go to the Microsoft documentation.
DefaultSize (inherited from System.Windows.Forms.StatusBar) | Select the method name to go to the Microsoft documentation.
DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
FontHeight (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RenderRightToLeft (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ResizeRedraw (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowFocusCues (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowKeyboardCues (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.

See Also

ContainerStatusBar Class | Genghis.Windows.Forms Namespace


ContainerStatusBar.Panels Property

Typed collection of ContainerStatusBarpanels

[Visual Basic]
Overloads Public ReadOnly Property Panels As Genghis.Windows.Forms.ContainerStatusBar.StatusBarPanelCollection
[C#]
public ContainerStatusBar.StatusBarPanelCollection Panels {get;}

Remarks

Provides the same functionality as except that it supports StatbarPanel instead of System.Windows.Forms.ContainerStatusBarpanel

See Also

ContainerStatusBar Class | ContainerStatusBar Members | Genghis.Windows.Forms Namespace | ContainerStatusBar.Panels Overload List

Copyright (C) 2002 The Genghis Group

ContainerStatusBar.Panels Property
Genghis Class Library

ContainerStatusBar.Panels Property

Typed collection of ContainerStatusBarpanels

[Visual Basic]
Overloads Public ReadOnly Property Panels As System.Windows.Forms.StatusBar.StatusBarPanelCollection
[C#]
public System.Windows.Forms.StatusBar.StatusBarPanelCollection Panels {get;}

Remarks

Provides the same functionality as except that it supports StatbarPanel instead of System.Windows.Forms.ContainerStatusBarpanel

See Also

ContainerStatusBar Class | ContainerStatusBar Members | Genghis.Windows.Forms Namespace | ContainerStatusBar.Panels Overload List


ContainerStatusBar Methods

The methods of the ContainerStatusBar class are listed below. For a complete list of ContainerStatusBar class members, see the ContainerStatusBar Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
BeginInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
BringToFront (inherited from Control) | Select the method name to go to the Microsoft documentation.
Contains (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateGraphics (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
DoDragDrop (inherited from Control) | Select the method name to go to the Microsoft documentation.
EndInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
FindForm (inherited from Control) | Select the method name to go to the Microsoft documentation.
Focus (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetChildAtPoint (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetContainerControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHostingPanel | Examines the exisitng panels hosted by the ContainerStatusBar to determine if any of them already host the control. Used in design mode to ensure that a control is not placed on more than one panel.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetNextControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetPanelAtPoint | Determines the ContainerStatusBarPanel that is under the point
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
Hide (inherited from Control) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
PerformLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
PerformLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
PointToClient (inherited from Control) | Select the method name to go to the Microsoft documentation.
PointToScreen (inherited from Control) | Select the method name to go to the Microsoft documentation.
PreProcessMessage (inherited from Control) | Select the method name to go to the Microsoft documentation.
RectangleToClient (inherited from Control) | Select the method name to go to the Microsoft documentation.
RectangleToScreen (inherited from Control) | Select the method name to go to the Microsoft documentation.
Refresh (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetBackColor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetBindings (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetCursor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetFont (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetForeColor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetImeMode (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetRightToLeft (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetText (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResumeLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResumeLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
Scale (inherited from Control) | Select the method name to go to the Microsoft documentation.
Scale (inherited from Control) | Select the method name to go to the Microsoft documentation.
Select (inherited from Control) | Select the method name to go to the Microsoft documentation.
SelectNextControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
SendToBack (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
Show (inherited from Control) | Select the method name to go to the Microsoft documentation.
SuspendLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
ToString (inherited from StatusBar) | Select the method name to go to the Microsoft documentation.
Update (inherited from Control) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateAccessibilityInstance (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateControlsInstance (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateHandle (inherited from StatusBar) | Select the method name to go to the Microsoft documentation.
DefWndProc (inherited from Control) | Select the method name to go to the Microsoft documentation.
DestroyHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from StatusBar) | Select the method name to go to the Microsoft documentation.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetStyle (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetTopLevel (inherited from Control) | Select the method name to go to the Microsoft documentation.
InitLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeGotFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeLostFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeOnClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokePaint (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokePaintBackground (inherited from Control) | Select the method name to go to the Microsoft documentation.
IsInputChar (inherited from Control) | Select the method name to go to the Microsoft documentation.
IsInputKey (inherited from Control) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
NotifyInvalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBackColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBackgroundImageChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBindingContextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnCausesValidationChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnChangeUICues (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnContextMenuChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnControlAdded (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnControlRemoved | Override standard processing of removing child controls from the ContainerStatusBar. Ensures that no panels host the control that has been removed.
OnCreateControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnCursorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDockChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDoubleClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragDrop (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragOver (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDrawItem | Handles drawing of ContainerStatusBarpanles with a value for their NestedControl Property.
OnEnabledChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnFontChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnForeColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnGiveFeedback (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnGotFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnHandleCreated (inherited from StatusBar) | Select the method name to go to the Microsoft documentation.
OnHandleDestroyed (inherited from StatusBar) | Select the method name to go to the Microsoft documentation.
OnHelpRequested (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnImeModeChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnInvalidated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnKeyDown (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnKeyPress (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnKeyUp (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLayout (inherited from StatusBar) | Select the method name to go to the Microsoft documentation.
OnLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLocationChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLostFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseDown (inherited from StatusBar) | Select the method name to go to the Microsoft documentation.
OnMouseEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseHover (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseMove (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseUp (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseWheel (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMove (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnNotifyMessage (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnPaint (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnPaintBackground (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnPanelClick (inherited from StatusBar) | Select the method name to go to the Microsoft documentation.
OnParentBackColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBackgroundImageChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBindingContextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentEnabledChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentFontChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentForeColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentRightToLeftChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentVisibleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnQueryContinueDrag (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnResize (inherited from StatusBar) | Select the method name to go to the Microsoft documentation.
OnRightToLeftChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnSizeChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnStyleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnSystemColorsChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTabIndexChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTabStopChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnValidated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnValidating (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnVisibleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessCmdKey (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessDialogChar (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessDialogKey (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessKeyEventArgs (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessKeyPreview (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessMnemonic (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseDragEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseKeyEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseMouseEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaisePaintEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RecreateHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetMouseEventArgs (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateContent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateHorizontal (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateLeftRight (inherited from Control) | Select the method name to go to the Microsoft documentation.
ScaleCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
Select (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetBoundsCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetClientSizeCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetStyle (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetTopLevel (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetVisibleCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateStyles (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateZOrder (inherited from Control) | Select the method name to go to the Microsoft documentation.
WndProc (inherited from StatusBar) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

UnsafeNativeMethods+IOleObject.Advise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Close (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleWindow.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.DoVerb (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Draw (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Draw (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.EnableModeless (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.EnumAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.EnumVerbs (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Freeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Freeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.FreezeEvents (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.GetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersist.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetClientSite (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetClipboardData (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetColorSet (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.GetColorSet (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.GetContentExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.GetControlInfo (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetMiscStatus (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetMoniker (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.GetSizeMax (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetUserClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetUserType (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleWindow.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.HandsOffStorage (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.InitFromData (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.InPlaceDeactivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.IsDirty (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.IsDirty (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.IsUpToDate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.OleUpdate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.OnAmbientPropertyChange (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.OnDocWindowActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.OnFrameWindowActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.OnMnemonic (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.QuickActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.ReactivateAndUndo (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.ResizeBorder (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.SaveCompleted (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.SetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.SetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetClientSite (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetColorScheme (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.SetContentExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetHostNames (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetMoniker (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.SetObjectRects (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.TranslateAccelerator (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.UIDeactivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Unadvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Unfreeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Unfreeze (inherited from Control) | Select the method name to go to the Microsoft documentation.

See Also

ContainerStatusBar Class | Genghis.Windows.Forms Namespace


ContainerStatusBar.GetHostingPanel Method

Examines the exisitng panels hosted by the ContainerStatusBar to determine if any of them already host the control. Used in design mode to ensure that a control is not placed on more than one panel.

[Visual Basic]
Public Function GetHostingPanel( _
   ByVal hostedControl As System.Windows.Forms.Control _
) As Genghis.Windows.Forms.ContainerStatusBarPanel
[C#]
public ContainerStatusBarPanel GetHostingPanel(
   Control hostedControl
);

Parameters

hostedControl

Return Value

The ContainerStatusBarPanel hosting the control or null if the control is not hosted on any panels.

See Also

ContainerStatusBar Class | ContainerStatusBar Members | Genghis.Windows.Forms Namespace


ContainerStatusBar.GetPanelAtPoint Method

Determines the ContainerStatusBarPanel that is under the point

[Visual Basic]
Public Function GetPanelAtPoint( _
   ByVal p As System.Drawing.Point _
) As Genghis.Windows.Forms.ContainerStatusBarPanel
[C#]
public ContainerStatusBarPanel GetPanelAtPoint(
   Point p
);

Parameters

p
The point in the ContainerStatusBar's coordinate system

Return Value

The panel under the point, or null if the point is out of range.

See Also

ContainerStatusBar Class | ContainerStatusBar Members | Genghis.Windows.Forms Namespace


ContainerStatusBar.OnControlRemoved Method

Override standard processing of removing child controls from the ContainerStatusBar. Ensures that no panels host the control that has been removed.

[Visual Basic]
Overrides Protected Sub OnControlRemoved( _
   ByVal e As System.Windows.Forms.ControlEventArgs _
)
[C#]
protected override void OnControlRemoved(
   ControlEventArgs e
);

Parameters

e

Remarks

Find the panel hosting the control and set it's hosted control property to null.

See Also

ContainerStatusBar Class | ContainerStatusBar Members | Genghis.Windows.Forms Namespace


ContainerStatusBar.OnDrawItem Method

Handles drawing of ContainerStatusBarpanles with a value for their NestedControl Property.

[Visual Basic]
Overrides Protected Sub OnDrawItem( _
   ByVal e As System.Windows.Forms.StatusBarDrawItemEventArgs _
)
[C#]
protected override void OnDrawItem(
   StatusBarDrawItemEventArgs e
);

Parameters

e

Remarks

Calls base implementation upon completion.

See Also

ContainerStatusBar Class | ContainerStatusBar Members | Genghis.Windows.Forms Namespace


ContainerStatusBar.StatusBarPanelCollection Class

Typed collection of ContainerStatusBarpanels.

For a list of all members of this type, see ContainerStatusBar.StatusBarPanelCollection Members.

System.Object
ContainerStatusBar.StatusBarPanelCollection

[Visual Basic]
Public Class ContainerStatusBar.StatusBarPanelCollection
   Implements IList, ICollection, IEnumerable
[C#]
public class ContainerStatusBar.StatusBarPanelCollection : IList, ICollection, IEnumerable

Remarks

Delegates storgae to the base StatsuBar's panels collection, but performs type checking and type conversions to ensure that item are ContainerStatusBarpanels, not System.Windows.Forms.ContainerStatusBarPanels.

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

ContainerStatusBar.StatusBarPanelCollection Members | Genghis.Windows.Forms Namespace


ContainerStatusBar.StatusBarPanelCollection Members

Public Instance Properties

Count | The number of panels in the collection
IsReadOnly |
Item |

Public Instance Methods

AddRange |
Clear |
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetEnumerator |
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
RemoveAt |
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

IList.Add | Overloaded.
IList.Contains | Overloaded.
ICollection.CopyTo |
IList.IndexOf | Overloaded.
IList.Insert | Overloaded.
IList.Remove | Overloaded.

See Also

ContainerStatusBar.StatusBarPanelCollection Class | Genghis.Windows.Forms Namespace


ContainerStatusBar.StatusBarPanelCollection Properties

The properties of the ContainerStatusBar.StatusBarPanelCollection class are listed below. For a complete list of ContainerStatusBar.StatusBarPanelCollection class members, see the ContainerStatusBar.StatusBarPanelCollection Members topic.

Public Instance Properties

Count | The number of panels in the collection
IsReadOnly |
Item |

See Also

ContainerStatusBar.StatusBarPanelCollection Class | Genghis.Windows.Forms Namespace


ContainerStatusBar.StatusBarPanelCollection.Count Property

The number of panels in the collection

[Visual Basic]
Overridable Public ReadOnly Property Count As Integer
[C#]
public int Count {virtual get;}

See Also

ContainerStatusBar.StatusBarPanelCollection Class | ContainerStatusBar.StatusBarPanelCollection Members | Genghis.Windows.Forms Namespace


ContainerStatusBar.StatusBarPanelCollection.IsReadOnly Property

[Visual Basic]
Overridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {virtual get;}

See Also

ContainerStatusBar.StatusBarPanelCollection Class | ContainerStatusBar.StatusBarPanelCollection Members | Genghis.Windows.Forms Namespace


ContainerStatusBar.StatusBarPanelCollection.Item Property

[Visual Basic]
Overridable Public Default Property Item( _
   ByVal index As Integer _
) As Genghis.Windows.Forms.ContainerStatusBarPanel
[C#]
public ContainerStatusBarPanel this[
   int index
] {virtual get; virtual set;}

See Also

ContainerStatusBar.StatusBarPanelCollection Class | ContainerStatusBar.StatusBarPanelCollection Members | Genghis.Windows.Forms Namespace


ContainerStatusBar.StatusBarPanelCollection Methods

The methods of the ContainerStatusBar.StatusBarPanelCollection class are listed below. For a complete list of ContainerStatusBar.StatusBarPanelCollection class members, see the ContainerStatusBar.StatusBarPanelCollection Members topic.

Public Instance Methods

AddRange |
Clear |
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetEnumerator |
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
RemoveAt |
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

IList.Add | Overloaded.
IList.Contains | Overloaded.
ICollection.CopyTo |
IList.IndexOf | Overloaded.
IList.Insert | Overloaded.
IList.Remove | Overloaded.

See Also

ContainerStatusBar.StatusBarPanelCollection Class | Genghis.Windows.Forms Namespace


Add Method

Genghis Class Library

ContainerStatusBar.StatusBarPanelCollection.Add

Overload List

private final int Add(object);

public virtual int Add(ContainerStatusBarPanel);

public virtual ContainerStatusBarPanel Add(string);

See Also

ContainerStatusBar.StatusBarPanelCollection Class | ContainerStatusBar.StatusBarPanelCollection Members | Genghis.Windows.Forms Namespace


ContainerStatusBar.StatusBarPanelCollection.Add Method (ContainerStatusBarPanel)

[Visual Basic]
Overridable Overloads Public Function Add( _
   ByVal panel As Genghis.Windows.Forms.ContainerStatusBarPanel _
) As Integer
[C#]
public virtual int Add(
   ContainerStatusBarPanel panel
);

See Also

ContainerStatusBar.StatusBarPanelCollection Class | ContainerStatusBar.StatusBarPanelCollection Members | Genghis.Windows.Forms Namespace | ContainerStatusBar.StatusBarPanelCollection.Add Overload List


ContainerStatusBar.StatusBarPanelCollection.Add Method (String)

[Visual Basic]
Overridable Overloads Public Function Add( _
   ByVal text As String _
) As Genghis.Windows.Forms.ContainerStatusBarPanel
[C#]
public virtual ContainerStatusBarPanel Add(
   string text
);

See Also

ContainerStatusBar.StatusBarPanelCollection Class | ContainerStatusBar.StatusBarPanelCollection Members | Genghis.Windows.Forms Namespace | ContainerStatusBar.StatusBarPanelCollection.Add Overload List


ContainerStatusBar.StatusBarPanelCollection.AddRange Method

[Visual Basic]
Overridable Public Sub AddRange( _
   ByVal panels As Genghis.Windows.Forms.ContainerStatusBarPanel() _
)
[C#]
public virtual void AddRange(
   ContainerStatusBarPanel[] panels
);

See Also

ContainerStatusBar.StatusBarPanelCollection Class | ContainerStatusBar.StatusBarPanelCollection Members | Genghis.Windows.Forms Namespace


ContainerStatusBar.StatusBarPanelCollection.Clear Method

[Visual Basic]
Overridable Public Sub Clear()
[C#]
public virtual void Clear();

See Also

ContainerStatusBar.StatusBarPanelCollection Class | ContainerStatusBar.StatusBarPanelCollection Members | Genghis.Windows.Forms Namespace


ContainerStatusBar.StatusBarPanelCollection.Contains Method (ContainerStatusBarPanel)

[Visual Basic]
Public Function Contains( _
   ByVal panel As Genghis.Windows.Forms.ContainerStatusBarPanel _
) As Boolean
[C#]
public bool Contains(
   ContainerStatusBarPanel panel
);

See Also

ContainerStatusBar.StatusBarPanelCollection Class | ContainerStatusBar.StatusBarPanelCollection Members | Genghis.Windows.Forms Namespace | ContainerStatusBar.StatusBarPanelCollection.Contains Overload List


ContainerStatusBar.StatusBarPanelCollection.GetEnumerator Method

[Visual Basic]
Overridable Public Function GetEnumerator() As System.Collections.IEnumerator
[C#]
public virtual IEnumerator GetEnumerator();

See Also

ContainerStatusBar.StatusBarPanelCollection Class | ContainerStatusBar.StatusBarPanelCollection Members | Genghis.Windows.Forms Namespace


ContainerStatusBar.StatusBarPanelCollection.IndexOf Method (ContainerStatusBarPanel)

[Visual Basic]
Public Function IndexOf( _
   ByVal panel As Genghis.Windows.Forms.ContainerStatusBarPanel _
) As Integer
[C#]
public int IndexOf(
   ContainerStatusBarPanel panel
);

See Also

ContainerStatusBar.StatusBarPanelCollection Class | ContainerStatusBar.StatusBarPanelCollection Members | Genghis.Windows.Forms Namespace | ContainerStatusBar.StatusBarPanelCollection.IndexOf Overload List


ContainerStatusBar.StatusBarPanelCollection.Insert Method (Int32, ContainerStatusBarPanel)

[Visual Basic]
Overridable Public Sub Insert( _
   ByVal index As Integer, _
   ByVal panel As Genghis.Windows.Forms.ContainerStatusBarPanel _
)
[C#]
public virtual void Insert(
   int index,
   ContainerStatusBarPanel panel
);

See Also

ContainerStatusBar.StatusBarPanelCollection Class | ContainerStatusBar.StatusBarPanelCollection Members | Genghis.Windows.Forms Namespace | ContainerStatusBar.StatusBarPanelCollection.Insert Overload List


ContainerStatusBar.StatusBarPanelCollection.Remove Method (ContainerStatusBarPanel)

[Visual Basic]
Overridable Public Sub Remove( _
   ByVal panel As Genghis.Windows.Forms.ContainerStatusBarPanel _
)
[C#]
public virtual void Remove(
   ContainerStatusBarPanel panel
);

See Also

ContainerStatusBar.StatusBarPanelCollection Class | ContainerStatusBar.StatusBarPanelCollection Members | Genghis.Windows.Forms Namespace | ContainerStatusBar.StatusBarPanelCollection.Remove Overload List


ContainerStatusBar.StatusBarPanelCollection.RemoveAt Method

[Visual Basic]
Overridable Public Sub RemoveAt( _
   ByVal index As Integer _
)
[C#]
public virtual void RemoveAt(
   int index
);

See Also

ContainerStatusBar.StatusBarPanelCollection Class | ContainerStatusBar.StatusBarPanelCollection Members | Genghis.Windows.Forms Namespace


ContainerStatusBar.StatusBarPanelCollection.CopyTo Method

[Visual Basic]
Sub CopyTo( _
   ByVal dest As System.Array, _
   ByVal index As Integer _
) Implements ICollection.CopyTo
[C#]
void ICollection.CopyTo(
   Array dest,
   int index
);

See Also

ContainerStatusBar.StatusBarPanelCollection Class | ContainerStatusBar.StatusBarPanelCollection Members | Genghis.Windows.Forms Namespace


ContainerStatusBar.StatusBarPanelCollection.Add Method (Object)

[Visual Basic]
Function Add( _
   ByVal value As Object _
) As Integer Implements IList.Add
[C#]
int IList.Add(
   object value
);

See Also

ContainerStatusBar.StatusBarPanelCollection Class | ContainerStatusBar.StatusBarPanelCollection Members | Genghis.Windows.Forms Namespace | ContainerStatusBar.StatusBarPanelCollection.Add Overload List


ContainerStatusBar.StatusBarPanelCollection.Contains Method (Object)

[Visual Basic]
Function Contains( _
   ByVal value As Object _
) As Boolean Implements IList.Contains
[C#]
bool IList.Contains(
   object value
);

See Also

ContainerStatusBar.StatusBarPanelCollection Class | ContainerStatusBar.StatusBarPanelCollection Members | Genghis.Windows.Forms Namespace | ContainerStatusBar.StatusBarPanelCollection.Contains Overload List


ContainerStatusBar.StatusBarPanelCollection.IndexOf Method (Object)

[Visual Basic]
Function IndexOf( _
   ByVal value As Object _
) As Integer Implements IList.IndexOf
[C#]
int IList.IndexOf(
   object value
);

See Also

ContainerStatusBar.StatusBarPanelCollection Class | ContainerStatusBar.StatusBarPanelCollection Members | Genghis.Windows.Forms Namespace | ContainerStatusBar.StatusBarPanelCollection.IndexOf Overload List


ContainerStatusBar.StatusBarPanelCollection.Insert Method (Int32, Object)

[Visual Basic]
Sub Insert( _
   ByVal index As Integer, _
   ByVal value As Object _
) Implements IList.Insert
[C#]
void IList.Insert(
   int index,
   object value
);

See Also

ContainerStatusBar.StatusBarPanelCollection Class | ContainerStatusBar.StatusBarPanelCollection Members | Genghis.Windows.Forms Namespace | ContainerStatusBar.StatusBarPanelCollection.Insert Overload List


ContainerStatusBar.StatusBarPanelCollection.Remove Method (Object)

[Visual Basic]
Sub Remove( _
   ByVal value As Object _
) Implements IList.Remove
[C#]
void IList.Remove(
   object value
);

See Also

ContainerStatusBar.StatusBarPanelCollection Class | ContainerStatusBar.StatusBarPanelCollection Members | Genghis.Windows.Forms Namespace | ContainerStatusBar.StatusBarPanelCollection.Remove Overload List


ContainerStatusBarPanel Class

A modified ContainerStatusBarPanel that adds support for a hosted Control

For a list of all members of this type, see ContainerStatusBarPanel Members.

System.Object
MarshalByRefObject
Component
StatusBarPanel
ContainerStatusBarPanel

[Visual Basic]
Public Class ContainerStatusBarPanel
   Inherits StatusBarPanel
   Implements IComponent, IDisposable, ISupportInitialize
[C#]
public class ContainerStatusBarPanel : StatusBarPanel, IComponent, IDisposable, ISupportInitialize

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

ContainerStatusBarPanel Members | Genghis.Windows.Forms Namespace


ContainerStatusBarPanel Members

Public Instance Constructors

ContainerStatusBarPanel Constructor

Public Instance Properties

Alignment (inherited from System.Windows.Forms.StatusBarPanel) | Select the method name to go to the Microsoft documentation.
AutoSize (inherited from System.Windows.Forms.StatusBarPanel) | Select the method name to go to the Microsoft documentation.
BorderStyle (inherited from System.Windows.Forms.StatusBarPanel) | Select the method name to go to the Microsoft documentation.
Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ControlPaddingBottom | The number of pixels to pad betwen the bottom edge of the panel and the bottom edge of the hosted control.
ControlPaddingLeft | The number of pixels to pad betwen the left edge of the panel and the left edge of the hosted control.
ControlPaddingRight | The number of pixels to pad betwen the left edge of the panel and the left edge of the hosted control.
ControlPaddingTop | The number of pixels to pad betwen the top edge of the panel and the top edge of the hosted control.
HostedControl | Specifies the control that will be displayed in the panel. ContainerStatusBar.
Icon (inherited from System.Windows.Forms.StatusBarPanel) | Select the method name to go to the Microsoft documentation.
MinWidth (inherited from System.Windows.Forms.StatusBarPanel) | Select the method name to go to the Microsoft documentation.
Parent | Overloaded. The StatuBar control hosting the panel.
Parent (inherited from System.Windows.Forms.StatusBarPanel) | Select the method name to go to the Microsoft documentation.
Site (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Style (inherited from System.Windows.Forms.StatusBarPanel) | Select the method name to go to the Microsoft documentation.
Text (inherited from System.Windows.Forms.StatusBarPanel) | Select the method name to go to the Microsoft documentation.
ToolTipText (inherited from System.Windows.Forms.StatusBarPanel) | Select the method name to go to the Microsoft documentation.
Width (inherited from System.Windows.Forms.StatusBarPanel) | Select the method name to go to the Microsoft documentation.

Public Instance Methods

BeginInit (inherited from StatusBarPanel) | Select the method name to go to the Microsoft documentation.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
EndInit (inherited from StatusBarPanel) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
ToString (inherited from StatusBarPanel) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Dispose (inherited from StatusBarPanel) | Select the method name to go to the Microsoft documentation.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
OnHostedControlChanged | What to do when the value of the HostControl has chnaged We do not fire public events for this event
OnPaddingChanged | What to do when any of the padding values have changed.

See Also

ContainerStatusBarPanel Class | Genghis.Windows.Forms Namespace


ContainerStatusBarPanel Constructor

[Visual Basic]
Public Sub New()
[C#]
public ContainerStatusBarPanel();

See Also

ContainerStatusBarPanel Class | ContainerStatusBarPanel Members | Genghis.Windows.Forms Namespace


ContainerStatusBarPanel Properties

The properties of the ContainerStatusBarPanel class are listed below. For a complete list of ContainerStatusBarPanel class members, see the ContainerStatusBarPanel Members topic.

Public Instance Properties

Alignment (inherited from System.Windows.Forms.StatusBarPanel) | Select the method name to go to the Microsoft documentation.
AutoSize (inherited from System.Windows.Forms.StatusBarPanel) | Select the method name to go to the Microsoft documentation.
BorderStyle (inherited from System.Windows.Forms.StatusBarPanel) | Select the method name to go to the Microsoft documentation.
Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ControlPaddingBottom | The number of pixels to pad betwen the bottom edge of the panel and the bottom edge of the hosted control.
ControlPaddingLeft | The number of pixels to pad betwen the left edge of the panel and the left edge of the hosted control.
ControlPaddingRight | The number of pixels to pad betwen the left edge of the panel and the left edge of the hosted control.
ControlPaddingTop | The number of pixels to pad betwen the top edge of the panel and the top edge of the hosted control.
HostedControl | Specifies the control that will be displayed in the panel. ContainerStatusBar.
Icon (inherited from System.Windows.Forms.StatusBarPanel) | Select the method name to go to the Microsoft documentation.
MinWidth (inherited from System.Windows.Forms.StatusBarPanel) | Select the method name to go to the Microsoft documentation.
Parent | Overloaded. The StatuBar control hosting the panel.
Parent (inherited from System.Windows.Forms.StatusBarPanel) | Select the method name to go to the Microsoft documentation.
Site (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Style (inherited from System.Windows.Forms.StatusBarPanel) | Select the method name to go to the Microsoft documentation.
Text (inherited from System.Windows.Forms.StatusBarPanel) | Select the method name to go to the Microsoft documentation.
ToolTipText (inherited from System.Windows.Forms.StatusBarPanel) | Select the method name to go to the Microsoft documentation.
Width (inherited from System.Windows.Forms.StatusBarPanel) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.

See Also

ContainerStatusBarPanel Class | Genghis.Windows.Forms Namespace


ContainerStatusBarPanel.ControlPaddingBottom Property

The number of pixels to pad betwen the bottom edge of the panel and the bottom edge of the hosted control.

[Visual Basic]
Public Property ControlPaddingBottom As Integer
[C#]
public int ControlPaddingBottom {get; set;}

See Also

ContainerStatusBarPanel Class | ContainerStatusBarPanel Members | Genghis.Windows.Forms Namespace


ContainerStatusBarPanel.ControlPaddingLeft Property

The number of pixels to pad betwen the left edge of the panel and the left edge of the hosted control.

[Visual Basic]
Public Property ControlPaddingLeft As Integer
[C#]
public int ControlPaddingLeft {get; set;}

See Also

ContainerStatusBarPanel Class | ContainerStatusBarPanel Members | Genghis.Windows.Forms Namespace


ContainerStatusBarPanel.ControlPaddingRight Property

The number of pixels to pad betwen the left edge of the panel and the left edge of the hosted control.

[Visual Basic]
Public Property ControlPaddingRight As Integer
[C#]
public int ControlPaddingRight {get; set;}

See Also

ContainerStatusBarPanel Class | ContainerStatusBarPanel Members | Genghis.Windows.Forms Namespace


ContainerStatusBarPanel.ControlPaddingTop Property

The number of pixels to pad betwen the top edge of the panel and the top edge of the hosted control.

[Visual Basic]
Public Property ControlPaddingTop As Integer
[C#]
public int ControlPaddingTop {get; set;}

See Also

ContainerStatusBarPanel Class | ContainerStatusBarPanel Members | Genghis.Windows.Forms Namespace


ContainerStatusBarPanel.HostedControl Property

Specifies the control that will be displayed in the panel. ContainerStatusBar.

[Visual Basic]
Public Property HostedControl As System.Windows.Forms.Control
[C#]
public System.Windows.Forms.Control HostedControl {get; set;}

See Also

ContainerStatusBarPanel Class | ContainerStatusBarPanel Members | Genghis.Windows.Forms Namespace


ContainerStatusBarPanel.Parent Property

The StatuBar control hosting the panel.

[Visual Basic]
Overloads Public ReadOnly Property Parent As Genghis.Windows.Forms.ContainerStatusBar
[C#]
public ContainerStatusBar Parent {get;}

Remarks

You can use this property to determine the ContainerStatusBar control that a ContainerStatusBarPanel object is contained within. ContainerStatusBarPanel objects are added to a ContainerStatusBar control by calling the Add method of the ContainerStatusBar.Panels property. The ContainerStatusBar.Panels property is a collection of a ContainerStatusBarPanel items.

See Also

ContainerStatusBarPanel Class | ContainerStatusBarPanel Members | Genghis.Windows.Forms Namespace | ContainerStatusBarPanel.Parent Overload List

Copyright (C) 2002 The Genghis Group

ContainerStatusBarPanel.Parent Property
Genghis Class Library

ContainerStatusBarPanel.Parent Property

The StatuBar control hosting the panel.

[Visual Basic]
Overloads Public ReadOnly Property Parent As System.Windows.Forms.StatusBar
[C#]
public System.Windows.Forms.StatusBar Parent {get;}

Remarks

You can use this property to determine the ContainerStatusBar control that a ContainerStatusBarPanel object is contained within. ContainerStatusBarPanel objects are added to a ContainerStatusBar control by calling the Add method of the ContainerStatusBar.Panels property. The ContainerStatusBar.Panels property is a collection of a ContainerStatusBarPanel items.

See Also

ContainerStatusBarPanel Class | ContainerStatusBarPanel Members | Genghis.Windows.Forms Namespace | ContainerStatusBarPanel.Parent Overload List


ContainerStatusBarPanel Methods

The methods of the ContainerStatusBarPanel class are listed below. For a complete list of ContainerStatusBarPanel class members, see the ContainerStatusBarPanel Members topic.

Public Instance Methods

BeginInit (inherited from StatusBarPanel) | Select the method name to go to the Microsoft documentation.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
EndInit (inherited from StatusBarPanel) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
ToString (inherited from StatusBarPanel) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Dispose (inherited from StatusBarPanel) | Select the method name to go to the Microsoft documentation.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
OnHostedControlChanged | What to do when the value of the HostControl has chnaged We do not fire public events for this event
OnPaddingChanged | What to do when any of the padding values have changed.

See Also

ContainerStatusBarPanel Class | Genghis.Windows.Forms Namespace


ContainerStatusBarPanel.BeginInit Method ()

Override base class implementation so we can trap the notification.

[Visual Basic]
NotOverridable Overloads Public Sub BeginInit()
[C#]
public final void BeginInit();

Remarks

Calls into the base implementation.

See Also

ContainerStatusBarPanel Class | ContainerStatusBarPanel Members | Genghis.Windows.Forms Namespace | ContainerStatusBarPanel.BeginInit Overload List

Copyright (C) 2002 The Genghis Group

ContainerStatusBarPanel.BeginInit Method ()
Genghis Class Library

ContainerStatusBarPanel.BeginInit Method ()

Override base class implementation so we can trap the notification.

[Visual Basic]
Overloads Public Sub BeginInit()
[C#]
public void BeginInit();

Remarks

Calls into the base implementation.

See Also

ContainerStatusBarPanel Class | ContainerStatusBarPanel Members | Genghis.Windows.Forms Namespace | ContainerStatusBarPanel.BeginInit Overload List


ContainerStatusBarPanel.EndInit Method ()

Override base class implementation so we can trap the notification.

[Visual Basic]
NotOverridable Overloads Public Sub EndInit()
[C#]
public final void EndInit();

Remarks

Calls into the base implementation.

See Also

ContainerStatusBarPanel Class | ContainerStatusBarPanel Members | Genghis.Windows.Forms Namespace | ContainerStatusBarPanel.EndInit Overload List

Copyright (C) 2002 The Genghis Group

ContainerStatusBarPanel.EndInit Method ()
Genghis Class Library

ContainerStatusBarPanel.EndInit Method ()

Override base class implementation so we can trap the notification.

[Visual Basic]
Overloads Public Sub EndInit()
[C#]
public void EndInit();

Remarks

Calls into the base implementation.

See Also

ContainerStatusBarPanel Class | ContainerStatusBarPanel Members | Genghis.Windows.Forms Namespace | ContainerStatusBarPanel.EndInit Overload List


ContainerStatusBarPanel.OnHostedControlChanged Method

What to do when the value of the HostControl has chnaged We do not fire public events for this event

[Visual Basic]
Overridable Protected Sub OnHostedControlChanged()
[C#]
protected virtual void OnHostedControlChanged();

See Also

ContainerStatusBarPanel Class | ContainerStatusBarPanel Members | Genghis.Windows.Forms Namespace


ContainerStatusBarPanel.OnPaddingChanged Method

What to do when any of the padding values have changed.

[Visual Basic]
Protected Sub OnPaddingChanged()
[C#]
protected void OnPaddingChanged();

Remarks

Public events are not fired for this event.

See Also

ContainerStatusBarPanel Class | ContainerStatusBarPanel Members | Genghis.Windows.Forms Namespace


CursorChanger Class

A class to change the cursor for the current window. Upon Disposal, the class will return the original cursor.

For a list of all members of this type, see CursorChanger Members.

System.Object
CursorChanger

[Visual Basic]
Public Class CursorChanger
   Implements IDisposable
[C#]
public class CursorChanger : IDisposable

Example

This example shows how the cursor will be changed during the scope of the object (before disposal):

            using (ChangeCursor cursorChanger = new CursorChanger(Cursors.WaitCursor))
            {
              ...
            }

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

CursorChanger Members | Genghis.Windows.Forms Namespace


CursorChanger Members

Public Instance Constructors

CursorChanger Constructor Constructs a new CursorChanger object specifying the new Cursor to show.

Public Instance Methods

Dispose | Dispose method. Returns the original
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize | Finalizer
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

CursorChanger Class | Genghis.Windows.Forms Namespace


CursorChanger Constructor

Constructs a new CursorChanger object specifying the new Cursor to show.

[Visual Basic]
Public Sub New( _
   ByVal newCursor As System.Windows.Forms.Cursor _
)
[C#]
public CursorChanger(
   Cursor newCursor
);

Parameters

newCursor
The new cursor to show during the lifetime of the CursorChanger object

See Also

CursorChanger Class | CursorChanger Members | Genghis.Windows.Forms Namespace


CursorChanger Methods

The methods of the CursorChanger class are listed below. For a complete list of CursorChanger class members, see the CursorChanger Members topic.

Public Instance Methods

Dispose | Dispose method. Returns the original
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize | Finalizer
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

CursorChanger Class | Genghis.Windows.Forms Namespace


CursorChanger.Dispose Method

Dispose method. Returns the original

[Visual Basic]
NotOverridable Public Sub Dispose()
[C#]
public final void Dispose();

See Also

CursorChanger Class | CursorChanger Members | Genghis.Windows.Forms Namespace


CursorChanger.Finalize Method

Finalizer

[Visual Basic]
Overrides Protected Sub Finalize()
[C#]
protected override void Finalize();

See Also

CursorChanger Class | CursorChanger Members | Genghis.Windows.Forms Namespace


CustomStateTreeView Class

A treeview that allows a custom image list for the check state.

For a list of all members of this type, see CustomStateTreeView Members.

System.Object
MarshalByRefObject
Component
Control
TreeView
CustomStateTreeView

[Visual Basic]
Public Class CustomStateTreeView
   Inherits TreeView
   Implements IComponent, IDisposable, IOleControl, IOleObject, IOleInPlaceObject, IOleInPlaceActiveObject, IOleWindow, IViewObject, IViewObject2, IPersist, IPersistStreamInit, IPersistPropertyBag, IPersistStorage, IQuickActivate, ISynchronizeInvoke, IWin32Window
[C#]
public class CustomStateTreeView : TreeView, IComponent, IDisposable, IOleControl, IOleObject, IOleInPlaceObject, IOleInPlaceActiveObject, IOleWindow, IViewObject, IViewObject2, IPersist, IPersistStreamInit, IPersistPropertyBag, IPersistStorage, IQuickActivate, ISynchronizeInvoke, IWin32Window

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

CustomStateTreeView Members | Genghis.Windows.Forms Namespace


CustomStateTreeView Members

Public Instance Constructors

CustomStateTreeView Constructor

Public Instance Properties

AccessibilityObject (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleDefaultActionDescription (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleDescription (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleRole (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AllowDrop (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Anchor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
BackColor (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
BackgroundImage (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
BindingContext (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
BorderStyle (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
Bottom (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Bounds (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CanFocus (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CanSelect (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Capture (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CausesValidation (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CheckBoxes (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
CheckStateImageList | Image list for the check state (image 0 is ignored)
ClientRectangle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ClientSize (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CompanyName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ContainsFocus (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ContextMenu (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Controls (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Created (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Cursor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DataBindings (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DisplayRectangle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Disposing (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Dock (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Enabled (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Focused (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Font (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ForeColor (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
FullRowSelect (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
Handle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
HasChildren (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Height (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
HideSelection (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
HotTracking (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
ImageIndex (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
ImageList |
ImeMode (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Indent (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
InvokeRequired (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsAccessible (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsDisposed (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsHandleCreated (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ItemHeight (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
LabelEdit (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
Left (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Location (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Name (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Nodes (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
Parent (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
PathSeparator (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
ProductName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ProductVersion (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RecreatingHandle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Region (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Right (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RightToLeft (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Scrollable (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
SelectedImageIndex (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
SelectedNode (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
ShowLines (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
ShowPlusMinus (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
ShowRootLines (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
Site (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Size (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Sorted (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
TabIndex (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TabStop (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Tag (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Text (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
Top (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TopLevelControl (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TopNode (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
Visible (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
VisibleCount (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
Width (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
WindowTarget (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.

Public Instance Methods

BeginInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
BeginInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
BeginUpdate (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
BringToFront (inherited from Control) | Select the method name to go to the Microsoft documentation.
CollapseAll (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
Contains (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateGraphics (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
DoDragDrop (inherited from Control) | Select the method name to go to the Microsoft documentation.
EndInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
EndUpdate (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
ExpandAll (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
FindForm (inherited from Control) | Select the method name to go to the Microsoft documentation.
Focus (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetCheckState | Get the check state of a node in the tree.
GetChildAtPoint (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetContainerControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetNextControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetNodeAt (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
GetNodeAt (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
GetNodeCount (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
Hide (inherited from Control) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
PerformLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
PerformLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
PointToClient (inherited from Control) | Select the method name to go to the Microsoft documentation.
PointToScreen (inherited from Control) | Select the method name to go to the Microsoft documentation.
PreProcessMessage (inherited from Control) | Select the method name to go to the Microsoft documentation.
RectangleToClient (inherited from Control) | Select the method name to go to the Microsoft documentation.
RectangleToScreen (inherited from Control) | Select the method name to go to the Microsoft documentation.
Refresh (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetBackColor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetBindings (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetCursor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetFont (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetForeColor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetImeMode (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetRightToLeft (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetText (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResumeLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResumeLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
Scale (inherited from Control) | Select the method name to go to the Microsoft documentation.
Scale (inherited from Control) | Select the method name to go to the Microsoft documentation.
Select (inherited from Control) | Select the method name to go to the Microsoft documentation.
SelectNextControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
SendToBack (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetCheckState | Set the check state of a node in the tree.
Show (inherited from Control) | Select the method name to go to the Microsoft documentation.
SuspendLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
ToString (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
Update (inherited from Control) | Select the method name to go to the Microsoft documentation.

Protected Instance Fields

checkStateImages

Protected Instance Properties

CreateParams (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
DefaultImeMode (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DefaultSize (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
FontHeight (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RenderRightToLeft (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ResizeRedraw (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowFocusCues (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowKeyboardCues (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateAccessibilityInstance (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateControlsInstance (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateHandle (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
DefWndProc (inherited from Control) | Select the method name to go to the Microsoft documentation.
DestroyHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetItemRenderStyles (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetStyle (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetTopLevel (inherited from Control) | Select the method name to go to the Microsoft documentation.
IndexToStateImageMask |
InitLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeGotFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeLostFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeOnClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokePaint (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokePaintBackground (inherited from Control) | Select the method name to go to the Microsoft documentation.
IsInputChar (inherited from Control) | Select the method name to go to the Microsoft documentation.
IsInputKey (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
NotifyInvalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnAfterCheck (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
OnAfterCollapse (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
OnAfterExpand (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
OnAfterLabelEdit (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
OnAfterSelect (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
OnBackColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBackgroundImageChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBeforeCheck (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
OnBeforeCollapse (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
OnBeforeExpand (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
OnBeforeLabelEdit (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
OnBeforeSelect (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
OnBindingContextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnCausesValidationChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnChangeUICues (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnContextMenuChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnControlAdded (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnControlRemoved (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnCreateControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnCursorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDockChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDoubleClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragDrop (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragOver (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnEnabledChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnFontChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnForeColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnGiveFeedback (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnGotFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnHandleCreated (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
OnHandleDestroyed (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
OnHelpRequested (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnImeModeChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnInvalidated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnItemDrag (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
OnKeyDown (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
OnKeyPress (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
OnKeyUp (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
OnLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLocationChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLostFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseDown (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseHover (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseMove (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseUp (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseWheel (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMove (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnNotifyMessage (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnPaint (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnPaintBackground (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBackColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBackgroundImageChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBindingContextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentEnabledChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentFontChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentForeColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentRightToLeftChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentVisibleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnQueryContinueDrag (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnResize (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnRightToLeftChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnSizeChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnStyleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnSystemColorsChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTabIndexChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTabStopChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnValidated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnValidating (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnVisibleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessCmdKey (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessDialogChar (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessDialogKey (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessKeyEventArgs (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessKeyPreview (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessMnemonic (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseDragEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseKeyEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseMouseEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaisePaintEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RecreateHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetMouseEventArgs (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateContent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateHorizontal (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateLeftRight (inherited from Control) | Select the method name to go to the Microsoft documentation.
ScaleCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
Select (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetBoundsCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetClientSizeCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetStyle (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetTopLevel (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetVisibleCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
StateImageMaskToIndex |
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateStyles (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateZOrder (inherited from Control) | Select the method name to go to the Microsoft documentation.
WndProc (inherited from TreeView) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

UnsafeNativeMethods+IOleObject.Advise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Close (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleWindow.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.DoVerb (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Draw (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Draw (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.EnableModeless (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.EnumAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.EnumVerbs (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Freeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Freeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.FreezeEvents (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.GetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersist.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetClientSite (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetClipboardData (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetColorSet (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.GetColorSet (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.GetContentExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.GetControlInfo (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetMiscStatus (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetMoniker (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.GetSizeMax (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetUserClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetUserType (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleWindow.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.HandsOffStorage (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.InitFromData (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.InPlaceDeactivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.IsDirty (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.IsDirty (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.IsUpToDate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.OleUpdate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.OnAmbientPropertyChange (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.OnDocWindowActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.OnFrameWindowActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.OnMnemonic (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.QuickActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.ReactivateAndUndo (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.ResizeBorder (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.SaveCompleted (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.SetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.SetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetClientSite (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetColorScheme (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.SetContentExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetHostNames (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetMoniker (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.SetObjectRects (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.TranslateAccelerator (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.UIDeactivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Unadvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Unfreeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Unfreeze (inherited from Control) | Select the method name to go to the Microsoft documentation.

See Also

CustomStateTreeView Class | Genghis.Windows.Forms Namespace


CustomStateTreeView Constructor

[Visual Basic]
Public Sub New()
[C#]
public CustomStateTreeView();

See Also

CustomStateTreeView Class | CustomStateTreeView Members | Genghis.Windows.Forms Namespace


CustomStateTreeView Fields

The fields of the CustomStateTreeView class are listed below. For a complete list of CustomStateTreeView class members, see the CustomStateTreeView Members topic.

Protected Instance Fields

checkStateImages

See Also

CustomStateTreeView Class | Genghis.Windows.Forms Namespace


CustomStateTreeView.checkStateImages Field

[Visual Basic]
Protected checkStateImages As System.Windows.Forms.ImageList
[C#]
protected ImageList checkStateImages;

See Also

CustomStateTreeView Class | CustomStateTreeView Members | Genghis.Windows.Forms Namespace


CustomStateTreeView Properties

The properties of the CustomStateTreeView class are listed below. For a complete list of CustomStateTreeView class members, see the CustomStateTreeView Members topic.

Public Instance Properties

AccessibilityObject (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleDefaultActionDescription (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleDescription (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleRole (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AllowDrop (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Anchor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
BackColor (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
BackgroundImage (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
BindingContext (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
BorderStyle (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
Bottom (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Bounds (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CanFocus (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CanSelect (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Capture (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CausesValidation (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CheckBoxes (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
CheckStateImageList | Image list for the check state (image 0 is ignored)
ClientRectangle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ClientSize (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CompanyName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ContainsFocus (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ContextMenu (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Controls (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Created (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Cursor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DataBindings (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DisplayRectangle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Disposing (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Dock (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Enabled (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Focused (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Font (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ForeColor (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
FullRowSelect (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
Handle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
HasChildren (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Height (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
HideSelection (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
HotTracking (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
ImageIndex (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
ImageList |
ImeMode (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Indent (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
InvokeRequired (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsAccessible (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsDisposed (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsHandleCreated (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ItemHeight (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
LabelEdit (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
Left (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Location (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Name (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Nodes (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
Parent (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
PathSeparator (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
ProductName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ProductVersion (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RecreatingHandle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Region (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Right (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RightToLeft (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Scrollable (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
SelectedImageIndex (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
SelectedNode (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
ShowLines (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
ShowPlusMinus (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
ShowRootLines (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
Site (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Size (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Sorted (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
TabIndex (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TabStop (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Tag (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Text (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
Top (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TopLevelControl (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TopNode (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
Visible (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
VisibleCount (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
Width (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
WindowTarget (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

CreateParams (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
DefaultImeMode (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DefaultSize (inherited from System.Windows.Forms.TreeView) | Select the method name to go to the Microsoft documentation.
DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
FontHeight (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RenderRightToLeft (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ResizeRedraw (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowFocusCues (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowKeyboardCues (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.

See Also

CustomStateTreeView Class | Genghis.Windows.Forms Namespace


CustomStateTreeView.CheckStateImageList Property

Image list for the check state (image 0 is ignored)

[Visual Basic]
Public Property CheckStateImageList As System.Windows.Forms.ImageList
[C#]
public System.Windows.Forms.ImageList CheckStateImageList {get; set;}

See Also

CustomStateTreeView Class | CustomStateTreeView Members | Genghis.Windows.Forms Namespace


CustomStateTreeView.ImageList Property

[Visual Basic]
Public Property ImageList As System.Windows.Forms.ImageList
[C#]
public System.Windows.Forms.ImageList ImageList {get; set;}

See Also

CustomStateTreeView Class | CustomStateTreeView Members | Genghis.Windows.Forms Namespace


CustomStateTreeView Methods

The methods of the CustomStateTreeView class are listed below. For a complete list of CustomStateTreeView class members, see the CustomStateTreeView Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
BeginInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
BeginUpdate (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
BringToFront (inherited from Control) | Select the method name to go to the Microsoft documentation.
CollapseAll (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
Contains (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateGraphics (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
DoDragDrop (inherited from Control) | Select the method name to go to the Microsoft documentation.
EndInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
EndUpdate (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
ExpandAll (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
FindForm (inherited from Control) | Select the method name to go to the Microsoft documentation.
Focus (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetCheckState | Get the check state of a node in the tree.
GetChildAtPoint (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetContainerControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetNextControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetNodeAt (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
GetNodeAt (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
GetNodeCount (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
Hide (inherited from Control) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
PerformLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
PerformLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
PointToClient (inherited from Control) | Select the method name to go to the Microsoft documentation.
PointToScreen (inherited from Control) | Select the method name to go to the Microsoft documentation.
PreProcessMessage (inherited from Control) | Select the method name to go to the Microsoft documentation.
RectangleToClient (inherited from Control) | Select the method name to go to the Microsoft documentation.
RectangleToScreen (inherited from Control) | Select the method name to go to the Microsoft documentation.
Refresh (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetBackColor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetBindings (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetCursor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetFont (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetForeColor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetImeMode (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetRightToLeft (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetText (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResumeLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResumeLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
Scale (inherited from Control) | Select the method name to go to the Microsoft documentation.
Scale (inherited from Control) | Select the method name to go to the Microsoft documentation.
Select (inherited from Control) | Select the method name to go to the Microsoft documentation.
SelectNextControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
SendToBack (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetCheckState | Set the check state of a node in the tree.
Show (inherited from Control) | Select the method name to go to the Microsoft documentation.
SuspendLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
ToString (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
Update (inherited from Control) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateAccessibilityInstance (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateControlsInstance (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateHandle (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
DefWndProc (inherited from Control) | Select the method name to go to the Microsoft documentation.
DestroyHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetItemRenderStyles (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetStyle (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetTopLevel (inherited from Control) | Select the method name to go to the Microsoft documentation.
IndexToStateImageMask |
InitLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeGotFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeLostFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeOnClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokePaint (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokePaintBackground (inherited from Control) | Select the method name to go to the Microsoft documentation.
IsInputChar (inherited from Control) | Select the method name to go to the Microsoft documentation.
IsInputKey (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
NotifyInvalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnAfterCheck (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
OnAfterCollapse (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
OnAfterExpand (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
OnAfterLabelEdit (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
OnAfterSelect (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
OnBackColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBackgroundImageChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBeforeCheck (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
OnBeforeCollapse (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
OnBeforeExpand (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
OnBeforeLabelEdit (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
OnBeforeSelect (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
OnBindingContextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnCausesValidationChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnChangeUICues (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnContextMenuChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnControlAdded (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnControlRemoved (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnCreateControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnCursorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDockChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDoubleClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragDrop (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragOver (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnEnabledChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnFontChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnForeColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnGiveFeedback (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnGotFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnHandleCreated (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
OnHandleDestroyed (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
OnHelpRequested (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnImeModeChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnInvalidated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnItemDrag (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
OnKeyDown (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
OnKeyPress (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
OnKeyUp (inherited from TreeView) | Select the method name to go to the Microsoft documentation.
OnLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLocationChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLostFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseDown (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseHover (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseMove (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseUp (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseWheel (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMove (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnNotifyMessage (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnPaint (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnPaintBackground (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBackColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBackgroundImageChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBindingContextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentEnabledChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentFontChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentForeColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentRightToLeftChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentVisibleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnQueryContinueDrag (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnResize (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnRightToLeftChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnSizeChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnStyleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnSystemColorsChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTabIndexChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTabStopChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnValidated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnValidating (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnVisibleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessCmdKey (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessDialogChar (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessDialogKey (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessKeyEventArgs (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessKeyPreview (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessMnemonic (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseDragEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseKeyEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseMouseEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaisePaintEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RecreateHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetMouseEventArgs (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateContent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateHorizontal (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateLeftRight (inherited from Control) | Select the method name to go to the Microsoft documentation.
ScaleCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
Select (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetBoundsCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetClientSizeCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetStyle (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetTopLevel (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetVisibleCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
StateImageMaskToIndex |
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateStyles (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateZOrder (inherited from Control) | Select the method name to go to the Microsoft documentation.
WndProc (inherited from TreeView) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

UnsafeNativeMethods+IOleObject.Advise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Close (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleWindow.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.DoVerb (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Draw (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Draw (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.EnableModeless (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.EnumAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.EnumVerbs (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Freeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Freeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.FreezeEvents (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.GetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersist.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetClientSite (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetClipboardData (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetColorSet (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.GetColorSet (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.GetContentExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.GetControlInfo (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetMiscStatus (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetMoniker (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.GetSizeMax (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetUserClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetUserType (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleWindow.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.HandsOffStorage (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.InitFromData (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.InPlaceDeactivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.IsDirty (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.IsDirty (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.IsUpToDate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.OleUpdate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.OnAmbientPropertyChange (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.OnDocWindowActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.OnFrameWindowActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.OnMnemonic (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.QuickActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.ReactivateAndUndo (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.ResizeBorder (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.SaveCompleted (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.SetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.SetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetClientSite (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetColorScheme (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.SetContentExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetHostNames (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetMoniker (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.SetObjectRects (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.TranslateAccelerator (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.UIDeactivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Unadvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Unfreeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Unfreeze (inherited from Control) | Select the method name to go to the Microsoft documentation.

See Also

CustomStateTreeView Class | Genghis.Windows.Forms Namespace


CustomStateTreeView.GetCheckState Method

Get the check state of a node in the tree.

[Visual Basic]
Public Function GetCheckState( _
   ByVal node As System.Windows.Forms.TreeNode _
) As Integer
[C#]
public int GetCheckState(
   TreeNode node
);

Parameters

node
The node

Return Value

The check state

See Also

CustomStateTreeView Class | CustomStateTreeView Members | Genghis.Windows.Forms Namespace


CustomStateTreeView.IndexToStateImageMask Method

[Visual Basic]
Protected Function IndexToStateImageMask( _
   ByVal i As Integer _
) As Integer
[C#]
protected int IndexToStateImageMask(
   int i
);

See Also

CustomStateTreeView Class | CustomStateTreeView Members | Genghis.Windows.Forms Namespace


CustomStateTreeView.SetCheckState Method

Set the check state of a node in the tree.

[Visual Basic]
Public Sub SetCheckState( _
   ByVal node As System.Windows.Forms.TreeNode, _
   ByVal state As Integer _
)
[C#]
public void SetCheckState(
   TreeNode node,
   int state
);

Parameters

node
The node
state
0-based index into image list (0 means no check state)

See Also

CustomStateTreeView Class | CustomStateTreeView Members | Genghis.Windows.Forms Namespace


CustomStateTreeView.StateImageMaskToIndex Method

[Visual Basic]
Protected Function StateImageMaskToIndex( _
   ByVal i As Integer _
) As Integer
[C#]
protected int StateImageMaskToIndex(
   int i
);

See Also

CustomStateTreeView Class | CustomStateTreeView Members | Genghis.Windows.Forms Namespace


FileDocument Class

For a list of all members of this type, see FileDocument Members.

System.Object
MarshalByRefObject
Component
FileDocument

[Visual Basic]
Public Class FileDocument
   Inherits Component
   Implements IComponent, IDisposable
[C#]
public class FileDocument : Component, IComponent, IDisposable

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

FileDocument Members | Genghis.Windows.Forms Namespace


FileDocument Members

Public Instance Constructors

FileDocument Overloaded. Initialize a new instance of the FileDocument class.

Public Instance Properties

Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Data |
DefaultExt |
Dirty |
FileCloseMenuItem |
FileName |
FileOpenMenuItem |
FileSaveAsMenuItem |
FileSaveMenuItem |
Filter |
HostingForm |
Site (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.

Public Instance Methods

Close |
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
New |
Open | Overloaded.
Save | Overloaded.
SaveAs |
ToString (inherited from Component) | Select the method name to go to the Microsoft documentation.

Public Instance Events

Changed

Protected Instance Properties

CaptionFileName |
DefaultFileName |
DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ShowExtension |

Protected Instance Methods

Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
Read |
SetCaption |
Write |

See Also

FileDocument Class | Genghis.Windows.Forms Namespace


FileDocument Constructor

Genghis Class Library

FileDocument

Overload List

public FileDocument();

public FileDocument(IContainer);

See Also

FileDocument Class | FileDocument Members | Genghis.Windows.Forms Namespace


FileDocument Constructor ()

[Visual Basic]
Overloads Public Sub New()
[C#]
public FileDocument();

See Also

FileDocument Class | FileDocument Members | Genghis.Windows.Forms Namespace | FileDocument Constructor Overload List


FileDocument Constructor (IContainer)

[Visual Basic]
Overloads Public Sub New( _
   ByVal container As System.ComponentModel.IContainer _
)
[C#]
public FileDocument(
   IContainer container
);

See Also

FileDocument Class | FileDocument Members | Genghis.Windows.Forms Namespace | FileDocument Constructor Overload List


FileDocument Properties

The properties of the FileDocument class are listed below. For a complete list of FileDocument class members, see the FileDocument Members topic.

Public Instance Properties

Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Data |
DefaultExt |
Dirty |
FileCloseMenuItem |
FileName |
FileOpenMenuItem |
FileSaveAsMenuItem |
FileSaveMenuItem |
Filter |
HostingForm |
Site (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

CaptionFileName |
DefaultFileName |
DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ShowExtension |

See Also

FileDocument Class | Genghis.Windows.Forms Namespace


FileDocument.CaptionFileName Property

[Visual Basic]
Protected ReadOnly Property CaptionFileName As String
[C#]
protected string CaptionFileName {get;}

See Also

FileDocument Class | FileDocument Members | Genghis.Windows.Forms Namespace


FileDocument.Data Property

[Visual Basic]
Public Property Data As Object
[C#]
public object Data {get; set;}

See Also

FileDocument Class | FileDocument Members | Genghis.Windows.Forms Namespace


FileDocument.DefaultExt Property

[Visual Basic]
Public Property DefaultExt As String
[C#]
public string DefaultExt {get; set;}

See Also

FileDocument Class | FileDocument Members | Genghis.Windows.Forms Namespace


FileDocument.DefaultFileName Property

[Visual Basic]
Protected ReadOnly Property DefaultFileName As String
[C#]
protected string DefaultFileName {get;}

See Also

FileDocument Class | FileDocument Members | Genghis.Windows.Forms Namespace


FileDocument.Dirty Property

[Visual Basic]
Public Property Dirty As Boolean
[C#]
public bool Dirty {get; set;}

See Also

FileDocument Class | FileDocument Members | Genghis.Windows.Forms Namespace


FileDocument.FileCloseMenuItem Property

[Visual Basic]
Public Property FileCloseMenuItem As System.Windows.Forms.MenuItem
[C#]
public System.Windows.Forms.MenuItem FileCloseMenuItem {get; set;}

See Also

FileDocument Class | FileDocument Members | Genghis.Windows.Forms Namespace


FileDocument.FileName Property

[Visual Basic]
Public Property FileName As String
[C#]
public string FileName {get; set;}

See Also

FileDocument Class | FileDocument Members | Genghis.Windows.Forms Namespace


FileDocument.FileOpenMenuItem Property

[Visual Basic]
Public Property FileOpenMenuItem As System.Windows.Forms.MenuItem
[C#]
public System.Windows.Forms.MenuItem FileOpenMenuItem {get; set;}

See Also

FileDocument Class | FileDocument Members | Genghis.Windows.Forms Namespace


FileDocument.FileSaveAsMenuItem Property

[Visual Basic]
Public Property FileSaveAsMenuItem As System.Windows.Forms.MenuItem
[C#]
public System.Windows.Forms.MenuItem FileSaveAsMenuItem {get; set;}

See Also

FileDocument Class | FileDocument Members | Genghis.Windows.Forms Namespace


FileDocument.FileSaveMenuItem Property

[Visual Basic]
Public Property FileSaveMenuItem As System.Windows.Forms.MenuItem
[C#]
public System.Windows.Forms.MenuItem FileSaveMenuItem {get; set;}

See Also

FileDocument Class | FileDocument Members | Genghis.Windows.Forms Namespace


FileDocument.Filter Property

[Visual Basic]
Public Property Filter As String
[C#]
public string Filter {get; set;}

See Also

FileDocument Class | FileDocument Members | Genghis.Windows.Forms Namespace


FileDocument.HostingForm Property

[Visual Basic]
Public Property HostingForm As System.Windows.Forms.Form
[C#]
public System.Windows.Forms.Form HostingForm {get; set;}

See Also

FileDocument Class | FileDocument Members | Genghis.Windows.Forms Namespace


FileDocument.ShowExtension Property

[Visual Basic]
Protected ReadOnly Property ShowExtension As Boolean
[C#]
protected bool ShowExtension {get;}

See Also

FileDocument Class | FileDocument Members | Genghis.Windows.Forms Namespace


FileDocument Methods

The methods of the FileDocument class are listed below. For a complete list of FileDocument class members, see the FileDocument Members topic.

Public Instance Methods

Close |
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
New |
Open | Overloaded.
Save | Overloaded.
SaveAs |
ToString (inherited from Component) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
Read |
SetCaption |
Write |

See Also

FileDocument Class | Genghis.Windows.Forms Namespace


FileDocument.Close Method

[Visual Basic]
Public Function Close() As Boolean
[C#]
public bool Close();

See Also

FileDocument Class | FileDocument Members | Genghis.Windows.Forms Namespace


FileDocument.New Method

[Visual Basic]
Public Function New() As Boolean
[C#]
public bool New();

See Also

FileDocument Class | FileDocument Members | Genghis.Windows.Forms Namespace


Open Method

Genghis Class Library

FileDocument.Open

Overload List

public bool Open();

public bool Open(string);

See Also

FileDocument Class | FileDocument Members | Genghis.Windows.Forms Namespace


FileDocument.Open Method ()

[Visual Basic]
Overloads Public Function Open() As Boolean
[C#]
public bool Open();

See Also

FileDocument Class | FileDocument Members | Genghis.Windows.Forms Namespace | FileDocument.Open Overload List


FileDocument.Open Method (String)

[Visual Basic]
Overloads Public Function Open( _
   ByVal newFileName As String _
) As Boolean
[C#]
public bool Open(
   string newFileName
);

See Also

FileDocument Class | FileDocument Members | Genghis.Windows.Forms Namespace | FileDocument.Open Overload List


FileDocument.Read Method

[Visual Basic]
Protected Sub Read( _
   ByVal fileName As String _
)
[C#]
protected void Read(
   string fileName
);

See Also

FileDocument Class | FileDocument Members | Genghis.Windows.Forms Namespace


Save Method

Genghis Class Library

FileDocument.Save

Overload List

public bool Save();

protected bool Save(bool);

See Also

FileDocument Class | FileDocument Members | Genghis.Windows.Forms Namespace


FileDocument.Save Method ()

[Visual Basic]
Overloads Public Function Save() As Boolean
[C#]
public bool Save();

See Also

FileDocument Class | FileDocument Members | Genghis.Windows.Forms Namespace | FileDocument.Save Overload List


FileDocument.Save Method (Boolean)

[Visual Basic]
Overloads Protected Function Save( _
   ByVal saveAs As Boolean _
) As Boolean
[C#]
protected bool Save(
   bool saveAs
);

See Also

FileDocument Class | FileDocument Members | Genghis.Windows.Forms Namespace | FileDocument.Save Overload List


FileDocument.SaveAs Method

[Visual Basic]
Public Function SaveAs() As Boolean
[C#]
public bool SaveAs();

See Also

FileDocument Class | FileDocument Members | Genghis.Windows.Forms Namespace


FileDocument.SetCaption Method

[Visual Basic]
Protected Sub SetCaption()
[C#]
protected void SetCaption();

See Also

FileDocument Class | FileDocument Members | Genghis.Windows.Forms Namespace


FileDocument.Write Method

[Visual Basic]
Protected Sub Write( _
   ByVal fileName As String _
)
[C#]
protected void Write(
   string fileName
);

See Also

FileDocument Class | FileDocument Members | Genghis.Windows.Forms Namespace


FileDocument Events

The events of the FileDocument class are listed below. For a complete list of FileDocument class members, see the FileDocument Members topic.

Public Instance Events

Changed

See Also

FileDocument Class | Genghis.Windows.Forms Namespace


FileDocument.Changed Event

[Visual Basic]
Public Changed As Genghis.Windows.Forms.FileDocument.ChangedEventHandler
[C#]
public ChangedEventHandler Changed;

See Also

FileDocument Class | FileDocument Members | Genghis.Windows.Forms Namespace


ChangedEventHandler Delegate

[Visual Basic]
Public Delegate Sub ChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As System.EventArgs _
)
[C#]
public delegate void ChangedEventHandler(
   object sender,
   EventArgs e
);

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

Genghis.Windows.Forms Namespace


FindReplaceDialog Class

FindReplace dialog component for .NET

For a list of all members of this type, see FindReplaceDialog Members.

System.Object
MarshalByRefObject
Component
FindReplaceDialog

[Visual Basic]
Public Class FindReplaceDialog
   Inherits Component
   Implements IComponent, IDisposable, IMessageFilter
[C#]
public class FindReplaceDialog : Component, IComponent, IDisposable, IMessageFilter

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

FindReplaceDialog Members | Genghis.Windows.Forms Namespace


FindReplaceDialog Members

Public Instance Constructors

FindReplaceDialog Constructor

Public Instance Properties

Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Direction |
DisableMatchCase |
DisableUpDown |
DisableWholeWord |
FindWhat |
HideMatchCase |
HideUpDown |
HideWholeWord |
MatchCase |
MatchWholeWord |
ReplaceWith |
ShowHelp |
Site (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Type |

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
OnDialogTerminate |
OnFindNext |
OnReplace |
OnReplaceAll |
PreFilterMessage |
ShowDialog |
ToString (inherited from Component) | Select the method name to go to the Microsoft documentation.

Public Instance Events

DialogTerminate
FindNext
Replace
ReplaceAll

Protected Instance Properties

DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

FindReplaceDialog Class | Genghis.Windows.Forms Namespace


FindReplaceDialog Constructor

[Visual Basic]
Public Sub New()
[C#]
public FindReplaceDialog();

See Also

FindReplaceDialog Class | FindReplaceDialog Members | Genghis.Windows.Forms Namespace


FindReplaceDialog Properties

The properties of the FindReplaceDialog class are listed below. For a complete list of FindReplaceDialog class members, see the FindReplaceDialog Members topic.

Public Instance Properties

Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Direction |
DisableMatchCase |
DisableUpDown |
DisableWholeWord |
FindWhat |
HideMatchCase |
HideUpDown |
HideWholeWord |
MatchCase |
MatchWholeWord |
ReplaceWith |
ShowHelp |
Site (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Type |

Protected Instance Properties

DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.

See Also

FindReplaceDialog Class | Genghis.Windows.Forms Namespace


FindReplaceDialog.Direction Property

[Visual Basic]
Public Property Direction As Genghis.Windows.Forms.FindReplaceDialog.FindDirection
[C#]
public FindReplaceDialog.FindDirection Direction {get; set;}

See Also

FindReplaceDialog Class | FindReplaceDialog Members | Genghis.Windows.Forms Namespace


FindReplaceDialog.DisableMatchCase Property

[Visual Basic]
Public Property DisableMatchCase As Boolean
[C#]
public bool DisableMatchCase {get; set;}

See Also

FindReplaceDialog Class | FindReplaceDialog Members | Genghis.Windows.Forms Namespace


FindReplaceDialog.DisableUpDown Property

[Visual Basic]
Public Property DisableUpDown As Boolean
[C#]
public bool DisableUpDown {get; set;}

See Also

FindReplaceDialog Class | FindReplaceDialog Members | Genghis.Windows.Forms Namespace


FindReplaceDialog.DisableWholeWord Property

[Visual Basic]
Public Property DisableWholeWord As Boolean
[C#]
public bool DisableWholeWord {get; set;}

See Also

FindReplaceDialog Class | FindReplaceDialog Members | Genghis.Windows.Forms Namespace


FindReplaceDialog.FindWhat Property

[Visual Basic]
Public Property FindWhat As String
[C#]
public string FindWhat {get; set;}

See Also

FindReplaceDialog Class | FindReplaceDialog Members | Genghis.Windows.Forms Namespace


FindReplaceDialog.HideMatchCase Property

[Visual Basic]
Public Property HideMatchCase As Boolean
[C#]
public bool HideMatchCase {get; set;}

See Also

FindReplaceDialog Class | FindReplaceDialog Members | Genghis.Windows.Forms Namespace


FindReplaceDialog.HideUpDown Property

[Visual Basic]
Public Property HideUpDown As Boolean
[C#]
public bool HideUpDown {get; set;}

See Also

FindReplaceDialog Class | FindReplaceDialog Members | Genghis.Windows.Forms Namespace


FindReplaceDialog.HideWholeWord Property

[Visual Basic]
Public Property HideWholeWord As Boolean
[C#]
public bool HideWholeWord {get; set;}

See Also

FindReplaceDialog Class | FindReplaceDialog Members | Genghis.Windows.Forms Namespace


FindReplaceDialog.MatchCase Property

[Visual Basic]
Public Property MatchCase As Boolean
[C#]
public bool MatchCase {get; set;}

See Also

FindReplaceDialog Class | FindReplaceDialog Members | Genghis.Windows.Forms Namespace


FindReplaceDialog.MatchWholeWord Property

[Visual Basic]
Public Property MatchWholeWord As Boolean
[C#]
public bool MatchWholeWord {get; set;}

See Also

FindReplaceDialog Class | FindReplaceDialog Members | Genghis.Windows.Forms Namespace


FindReplaceDialog.ReplaceWith Property

[Visual Basic]
Public Property ReplaceWith As String
[C#]
public string ReplaceWith {get; set;}

See Also

FindReplaceDialog Class | FindReplaceDialog Members | Genghis.Windows.Forms Namespace


FindReplaceDialog.ShowHelp Property

[Visual Basic]
Public Property ShowHelp As Boolean
[C#]
public bool ShowHelp {get; set;}

See Also

FindReplaceDialog Class | FindReplaceDialog Members | Genghis.Windows.Forms Namespace


FindReplaceDialog.Type Property

[Visual Basic]
Public Property Type As Genghis.Windows.Forms.FindReplaceDialog.FindReplaceDialogType
[C#]
public FindReplaceDialog.FindReplaceDialogType Type {get; set;}

See Also

FindReplaceDialog Class | FindReplaceDialog Members | Genghis.Windows.Forms Namespace


FindReplaceDialog Methods

The methods of the FindReplaceDialog class are listed below. For a complete list of FindReplaceDialog class members, see the FindReplaceDialog Members topic.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
OnDialogTerminate |
OnFindNext |
OnReplace |
OnReplaceAll |
PreFilterMessage |
ShowDialog |
ToString (inherited from Component) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

FindReplaceDialog Class | Genghis.Windows.Forms Namespace


FindReplaceDialog.Dispose Method (Boolean)

[Visual Basic]
Overrides Overloads Protected Sub Dispose( _
   ByVal disposing As Boolean _
)
[C#]
protected override void Dispose(
   bool disposing
);

See Also

FindReplaceDialog Class | FindReplaceDialog Members | Genghis.Windows.Forms Namespace | FindReplaceDialog.Dispose Overload List


FindReplaceDialog.OnDialogTerminate Method

[Visual Basic]
Overridable Public Sub OnDialogTerminate()
[C#]
public virtual void OnDialogTerminate();

See Also

FindReplaceDialog Class | FindReplaceDialog Members | Genghis.Windows.Forms Namespace


FindReplaceDialog.OnFindNext Method

[Visual Basic]
Overridable Public Sub OnFindNext()
[C#]
public virtual void OnFindNext();

See Also

FindReplaceDialog Class | FindReplaceDialog Members | Genghis.Windows.Forms Namespace


FindReplaceDialog.OnReplace Method

[Visual Basic]
Overridable Public Sub OnReplace()
[C#]
public virtual void OnReplace();

See Also

FindReplaceDialog Class | FindReplaceDialog Members | Genghis.Windows.Forms Namespace


FindReplaceDialog.OnReplaceAll Method

[Visual Basic]
Overridable Public Sub OnReplaceAll()
[C#]
public virtual void OnReplaceAll();

See Also

FindReplaceDialog Class | FindReplaceDialog Members | Genghis.Windows.Forms Namespace


FindReplaceDialog.PreFilterMessage Method

[Visual Basic]
NotOverridable Public Function PreFilterMessage( _
   ByRef m As System.Windows.Forms.Message _
) As Boolean
[C#]
public final bool PreFilterMessage(
   ref Message m
);

See Also

FindReplaceDialog Class | FindReplaceDialog Members | Genghis.Windows.Forms Namespace


FindReplaceDialog.ShowDialog Method

[Visual Basic]
Public Function ShowDialog( _
   ByVal owner As System.Windows.Forms.IWin32Window _
) As Boolean
[C#]
public bool ShowDialog(
   IWin32Window owner
);

See Also

FindReplaceDialog Class | FindReplaceDialog Members | Genghis.Windows.Forms Namespace


FindReplaceDialog Events

The events of the FindReplaceDialog class are listed below. For a complete list of FindReplaceDialog class members, see the FindReplaceDialog Members topic.

Public Instance Events

DialogTerminate
FindNext
Replace
ReplaceAll

See Also

FindReplaceDialog Class | Genghis.Windows.Forms Namespace


FindReplaceDialog.DialogTerminate Event

[Visual Basic]
Public DialogTerminate As System.EventHandler
[C#]
public EventHandler DialogTerminate;

See Also

FindReplaceDialog Class | FindReplaceDialog Members | Genghis.Windows.Forms Namespace


FindReplaceDialog.FindNext Event

[Visual Basic]
Public FindNext As System.EventHandler
[C#]
public EventHandler FindNext;

See Also

FindReplaceDialog Class | FindReplaceDialog Members | Genghis.Windows.Forms Namespace


FindReplaceDialog.Replace Event

[Visual Basic]
Public Replace As System.EventHandler
[C#]
public EventHandler Replace;

See Also

FindReplaceDialog Class | FindReplaceDialog Members | Genghis.Windows.Forms Namespace


FindReplaceDialog.ReplaceAll Event

[Visual Basic]
Public ReplaceAll As System.EventHandler
[C#]
public EventHandler ReplaceAll;

See Also

FindReplaceDialog Class | FindReplaceDialog Members | Genghis.Windows.Forms Namespace


FindReplaceDialog.FindDirection Enumeration

[Visual Basic]
Public Enum FindReplaceDialog.FindDirection
[C#]
public enum FindReplaceDialog.FindDirection

Members

Member Name | Description
Up |
Down |

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

Genghis.Windows.Forms Namespace


FindReplaceDialog.FindReplace Class

For a list of all members of this type, see FindReplaceDialog.FindReplace Members.

System.Object
FindReplaceDialog.FindReplace

[Visual Basic]
Public Class FindReplaceDialog.FindReplace
[C#]
public class FindReplaceDialog.FindReplace

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

FindReplaceDialog.FindReplace Members | Genghis.Windows.Forms Namespace


FindReplaceDialog.FindReplace Members

Public Instance Constructors

FindReplaceDialog.FindReplace Constructor

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

FindReplaceDialog.FindReplace Class | Genghis.Windows.Forms Namespace


FindReplaceDialog.FindReplace Constructor

[Visual Basic]
Public Sub New()
[C#]
public FindReplaceDialog.FindReplace();

See Also

FindReplaceDialog.FindReplace Class | FindReplaceDialog.FindReplace Members | Genghis.Windows.Forms Namespace


FindReplaceDialog.FindReplaceDialogType Enumeration

[Visual Basic]
Public Enum FindReplaceDialog.FindReplaceDialogType
[C#]
public enum FindReplaceDialog.FindReplaceDialogType

Members

Member Name | Description
Find |
Replace |

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

Genghis.Windows.Forms Namespace


FolderNameDialog Class

Summary description for ImageCombo.

For a list of all members of this type, see FolderNameDialog Members.

System.Object
UITypeEditor
FolderNameEditor
FolderNameDialog

[Visual Basic]
Public Class FolderNameDialog
   Inherits FolderNameEditor
   Implements IComponent, IDisposable
[C#]
public class FolderNameDialog : FolderNameEditor, IComponent, IDisposable

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

FolderNameDialog Members | Genghis.Windows.Forms Namespace


FolderNameDialog Members

Public Instance Constructors

FolderNameDialog Constructor

Public Instance Properties

BrowseForComputer
BrowseForEverything
BrowseForPrinter
Description
DirectoryPath
DontTranslateTarget
NewUI
NoNewFolderButton
RestrictToDomain
RestrictToFilesystem
RestrictToSubfolders
ShowHint
ShowShareable
ShowStatusText
ShowTextBox
Site
StartLocation
ValidResultsOnly

Public Instance Methods

Dispose |
EditValue (inherited from FolderNameEditor) | Select the method name to go to the Microsoft documentation.
EditValue (inherited from UITypeEditor) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetEditStyle (inherited from FolderNameEditor) | Select the method name to go to the Microsoft documentation.
GetEditStyle (inherited from UITypeEditor) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetPaintValueSupported (inherited from UITypeEditor) | Select the method name to go to the Microsoft documentation.
GetPaintValueSupported (inherited from UITypeEditor) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
PaintValue (inherited from UITypeEditor) | Select the method name to go to the Microsoft documentation.
PaintValue (inherited from UITypeEditor) | Select the method name to go to the Microsoft documentation.
ShowDialog | Overloaded.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Public Instance Events

Disposed

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeDialog (inherited from FolderNameEditor) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

FolderNameDialog Class | Genghis.Windows.Forms Namespace


FolderNameDialog Constructor

[Visual Basic]
Public Sub New()
[C#]
public FolderNameDialog();

See Also

FolderNameDialog Class | FolderNameDialog Members | Genghis.Windows.Forms Namespace


FolderNameDialog Properties

The properties of the FolderNameDialog class are listed below. For a complete list of FolderNameDialog class members, see the FolderNameDialog Members topic.

Public Instance Properties

BrowseForComputer
BrowseForEverything
BrowseForPrinter
Description
DirectoryPath
DontTranslateTarget
NewUI
NoNewFolderButton
RestrictToDomain
RestrictToFilesystem
RestrictToSubfolders
ShowHint
ShowShareable
ShowStatusText
ShowTextBox
Site
StartLocation
ValidResultsOnly

See Also

FolderNameDialog Class | Genghis.Windows.Forms Namespace


FolderNameDialog.BrowseForComputer Property

[Visual Basic]
Public Property BrowseForComputer As Boolean
[C#]
public bool BrowseForComputer {get; set;}

See Also

FolderNameDialog Class | FolderNameDialog Members | Genghis.Windows.Forms Namespace


FolderNameDialog.BrowseForEverything Property

[Visual Basic]
Public Property BrowseForEverything As Boolean
[C#]
public bool BrowseForEverything {get; set;}

See Also

FolderNameDialog Class | FolderNameDialog Members | Genghis.Windows.Forms Namespace


FolderNameDialog.BrowseForPrinter Property

[Visual Basic]
Public Property BrowseForPrinter As Boolean
[C#]
public bool BrowseForPrinter {get; set;}

See Also

FolderNameDialog Class | FolderNameDialog Members | Genghis.Windows.Forms Namespace


FolderNameDialog.Description Property

[Visual Basic]
Public Property Description As String
[C#]
public string Description {get; set;}

See Also

FolderNameDialog Class | FolderNameDialog Members | Genghis.Windows.Forms Namespace


FolderNameDialog.DirectoryPath Property

[Visual Basic]
Public ReadOnly Property DirectoryPath As String
[C#]
public string DirectoryPath {get;}

See Also

FolderNameDialog Class | FolderNameDialog Members | Genghis.Windows.Forms Namespace


FolderNameDialog.DontTranslateTarget Property

[Visual Basic]
Public Property DontTranslateTarget As Boolean
[C#]
public bool DontTranslateTarget {get; set;}

See Also

FolderNameDialog Class | FolderNameDialog Members | Genghis.Windows.Forms Namespace


FolderNameDialog.NewUI Property

[Visual Basic]
Public Property NewUI As Boolean
[C#]
public bool NewUI {get; set;}

See Also

FolderNameDialog Class | FolderNameDialog Members | Genghis.Windows.Forms Namespace


FolderNameDialog.NoNewFolderButton Property

[Visual Basic]
Public Property NoNewFolderButton As Boolean
[C#]
public bool NoNewFolderButton {get; set;}

See Also

FolderNameDialog Class | FolderNameDialog Members | Genghis.Windows.Forms Namespace


FolderNameDialog.RestrictToDomain Property

[Visual Basic]
Public Property RestrictToDomain As Boolean
[C#]
public bool RestrictToDomain {get; set;}

See Also

FolderNameDialog Class | FolderNameDialog Members | Genghis.Windows.Forms Namespace


FolderNameDialog.RestrictToFilesystem Property

[Visual Basic]
Public Property RestrictToFilesystem As Boolean
[C#]
public bool RestrictToFilesystem {get; set;}

See Also

FolderNameDialog Class | FolderNameDialog Members | Genghis.Windows.Forms Namespace


FolderNameDialog.RestrictToSubfolders Property

[Visual Basic]
Public Property RestrictToSubfolders As Boolean
[C#]
public bool RestrictToSubfolders {get; set;}

See Also

FolderNameDialog Class | FolderNameDialog Members | Genghis.Windows.Forms Namespace


FolderNameDialog.ShowHint Property

[Visual Basic]
Public Property ShowHint As Boolean
[C#]
public bool ShowHint {get; set;}

See Also

FolderNameDialog Class | FolderNameDialog Members | Genghis.Windows.Forms Namespace


FolderNameDialog.ShowShareable Property

[Visual Basic]
Public Property ShowShareable As Boolean
[C#]
public bool ShowShareable {get; set;}

See Also

FolderNameDialog Class | FolderNameDialog Members | Genghis.Windows.Forms Namespace


FolderNameDialog.ShowStatusText Property

[Visual Basic]
Public Property ShowStatusText As Boolean
[C#]
public bool ShowStatusText {get; set;}

See Also

FolderNameDialog Class | FolderNameDialog Members | Genghis.Windows.Forms Namespace


FolderNameDialog.ShowTextBox Property

[Visual Basic]
Public Property ShowTextBox As Boolean
[C#]
public bool ShowTextBox {get; set;}

See Also

FolderNameDialog Class | FolderNameDialog Members | Genghis.Windows.Forms Namespace


FolderNameDialog.Site Property

[Visual Basic]
Overridable Public Property Site As System.ComponentModel.ISite
[C#]
public System.ComponentModel.ISite Site {virtual get; virtual set;}

See Also

FolderNameDialog Class | FolderNameDialog Members | Genghis.Windows.Forms Namespace


FolderNameDialog.StartLocation Property

[Visual Basic]
Public Property StartLocation As Genghis.Windows.Forms.FolderNameDialog.FolderNameFolder
[C#]
public FolderNameDialog.FolderNameFolder StartLocation {get; set;}

See Also

FolderNameDialog Class | FolderNameDialog Members | Genghis.Windows.Forms Namespace


FolderNameDialog.ValidResultsOnly Property

[Visual Basic]
Public Property ValidResultsOnly As Boolean
[C#]
public bool ValidResultsOnly {get; set;}

See Also

FolderNameDialog Class | FolderNameDialog Members | Genghis.Windows.Forms Namespace


FolderNameDialog Methods

The methods of the FolderNameDialog class are listed below. For a complete list of FolderNameDialog class members, see the FolderNameDialog Members topic.

Public Instance Methods

Dispose |
EditValue (inherited from FolderNameEditor) | Select the method name to go to the Microsoft documentation.
EditValue (inherited from UITypeEditor) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetEditStyle (inherited from FolderNameEditor) | Select the method name to go to the Microsoft documentation.
GetEditStyle (inherited from UITypeEditor) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetPaintValueSupported (inherited from UITypeEditor) | Select the method name to go to the Microsoft documentation.
GetPaintValueSupported (inherited from UITypeEditor) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
PaintValue (inherited from UITypeEditor) | Select the method name to go to the Microsoft documentation.
PaintValue (inherited from UITypeEditor) | Select the method name to go to the Microsoft documentation.
ShowDialog | Overloaded.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeDialog (inherited from FolderNameEditor) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

FolderNameDialog Class | Genghis.Windows.Forms Namespace


FolderNameDialog.Dispose Method

[Visual Basic]
Overridable Public Sub Dispose()
[C#]
public virtual void Dispose();

See Also

FolderNameDialog Class | FolderNameDialog Members | Genghis.Windows.Forms Namespace


ShowDialog Method

Genghis Class Library

FolderNameDialog.ShowDialog

Overload List

public DialogResult ShowDialog();

public DialogResult ShowDialog(IWin32Window);

See Also

FolderNameDialog Class | FolderNameDialog Members | Genghis.Windows.Forms Namespace


FolderNameDialog.ShowDialog Method ()

[Visual Basic]
Overloads Public Function ShowDialog() As System.Windows.Forms.DialogResult
[C#]
public DialogResult ShowDialog();

See Also

FolderNameDialog Class | FolderNameDialog Members | Genghis.Windows.Forms Namespace | FolderNameDialog.ShowDialog Overload List


FolderNameDialog.ShowDialog Method (IWin32Window)

[Visual Basic]
Overloads Public Function ShowDialog( _
   ByVal owner As System.Windows.Forms.IWin32Window _
) As System.Windows.Forms.DialogResult
[C#]
public DialogResult ShowDialog(
   IWin32Window owner
);

See Also

FolderNameDialog Class | FolderNameDialog Members | Genghis.Windows.Forms Namespace | FolderNameDialog.ShowDialog Overload List


FolderNameDialog Events

The events of the FolderNameDialog class are listed below. For a complete list of FolderNameDialog class members, see the FolderNameDialog Members topic.

Public Instance Events

Disposed

See Also

FolderNameDialog Class | Genghis.Windows.Forms Namespace


FolderNameDialog.Disposed Event

[Visual Basic]
Public Disposed As System.EventHandler
[C#]
public EventHandler Disposed;

See Also

FolderNameDialog Class | FolderNameDialog Members | Genghis.Windows.Forms Namespace


FolderNameDialog.FolderNameFolder Enumeration

[Visual Basic]
Public Enum FolderNameDialog.FolderNameFolder
[C#]
public enum FolderNameDialog.FolderNameFolder

Members

Member Name | Description
Desktop |
Favorites |
MyComputer |
MyDocuments |
MyPictures |
NetAndDialUpConnections |
NetworkNeighborhood |
Printers |
Recent |
SendTo |
StartMenu |
Templates |

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

Genghis.Windows.Forms Namespace


FolderNameDialog.FolderNameStyles Enumeration

[Visual Basic]
Public Enum FolderNameDialog.FolderNameStyles
[C#]
public enum FolderNameDialog.FolderNameStyles

Members

Member Name | Description
BrowseForComputer |
BrowseForEverything |
BrowseForPrinter |
DontTranslateTarget |
NewUI |
NoNewFolderButton |
RestrictToDomain |
RestrictToFilesystem |
RestrictToSubfolders |
ShowHint |
ShowShareable | Add a UA hint to the dialog, in place of the edit box. May not be combined with ShowTextBox
ShowStatusText | requires NewUI
ShowTextBox |
ValidResultsOnly |

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

Genghis.Windows.Forms Namespace


FormValidator Class

Performs validation on the form.

For a list of all members of this type, see FormValidator Members.

System.Object
MarshalByRefObject
Component
FormValidator

[Visual Basic]
Public Class FormValidator
   Inherits Component
   Implements IComponent, IDisposable, ISupportInitialize
[C#]
public class FormValidator : Component, IComponent, IDisposable, ISupportInitialize

Remarks

Form-level validation is performed by calling Validate on each validation control on the form. IsValid returns whether the most recent Validation was a success or not.

FormValidator offers two forms of access to the FormValidator for a specified form. The first, a static accessor, GetFormValidator, provides runtime access to either a default FormValidator component always assigned to form, or the FormValidator component you have used on your form. The second is the FormValidator component itself, which allows you to set form-wide validation properties, including ValidateOnLoad.

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

FormValidator Members | Genghis.Windows.Forms Namespace


FormValidator Members

Public Static (Shared) Methods

GetFormValidator The FormValidator provides static access to the current FormValidator assigned to the specified form.

Public Instance Constructors

FormValidator Overloaded. Initialize a new instance of the FormValidator class.

Public Instance Properties

Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
HostingForm | Gets or sets the component's hosting form.
IsValid | Gets a value that indicates whether the associated form passes validation.
Site (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ValidateOnLoad | Gets or sets whether the FormValidator should validate all controls on form load.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Component) | Select the method name to go to the Microsoft documentation.
Validate | Performs validation on the form.

Protected Instance Properties

DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

ISupportInitialize.BeginInit
ISupportInitialize.EndInit

See Also

FormValidator Class | Genghis.Windows.Forms Namespace


FormValidator Constructor

Genghis Class Library

FormValidator

Initializes a new instance of the FormValidator class.

Overload List

Initializes a new instance of the FormValidator class.

public FormValidator();

Initializes a new instance of the FormValidator class, associated with the specified form.

public FormValidator(Form);

See Also

FormValidator Class | FormValidator Members | Genghis.Windows.Forms Namespace


FormValidator Constructor ()

Initializes a new instance of the FormValidator class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public FormValidator();

See Also

FormValidator Class | FormValidator Members | Genghis.Windows.Forms Namespace | FormValidator Constructor Overload List


FormValidator Constructor (Form)

Initializes a new instance of the FormValidator class, associated with the specified form.

[Visual Basic]
Overloads Public Sub New( _
   ByVal form As System.Windows.Forms.Form _
)
[C#]
public FormValidator(
   Form form
);

Parameters

form
The Form that this FormValidator instance is associated with.

See Also

FormValidator Class | FormValidator Members | Genghis.Windows.Forms Namespace | FormValidator Constructor Overload List


FormValidator Properties

The properties of the FormValidator class are listed below. For a complete list of FormValidator class members, see the FormValidator Members topic.

Public Instance Properties

Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
HostingForm | Gets or sets the component's hosting form.
IsValid | Gets a value that indicates whether the associated form passes validation.
Site (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ValidateOnLoad | Gets or sets whether the FormValidator should validate all controls on form load.

Protected Instance Properties

DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.

See Also

FormValidator Class | Genghis.Windows.Forms Namespace


FormValidator.HostingForm Property

Gets or sets the component's hosting form.

[Visual Basic]
Public Property HostingForm As System.Windows.Forms.Form
[C#]
public System.Windows.Forms.Form HostingForm {get; set;}

Property Value

The component's hosting form. The default value is null.

See Also

FormValidator Class | FormValidator Members | Genghis.Windows.Forms Namespace


FormValidator.IsValid Property

Gets a value that indicates whether the associated form passes validation.

[Visual Basic]
Public ReadOnly Property IsValid As Boolean
[C#]
public bool IsValid {get;}

Property Value

The value that indicates whether the associated form passes validation.

See Also

FormValidator Class | FormValidator Members | Genghis.Windows.Forms Namespace


FormValidator.ValidateOnLoad Property

Gets or sets whether the FormValidator should validate all controls on form load.

[Visual Basic]
Public Property ValidateOnLoad As Boolean
[C#]
public bool ValidateOnLoad {get; set;}

Property Value

true if validation on form load is required; otherwise, false.

See Also

FormValidator Class | FormValidator Members | Genghis.Windows.Forms Namespace


FormValidator Methods

The methods of the FormValidator class are listed below. For a complete list of FormValidator class members, see the FormValidator Members topic.

Public Static (Shared) Methods

GetFormValidator The FormValidator provides static access to the current FormValidator assigned to the specified form.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Component) | Select the method name to go to the Microsoft documentation.
Validate | Performs validation on the form.

Protected Instance Methods

Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

ISupportInitialize.BeginInit
ISupportInitialize.EndInit

See Also

FormValidator Class | Genghis.Windows.Forms Namespace


FormValidator.Dispose Method (Boolean)

Clean up any resources being used.

[Visual Basic]
Overrides Overloads Protected Sub Dispose( _
   ByVal disposing As Boolean _
)
[C#]
protected override void Dispose(
   bool disposing
);

See Also

FormValidator Class | FormValidator Members | Genghis.Windows.Forms Namespace | FormValidator.Dispose Overload List


FormValidator.GetFormValidator Method

The FormValidator provides static access to the current FormValidator assigned to the specified form.

[Visual Basic]
Public Shared Function GetFormValidator( _
   ByVal form As System.Windows.Forms.Form _
) As Genghis.Windows.Forms.FormValidator
[C#]
public static FormValidator GetFormValidator(
   Form form
);

Remarks

If a FormValidator has not already been assigned to the form, a default one is created. This represents the situation where a FormControl has not been placed onto the form. In that case, the FormValidator control would assign itself to the form, replacing the default FormValidator control, if there is one. If a new FormValidator replaces an existing FormValidator, it will inherit the existing FormValidator's BaseValidatorCollection, the collection of BaseValidators already registered with the form, via a FormValidator.

See Also

FormValidator Class | FormValidator Members | Genghis.Windows.Forms Namespace


FormValidator.BeginInit Method

[Visual Basic]
Sub BeginInit() Implements ISupportInitialize.BeginInit
[C#]
void ISupportInitialize.BeginInit();

See Also

FormValidator Class | FormValidator Members | Genghis.Windows.Forms Namespace


FormValidator.EndInit Method

[Visual Basic]
Sub EndInit() Implements ISupportInitialize.EndInit
[C#]
void ISupportInitialize.EndInit();

See Also

FormValidator Class | FormValidator Members | Genghis.Windows.Forms Namespace


FormValidator.Validate Method

Performs validation on the form.

[Visual Basic]
Public Sub Validate()
[C#]
public void Validate();

Remarks

Form-level validation is performed by calling Validate on each validation control on the form.

See Also

FormValidator Class | FormValidator Members | Genghis.Windows.Forms Namespace


FormValidatorCollection Class

A strongly-typed collection of FormValidator objects.

For a list of all members of this type, see FormValidatorCollection Members.

System.Object
FormValidatorCollection

[Visual Basic]
Public Class FormValidatorCollection
   Implements IList, ICollection, IEnumerable, ICloneable
[C#]
public class FormValidatorCollection : IList, ICollection, IEnumerable, ICloneable

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

FormValidatorCollection Members | Genghis.Windows.Forms Namespace


FormValidatorCollection Members

Public Static (Shared) Methods

ReadOnly | Creates a read-only wrapper for a FormValidatorCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a FormValidatorCollection instance.

Public Instance Constructors

FormValidatorCollection Overloaded. Initialize a new instance of the FormValidatorCollection class.

Public Instance Properties

Capacity | Gets or sets the number of elements the FormValidatorCollection can contain.
Count | Gets the number of elements actually contained in the FormValidatorCollection.
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the FormValidator at the specified index.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

AddRange | Overloaded. Adds the elements of a FormValidator array to the current FormValidatorCollection.
Clear | Removes all elements from the FormValidatorCollection.
Clone | Creates a shallow copy of the FormValidatorCollection.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
RemoveAt | Overloaded. Removes the element at the specified index of the FormValidatorCollection.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

IList.Add | Overloaded.
IList.Contains | Overloaded.
ICollection.CopyTo | Overloaded.
IEnumerable.GetEnumerator | Overloaded.
IList.IndexOf | Overloaded.
IList.Insert | Overloaded.
IList.Remove | Overloaded.

See Also

FormValidatorCollection Class | Genghis.Windows.Forms Namespace


FormValidatorCollection Constructor

Genghis Class Library

FormValidatorCollection

Initializes a new instance of the FormValidatorCollection class that is empty and has the default initial capacity.

Overload List

Initializes a new instance of the FormValidatorCollection class that is empty and has the default initial capacity.

public FormValidatorCollection();

Initializes a new instance of the FormValidatorCollection class that has the specified initial capacity.

public FormValidatorCollection(int);

Initializes a new instance of the FormValidatorCollection class that contains elements copied from the specified FormValidatorCollection.

public FormValidatorCollection(FormValidatorCollection);

Initializes a new instance of the FormValidatorCollection class that contains elements copied from the specified FormValidator array.

public FormValidatorCollection(FormValidator[]);

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace


FormValidatorCollection Constructor ()

Initializes a new instance of the FormValidatorCollection class that is empty and has the default initial capacity.

[Visual Basic]
Overloads Public Sub New()
[C#]
public FormValidatorCollection();

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace | FormValidatorCollection Constructor Overload List


FormValidatorCollection Constructor (Int32)

Initializes a new instance of the FormValidatorCollection class that has the specified initial capacity.

[Visual Basic]
Overloads Public Sub New( _
   ByVal capacity As Integer _
)
[C#]
public FormValidatorCollection(
   int capacity
);

Parameters

capacity
The number of elements that the new FormValidatorCollection is initially capable of storing.

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace | FormValidatorCollection Constructor Overload List


FormValidatorCollection Constructor (FormValidatorCollection)

Initializes a new instance of the FormValidatorCollection class that contains elements copied from the specified FormValidatorCollection.

[Visual Basic]
Overloads Public Sub New( _
   ByVal c As Genghis.Windows.Forms.FormValidatorCollection _
)
[C#]
public FormValidatorCollection(
   FormValidatorCollection c
);

Parameters

c
The FormValidatorCollection whose elements are copied to the new collection.

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace | FormValidatorCollection Constructor Overload List


FormValidatorCollection Constructor (FormValidator[])

Initializes a new instance of the FormValidatorCollection class that contains elements copied from the specified FormValidator array.

[Visual Basic]
Overloads Public Sub New( _
   ByVal a As Genghis.Windows.Forms.FormValidator() _
)
[C#]
public FormValidatorCollection(
   FormValidator[] a
);

Parameters

a
The FormValidator array whose elements are copied to the new list.

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace | FormValidatorCollection Constructor Overload List


FormValidatorCollection Properties

The properties of the FormValidatorCollection class are listed below. For a complete list of FormValidatorCollection class members, see the FormValidatorCollection Members topic.

Public Instance Properties

Capacity | Gets or sets the number of elements the FormValidatorCollection can contain.
Count | Gets the number of elements actually contained in the FormValidatorCollection.
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | gets a value indicating whether the IList is read-only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item | Gets or sets the FormValidator at the specified index.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

FormValidatorCollection Class | Genghis.Windows.Forms Namespace


FormValidatorCollection.Capacity Property

Gets or sets the number of elements the FormValidatorCollection can contain.

[Visual Basic]
Overridable Public Property Capacity As Integer
[C#]
public int Capacity {virtual get; virtual set;}

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace


FormValidatorCollection.Count Property

Gets the number of elements actually contained in the FormValidatorCollection.

[Visual Basic]
Overridable Public ReadOnly Property Count As Integer
[C#]
public int Count {virtual get;}

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace


FormValidatorCollection.IsFixedSize Property

Gets a value indicating whether the collection has a fixed size.

[Visual Basic]
Overridable Public ReadOnly Property IsFixedSize As Boolean
[C#]
public bool IsFixedSize {virtual get;}

Property Value

true if the collection has a fixed size; otherwise, false. The default is false

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace


FormValidatorCollection.IsReadOnly Property

gets a value indicating whether the IList is read-only.

[Visual Basic]
Overridable Public ReadOnly Property IsReadOnly As Boolean
[C#]
public bool IsReadOnly {virtual get;}

Property Value

true if the collection is read-only; otherwise, false. The default is false

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace


FormValidatorCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

[Visual Basic]
Overridable Public ReadOnly Property IsSynchronized As Boolean
[C#]
public bool IsSynchronized {virtual get;}

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace


FormValidatorCollection.Item Property

Gets or sets the FormValidator at the specified index.

[Visual Basic]
Overridable Public Default Property Item( _
   ByVal index As Integer _
) As Genghis.Windows.Forms.FormValidator
[C#]
public FormValidator this[
   int index
] {virtual get; virtual set;}

Parameters

index
The zero-based index of the element to get or set.

Exceptions

Exception Type | Condition
System.ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace


FormValidatorCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

[Visual Basic]
Overridable Public ReadOnly Property SyncRoot As Object
[C#]
public object SyncRoot {virtual get;}

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace


FormValidatorCollection Methods

The methods of the FormValidatorCollection class are listed below. For a complete list of FormValidatorCollection class members, see the FormValidatorCollection Members topic.

Public Static (Shared) Methods

ReadOnly | Creates a read-only wrapper for a FormValidatorCollection instance.
Synchronized | Creates a synchronized (thread-safe) wrapper for a FormValidatorCollection instance.

Public Instance Methods

AddRange | Overloaded. Adds the elements of a FormValidator array to the current FormValidatorCollection.
Clear | Removes all elements from the FormValidatorCollection.
Clone | Creates a shallow copy of the FormValidatorCollection.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
RemoveAt | Overloaded. Removes the element at the specified index of the FormValidatorCollection.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.
TrimToSize | Sets the capacity to the actual number of elements.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

IList.Add | Overloaded.
IList.Contains | Overloaded.
ICollection.CopyTo | Overloaded.
IEnumerable.GetEnumerator | Overloaded.
IList.IndexOf | Overloaded.
IList.Insert | Overloaded.
IList.Remove | Overloaded.

See Also

FormValidatorCollection Class | Genghis.Windows.Forms Namespace


FormValidatorCollection.Add Method (FormValidator)

Adds a FormValidator to the end of the FormValidatorCollection.

[Visual Basic]
Overridable Public Function Add( _
   ByVal item As Genghis.Windows.Forms.FormValidator _
) As Integer
[C#]
public virtual int Add(
   FormValidator item
);

Parameters

item
The FormValidator to be added to the end of the FormValidatorCollection.

Return Value

The index at which the value has been added.

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace | FormValidatorCollection.Add Overload List


AddRange Method

Genghis Class Library

FormValidatorCollection.AddRange

Adds the elements of a FormValidator array to the current FormValidatorCollection.

Overload List

Adds the elements of a FormValidator array to the current FormValidatorCollection.

public virtual int AddRange(FormValidator[]);

Adds the elements of another FormValidatorCollection to the current FormValidatorCollection.

public virtual int AddRange(FormValidatorCollection);

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace


FormValidatorCollection.AddRange Method (FormValidator[])

Adds the elements of a FormValidator array to the current FormValidatorCollection.

[Visual Basic]
Overridable Overloads Public Function AddRange( _
   ByVal x As Genghis.Windows.Forms.FormValidator() _
) As Integer
[C#]
public virtual int AddRange(
   FormValidator[] x
);

Parameters

x
The FormValidator array whose elements should be added to the end of the FormValidatorCollection.

Return Value

The new Count of the FormValidatorCollection.

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace | FormValidatorCollection.AddRange Overload List


FormValidatorCollection.AddRange Method (FormValidatorCollection)

Adds the elements of another FormValidatorCollection to the current FormValidatorCollection.

[Visual Basic]
Overridable Overloads Public Function AddRange( _
   ByVal x As Genghis.Windows.Forms.FormValidatorCollection _
) As Integer
[C#]
public virtual int AddRange(
   FormValidatorCollection x
);

Parameters

x
The FormValidatorCollection whose elements should be added to the end of the current FormValidatorCollection.

Return Value

The new Count of the FormValidatorCollection.

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace | FormValidatorCollection.AddRange Overload List


FormValidatorCollection.Clear Method

Removes all elements from the FormValidatorCollection.

[Visual Basic]
Overridable Public Sub Clear()
[C#]
public virtual void Clear();

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace


FormValidatorCollection.Clone Method

Creates a shallow copy of the FormValidatorCollection.

[Visual Basic]
Overridable Public Function Clone() As Object
[C#]
public virtual object Clone();

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace


FormValidatorCollection.Contains Method (FormValidator)

Determines whether a given FormValidator is in the FormValidatorCollection.

[Visual Basic]
Overridable Public Function Contains( _
   ByVal item As Genghis.Windows.Forms.FormValidator _
) As Boolean
[C#]
public virtual bool Contains(
   FormValidator item
);

Parameters

item
The FormValidator to check for.

Return Value

true if item is found in the FormValidatorCollection; otherwise, false.

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace | FormValidatorCollection.Contains Overload List


CopyTo Method

Genghis Class Library

FormValidatorCollection.CopyTo

Copies the entire FormValidatorCollection to a one-dimensional string array.

Overload List

private final void CopyTo(Array,int);

Copies the entire FormValidatorCollection to a one-dimensional FormValidator array, starting at the specified index of the target array.

public virtual void CopyTo(FormValidator[],int);

Copies the entire FormValidatorCollection to a one-dimensional string array.

public virtual void CopyTo(FormValidator[]);

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace


FormValidatorCollection.CopyTo Method (FormValidator[])

Copies the entire FormValidatorCollection to a one-dimensional string array.

[Visual Basic]
Overridable Overloads Public Sub CopyTo( _
   ByVal array As Genghis.Windows.Forms.FormValidator() _
)
[C#]
public virtual void CopyTo(
   FormValidator[] array
);

Parameters

array
The one-dimensional FormValidator array to copy to.

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace | FormValidatorCollection.CopyTo Overload List


FormValidatorCollection.CopyTo Method (FormValidator[], Int32)

Copies the entire FormValidatorCollection to a one-dimensional FormValidator array, starting at the specified index of the target array.

[Visual Basic]
Overridable Overloads Public Sub CopyTo( _
   ByVal array As Genghis.Windows.Forms.FormValidator(), _
   ByVal start As Integer _
)
[C#]
public virtual void CopyTo(
   FormValidator[] array,
   int start
);

Parameters

array
The one-dimensional FormValidator array to copy to.
start
The zero-based index in array at which copying begins.

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace | FormValidatorCollection.CopyTo Overload List


FormValidatorCollection.GetEnumerator Method ()

Returns an enumerator that can iterate through the FormValidatorCollection.

[Visual Basic]
Overridable Public Function GetEnumerator() As Genghis.Windows.Forms.FormValidatorCollection.IFormValidatorCollectionEnumerator
[C#]
public virtual IFormValidatorCollectionEnumerator GetEnumerator();

Return Value

An Genghis.Windows.Forms.FormValidatorCollection.Enumerator for the entire FormValidatorCollection.

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace | FormValidatorCollection.GetEnumerator Overload List


FormValidatorCollection.IndexOf Method (FormValidator)

Returns the zero-based index of the first occurrence of a FormValidator in the FormValidatorCollection.

[Visual Basic]
Overridable Public Function IndexOf( _
   ByVal item As Genghis.Windows.Forms.FormValidator _
) As Integer
[C#]
public virtual int IndexOf(
   FormValidator item
);

Parameters

item
The FormValidator to locate in the FormValidatorCollection.

Return Value

The zero-based index of the first occurrence of item in the entire FormValidatorCollection, if found; otherwise, -1.

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace | FormValidatorCollection.IndexOf Overload List


FormValidatorCollection.Insert Method (Int32, FormValidator)

Inserts an element into the FormValidatorCollection at the specified index.

[Visual Basic]
Overridable Public Sub Insert( _
   ByVal index As Integer, _
   ByVal item As Genghis.Windows.Forms.FormValidator _
)
[C#]
public virtual void Insert(
   int index,
   FormValidator item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The FormValidator to insert.

Exceptions

Exception Type | Condition
System.ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace | FormValidatorCollection.Insert Overload List


FormValidatorCollection.ReadOnly Method

Creates a read-only wrapper for a FormValidatorCollection instance.

[Visual Basic]
Public Shared Function ReadOnly( _
   ByVal list As Genghis.Windows.Forms.FormValidatorCollection _
) As Genghis.Windows.Forms.FormValidatorCollection
[C#]
public static FormValidatorCollection ReadOnly(
   FormValidatorCollection list
);

Return Value

An FormValidatorCollection wrapper that is read-only.

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace


FormValidatorCollection.Remove Method (FormValidator)

Removes the first occurrence of a specific FormValidator from the FormValidatorCollection.

[Visual Basic]
Overridable Public Sub Remove( _
   ByVal item As Genghis.Windows.Forms.FormValidator _
)
[C#]
public virtual void Remove(
   FormValidator item
);

Parameters

item
The FormValidator to remove from the FormValidatorCollection.

Exceptions

Exception Type | Condition
System.ArgumentException | The specified FormValidator was not found in the FormValidatorCollection.

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace | FormValidatorCollection.Remove Overload List


FormValidatorCollection.RemoveAt Method (Int32)

Removes the element at the specified index of the FormValidatorCollection.

[Visual Basic]
Overridable Public Sub RemoveAt( _
   ByVal index As Integer _
)
[C#]
public virtual void RemoveAt(
   int index
);

Parameters

index
The zero-based index of the element to remove.

Exceptions

Exception Type | Condition
System.ArgumentOutOfRangeException | index is less than zero -or- index is equal to or greater than Count.

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace | FormValidatorCollection.RemoveAt Overload List


FormValidatorCollection.Synchronized Method

Creates a synchronized (thread-safe) wrapper for a FormValidatorCollection instance.

[Visual Basic]
Public Shared Function Synchronized( _
   ByVal list As Genghis.Windows.Forms.FormValidatorCollection _
) As Genghis.Windows.Forms.FormValidatorCollection
[C#]
public static FormValidatorCollection Synchronized(
   FormValidatorCollection list
);

Return Value

An FormValidatorCollection wrapper that is synchronized (thread-safe).

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace


FormValidatorCollection.CopyTo Method (Array, Int32)

[Visual Basic]
Sub CopyTo( _
   ByVal array As System.Array, _
   ByVal start As Integer _
) Implements ICollection.CopyTo
[C#]
void ICollection.CopyTo(
   Array array,
   int start
);

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace | FormValidatorCollection.CopyTo Overload List


FormValidatorCollection.GetEnumerator Method ()

[Visual Basic]
Function GetEnumerator() As System.Collections.IEnumerator Implements IEnumerable.GetEnumerator
[C#]
IEnumerator IEnumerable.GetEnumerator();

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace | FormValidatorCollection.GetEnumerator Overload List


FormValidatorCollection.Add Method (Object)

[Visual Basic]
Function Add( _
   ByVal x As Object _
) As Integer Implements IList.Add
[C#]
int IList.Add(
   object x
);

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace | FormValidatorCollection.Add Overload List


FormValidatorCollection.Contains Method (Object)

[Visual Basic]
Function Contains( _
   ByVal x As Object _
) As Boolean Implements IList.Contains
[C#]
bool IList.Contains(
   object x
);

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace | FormValidatorCollection.Contains Overload List


FormValidatorCollection.IndexOf Method (Object)

[Visual Basic]
Function IndexOf( _
   ByVal x As Object _
) As Integer Implements IList.IndexOf
[C#]
int IList.IndexOf(
   object x
);

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace | FormValidatorCollection.IndexOf Overload List


FormValidatorCollection.Insert Method (Int32, Object)

[Visual Basic]
Sub Insert( _
   ByVal pos As Integer, _
   ByVal x As Object _
) Implements IList.Insert
[C#]
void IList.Insert(
   int pos,
   object x
);

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace | FormValidatorCollection.Insert Overload List


FormValidatorCollection.Remove Method (Object)

[Visual Basic]
Sub Remove( _
   ByVal x As Object _
) Implements IList.Remove
[C#]
void IList.Remove(
   object x
);

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace | FormValidatorCollection.Remove Overload List


FormValidatorCollection.RemoveAt Method (Int32)

[Visual Basic]
Sub RemoveAt( _
   ByVal pos As Integer _
) Implements IList.RemoveAt
[C#]
void IList.RemoveAt(
   int pos
);

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace | FormValidatorCollection.RemoveAt Overload List


FormValidatorCollection.TrimToSize Method

Sets the capacity to the actual number of elements.

[Visual Basic]
Overridable Public Sub TrimToSize()
[C#]
public virtual void TrimToSize();

See Also

FormValidatorCollection Class | FormValidatorCollection Members | Genghis.Windows.Forms Namespace


FormValidatorCollection.IFormValidatorCollectionEnumerator Interface

Supports type-safe iteration over a FormValidatorCollection.

For a list of all members of this type, see FormValidatorCollection.IFormValidatorCollectionEnumerator Members.

[Visual Basic]
Public Interface FormValidatorCollection.IFormValidatorCollectionEnumerator
[C#]
public interface FormValidatorCollection.IFormValidatorCollectionEnumerator

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

FormValidatorCollection.IFormValidatorCollectionEnumerator Members | Genghis.Windows.Forms Namespace


FormValidatorCollection.IFormValidatorCollectionEnumerator Members

Public Instance Properties

Current Gets the current element in the collection.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

FormValidatorCollection.IFormValidatorCollectionEnumerator Interface | Genghis.Windows.Forms Namespace


FormValidatorCollection.IFormValidatorCollectionEnumerator Properties

The properties of the FormValidatorCollection.IFormValidatorCollectionEnumerator class are listed below. For a complete list of FormValidatorCollection.IFormValidatorCollectionEnumerator class members, see the FormValidatorCollection.IFormValidatorCollectionEnumerator Members topic.

Public Instance Properties

Current Gets the current element in the collection.

See Also

FormValidatorCollection.IFormValidatorCollectionEnumerator Interface | Genghis.Windows.Forms Namespace


FormValidatorCollection.IFormValidatorCollectionEnumerator.Current Property

Gets the current element in the collection.

[Visual Basic]
Property Current As Genghis.Windows.Forms.FormValidator
[C#]
FormValidator Current {get;}

See Also

FormValidatorCollection.IFormValidatorCollectionEnumerator Interface | FormValidatorCollection.IFormValidatorCollectionEnumerator Members | Genghis.Windows.Forms Namespace


FormValidatorCollection.IFormValidatorCollectionEnumerator Methods

The methods of the FormValidatorCollection.IFormValidatorCollectionEnumerator class are listed below. For a complete list of FormValidatorCollection.IFormValidatorCollectionEnumerator class members, see the FormValidatorCollection.IFormValidatorCollectionEnumerator Members topic.

Public Instance Methods

MoveNext | Advances the enumerator to the next element in the collection.
Reset | Sets the enumerator to its initial position, before the first element in the collection.

See Also

FormValidatorCollection.IFormValidatorCollectionEnumerator Interface | Genghis.Windows.Forms Namespace


FormValidatorCollection.IFormValidatorCollectionEnumerator.MoveNext Method

Advances the enumerator to the next element in the collection.

[Visual Basic]
Function MoveNext() As Boolean
[C#]
bool MoveNext();

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Exceptions

Exception Type | Condition
System.InvalidOperationException | The collection was modified after the enumerator was created.

See Also

FormValidatorCollection.IFormValidatorCollectionEnumerator Interface | FormValidatorCollection.IFormValidatorCollectionEnumerator Members | Genghis.Windows.Forms Namespace


FormValidatorCollection.IFormValidatorCollectionEnumerator.Reset Method

Sets the enumerator to its initial position, before the first element in the collection.

[Visual Basic]
Sub Reset()
[C#]
void Reset();

See Also

FormValidatorCollection.IFormValidatorCollectionEnumerator Interface | FormValidatorCollection.IFormValidatorCollectionEnumerator Members | Genghis.Windows.Forms Namespace


HandleChangeEventHandler Delegate

Represents the method prototype a delegate must conform to sink events when handles are added or removed from the HandleCollector

[Visual Basic]
Public Delegate Sub HandleChangeEventHandler( _
   ByVal handleType As String, _
   ByVal handleValue As System.IntPtr, _
   ByVal currentHandleCount As Integer _
)
[C#]
public delegate void HandleChangeEventHandler(
   string handleType,
   IntPtr handleValue,
   int currentHandleCount
);

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

Genghis.Windows.Forms Namespace


HandleCollector Class

Summary description for GenghisHandleCollector.

For a list of all members of this type, see HandleCollector Members.

System.Object
HandleCollector

[Visual Basic]
Public Class HandleCollector
[C#]
public class HandleCollector

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

HandleCollector Members | Genghis.Windows.Forms Namespace


HandleCollector Members

Public Static (Shared) Properties

RegisteredHandleCount | Returns the total number of handles that have been registered regardless of their type
RegisteredHandleTypes | Returns a System.Collections.Hashtable copy of all the currently registered handle types
RegisteredHandleTypesCount | Returns the total number of unique handle types that have been registered
UseStrongNamedAssembly | Only set this to true if using a strongly named assembly. Setting this to false may work around problems with loading the strongly named assembly, but might thrown unexpected exceptions.

Public Static (Shared) Methods

Add | Adds the given handle to the handle collector. The handle is added to the System.Windows.Forms sealed HandleCollector class so as to consolidate handle tracking between an external class and the internals within that namespace. The garbage collector will automatically determine when/if the handles need to be collected.
GetRegisteredHandleType | Finds if a handle has been registered, and if so, returns its HandleCollector.RegisteredHandleType
GetTypeSpecificRegisteredHandleCount | Overloaded. Finds the number of handles of a given type that have been registered
RegisterType | Registers a new type of handle with the handle collector.
Remove | Removes the given handle from the handle collector. This handle will be removed from the System.Windows.Forms sealed HandleCollector class. Therefore it will not be included in the garbage collection kick-off algorithm.

Public Static (Shared) Events

HandleAdded | Occurs whenever a new handle has been added to the handle collector
HandleRemoved | Occurs whenever an existing handle has been removed from the handle collector

Public Instance Constructors

HandleCollector Constructor

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

HandleCollector Class | Genghis.Windows.Forms Namespace


HandleCollector Constructor

[Visual Basic]
Public Sub New()
[C#]
public HandleCollector();

See Also

HandleCollector Class | HandleCollector Members | Genghis.Windows.Forms Namespace


HandleCollector Properties

The properties of the HandleCollector class are listed below. For a complete list of HandleCollector class members, see the HandleCollector Members topic.

Public Static (Shared) Properties

RegisteredHandleCount | Returns the total number of handles that have been registered regardless of their type
RegisteredHandleTypes | Returns a System.Collections.Hashtable copy of all the currently registered handle types
RegisteredHandleTypesCount | Returns the total number of unique handle types that have been registered
UseStrongNamedAssembly | Only set this to true if using a strongly named assembly. Setting this to false may work around problems with loading the strongly named assembly, but might thrown unexpected exceptions.

See Also

HandleCollector Class | Genghis.Windows.Forms Namespace


HandleCollector.RegisteredHandleCount Property

Returns the total number of handles that have been registered regardless of their type

[Visual Basic]
Public Shared ReadOnly Property RegisteredHandleCount As Integer
[C#]
public static int RegisteredHandleCount {get;}

See Also

HandleCollector Class | HandleCollector Members | Genghis.Windows.Forms Namespace


HandleCollector.RegisteredHandleTypes Property

Returns a System.Collections.Hashtable copy of all the currently registered handle types

[Visual Basic]
Public Shared ReadOnly Property RegisteredHandleTypes As System.Collections.Hashtable
[C#]
public static System.Collections.Hashtable RegisteredHandleTypes {get;}

Remarks

The key is the string representation of the name The value is the corresponding HandleCollector.RegisteredHandleType type

Exceptions

Exception Type | Condition
Genghis.Windows.Forms.WindowsFormsNotInitializedException | Occurrs any time the HandleCollector is used before System.Windows.Forms has initialized it's internal HandleCollector

See Also

HandleCollector Class | HandleCollector Members | Genghis.Windows.Forms Namespace


HandleCollector.RegisteredHandleTypesCount Property

Returns the total number of unique handle types that have been registered

[Visual Basic]
Public Shared ReadOnly Property RegisteredHandleTypesCount As Integer
[C#]
public static int RegisteredHandleTypesCount {get;}

Exceptions

Exception Type | Condition
Genghis.Windows.Forms.WindowsFormsNotInitializedException | Occurrs any time the HandleCollector is used before System.Windows.Forms has initialized it's internal HandleCollector

See Also

HandleCollector Class | HandleCollector Members | Genghis.Windows.Forms Namespace


HandleCollector.UseStrongNamedAssembly Property

Only set this to true if using a strongly named assembly. Setting this to false may work around problems with loading the strongly named assembly, but might thrown unexpected exceptions.

[Visual Basic]
Public Shared Property UseStrongNamedAssembly As Boolean
[C#]
public static bool UseStrongNamedAssembly {get; set;}

Remarks

The current strong named System.Windows.Forms assemblies supported are: System.Windows.Forms, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089 *** USE AT YOUR OWN RISK *** Setting this property to false, forces an attempt to connect to a difference instance of System.Windows.Forms than those specified above, and could cause unpredictable results and/or crashes

See Also

HandleCollector Class | HandleCollector Members | Genghis.Windows.Forms Namespace


HandleCollector Methods

The methods of the HandleCollector class are listed below. For a complete list of HandleCollector class members, see the HandleCollector Members topic.

Public Static (Shared) Methods

Add | Adds the given handle to the handle collector. The handle is added to the System.Windows.Forms sealed HandleCollector class so as to consolidate handle tracking between an external class and the internals within that namespace. The garbage collector will automatically determine when/if the handles need to be collected.
GetRegisteredHandleType | Finds if a handle has been registered, and if so, returns its HandleCollector.RegisteredHandleType
GetTypeSpecificRegisteredHandleCount | Overloaded. Finds the number of handles of a given type that have been registered
RegisterType | Registers a new type of handle with the handle collector.
Remove | Removes the given handle from the handle collector. This handle will be removed from the System.Windows.Forms sealed HandleCollector class. Therefore it will not be included in the garbage collection kick-off algorithm.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

HandleCollector Class | Genghis.Windows.Forms Namespace


HandleCollector.Add Method

Adds the given handle to the handle collector. The handle is added to the System.Windows.Forms sealed HandleCollector class so as to consolidate handle tracking between an external class and the internals within that namespace. The garbage collector will automatically determine when/if the handles need to be collected.

[Visual Basic]
Public Shared Function Add( _
   ByVal handle As System.IntPtr, _
   ByVal type As Genghis.Windows.Forms.HandleCollector.RegisteredHandleType _
) As System.IntPtr
[C#]
public static IntPtr Add(
   IntPtr handle,
   RegisteredHandleType type
);

Parameters

handle
A System.IntPtr referencing a handle of the specified type
type
A HandleCollector.RegisteredHandleType representing the type of the handle

Return Value

The handle that was passed into the Add method

Exceptions

Exception Type | Condition
Genghis.Windows.Forms.HandleTypeNotRegisteredException | Occurs when the specified type has not been registered

See Also

HandleCollector Class | HandleCollector Members | Genghis.Windows.Forms Namespace


HandleCollector.GetRegisteredHandleType Method

Finds if a handle has been registered, and if so, returns its HandleCollector.RegisteredHandleType

[Visual Basic]
Public Shared Function GetRegisteredHandleType( _
   ByVal handleType As String _
) As Genghis.Windows.Forms.HandleCollector.RegisteredHandleType
[C#]
public static RegisteredHandleType GetRegisteredHandleType(
   string handleType
);

Parameters

handleType
The string representation of the handle type

Return Value

The int type corresponding to the handle name, otherwise null if it hasn't been registered, or if the internal System.Windows.Forms HandleCollector has not yet been initialized, and registered types

See Also

HandleCollector Class | HandleCollector Members | Genghis.Windows.Forms Namespace


GetTypeSpecificRegisteredHandleCount Method

Genghis Class Library

HandleCollector.GetTypeSpecificRegisteredHandleCount

Finds the number of handles of a given type that have been registered

Overload List

Finds the number of handles of a given type that have been registered

public static int GetTypeSpecificRegisteredHandleCount(string);

Finds the number of handles of a given type that have been registered

public static int GetTypeSpecificRegisteredHandleCount(RegisteredHandleType);

See Also

HandleCollector Class | HandleCollector Members | Genghis.Windows.Forms Namespace


HandleCollector.GetTypeSpecificRegisteredHandleCount Method (RegisteredHandleType)

Finds the number of handles of a given type that have been registered

[Visual Basic]
Overloads Public Shared Function GetTypeSpecificRegisteredHandleCount( _
   ByVal registeredHandleType As Genghis.Windows.Forms.HandleCollector.RegisteredHandleType _
) As Integer
[C#]
public static int GetTypeSpecificRegisteredHandleCount(
   RegisteredHandleType registeredHandleType
);

Parameters

registeredHandleType

Return Value

The number of handles registered, or 0 if there are none

See Also

HandleCollector Class | HandleCollector Members | Genghis.Windows.Forms Namespace | HandleCollector.GetTypeSpecificRegisteredHandleCount Overload List


HandleCollector.GetTypeSpecificRegisteredHandleCount Method (String)

Finds the number of handles of a given type that have been registered

[Visual Basic]
Overloads Public Shared Function GetTypeSpecificRegisteredHandleCount( _
   ByVal handleType As String _
) As Integer
[C#]
public static int GetTypeSpecificRegisteredHandleCount(
   string handleType
);

Parameters

handleType
The string representation of a handle type

Return Value

The number of handles registered, or 0 if there are none

See Also

HandleCollector Class | HandleCollector Members | Genghis.Windows.Forms Namespace | HandleCollector.GetTypeSpecificRegisteredHandleCount Overload List


HandleCollector.RegisterType Method

Registers a new type of handle with the handle collector.

[Visual Basic]
Public Shared Function RegisterType( _
   ByVal typeName As String, _
   ByVal expense As Integer, _
   ByVal initialThreshold As Integer _
) As Genghis.Windows.Forms.HandleCollector.RegisteredHandleType
[C#]
public static RegisteredHandleType RegisterType(
   string typeName,
   int expense,
   int initialThreshold
);

Parameters

typeName
String name of the handle type
expense
An expense in the range of 0 - 100. 0 is the least expensive handle, and 100 is the most expensive
initialThreshold
Number of handles that must be added to the handle collector before garbage collection is initiated

Return Value

A HandleCollector.RegisteredHandleType representing the handles type, that must be used with the Add and Remove methods, or null if one could not be created

Remarks

Within System.Windows.Forms, the following types are already registered: Accelerator Cursor EnhancedMetaFile Find GDI HDC Icon Kernel Menu Window To retreive the current HandleCollector.RegisteredHandleType representing the handles type, use the GetRegisteredHandleType method or examine the RegisteredHandleTypes collection If you attempt to add a typeName that has already been registered, the specified expense and initialThreshold values are ignored, and the ones that are already registered are used

Exceptions

Exception Type | Condition
System.ArgumentOutOfRangeException | Occurrs when an expense is not between 0 and 100, or the initialThreshold is set below 0
Genghis.Windows.Forms.WindowsFormsNotInitializedException | Occurrs any time the HandleCollector is used before System.Windows.Forms has initialized it's internal HandleCollector

See Also

HandleCollector Class | HandleCollector Members | Genghis.Windows.Forms Namespace


HandleCollector.Remove Method

Removes the given handle from the handle collector. This handle will be removed from the System.Windows.Forms sealed HandleCollector class. Therefore it will not be included in the garbage collection kick-off algorithm.

[Visual Basic]
Public Shared Function Remove( _
   ByVal handle As System.IntPtr, _
   ByVal type As Genghis.Windows.Forms.HandleCollector.RegisteredHandleType _
) As System.IntPtr
[C#]
public static IntPtr Remove(
   IntPtr handle,
   RegisteredHandleType type
);

Parameters

handle
A System.IntPtr referencing a handle of the specified type
type
A HandleCollector.RegisteredHandleType representing the type of the handle

Return Value

The handle that was passed into the Remove method

Exceptions

Exception Type | Condition
Genghis.Windows.Forms.HandleTypeNotRegisteredException | Occurs when the specified type has not been registered

See Also

HandleCollector Class | HandleCollector Members | Genghis.Windows.Forms Namespace


HandleCollector Events

The events of the HandleCollector class are listed below. For a complete list of HandleCollector class members, see the HandleCollector Members topic.

Public Static (Shared) Events

HandleAdded | Occurs whenever a new handle has been added to the handle collector
HandleRemoved | Occurs whenever an existing handle has been removed from the handle collector

See Also

HandleCollector Class | Genghis.Windows.Forms Namespace


HandleCollector.HandleAdded Event

Occurs whenever a new handle has been added to the handle collector

[Visual Basic]
Public Shared HandleAdded As Genghis.Windows.Forms.HandleChangeEventHandler
[C#]
public static HandleChangeEventHandler HandleAdded;

See Also

HandleCollector Class | HandleCollector Members | Genghis.Windows.Forms Namespace


HandleCollector.HandleRemoved Event

Occurs whenever an existing handle has been removed from the handle collector

[Visual Basic]
Public Shared HandleRemoved As Genghis.Windows.Forms.HandleChangeEventHandler
[C#]
public static HandleChangeEventHandler HandleRemoved;

See Also

HandleCollector Class | HandleCollector Members | Genghis.Windows.Forms Namespace


HandleCollector.RegisteredHandleType Class

Describes a handle type that has been registered with the handle collector. Helps to ensure type-safe use of add and remove with only registered types.

For a list of all members of this type, see HandleCollector.RegisteredHandleType Members.

System.Object
HandleCollector.RegisteredHandleType

[Visual Basic]
Public Class HandleCollector.RegisteredHandleType
[C#]
public class HandleCollector.RegisteredHandleType

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

HandleCollector.RegisteredHandleType Members | Genghis.Windows.Forms Namespace


HandleCollector.RegisteredHandleType Members

Public Instance Properties

Expense | An expense in the range of 0 - 100. 0 is the least expensive handle, and 100 is the most expensive
InitialThreshold | Number of handles of this type that must be added to the handle collector before garbage collection is initiated
Name | String name of the handle type
Type | The underlying int type used internally to identify this handle type

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

HandleCollector.RegisteredHandleType Class | Genghis.Windows.Forms Namespace


HandleCollector.RegisteredHandleType Properties

The properties of the HandleCollector.RegisteredHandleType class are listed below. For a complete list of HandleCollector.RegisteredHandleType class members, see the HandleCollector.RegisteredHandleType Members topic.

Public Instance Properties

Expense | An expense in the range of 0 - 100. 0 is the least expensive handle, and 100 is the most expensive
InitialThreshold | Number of handles of this type that must be added to the handle collector before garbage collection is initiated
Name | String name of the handle type
Type | The underlying int type used internally to identify this handle type

See Also

HandleCollector.RegisteredHandleType Class | Genghis.Windows.Forms Namespace


HandleCollector.RegisteredHandleType.Expense Property

An expense in the range of 0 - 100. 0 is the least expensive handle, and 100 is the most expensive

[Visual Basic]
Public ReadOnly Property Expense As Integer
[C#]
public int Expense {get;}

See Also

HandleCollector.RegisteredHandleType Class | HandleCollector.RegisteredHandleType Members | Genghis.Windows.Forms Namespace


HandleCollector.RegisteredHandleType.InitialThreshold Property

Number of handles of this type that must be added to the handle collector before garbage collection is initiated

[Visual Basic]
Public ReadOnly Property InitialThreshold As Integer
[C#]
public int InitialThreshold {get;}

See Also

HandleCollector.RegisteredHandleType Class | HandleCollector.RegisteredHandleType Members | Genghis.Windows.Forms Namespace


HandleCollector.RegisteredHandleType.Name Property

String name of the handle type

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}

See Also

HandleCollector.RegisteredHandleType Class | HandleCollector.RegisteredHandleType Members | Genghis.Windows.Forms Namespace


HandleCollector.RegisteredHandleType.Type Property

The underlying int type used internally to identify this handle type

[Visual Basic]
Public ReadOnly Property Type As Integer
[C#]
public int Type {get;}

See Also

HandleCollector.RegisteredHandleType Class | HandleCollector.RegisteredHandleType Members | Genghis.Windows.Forms Namespace


HandleTypeNotRegisteredException Class

Represents an exception that can be thrown by the HandleCollector, when a type is used that has not been registered first

For a list of all members of this type, see HandleTypeNotRegisteredException Members.

System.Object
Exception
ApplicationException
HandleTypeNotRegisteredException

[Visual Basic]
Public Class HandleTypeNotRegisteredException
   Inherits ApplicationException
   Implements ISerializable
[C#]
public class HandleTypeNotRegisteredException : ApplicationException, ISerializable

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

HandleTypeNotRegisteredException Members | Genghis.Windows.Forms Namespace


HandleTypeNotRegisteredException Members

Public Instance Constructors

HandleTypeNotRegisteredException Constructor Constructs a new exception that contains the handle type that has not been registered

Public Instance Properties

HelpLink (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
InnerException (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
Message (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
Source (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
StackTrace (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
TargetSite (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
Type | The type that was not registered before use

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetBaseException (inherited from Exception) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetObjectData (inherited from Exception) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Exception) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

HResult (inherited from System.Exception) Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

HandleTypeNotRegisteredException Class | Genghis.Windows.Forms Namespace


HandleTypeNotRegisteredException Constructor

Constructs a new exception that contains the handle type that has not been registered

[Visual Basic]
Public Sub New( _
   ByVal type As Integer _
)
[C#]
public HandleTypeNotRegisteredException(
   int type
);

Parameters

type

See Also

HandleTypeNotRegisteredException Class | HandleTypeNotRegisteredException Members | Genghis.Windows.Forms Namespace


HandleTypeNotRegisteredException Properties

The properties of the HandleTypeNotRegisteredException class are listed below. For a complete list of HandleTypeNotRegisteredException class members, see the HandleTypeNotRegisteredException Members topic.

Public Instance Properties

HelpLink (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
InnerException (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
Message (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
Source (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
StackTrace (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
TargetSite (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
Type | The type that was not registered before use

Protected Instance Properties

HResult (inherited from System.Exception) Select the method name to go to the Microsoft documentation.

See Also

HandleTypeNotRegisteredException Class | Genghis.Windows.Forms Namespace


HandleTypeNotRegisteredException.Type Property

The type that was not registered before use

[Visual Basic]
Public ReadOnly Property Type As Integer
[C#]
public int Type {get;}

See Also

HandleTypeNotRegisteredException Class | HandleTypeNotRegisteredException Members | Genghis.Windows.Forms Namespace


HeaderGroupBox Class

A simple header-only GroupBox. Supports Right-To-Left reading, and should (I hope) look pretty much like the real thing.

For a list of all members of this type, see HeaderGroupBox Members.

System.Object
MarshalByRefObject
Component
Control
GroupBox
HeaderGroupBox

[Visual Basic]
Public Class HeaderGroupBox
   Inherits GroupBox
   Implements IComponent, IDisposable, IOleControl, IOleObject, IOleInPlaceObject, IOleInPlaceActiveObject, IOleWindow, IViewObject, IViewObject2, IPersist, IPersistStreamInit, IPersistPropertyBag, IPersistStorage, IQuickActivate, ISynchronizeInvoke, IWin32Window
[C#]
public class HeaderGroupBox : GroupBox, IComponent, IDisposable, IOleControl, IOleObject, IOleInPlaceObject, IOleInPlaceActiveObject, IOleWindow, IViewObject, IViewObject2, IPersist, IPersistStreamInit, IPersistPropertyBag, IPersistStorage, IQuickActivate, ISynchronizeInvoke, IWin32Window

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

HeaderGroupBox Members | Genghis.Windows.Forms Namespace


HeaderGroupBox Members

Public Instance Constructors

HeaderGroupBox Constructor

Public Instance Properties

AccessibilityObject (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleDefaultActionDescription (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleDescription (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleRole (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AllowDrop (inherited from System.Windows.Forms.GroupBox) | Select the method name to go to the Microsoft documentation.
Anchor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
BackColor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
BackgroundImage (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
BindingContext (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Bottom (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Bounds (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CanFocus (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CanSelect (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Capture (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CausesValidation (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ClientRectangle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ClientSize (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CompanyName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ContainsFocus (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ContextMenu (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Controls (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Created (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Cursor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DataBindings (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DisplayRectangle (inherited from System.Windows.Forms.GroupBox) | Select the method name to go to the Microsoft documentation.
Disposing (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Dock (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Enabled (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
FlatStyle (inherited from System.Windows.Forms.GroupBox) | Select the method name to go to the Microsoft documentation.
Focused (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Font (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ForeColor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Handle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
HasChildren (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Height (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ImeMode (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
InvokeRequired (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsAccessible (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsDisposed (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsHandleCreated (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Left (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Location (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Name (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Padding |
Parent (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ProductName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ProductVersion (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RecreatingHandle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Region (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Right (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RightToLeft (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Site (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Size (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TabIndex (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TabStop (inherited from System.Windows.Forms.GroupBox) | Select the method name to go to the Microsoft documentation.
Tag (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Text (inherited from System.Windows.Forms.GroupBox) | Select the method name to go to the Microsoft documentation.
Top (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TopLevelControl (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Visible (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Width (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
WindowTarget (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.

Public Instance Methods

BeginInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
BeginInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
BringToFront (inherited from Control) | Select the method name to go to the Microsoft documentation.
Contains (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateGraphics (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
DoDragDrop (inherited from Control) | Select the method name to go to the Microsoft documentation.
EndInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
FindForm (inherited from Control) | Select the method name to go to the Microsoft documentation.
Focus (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetChildAtPoint (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetContainerControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetNextControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
Hide (inherited from Control) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
PerformLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
PerformLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
PointToClient (inherited from Control) | Select the method name to go to the Microsoft documentation.
PointToScreen (inherited from Control) | Select the method name to go to the Microsoft documentation.
PreProcessMessage (inherited from Control) | Select the method name to go to the Microsoft documentation.
RectangleToClient (inherited from Control) | Select the method name to go to the Microsoft documentation.
RectangleToScreen (inherited from Control) | Select the method name to go to the Microsoft documentation.
Refresh (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetBackColor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetBindings (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetCursor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetFont (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetForeColor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetImeMode (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetRightToLeft (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetText (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResumeLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResumeLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
Scale (inherited from Control) | Select the method name to go to the Microsoft documentation.
Scale (inherited from Control) | Select the method name to go to the Microsoft documentation.
Select (inherited from Control) | Select the method name to go to the Microsoft documentation.
SelectNextControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
SendToBack (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
Show (inherited from Control) | Select the method name to go to the Microsoft documentation.
SuspendLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
ToString (inherited from GroupBox) | Select the method name to go to the Microsoft documentation.
Update (inherited from Control) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

CreateParams (inherited from System.Windows.Forms.GroupBox) | Select the method name to go to the Microsoft documentation.
DefaultImeMode (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DefaultSize (inherited from System.Windows.Forms.GroupBox) | Select the method name to go to the Microsoft documentation.
DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
FontHeight (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RenderRightToLeft (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ResizeRedraw (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowFocusCues (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowKeyboardCues (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateAccessibilityInstance (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateControlsInstance (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
DefWndProc (inherited from Control) | Select the method name to go to the Microsoft documentation.
DestroyHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Control) | Select the method name to go to the Microsoft documentation.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetStyle (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetTopLevel (inherited from Control) | Select the method name to go to the Microsoft documentation.
InitLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeGotFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeLostFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeOnClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokePaint (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokePaintBackground (inherited from Control) | Select the method name to go to the Microsoft documentation.
IsInputChar (inherited from Control) | Select the method name to go to the Microsoft documentation.
IsInputKey (inherited from Control) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
NotifyInvalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBackColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBackgroundImageChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBindingContextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnCausesValidationChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnChangeUICues (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnContextMenuChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnControlAdded (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnControlRemoved (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnCreateControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnCursorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDockChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDoubleClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragDrop (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragOver (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnEnabledChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnFontChanged (inherited from GroupBox) | Select the method name to go to the Microsoft documentation.
OnForeColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnGiveFeedback (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnGotFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnHandleCreated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnHandleDestroyed (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnHelpRequested (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnImeModeChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnInvalidated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnKeyDown (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnKeyPress (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnKeyUp (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLocationChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLostFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseDown (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseHover (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseMove (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseUp (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseWheel (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMove (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnNotifyMessage (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnPaint |
OnPaintBackground (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBackColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBackgroundImageChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBindingContextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentEnabledChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentFontChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentForeColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentRightToLeftChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentVisibleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnQueryContinueDrag (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnResize (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnRightToLeftChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnSizeChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnStyleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnSystemColorsChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTabIndexChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTabStopChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnValidated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnValidating (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnVisibleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessCmdKey (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessDialogChar (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessDialogKey (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessKeyEventArgs (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessKeyPreview (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessMnemonic (inherited from GroupBox) | Select the method name to go to the Microsoft documentation.
RaiseDragEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseKeyEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseMouseEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaisePaintEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RecreateHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetMouseEventArgs (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateContent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateHorizontal (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateLeftRight (inherited from Control) | Select the method name to go to the Microsoft documentation.
ScaleCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
Select (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetBoundsCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetClientSizeCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetStyle (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetTopLevel (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetVisibleCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateStyles (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateZOrder (inherited from Control) | Select the method name to go to the Microsoft documentation.
WndProc (inherited from GroupBox) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

UnsafeNativeMethods+IOleObject.Advise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Close (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleWindow.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.DoVerb (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Draw (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Draw (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.EnableModeless (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.EnumAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.EnumVerbs (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Freeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Freeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.FreezeEvents (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.GetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersist.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetClientSite (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetClipboardData (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetColorSet (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.GetColorSet (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.GetContentExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.GetControlInfo (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetMiscStatus (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetMoniker (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.GetSizeMax (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetUserClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetUserType (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleWindow.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.HandsOffStorage (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.InitFromData (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.InPlaceDeactivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.IsDirty (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.IsDirty (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.IsUpToDate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.OleUpdate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.OnAmbientPropertyChange (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.OnDocWindowActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.OnFrameWindowActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.OnMnemonic (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.QuickActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.ReactivateAndUndo (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.ResizeBorder (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.SaveCompleted (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.SetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.SetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetClientSite (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetColorScheme (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.SetContentExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetHostNames (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetMoniker (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.SetObjectRects (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.TranslateAccelerator (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.UIDeactivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Unadvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Unfreeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Unfreeze (inherited from Control) | Select the method name to go to the Microsoft documentation.

See Also

HeaderGroupBox Class | Genghis.Windows.Forms Namespace


HeaderGroupBox Constructor

[Visual Basic]
Public Sub New()
[C#]
public HeaderGroupBox();

See Also

HeaderGroupBox Class | HeaderGroupBox Members | Genghis.Windows.Forms Namespace


HeaderGroupBox Properties

The properties of the HeaderGroupBox class are listed below. For a complete list of HeaderGroupBox class members, see the HeaderGroupBox Members topic.

Public Instance Properties

AccessibilityObject (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleDefaultActionDescription (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleDescription (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleRole (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AllowDrop (inherited from System.Windows.Forms.GroupBox) | Select the method name to go to the Microsoft documentation.
Anchor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
BackColor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
BackgroundImage (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
BindingContext (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Bottom (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Bounds (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CanFocus (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CanSelect (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Capture (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CausesValidation (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ClientRectangle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ClientSize (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CompanyName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ContainsFocus (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ContextMenu (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Controls (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Created (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Cursor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DataBindings (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DisplayRectangle (inherited from System.Windows.Forms.GroupBox) | Select the method name to go to the Microsoft documentation.
Disposing (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Dock (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Enabled (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
FlatStyle (inherited from System.Windows.Forms.GroupBox) | Select the method name to go to the Microsoft documentation.
Focused (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Font (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ForeColor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Handle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
HasChildren (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Height (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ImeMode (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
InvokeRequired (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsAccessible (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsDisposed (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsHandleCreated (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Left (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Location (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Name (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Padding |
Parent (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ProductName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ProductVersion (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RecreatingHandle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Region (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Right (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RightToLeft (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Site (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Size (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TabIndex (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TabStop (inherited from System.Windows.Forms.GroupBox) | Select the method name to go to the Microsoft documentation.
Tag (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Text (inherited from System.Windows.Forms.GroupBox) | Select the method name to go to the Microsoft documentation.
Top (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TopLevelControl (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Visible (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Width (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
WindowTarget (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

CreateParams (inherited from System.Windows.Forms.GroupBox) | Select the method name to go to the Microsoft documentation.
DefaultImeMode (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DefaultSize (inherited from System.Windows.Forms.GroupBox) | Select the method name to go to the Microsoft documentation.
DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
FontHeight (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RenderRightToLeft (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ResizeRedraw (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowFocusCues (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowKeyboardCues (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.

See Also

HeaderGroupBox Class | Genghis.Windows.Forms Namespace


HeaderGroupBox.Padding Property

[Visual Basic]
Public Property Padding As Integer
[C#]
public int Padding {get; set;}

See Also

HeaderGroupBox Class | HeaderGroupBox Members | Genghis.Windows.Forms Namespace


HeaderGroupBox Methods

The methods of the HeaderGroupBox class are listed below. For a complete list of HeaderGroupBox class members, see the HeaderGroupBox Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
BeginInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
BringToFront (inherited from Control) | Select the method name to go to the Microsoft documentation.
Contains (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateGraphics (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
DoDragDrop (inherited from Control) | Select the method name to go to the Microsoft documentation.
EndInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
FindForm (inherited from Control) | Select the method name to go to the Microsoft documentation.
Focus (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetChildAtPoint (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetContainerControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetNextControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
Hide (inherited from Control) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
PerformLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
PerformLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
PointToClient (inherited from Control) | Select the method name to go to the Microsoft documentation.
PointToScreen (inherited from Control) | Select the method name to go to the Microsoft documentation.
PreProcessMessage (inherited from Control) | Select the method name to go to the Microsoft documentation.
RectangleToClient (inherited from Control) | Select the method name to go to the Microsoft documentation.
RectangleToScreen (inherited from Control) | Select the method name to go to the Microsoft documentation.
Refresh (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetBackColor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetBindings (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetCursor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetFont (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetForeColor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetImeMode (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetRightToLeft (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetText (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResumeLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResumeLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
Scale (inherited from Control) | Select the method name to go to the Microsoft documentation.
Scale (inherited from Control) | Select the method name to go to the Microsoft documentation.
Select (inherited from Control) | Select the method name to go to the Microsoft documentation.
SelectNextControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
SendToBack (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
Show (inherited from Control) | Select the method name to go to the Microsoft documentation.
SuspendLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
ToString (inherited from GroupBox) | Select the method name to go to the Microsoft documentation.
Update (inherited from Control) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateAccessibilityInstance (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateControlsInstance (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
DefWndProc (inherited from Control) | Select the method name to go to the Microsoft documentation.
DestroyHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Control) | Select the method name to go to the Microsoft documentation.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetStyle (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetTopLevel (inherited from Control) | Select the method name to go to the Microsoft documentation.
InitLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeGotFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeLostFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeOnClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokePaint (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokePaintBackground (inherited from Control) | Select the method name to go to the Microsoft documentation.
IsInputChar (inherited from Control) | Select the method name to go to the Microsoft documentation.
IsInputKey (inherited from Control) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
NotifyInvalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBackColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBackgroundImageChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBindingContextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnCausesValidationChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnChangeUICues (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnContextMenuChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnControlAdded (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnControlRemoved (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnCreateControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnCursorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDockChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDoubleClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragDrop (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragOver (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnEnabledChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnFontChanged (inherited from GroupBox) | Select the method name to go to the Microsoft documentation.
OnForeColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnGiveFeedback (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnGotFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnHandleCreated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnHandleDestroyed (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnHelpRequested (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnImeModeChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnInvalidated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnKeyDown (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnKeyPress (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnKeyUp (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLocationChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLostFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseDown (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseHover (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseMove (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseUp (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseWheel (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMove (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnNotifyMessage (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnPaint |
OnPaintBackground (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBackColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBackgroundImageChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBindingContextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentEnabledChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentFontChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentForeColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentRightToLeftChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentVisibleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnQueryContinueDrag (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnResize (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnRightToLeftChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnSizeChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnStyleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnSystemColorsChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTabIndexChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTabStopChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnValidated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnValidating (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnVisibleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessCmdKey (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessDialogChar (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessDialogKey (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessKeyEventArgs (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessKeyPreview (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessMnemonic (inherited from GroupBox) | Select the method name to go to the Microsoft documentation.
RaiseDragEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseKeyEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseMouseEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaisePaintEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RecreateHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetMouseEventArgs (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateContent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateHorizontal (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateLeftRight (inherited from Control) | Select the method name to go to the Microsoft documentation.
ScaleCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
Select (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetBoundsCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetClientSizeCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetStyle (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetTopLevel (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetVisibleCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateStyles (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateZOrder (inherited from Control) | Select the method name to go to the Microsoft documentation.
WndProc (inherited from GroupBox) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

UnsafeNativeMethods+IOleObject.Advise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Close (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleWindow.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.DoVerb (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Draw (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Draw (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.EnableModeless (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.EnumAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.EnumVerbs (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Freeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Freeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.FreezeEvents (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.GetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersist.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetClientSite (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetClipboardData (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetColorSet (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.GetColorSet (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.GetContentExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.GetControlInfo (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetMiscStatus (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetMoniker (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.GetSizeMax (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetUserClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetUserType (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleWindow.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.HandsOffStorage (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.InitFromData (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.InPlaceDeactivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.IsDirty (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.IsDirty (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.IsUpToDate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.OleUpdate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.OnAmbientPropertyChange (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.OnDocWindowActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.OnFrameWindowActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.OnMnemonic (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.QuickActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.ReactivateAndUndo (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.ResizeBorder (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.SaveCompleted (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.SetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.SetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetClientSite (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetColorScheme (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.SetContentExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetHostNames (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetMoniker (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.SetObjectRects (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.TranslateAccelerator (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.UIDeactivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Unadvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Unfreeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Unfreeze (inherited from Control) | Select the method name to go to the Microsoft documentation.

See Also

HeaderGroupBox Class | Genghis.Windows.Forms Namespace


HeaderGroupBox.OnPaint Method

[Visual Basic]
Overrides Protected Sub OnPaint( _
   ByVal e As System.Windows.Forms.PaintEventArgs _
)
[C#]
protected override void OnPaint(
   PaintEventArgs e
);

See Also

HeaderGroupBox Class | HeaderGroupBox Members | Genghis.Windows.Forms Namespace


ImageCombo Class

Summary description for ImageCombo.

For a list of all members of this type, see ImageCombo Members.

System.Object
MarshalByRefObject
Component
Control
ListControl
ComboBox
ImageCombo

[Visual Basic]
Public Class ImageCombo
   Inherits ComboBox
   Implements IComponent, IDisposable, IOleControl, IOleObject, IOleInPlaceObject, IOleInPlaceActiveObject, IOleWindow, IViewObject, IViewObject2, IPersist, IPersistStreamInit, IPersistPropertyBag, IPersistStorage, IQuickActivate, ISynchronizeInvoke, IWin32Window
[C#]
public class ImageCombo : ComboBox, IComponent, IDisposable, IOleControl, IOleObject, IOleInPlaceObject, IOleInPlaceActiveObject, IOleWindow, IViewObject, IViewObject2, IPersist, IPersistStreamInit, IPersistPropertyBag, IPersistStorage, IQuickActivate, ISynchronizeInvoke, IWin32Window

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

ImageCombo Members | Genghis.Windows.Forms Namespace


ImageCombo Members

Public Instance Constructors

ImageCombo Constructor

Public Instance Properties

AccessibilityObject (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleDefaultActionDescription (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleDescription (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleRole (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AllowDrop (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Anchor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
BackColor (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
BackgroundImage (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
BindingContext (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Bottom (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Bounds (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CanFocus (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CanSelect (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Capture (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CausesValidation (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ClientRectangle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ClientSize (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CompanyName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ContainsFocus (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ContextMenu (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Controls (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Created (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Cursor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DataBindings (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DataSource (inherited from System.Windows.Forms.ListControl) | Select the method name to go to the Microsoft documentation.
DisplayMember (inherited from System.Windows.Forms.ListControl) | Select the method name to go to the Microsoft documentation.
DisplayRectangle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Disposing (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Dock (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DrawMode (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
DropDownStyle (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
DropDownWidth (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
DroppedDown (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
Enabled (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Focused (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
Font (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ForeColor (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
Handle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
HasChildren (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Height (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ImageList |
ImageMember |
ImeMode (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IndentMember |
IntegralHeight (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
InvokeRequired (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsAccessible (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsDisposed (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsHandleCreated (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ItemHeight (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
Items (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
Left (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Location (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
MaxDropDownItems (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
MaxLength (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
Name (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Parent (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
PreferredHeight (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
ProductName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ProductVersion (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RecreatingHandle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Region (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Right (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RightToLeft (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
SelectedImageMember |
SelectedIndex (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
SelectedItem (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
SelectedText (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
SelectedValue (inherited from System.Windows.Forms.ListControl) | Select the method name to go to the Microsoft documentation.
SelectionLength (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
SelectionStart (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
Site (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Size (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Sorted (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
TabIndex (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TabStop (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Tag (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Text (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
Top (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TopLevelControl (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ValueMember (inherited from System.Windows.Forms.ListControl) | Select the method name to go to the Microsoft documentation.
Visible (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Width (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
WindowTarget (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.

Public Instance Methods

BeginInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
BeginInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
BeginUpdate (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
BringToFront (inherited from Control) | Select the method name to go to the Microsoft documentation.
Contains (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateGraphics (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
DoDragDrop (inherited from Control) | Select the method name to go to the Microsoft documentation.
EndInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
EndUpdate (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
FindForm (inherited from Control) | Select the method name to go to the Microsoft documentation.
FindString (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
FindString (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
FindStringExact (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
FindStringExact (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
Focus (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetChildAtPoint (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetContainerControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetItemHeight (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
GetItemText (inherited from ListControl) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetNextControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
Hide (inherited from Control) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
PerformLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
PerformLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
PointToClient (inherited from Control) | Select the method name to go to the Microsoft documentation.
PointToScreen (inherited from Control) | Select the method name to go to the Microsoft documentation.
PreProcessMessage (inherited from Control) | Select the method name to go to the Microsoft documentation.
RectangleToClient (inherited from Control) | Select the method name to go to the Microsoft documentation.
RectangleToScreen (inherited from Control) | Select the method name to go to the Microsoft documentation.
Refresh (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetBackColor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetBindings (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetCursor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetFont (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetForeColor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetImeMode (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetRightToLeft (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetText (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResumeLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResumeLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
Scale (inherited from Control) | Select the method name to go to the Microsoft documentation.
Scale (inherited from Control) | Select the method name to go to the Microsoft documentation.
Select (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
Select (inherited from Control) | Select the method name to go to the Microsoft documentation.
SelectAll (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
SelectNextControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
SendToBack (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
Show (inherited from Control) | Select the method name to go to the Microsoft documentation.
SuspendLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
ToString (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
Update (inherited from Control) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

CreateParams (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
DataManager (inherited from System.Windows.Forms.ListControl) | Select the method name to go to the Microsoft documentation.
DefaultImeMode (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DefaultSize (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
FontHeight (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RenderRightToLeft (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ResizeRedraw (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowFocusCues (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowKeyboardCues (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Select the method name to go to the Microsoft documentation.
AddItemsCore (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
CreateAccessibilityInstance (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateControlsInstance (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
DefWndProc (inherited from Control) | Select the method name to go to the Microsoft documentation.
DestroyHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
FilterItemOnProperty (inherited from ListControl) | Select the method name to go to the Microsoft documentation.
FilterItemOnProperty (inherited from ListControl) | Select the method name to go to the Microsoft documentation.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetStyle (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetTopLevel (inherited from Control) | Select the method name to go to the Microsoft documentation.
InitLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeGotFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeLostFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeOnClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokePaint (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokePaintBackground (inherited from Control) | Select the method name to go to the Microsoft documentation.
IsInputChar (inherited from Control) | Select the method name to go to the Microsoft documentation.
IsInputKey (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
NotifyInvalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBackColorChanged (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnBackgroundImageChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBindingContextChanged (inherited from ListControl) | Select the method name to go to the Microsoft documentation.
OnCausesValidationChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnChangeUICues (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnContextMenuChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnControlAdded (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnControlRemoved (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnCreateControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnCursorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDataSourceChanged (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnDisplayMemberChanged (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnDockChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDoubleClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragDrop (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragOver (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDrawItem (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnDropDown (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnDropDownStyleChanged (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnEnabledChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnFontChanged (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnForeColorChanged (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnGiveFeedback (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnGotFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnHandleCreated (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnHandleDestroyed (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnHelpRequested (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnImeModeChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnInvalidated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnKeyDown (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnKeyPress (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnKeyUp (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLocationChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLostFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMeasureItem (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnMouseDown (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseHover (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseMove (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseUp (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseWheel (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMove (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnNotifyMessage (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnPaint (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnPaintBackground (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBackColorChanged (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnParentBackgroundImageChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBindingContextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentEnabledChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentFontChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentForeColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentRightToLeftChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentVisibleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnQueryContinueDrag (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnResize (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnRightToLeftChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnSelectedIndexChanged (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnSelectedItemChanged (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnSelectedValueChanged (inherited from ListControl) | Select the method name to go to the Microsoft documentation.
OnSelectionChangeCommitted (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
OnSizeChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnStyleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnSystemColorsChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTabIndexChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTabStopChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnValidated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnValidating (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnValueMemberChanged (inherited from ListControl) | Select the method name to go to the Microsoft documentation.
OnVisibleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessCmdKey (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessDialogChar (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessDialogKey (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessKeyEventArgs (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessKeyPreview (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessMnemonic (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseDragEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseKeyEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseMouseEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaisePaintEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RecreateHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
RefreshItem (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
ResetMouseEventArgs (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateContent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateHorizontal (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateLeftRight (inherited from Control) | Select the method name to go to the Microsoft documentation.
ScaleCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
Select (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetBoundsCore (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
SetClientSizeCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetItemCore (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
SetItemsCore (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.
SetStyle (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetTopLevel (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetVisibleCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateStyles (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateZOrder (inherited from Control) | Select the method name to go to the Microsoft documentation.
WndProc (inherited from ComboBox) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

UnsafeNativeMethods+IOleObject.Advise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Close (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleWindow.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.DoVerb (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Draw (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Draw (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.EnableModeless (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.EnumAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.EnumVerbs (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Freeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Freeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.FreezeEvents (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.GetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersist.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetClientSite (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetClipboardData (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetColorSet (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.GetColorSet (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.GetContentExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.GetControlInfo (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetMiscStatus (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetMoniker (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.GetSizeMax (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetUserClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetUserType (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleWindow.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.HandsOffStorage (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.InitFromData (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.InPlaceDeactivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.IsDirty (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.IsDirty (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.IsUpToDate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.OleUpdate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.OnAmbientPropertyChange (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.OnDocWindowActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.OnFrameWindowActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.OnMnemonic (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.QuickActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.ReactivateAndUndo (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.ResizeBorder (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.SaveCompleted (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.SetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.SetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetClientSite (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetColorScheme (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.SetContentExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetHostNames (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetMoniker (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.SetObjectRects (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.TranslateAccelerator (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.UIDeactivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Unadvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Unfreeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Unfreeze (inherited from Control) | Select the method name to go to the Microsoft documentation.

See Also

ImageCombo Class | Genghis.Windows.Forms Namespace


ImageCombo Constructor

[Visual Basic]
Public Sub New()
[C#]
public ImageCombo();

See Also

ImageCombo Class | ImageCombo Members | Genghis.Windows.Forms Namespace


ImageCombo Properties

The properties of the ImageCombo class are listed below. For a complete list of ImageCombo class members, see the ImageCombo Members topic.

Public Instance Properties

AccessibilityObject (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleDefaultActionDescription (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleDescription (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleRole (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AllowDrop (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Anchor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
BackColor (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
BackgroundImage (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
BindingContext (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Bottom (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Bounds (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CanFocus (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CanSelect (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Capture (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CausesValidation (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ClientRectangle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ClientSize (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CompanyName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ContainsFocus (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ContextMenu (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Controls (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Created (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Cursor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DataBindings (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DataSource (inherited from System.Windows.Forms.ListControl) | Select the method name to go to the Microsoft documentation.
DisplayMember (inherited from System.Windows.Forms.ListControl) | Select the method name to go to the Microsoft documentation.
DisplayRectangle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Disposing (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Dock (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DrawMode (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
DropDownStyle (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
DropDownWidth (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
DroppedDown (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
Enabled (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Focused (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
Font (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ForeColor (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
Handle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
HasChildren (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Height (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ImageList |
ImageMember |
ImeMode (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IndentMember |
IntegralHeight (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
InvokeRequired (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsAccessible (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsDisposed (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsHandleCreated (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ItemHeight (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
Items (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
Left (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Location (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
MaxDropDownItems (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
MaxLength (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
Name (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Parent (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
PreferredHeight (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
ProductName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ProductVersion (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RecreatingHandle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Region (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Right (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RightToLeft (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
SelectedImageMember |
SelectedIndex (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
SelectedItem (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
SelectedText (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
SelectedValue (inherited from System.Windows.Forms.ListControl) | Select the method name to go to the Microsoft documentation.
SelectionLength (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
SelectionStart (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
Site (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Size (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Sorted (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
TabIndex (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TabStop (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Tag (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Text (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
Top (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TopLevelControl (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ValueMember (inherited from System.Windows.Forms.ListControl) | Select the method name to go to the Microsoft documentation.
Visible (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Width (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
WindowTarget (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

CreateParams (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
DataManager (inherited from System.Windows.Forms.ListControl) | Select the method name to go to the Microsoft documentation.
DefaultImeMode (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DefaultSize (inherited from System.Windows.Forms.ComboBox) | Select the method name to go to the Microsoft documentation.
DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
FontHeight (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RenderRightToLeft (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ResizeRedraw (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowFocusCues (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowKeyboardCues (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.

See Also

ImageCombo Class | Genghis.Windows.Forms Namespace


ImageCombo.ImageList Property

[Visual Basic]
Public Property ImageList As System.Windows.Forms.ImageList
[C#]
public System.Windows.Forms.ImageList ImageList {get; set;}

See Also

ImageCombo Class | ImageCombo Members | Genghis.Windows.Forms Namespace


ImageCombo.ImageMember Property

[Visual Basic]
Public Property ImageMember As String
[C#]
public string ImageMember {get; set;}

See Also

ImageCombo Class | ImageCombo Members | Genghis.Windows.Forms Namespace


ImageCombo.IndentMember Property

[Visual Basic]
Public Property IndentMember As String
[C#]
public string IndentMember {get; set;}

See Also

ImageCombo Class | ImageCombo Members | Genghis.Windows.Forms Namespace


ImageCombo.SelectedImageMember Property

[Visual Basic]
Public Property SelectedImageMember As String
[C#]
public string SelectedImageMember {get; set;}

See Also

ImageCombo Class | ImageCombo Members | Genghis.Windows.Forms Namespace


ListViewCompareType Enumeration

[Visual Basic]
Public Enum ListViewCompareType
[C#]
public enum ListViewCompareType

Members

Member Name | Description
None |
String |
Integer |
Float |
Date |

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

Genghis.Windows.Forms Namespace


ListViewSorter Class

ListViewSorter sorts a listview in reportview style.

For a list of all members of this type, see ListViewSorter Members.

System.Object
ListViewSorter

[Visual Basic]
Public Class ListViewSorter
   Implements IComparer
[C#]
public class ListViewSorter : IComparer

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

ListViewSorter Members | Genghis.Windows.Forms Namespace


ListViewSorter Members

Public Instance Constructors

ListViewSorter Constructor

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
OnListViewColumnClick |
SetColumns | Sets the compare types for each column in the ListView
SortColumn | Overloaded. Sorts the ListView
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

IComparer.Compare

See Also

ListViewSorter Class | Genghis.Windows.Forms Namespace


ListViewSorter Constructor

[Visual Basic]
Public Sub New()
[C#]
public ListViewSorter();

See Also

ListViewSorter Class | ListViewSorter Members | Genghis.Windows.Forms Namespace


ListViewSorter Methods

The methods of the ListViewSorter class are listed below. For a complete list of ListViewSorter class members, see the ListViewSorter Members topic.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
OnListViewColumnClick |
SetColumns | Sets the compare types for each column in the ListView
SortColumn | Overloaded. Sorts the ListView
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

IComparer.Compare

See Also

ListViewSorter Class | Genghis.Windows.Forms Namespace


ListViewSorter.OnListViewColumnClick Method

[Visual Basic]
Public Sub OnListViewColumnClick( _
   ByVal sender As Object, _
   ByVal e As System.Windows.Forms.ColumnClickEventArgs _
)
[C#]
public void OnListViewColumnClick(
   object sender,
   ColumnClickEventArgs e
);

See Also

ListViewSorter Class | ListViewSorter Members | Genghis.Windows.Forms Namespace


ListViewSorter.SetColumns Method

Sets the compare types for each column in the ListView

[Visual Basic]
Public Sub SetColumns( _
   ByVal compareTypes As Genghis.Windows.Forms.ListViewCompareType() _
)
[C#]
public void SetColumns(
   ListViewCompareType[] compareTypes
);

Parameters

compareTypes

See Also

ListViewSorter Class | ListViewSorter Members | Genghis.Windows.Forms Namespace


SortColumn Method

Genghis Class Library

ListViewSorter.SortColumn

Sorts the ListView

Overload List

Sorts the ListView

public void SortColumn(ListView,int);

Sorts the ListView

public void SortColumn(ListView,int,bool);

See Also

ListViewSorter Class | ListViewSorter Members | Genghis.Windows.Forms Namespace


ListViewSorter.SortColumn Method (ListView, Int32)

Sorts the ListView

[Visual Basic]
Overloads Public Sub SortColumn( _
   ByVal listView As System.Windows.Forms.ListView, _
   ByVal column As Integer _
)
[C#]
public void SortColumn(
   ListView listView,
   int column
);

Parameters

listView
ListView to sort
column
columnindex to sort

See Also

ListViewSorter Class | ListViewSorter Members | Genghis.Windows.Forms Namespace | ListViewSorter.SortColumn Overload List


ListViewSorter.SortColumn Method (ListView, Int32, Boolean)

Sorts the ListView

[Visual Basic]
Overloads Public Sub SortColumn( _
   ByVal listView As System.Windows.Forms.ListView, _
   ByVal column As Integer, _
   ByVal addColumn As Boolean _
)
[C#]
public void SortColumn(
   ListView listView,
   int column,
   bool addColumn
);

Parameters

listView
ListView to sort
column
columnindex to sort
addColumn
adds column to tail of already sorted columns

See Also

ListViewSorter Class | ListViewSorter Members | Genghis.Windows.Forms Namespace | ListViewSorter.SortColumn Overload List


ListViewSorter.Compare Method

[Visual Basic]
Function Compare( _
   ByVal item1 As Object, _
   ByVal item2 As Object _
) As Integer Implements IComparer.Compare
[C#]
int IComparer.Compare(
   object item1,
   object item2
);

See Also

ListViewSorter Class | ListViewSorter Members | Genghis.Windows.Forms Namespace


MRU Class

For a list of all members of this type, see MRU Members.

System.Object
MarshalByRefObject
Component
MRU

[Visual Basic]
Public Class MRU
   Inherits Component
   Implements IComponent, IDisposable
[C#]
public class MRU : Component, IComponent, IDisposable

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

MRU Members | Genghis.Windows.Forms Namespace


MRU Members

Public Instance Constructors

MRU Constructor

Public Instance Properties

Capacity |
Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Count |
Item |
Parent |
Site (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Style |
TextWidth |

Public Instance Methods

Add |
Clear |
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetFileName |
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Component) | Select the method name to go to the Microsoft documentation.

Public Instance Events

MRUClick

Protected Instance Properties

DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

MRU Class | Genghis.Windows.Forms Namespace


MRU Constructor

[Visual Basic]
Public Sub New()
[C#]
public MRU();

See Also

MRU Class | MRU Members | Genghis.Windows.Forms Namespace


MRU Properties

The properties of the MRU class are listed below. For a complete list of MRU class members, see the MRU Members topic.

Public Instance Properties

Capacity |
Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Count |
Item |
Parent |
Site (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Style |
TextWidth |

Protected Instance Properties

DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.

See Also

MRU Class | Genghis.Windows.Forms Namespace


MRU.Capacity Property

[Visual Basic]
Public Property Capacity As Integer
[C#]
public int Capacity {get; set;}

See Also

MRU Class | MRU Members | Genghis.Windows.Forms Namespace


MRU.Count Property

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}

See Also

MRU Class | MRU Members | Genghis.Windows.Forms Namespace


MRU.Item Property

[Visual Basic]
Public Default ReadOnly Property Item( _
   ByVal index As Integer _
) As String
[C#]
public string this[
   int index
] {get;}

See Also

MRU Class | MRU Members | Genghis.Windows.Forms Namespace


MRU.Parent Property

[Visual Basic]
Public Property Parent As System.Windows.Forms.MenuItem
[C#]
public System.Windows.Forms.MenuItem Parent {get; set;}

See Also

MRU Class | MRU Members | Genghis.Windows.Forms Namespace


MRU.Style Property

[Visual Basic]
Public Property Style As Genghis.Windows.Forms.MRUStyle
[C#]
public MRUStyle Style {get; set;}

See Also

MRU Class | MRU Members | Genghis.Windows.Forms Namespace


MRU.TextWidth Property

[Visual Basic]
Public Property TextWidth As Integer
[C#]
public int TextWidth {get; set;}

See Also

MRU Class | MRU Members | Genghis.Windows.Forms Namespace


MRU Methods

The methods of the MRU class are listed below. For a complete list of MRU class members, see the MRU Members topic.

Public Instance Methods

Add |
Clear |
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetFileName |
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Component) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

MRU Class | Genghis.Windows.Forms Namespace


MRU.Add Method

[Visual Basic]
Public Sub Add( _
   ByVal mruFileName As String _
)
[C#]
public void Add(
   string mruFileName
);

See Also

MRU Class | MRU Members | Genghis.Windows.Forms Namespace


MRU.Clear Method

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();

See Also

MRU Class | MRU Members | Genghis.Windows.Forms Namespace


MRU.GetFileName Method

[Visual Basic]
Public Function GetFileName( _
   ByVal menuItemIndex As Integer _
) As String
[C#]
public string GetFileName(
   int menuItemIndex
);

See Also

MRU Class | MRU Members | Genghis.Windows.Forms Namespace


MRU Events

The events of the MRU class are listed below. For a complete list of MRU class members, see the MRU Members topic.

Public Instance Events

MRUClick

See Also

MRU Class | Genghis.Windows.Forms Namespace


MRU.MRUClick Event

[Visual Basic]
Public MRUClick As Genghis.Windows.Forms.MRU.onMRUClick
[C#]
public onMRUClick MRUClick;

See Also

MRU Class | MRU Members | Genghis.Windows.Forms Namespace


onMRUClick Delegate

[Visual Basic]
Public Delegate Sub onMRUClick( _
   ByVal sender As Object, _
   ByVal FileName As String _
)
[C#]
public delegate void onMRUClick(
   object sender,
   string FileName
);

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

Genghis.Windows.Forms Namespace


MRUMenuItem Class

For a list of all members of this type, see MRUMenuItem Members.

System.Object
MarshalByRefObject
Component
Menu
MenuItem
MRUMenuItem

[Visual Basic]
Public Class MRUMenuItem
   Inherits MenuItem
   Implements IComponent, IDisposable
[C#]
public class MRUMenuItem : MenuItem, IComponent, IDisposable

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

MRUMenuItem Members | Genghis.Windows.Forms Namespace


MRUMenuItem Members

Public Instance Constructors

MRUMenuItem Constructor

Public Instance Properties

BarBreak (inherited from System.Windows.Forms.MenuItem) | Select the method name to go to the Microsoft documentation.
Break (inherited from System.Windows.Forms.MenuItem) | Select the method name to go to the Microsoft documentation.
Checked (inherited from System.Windows.Forms.MenuItem) | Select the method name to go to the Microsoft documentation.
Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
DefaultItem (inherited from System.Windows.Forms.MenuItem) | Select the method name to go to the Microsoft documentation.
Enabled (inherited from System.Windows.Forms.MenuItem) | Select the method name to go to the Microsoft documentation.
Handle (inherited from System.Windows.Forms.Menu) | Select the method name to go to the Microsoft documentation.
Index (inherited from System.Windows.Forms.MenuItem) | Select the method name to go to the Microsoft documentation.
IsParent (inherited from System.Windows.Forms.MenuItem) | Select the method name to go to the Microsoft documentation.
MdiList (inherited from System.Windows.Forms.MenuItem) | Select the method name to go to the Microsoft documentation.
MdiListItem (inherited from System.Windows.Forms.Menu) | Select the method name to go to the Microsoft documentation.
MenuItems (inherited from System.Windows.Forms.Menu) | Select the method name to go to the Microsoft documentation.
MergeOrder (inherited from System.Windows.Forms.MenuItem) | Select the method name to go to the Microsoft documentation.
MergeType (inherited from System.Windows.Forms.MenuItem) | Select the method name to go to the Microsoft documentation.
Mnemonic (inherited from System.Windows.Forms.MenuItem) | Select the method name to go to the Microsoft documentation.
OwnerDraw (inherited from System.Windows.Forms.MenuItem) | Select the method name to go to the Microsoft documentation.
Parent (inherited from System.Windows.Forms.MenuItem) | Select the method name to go to the Microsoft documentation.
RadioCheck (inherited from System.Windows.Forms.MenuItem) | Select the method name to go to the Microsoft documentation.
Shortcut (inherited from System.Windows.Forms.MenuItem) | Select the method name to go to the Microsoft documentation.
ShowShortcut (inherited from System.Windows.Forms.MenuItem) | Select the method name to go to the Microsoft documentation.
Site (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Text (inherited from System.Windows.Forms.MenuItem) | Select the method name to go to the Microsoft documentation.
Visible (inherited from System.Windows.Forms.MenuItem) | Select the method name to go to the Microsoft documentation.

Public Instance Methods

CloneMenu (inherited from MenuItem) | Select the method name to go to the Microsoft documentation.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
FindMenuItem (inherited from Menu) | Select the method name to go to the Microsoft documentation.
GetContextMenu (inherited from Menu) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetMainMenu (inherited from Menu) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
MergeMenu (inherited from MenuItem) | Select the method name to go to the Microsoft documentation.
MergeMenu (inherited from Menu) | Select the method name to go to the Microsoft documentation.
MergeMenu (inherited from MenuItem) | Select the method name to go to the Microsoft documentation.
PerformClick (inherited from MenuItem) | Select the method name to go to the Microsoft documentation.
PerformSelect (inherited from MenuItem) | Select the method name to go to the Microsoft documentation.
ToString (inherited from MenuItem) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
MenuID (inherited from System.Windows.Forms.MenuItem) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

CloneMenu (inherited from MenuItem) | Select the method name to go to the Microsoft documentation.
CloneMenu (inherited from Menu) | Select the method name to go to the Microsoft documentation.
CreateMenuHandle (inherited from Menu) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from MenuItem) | Select the method name to go to the Microsoft documentation.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
FindMergePosition (inherited from Menu) | Select the method name to go to the Microsoft documentation.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
OnClick (inherited from MenuItem) | Select the method name to go to the Microsoft documentation.
OnDrawItem (inherited from MenuItem) | Select the method name to go to the Microsoft documentation.
OnInitMenuPopup (inherited from MenuItem) | Select the method name to go to the Microsoft documentation.
OnMeasureItem (inherited from MenuItem) | Select the method name to go to the Microsoft documentation.
OnPopup (inherited from MenuItem) | Select the method name to go to the Microsoft documentation.
OnSelect (inherited from MenuItem) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Methods

ProcessCmdKey (inherited from Menu) Select the method name to go to the Microsoft documentation.

See Also

MRUMenuItem Class | Genghis.Windows.Forms Namespace


MRUMenuItem Constructor

[Visual Basic]
Public Sub New( _
   ByVal text As String, _
   ByVal onClick As System.EventHandler _
)
[C#]
public MRUMenuItem(
   string text,
   EventHandler onClick
);

See Also

MRUMenuItem Class | MRUMenuItem Members | Genghis.Windows.Forms Namespace


MRUStringCollection.MRUStringCollectionEnumerator Class

For a list of all members of this type, see MRUStringCollection.MRUStringCollectionEnumerator Members.

System.Object
MRUStringCollection.MRUStringCollectionEnumerator

[Visual Basic]
Public Class MRUStringCollection.MRUStringCollectionEnumerator
   Implements IEnumerator
[C#]
public class MRUStringCollection.MRUStringCollectionEnumerator : IEnumerator

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

MRUStringCollection.MRUStringCollectionEnumerator Members | Genghis.Windows.Forms Namespace


MRUStringCollection.MRUStringCollectionEnumerator Members

Public Instance Constructors

MRUStringCollection.MRUStringCollectionEnumerator Constructor

Public Instance Properties

Current

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

IEnumerator.MoveNext | Overloaded.
IEnumerator.Reset | Overloaded.

See Also

MRUStringCollection.MRUStringCollectionEnumerator Class | Genghis.Windows.Forms Namespace


MRUStringCollection.MRUStringCollectionEnumerator Constructor

[Visual Basic]
Public Sub New( _
   ByVal mruStringCollection As System.Collections.Specialized.StringCollection _
)
[C#]
public MRUStringCollection.MRUStringCollectionEnumerator(
   StringCollection mruStringCollection
);

See Also

MRUStringCollection.MRUStringCollectionEnumerator Class | MRUStringCollection.MRUStringCollectionEnumerator Members | Genghis.Windows.Forms Namespace


MRUStringCollection.MRUStringCollectionEnumerator Properties

The properties of the MRUStringCollection.MRUStringCollectionEnumerator class are listed below. For a complete list of MRUStringCollection.MRUStringCollectionEnumerator class members, see the MRUStringCollection.MRUStringCollectionEnumerator Members topic.

Public Instance Properties

Current

See Also

MRUStringCollection.MRUStringCollectionEnumerator Class | Genghis.Windows.Forms Namespace


MRUStringCollection.MRUStringCollectionEnumerator.Current Property

[Visual Basic]
Public ReadOnly Property Current As String
[C#]
public string Current {get;}

See Also

MRUStringCollection.MRUStringCollectionEnumerator Class | MRUStringCollection.MRUStringCollectionEnumerator Members | Genghis.Windows.Forms Namespace


MRUStringCollection.MRUStringCollectionEnumerator Methods

The methods of the MRUStringCollection.MRUStringCollectionEnumerator class are listed below. For a complete list of MRUStringCollection.MRUStringCollectionEnumerator class members, see the MRUStringCollection.MRUStringCollectionEnumerator Members topic.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

IEnumerator.MoveNext | Overloaded.
IEnumerator.Reset | Overloaded.

See Also

MRUStringCollection.MRUStringCollectionEnumerator Class | Genghis.Windows.Forms Namespace


MRUStringCollection.MRUStringCollectionEnumerator.MoveNext Method ()

[Visual Basic]
Public Function MoveNext() As Boolean
[C#]
public bool MoveNext();

See Also

MRUStringCollection.MRUStringCollectionEnumerator Class | MRUStringCollection.MRUStringCollectionEnumerator Members | Genghis.Windows.Forms Namespace | MRUStringCollection.MRUStringCollectionEnumerator.MoveNext Overload List


MRUStringCollection.MRUStringCollectionEnumerator.Reset Method ()

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

MRUStringCollection.MRUStringCollectionEnumerator Class | MRUStringCollection.MRUStringCollectionEnumerator Members | Genghis.Windows.Forms Namespace | MRUStringCollection.MRUStringCollectionEnumerator.Reset Overload List


MRUStringCollection.MRUStringCollectionEnumerator.MoveNext Method ()

[Visual Basic]
Function MoveNext() As Boolean Implements IEnumerator.MoveNext
[C#]
bool IEnumerator.MoveNext();

See Also

MRUStringCollection.MRUStringCollectionEnumerator Class | MRUStringCollection.MRUStringCollectionEnumerator Members | Genghis.Windows.Forms Namespace | MRUStringCollection.MRUStringCollectionEnumerator.MoveNext Overload List


MRUStringCollection.MRUStringCollectionEnumerator.Reset Method ()

[Visual Basic]
Sub Reset() Implements IEnumerator.Reset
[C#]
void IEnumerator.Reset();

See Also

MRUStringCollection.MRUStringCollectionEnumerator Class | MRUStringCollection.MRUStringCollectionEnumerator Members | Genghis.Windows.Forms Namespace | MRUStringCollection.MRUStringCollectionEnumerator.Reset Overload List


MRUStyle Enumeration

[Visual Basic]
Public Enum MRUStyle
[C#]
public enum MRUStyle

Members

Member Name | Description
InMenu |
InSubMenu |

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

Genghis.Windows.Forms Namespace


RangeValidator Class

Checks whether the value of an input control is within a specified range of values.

For a list of all members of this type, see RangeValidator Members.

System.Object
MarshalByRefObject
Component
BaseValidator
BaseCompareValidator
RangeValidator

[Visual Basic]
Public Class RangeValidator
   Inherits BaseCompareValidator
   Implements IComponent, IDisposable, ISupportInitialize
[C#]
public class RangeValidator : BaseCompareValidator, IComponent, IDisposable, ISupportInitialize

Remarks

The RangeValidator control checks whether the value of an input control falls within the range specified by MinimumValue and MaximumValue. Both of these properties must be provided for the control to run. The range comparison is performed using a specific type, specified by BaseCompareValidator.Type. The range comparison will succeed if the value being compared is greater-than-or-equal-to MinimumValue and less-than-or-equal-to MaximumValue.

Note If the input control's value does not match the type specified by BaseCompareValidator.Type the validation fails.

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

RangeValidator Members | Genghis.Windows.Forms Namespace


RangeValidator Members

Public Instance Constructors

RangeValidator Constructor

Public Instance Properties

Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ControlToValidate (inherited from BaseValidator) | Gets or sets the input control to validate.
ErrorMessage (inherited from BaseValidator) | Gets or sets the text for the error message.
HostingForm (inherited from BaseValidator) | Gets or sets the component's hosting form.
Icon (inherited from BaseValidator) | Gets or sets the Icon that is displayed next to a control when an error description string has been set for the control.
IconAlignment (inherited from BaseValidator) | Gets or sets the location where the error icon should be placed in relation to the control.
IconPadding (inherited from BaseValidator) | Gets or sets the amount of extra space to leave between the specified control and the error icon.
IsValid (inherited from BaseValidator) | Gets a value that indicates whether the associated input control passes validation.
MaximumValue | Gets or sets a the maximum value of the range being tested.
MinimumValue | Gets or sets a the minimum value of the range being tested.
Required | Gets or sets whether this control is required.
Site (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Type (inherited from BaseCompareValidator) | Gets or sets what type-checking will be applied to the validation.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Component) | Select the method name to go to the Microsoft documentation.
Validate (inherited from BaseValidator) | Performs validation on the associated input control and updates the IsValid property.

Protected Instance Properties

DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
TypeConverter (inherited from BaseCompareValidator) | Gets a TypeConverter capable of performing conversions to and from the type, specified by ValidationDataType.

Protected Instance Methods

CanConvert (inherited from BaseCompareValidator) | Returns a value indicating whether the string value can be converted to the type specified by Type.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
EvaluateIsValid | This member overrides BaseValidator.EvaluateIsValid.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
Format (inherited from BaseCompareValidator) | Returns a formatted string.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

ISupportInitialize.BeginInit (inherited from BaseValidator)
ISupportInitialize.EndInit (inherited from BaseValidator)

See Also

RangeValidator Class | Genghis.Windows.Forms Namespace


RangeValidator Constructor

[Visual Basic]
Public Sub New()
[C#]
public RangeValidator();

See Also

RangeValidator Class | RangeValidator Members | Genghis.Windows.Forms Namespace


RangeValidator Properties

The properties of the RangeValidator class are listed below. For a complete list of RangeValidator class members, see the RangeValidator Members topic.

Public Instance Properties

Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ControlToValidate (inherited from BaseValidator) | Gets or sets the input control to validate.
ErrorMessage (inherited from BaseValidator) | Gets or sets the text for the error message.
HostingForm (inherited from BaseValidator) | Gets or sets the component's hosting form.
Icon (inherited from BaseValidator) | Gets or sets the Icon that is displayed next to a control when an error description string has been set for the control.
IconAlignment (inherited from BaseValidator) | Gets or sets the location where the error icon should be placed in relation to the control.
IconPadding (inherited from BaseValidator) | Gets or sets the amount of extra space to leave between the specified control and the error icon.
IsValid (inherited from BaseValidator) | Gets a value that indicates whether the associated input control passes validation.
MaximumValue | Gets or sets a the maximum value of the range being tested.
MinimumValue | Gets or sets a the minimum value of the range being tested.
Required | Gets or sets whether this control is required.
Site (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Type (inherited from BaseCompareValidator) | Gets or sets what type-checking will be applied to the validation.

Protected Instance Properties

DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
TypeConverter (inherited from BaseCompareValidator) | Gets a TypeConverter capable of performing conversions to and from the type, specified by ValidationDataType.

See Also

RangeValidator Class | Genghis.Windows.Forms Namespace


RangeValidator.MaximumValue Property

Gets or sets a the maximum value of the range being tested.

[Visual Basic]
Public Property MaximumValue As String
[C#]
public string MaximumValue {get; set;}

Property Value

The maximum value of the range being tested.

See Also

RangeValidator Class | RangeValidator Members | Genghis.Windows.Forms Namespace


RangeValidator.MinimumValue Property

Gets or sets a the minimum value of the range being tested.

[Visual Basic]
Public Property MinimumValue As String
[C#]
public string MinimumValue {get; set;}

Property Value

The minimum value of the range being tested.

See Also

RangeValidator Class | RangeValidator Members | Genghis.Windows.Forms Namespace


RangeValidator.Required Property

Gets or sets whether this control is required.

[Visual Basic]
Public Property Required As Boolean
[C#]
public bool Required {get; set;}

Property Value

true if this control is required; otherwise, false.

See Also

RangeValidator Class | RangeValidator Members | Genghis.Windows.Forms Namespace


RangeValidator Methods

The methods of the RangeValidator class are listed below. For a complete list of RangeValidator class members, see the RangeValidator Members topic.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Component) | Select the method name to go to the Microsoft documentation.
Validate (inherited from BaseValidator) | Performs validation on the associated input control and updates the IsValid property.

Protected Instance Methods

CanConvert (inherited from BaseCompareValidator) | Returns a value indicating whether the string value can be converted to the type specified by Type.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
EvaluateIsValid | This member overrides BaseValidator.EvaluateIsValid.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
Format (inherited from BaseCompareValidator) | Returns a formatted string.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

ISupportInitialize.BeginInit (inherited from BaseValidator)
ISupportInitialize.EndInit (inherited from BaseValidator)

See Also

RangeValidator Class | Genghis.Windows.Forms Namespace


RangeValidator.EvaluateIsValid Method

This member overrides BaseValidator.EvaluateIsValid.

[Visual Basic]
Overrides Protected Function EvaluateIsValid() As Boolean
[C#]
protected override bool EvaluateIsValid();

See Also

RangeValidator Class | RangeValidator Members | Genghis.Windows.Forms Namespace


RegularExpressionValidator Class

Validates whether the value of an associated input control matches the pattern specified by a regular expression.

For a list of all members of this type, see RegularExpressionValidator Members.

System.Object
MarshalByRefObject
Component
BaseValidator
RegularExpressionValidator

[Visual Basic]
Public Class RegularExpressionValidator
   Inherits BaseValidator
   Implements IComponent, IDisposable, ISupportInitialize
[C#]
public class RegularExpressionValidator : BaseValidator, IComponent, IDisposable, ISupportInitialize

Remarks

The RegularExpressionValidator control checks whether the value of an input control matches a pattern defined by a regular expression. Validation succeeds if the input control's value is empty.

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

RegularExpressionValidator Members | Genghis.Windows.Forms Namespace


RegularExpressionValidator Members

Public Instance Constructors

RegularExpressionValidator Constructor

Public Instance Properties

Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ControlToValidate (inherited from BaseValidator) | Gets or sets the input control to validate.
ErrorMessage (inherited from BaseValidator) | Gets or sets the text for the error message.
HostingForm (inherited from BaseValidator) | Gets or sets the component's hosting form.
Icon (inherited from BaseValidator) | Gets or sets the Icon that is displayed next to a control when an error description string has been set for the control.
IconAlignment (inherited from BaseValidator) | Gets or sets the location where the error icon should be placed in relation to the control.
IconPadding (inherited from BaseValidator) | Gets or sets the amount of extra space to leave between the specified control and the error icon.
IsValid (inherited from BaseValidator) | Gets a value that indicates whether the associated input control passes validation.
Required | Gets or sets whether this control is required.
Site (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ValidationExpression | Gets or sets a the regular expression used to validated the associated input control.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Component) | Select the method name to go to the Microsoft documentation.
Validate (inherited from BaseValidator) | Performs validation on the associated input control and updates the IsValid property.

Protected Instance Properties

DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
EvaluateIsValid | This member overrides BaseValidator.EvaluateIsValid.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

ISupportInitialize.BeginInit (inherited from BaseValidator)
ISupportInitialize.EndInit (inherited from BaseValidator)

See Also

RegularExpressionValidator Class | Genghis.Windows.Forms Namespace


RegularExpressionValidator Constructor

[Visual Basic]
Public Sub New()
[C#]
public RegularExpressionValidator();

See Also

RegularExpressionValidator Class | RegularExpressionValidator Members | Genghis.Windows.Forms Namespace


RegularExpressionValidator Properties

The properties of the RegularExpressionValidator class are listed below. For a complete list of RegularExpressionValidator class members, see the RegularExpressionValidator Members topic.

Public Instance Properties

Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ControlToValidate (inherited from BaseValidator) | Gets or sets the input control to validate.
ErrorMessage (inherited from BaseValidator) | Gets or sets the text for the error message.
HostingForm (inherited from BaseValidator) | Gets or sets the component's hosting form.
Icon (inherited from BaseValidator) | Gets or sets the Icon that is displayed next to a control when an error description string has been set for the control.
IconAlignment (inherited from BaseValidator) | Gets or sets the location where the error icon should be placed in relation to the control.
IconPadding (inherited from BaseValidator) | Gets or sets the amount of extra space to leave between the specified control and the error icon.
IsValid (inherited from BaseValidator) | Gets a value that indicates whether the associated input control passes validation.
Required | Gets or sets whether this control is required.
Site (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ValidationExpression | Gets or sets a the regular expression used to validated the associated input control.

Protected Instance Properties

DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.

See Also

RegularExpressionValidator Class | Genghis.Windows.Forms Namespace


RegularExpressionValidator.Required Property

Gets or sets whether this control is required.

[Visual Basic]
Public Property Required As Boolean
[C#]
public bool Required {get; set;}

Property Value

true if this control is required; otherwise, false.

See Also

RegularExpressionValidator Class | RegularExpressionValidator Members | Genghis.Windows.Forms Namespace


RegularExpressionValidator.ValidationExpression Property

Gets or sets a the regular expression used to validated the associated input control.

[Visual Basic]
Public Property ValidationExpression As String
[C#]
public string ValidationExpression {get; set;}

Property Value

The regular expression used to validated the associated input control.

See Also

RegularExpressionValidator Class | RegularExpressionValidator Members | Genghis.Windows.Forms Namespace


RegularExpressionValidator Methods

The methods of the RegularExpressionValidator class are listed below. For a complete list of RegularExpressionValidator class members, see the RegularExpressionValidator Members topic.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Component) | Select the method name to go to the Microsoft documentation.
Validate (inherited from BaseValidator) | Performs validation on the associated input control and updates the IsValid property.

Protected Instance Methods

Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
EvaluateIsValid | This member overrides BaseValidator.EvaluateIsValid.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

ISupportInitialize.BeginInit (inherited from BaseValidator)
ISupportInitialize.EndInit (inherited from BaseValidator)

See Also

RegularExpressionValidator Class | Genghis.Windows.Forms Namespace


RegularExpressionValidator.EvaluateIsValid Method

This member overrides BaseValidator.EvaluateIsValid.

[Visual Basic]
Overrides Protected Function EvaluateIsValid() As Boolean
[C#]
protected override bool EvaluateIsValid();

See Also

RegularExpressionValidator Class | RegularExpressionValidator Members | Genghis.Windows.Forms Namespace


RequiredFieldValidator Class

Makes the associated input control a required field.

For a list of all members of this type, see RequiredFieldValidator Members.

System.Object
MarshalByRefObject
Component
BaseValidator
RequiredFieldValidator

[Visual Basic]
Public Class RequiredFieldValidator
   Inherits BaseValidator
   Implements IComponent, IDisposable, ISupportInitialize
[C#]
public class RequiredFieldValidator : BaseValidator, IComponent, IDisposable, ISupportInitialize

Remarks

Use this control to make an input control a required field. The input control fails validation if its value does not change from the InitialValue property upon losing focus.

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

RequiredFieldValidator Members | Genghis.Windows.Forms Namespace


RequiredFieldValidator Members

Public Instance Constructors

RequiredFieldValidator Constructor

Public Instance Properties

Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ControlToValidate (inherited from BaseValidator) | Gets or sets the input control to validate.
ErrorMessage (inherited from BaseValidator) | Gets or sets the text for the error message.
HostingForm (inherited from BaseValidator) | Gets or sets the component's hosting form.
Icon (inherited from BaseValidator) | Gets or sets the Icon that is displayed next to a control when an error description string has been set for the control.
IconAlignment (inherited from BaseValidator) | Gets or sets the location where the error icon should be placed in relation to the control.
IconPadding (inherited from BaseValidator) | Gets or sets the amount of extra space to leave between the specified control and the error icon.
InitialValue | Gets or sets the initial value of the associated input control.
IsValid (inherited from BaseValidator) | Gets a value that indicates whether the associated input control passes validation.
Site (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Component) | Select the method name to go to the Microsoft documentation.
Validate (inherited from BaseValidator) | Performs validation on the associated input control and updates the IsValid property.

Protected Instance Properties

DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
EvaluateIsValid | This member overrides BaseValidator.EvaluateIsValid.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

ISupportInitialize.BeginInit (inherited from BaseValidator)
ISupportInitialize.EndInit (inherited from BaseValidator)

See Also

RequiredFieldValidator Class | Genghis.Windows.Forms Namespace


RequiredFieldValidator Constructor

[Visual Basic]
Public Sub New()
[C#]
public RequiredFieldValidator();

See Also

RequiredFieldValidator Class | RequiredFieldValidator Members | Genghis.Windows.Forms Namespace


RequiredFieldValidator Properties

The properties of the RequiredFieldValidator class are listed below. For a complete list of RequiredFieldValidator class members, see the RequiredFieldValidator Members topic.

Public Instance Properties

Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ControlToValidate (inherited from BaseValidator) | Gets or sets the input control to validate.
ErrorMessage (inherited from BaseValidator) | Gets or sets the text for the error message.
HostingForm (inherited from BaseValidator) | Gets or sets the component's hosting form.
Icon (inherited from BaseValidator) | Gets or sets the Icon that is displayed next to a control when an error description string has been set for the control.
IconAlignment (inherited from BaseValidator) | Gets or sets the location where the error icon should be placed in relation to the control.
IconPadding (inherited from BaseValidator) | Gets or sets the amount of extra space to leave between the specified control and the error icon.
InitialValue | Gets or sets the initial value of the associated input control.
IsValid (inherited from BaseValidator) | Gets a value that indicates whether the associated input control passes validation.
Site (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.

See Also

RequiredFieldValidator Class | Genghis.Windows.Forms Namespace


RequiredFieldValidator.InitialValue Property

Gets or sets the initial value of the associated input control.

[Visual Basic]
Public Property InitialValue As String
[C#]
public string InitialValue {get; set;}

Property Value

The initial value of the associated input control.

See Also

RequiredFieldValidator Class | RequiredFieldValidator Members | Genghis.Windows.Forms Namespace


RequiredFieldValidator Methods

The methods of the RequiredFieldValidator class are listed below. For a complete list of RequiredFieldValidator class members, see the RequiredFieldValidator Members topic.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Component) | Select the method name to go to the Microsoft documentation.
Validate (inherited from BaseValidator) | Performs validation on the associated input control and updates the IsValid property.

Protected Instance Methods

Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
EvaluateIsValid | This member overrides BaseValidator.EvaluateIsValid.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

ISupportInitialize.BeginInit (inherited from BaseValidator)
ISupportInitialize.EndInit (inherited from BaseValidator)

See Also

RequiredFieldValidator Class | Genghis.Windows.Forms Namespace


RequiredFieldValidator.EvaluateIsValid Method

This member overrides BaseValidator.EvaluateIsValid.

[Visual Basic]
Overrides Protected Function EvaluateIsValid() As Boolean
[C#]
protected override bool EvaluateIsValid();

See Also

RequiredFieldValidator Class | RequiredFieldValidator Members | Genghis.Windows.Forms Namespace


ScreenSaver Class

The main screensaver window -- big, black, borderless, and topmost. The window closes itself on keystrokes and (optionally) mouse movement.

For a list of all members of this type, see ScreenSaver Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
ScreenSaver

[Visual Basic]
Public Class ScreenSaver
   Inherits Form
   Implements IComponent, IDisposable, IOleControl, IOleObject, IOleInPlaceObject, IOleInPlaceActiveObject, IOleWindow, IViewObject, IViewObject2, IPersist, IPersistStreamInit, IPersistPropertyBag, IPersistStorage, IQuickActivate, ISynchronizeInvoke, IWin32Window, IContainerControl
[C#]
public class ScreenSaver : Form, IComponent, IDisposable, IOleControl, IOleObject, IOleInPlaceObject, IOleInPlaceActiveObject, IOleWindow, IViewObject, IViewObject2, IPersist, IPersistStreamInit, IPersistPropertyBag, IPersistStorage, IQuickActivate, ISynchronizeInvoke, IWin32Window, IContainerControl

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

ScreenSaver Members | Genghis.Windows.Forms Namespace


ScreenSaver Members

Public Static (Shared) Properties

ConfigurationMode

Public Instance Constructors

ScreenSaver Constructor

Public Instance Properties

AcceptButton (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
AccessibilityObject (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleDefaultActionDescription (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleDescription (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleRole (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ActiveControl (inherited from System.Windows.Forms.ContainerControl) | Select the method name to go to the Microsoft documentation.
ActiveMdiChild (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
AllowDrop (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AllowTransparency (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Anchor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AutoScale (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
AutoScaleBaseSize (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
AutoScroll (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
AutoScrollMargin (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
AutoScrollMinSize (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
AutoScrollPosition (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
BackColor (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
BackgroundImage (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
BindingContext (inherited from System.Windows.Forms.ContainerControl) | Select the method name to go to the Microsoft documentation.
Bottom (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Bounds (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CancelButton (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
CanFocus (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CanSelect (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Capture (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CausesValidation (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ClientRectangle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ClientSize (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
CompanyName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ContainsFocus (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ContextMenu (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ControlBox (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Controls (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Created (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Cursor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DataBindings (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DesktopBounds (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
DesktopLocation (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
DialogResult (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
DisplayRectangle (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
Disposing (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Dock (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DockPadding (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
Enabled (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Focused (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Font (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ForeColor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
FormBorderStyle (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Handle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
HasChildren (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Height (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
HelpButton (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Icon (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
ImeMode (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
InvokeRequired (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsAccessible (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsDisposed (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsHandleCreated (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsMdiChild (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
IsMdiContainer (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
IsRestrictedWindow (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
KeyPreview (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Left (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Location (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
MaximizeBox (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
MaximumSize (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
MdiChildren (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
MdiParent (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Menu (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
MergedMenu (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
MinimizeBox (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
MinimumSize (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Modal (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Name (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Opacity (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
OwnedForms (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Owner (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Parent (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ParentForm (inherited from System.Windows.Forms.ContainerControl) | Select the method name to go to the Microsoft documentation.
ProductName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ProductVersion (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RecreatingHandle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Region (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Right (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RightToLeft (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowInTaskbar (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Site (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Size (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
SizeGripStyle (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
StartPosition (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
TabIndex (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
TabStop (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Tag (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Text (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Top (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TopLevel (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
TopLevelControl (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TopMost (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
TransparencyKey (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Visible (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Width (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
WindowState (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
WindowTarget (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.

Public Instance Methods

Activate (inherited from Form) | Select the method name to go to the Microsoft documentation.
AddOwnedForm (inherited from Form) | Select the method name to go to the Microsoft documentation.
BeginInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
BeginInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
BringToFront (inherited from Control) | Select the method name to go to the Microsoft documentation.
Close (inherited from Form) | Select the method name to go to the Microsoft documentation.
Contains (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateGraphics (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
DoDragDrop (inherited from Control) | Select the method name to go to the Microsoft documentation.
EndInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
FindForm (inherited from Control) | Select the method name to go to the Microsoft documentation.
Focus (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetChildAtPoint (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetContainerControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetNextControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
Hide (inherited from Control) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
LayoutMdi (inherited from Form) | Select the method name to go to the Microsoft documentation.
PerformLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
PerformLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
PointToClient (inherited from Control) | Select the method name to go to the Microsoft documentation.
PointToScreen (inherited from Control) | Select the method name to go to the Microsoft documentation.
PreProcessMessage (inherited from Control) | Select the method name to go to the Microsoft documentation.
RectangleToClient (inherited from Control) | Select the method name to go to the Microsoft documentation.
RectangleToScreen (inherited from Control) | Select the method name to go to the Microsoft documentation.
Refresh (inherited from Control) | Select the method name to go to the Microsoft documentation.
RemoveOwnedForm (inherited from Form) | Select the method name to go to the Microsoft documentation.
ResetBackColor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetBindings (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetCursor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetFont (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetForeColor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetImeMode (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetRightToLeft (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetText (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResumeLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResumeLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
Scale (inherited from Control) | Select the method name to go to the Microsoft documentation.
Scale (inherited from Control) | Select the method name to go to the Microsoft documentation.
ScrollControlIntoView (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
Select (inherited from Control) | Select the method name to go to the Microsoft documentation.
SelectNextControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
SendToBack (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetAutoScrollMargin (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
SetBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetDesktopBounds (inherited from Form) | Select the method name to go to the Microsoft documentation.
SetDesktopLocation (inherited from Form) | Select the method name to go to the Microsoft documentation.
Show (inherited from Control) | Select the method name to go to the Microsoft documentation.
ShowDialog (inherited from Form) | Select the method name to go to the Microsoft documentation.
ShowDialog (inherited from Form) | Select the method name to go to the Microsoft documentation.
SuspendLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Form) | Select the method name to go to the Microsoft documentation.
Update (inherited from Control) | Select the method name to go to the Microsoft documentation.
Validate (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

CreateParams (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
DefaultImeMode (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
DefaultSize (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
FontHeight (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
HScroll (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
IgnoreMouseMove |
MaximizedBounds (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
RenderRightToLeft (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ResizeRedraw (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowFocusCues (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowKeyboardCues (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
VScroll (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Select the method name to go to the Microsoft documentation.
ActivateMdiChild (inherited from Form) | Select the method name to go to the Microsoft documentation.
AdjustFormScrollbars (inherited from Form) | Select the method name to go to the Microsoft documentation.
ApplyAutoScaling (inherited from Form) | Select the method name to go to the Microsoft documentation.
CenterToParent (inherited from Form) | Select the method name to go to the Microsoft documentation.
CenterToScreen (inherited from Form) | Select the method name to go to the Microsoft documentation.
CreateAccessibilityInstance (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateControlsInstance (inherited from Form) | Select the method name to go to the Microsoft documentation.
CreateHandle (inherited from Form) | Select the method name to go to the Microsoft documentation.
DefWndProc (inherited from Form) | Select the method name to go to the Microsoft documentation.
DestroyHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetScrollState (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetStyle (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetTopLevel (inherited from Control) | Select the method name to go to the Microsoft documentation.
InitLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeGotFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeLostFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeOnClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokePaint (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokePaintBackground (inherited from Control) | Select the method name to go to the Microsoft documentation.
IsInputChar (inherited from Control) | Select the method name to go to the Microsoft documentation.
IsInputKey (inherited from Control) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
NotifyInvalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnActivated (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnBackColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBackgroundImageChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBindingContextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnCausesValidationChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnChangeUICues (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnClick |
OnClosed |
OnClosing (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnContextMenuChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnControlAdded (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnControlRemoved (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
OnCreateControl (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnCursorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDeactivate (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnDockChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDoubleClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragDrop (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragOver (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnEnabledChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnFontChanged (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnForeColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnGiveFeedback (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnGotFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnHandleCreated (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnHandleDestroyed (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnHelpRequested (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnImeModeChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnInputLanguageChanged (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnInputLanguageChanging (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnInvalidated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnKeyDown |
OnKeyPress (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnKeyUp (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLayout (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
OnLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLoad |
OnLocationChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLostFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMaximizedBoundsChanged (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnMaximumSizeChanged (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnMdiChildActivate (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnMenuComplete (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnMenuStart (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnMinimumSizeChanged (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnMouseDown (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseHover (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseMove |
OnMouseUp (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseWheel (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
OnMove (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnNotifyMessage (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnPaint (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnPaintBackground (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBackColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBackgroundImageChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBindingContextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentEnabledChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentFontChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentForeColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentRightToLeftChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentVisibleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnQueryContinueDrag (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnResize (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnRightToLeftChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnSizeChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnStyleChanged (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnSystemColorsChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTabIndexChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTabStopChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTextChanged (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnValidated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnValidating (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnVisibleChanged (inherited from Form) | Select the method name to go to the Microsoft documentation.
ProcessCmdKey (inherited from Form) | Select the method name to go to the Microsoft documentation.
ProcessDialogChar (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
ProcessDialogKey (inherited from Form) | Select the method name to go to the Microsoft documentation.
ProcessKeyEventArgs (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessKeyPreview (inherited from Form) | Select the method name to go to the Microsoft documentation.
ProcessMnemonic (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
ProcessTabKey (inherited from Form) | Select the method name to go to the Microsoft documentation.
RaiseDragEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseKeyEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseMouseEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaisePaintEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RecreateHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetMouseEventArgs (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateContent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateHorizontal (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateLeftRight (inherited from Control) | Select the method name to go to the Microsoft documentation.
ScaleCore (inherited from Form) | Select the method name to go to the Microsoft documentation.
Select (inherited from Form) | Select the method name to go to the Microsoft documentation.
SetBoundsCore (inherited from Form) | Select the method name to go to the Microsoft documentation.
SetClientSizeCore (inherited from Form) | Select the method name to go to the Microsoft documentation.
SetDisplayRectLocation (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
SetScrollState (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
SetStyle (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetTopLevel (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetVisibleCore (inherited from Form) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateDefaultButton (inherited from Form) | Select the method name to go to the Microsoft documentation.
UpdateStyles (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateZOrder (inherited from Control) | Select the method name to go to the Microsoft documentation.
WndProc (inherited from Form) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Advise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Close (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleWindow.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.DoVerb (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Draw (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Draw (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.EnableModeless (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.EnumAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.EnumVerbs (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Freeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Freeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.FreezeEvents (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.GetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersist.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetClientSite (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetClipboardData (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetColorSet (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.GetColorSet (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.GetContentExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.GetControlInfo (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetMiscStatus (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetMoniker (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.GetSizeMax (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetUserClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetUserType (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleWindow.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.HandsOffStorage (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.InitFromData (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.InPlaceDeactivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.IsDirty (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.IsDirty (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.IsUpToDate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.OleUpdate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.OnAmbientPropertyChange (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.OnDocWindowActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.OnFrameWindowActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.OnMnemonic (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.QuickActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.ReactivateAndUndo (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.ResizeBorder (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.SaveCompleted (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.SetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.SetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetClientSite (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetColorScheme (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.SetContentExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetHostNames (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetMoniker (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.SetObjectRects (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.TranslateAccelerator (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.UIDeactivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Unadvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Unfreeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Unfreeze (inherited from Control) | Select the method name to go to the Microsoft documentation.

See Also

ScreenSaver Class | Genghis.Windows.Forms Namespace


ScreenSaver Constructor

[Visual Basic]
Public Sub New()
[C#]
public ScreenSaver();

See Also

ScreenSaver Class | ScreenSaver Members | Genghis.Windows.Forms Namespace


ScreenSaver Properties

The properties of the ScreenSaver class are listed below. For a complete list of ScreenSaver class members, see the ScreenSaver Members topic.

Public Static (Shared) Properties

ConfigurationMode

Public Instance Properties

AcceptButton (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
AccessibilityObject (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleDefaultActionDescription (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleDescription (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleRole (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ActiveControl (inherited from System.Windows.Forms.ContainerControl) | Select the method name to go to the Microsoft documentation.
ActiveMdiChild (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
AllowDrop (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AllowTransparency (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Anchor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AutoScale (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
AutoScaleBaseSize (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
AutoScroll (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
AutoScrollMargin (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
AutoScrollMinSize (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
AutoScrollPosition (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
BackColor (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
BackgroundImage (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
BindingContext (inherited from System.Windows.Forms.ContainerControl) | Select the method name to go to the Microsoft documentation.
Bottom (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Bounds (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CancelButton (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
CanFocus (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CanSelect (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Capture (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CausesValidation (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ClientRectangle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ClientSize (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
CompanyName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ContainsFocus (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ContextMenu (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ControlBox (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Controls (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Created (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Cursor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DataBindings (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DesktopBounds (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
DesktopLocation (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
DialogResult (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
DisplayRectangle (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
Disposing (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Dock (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DockPadding (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
Enabled (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Focused (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Font (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ForeColor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
FormBorderStyle (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Handle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
HasChildren (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Height (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
HelpButton (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Icon (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
ImeMode (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
InvokeRequired (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsAccessible (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsDisposed (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsHandleCreated (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsMdiChild (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
IsMdiContainer (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
IsRestrictedWindow (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
KeyPreview (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Left (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Location (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
MaximizeBox (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
MaximumSize (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
MdiChildren (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
MdiParent (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Menu (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
MergedMenu (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
MinimizeBox (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
MinimumSize (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Modal (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Name (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Opacity (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
OwnedForms (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Owner (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Parent (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ParentForm (inherited from System.Windows.Forms.ContainerControl) | Select the method name to go to the Microsoft documentation.
ProductName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ProductVersion (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RecreatingHandle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Region (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Right (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RightToLeft (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowInTaskbar (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Site (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Size (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
SizeGripStyle (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
StartPosition (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
TabIndex (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
TabStop (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Tag (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Text (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Top (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TopLevel (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
TopLevelControl (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TopMost (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
TransparencyKey (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Visible (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Width (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
WindowState (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
WindowTarget (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

CreateParams (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
DefaultImeMode (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
DefaultSize (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
FontHeight (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
HScroll (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
IgnoreMouseMove |
MaximizedBounds (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
RenderRightToLeft (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ResizeRedraw (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowFocusCues (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowKeyboardCues (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
VScroll (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.

See Also

ScreenSaver Class | Genghis.Windows.Forms Namespace


ScreenSaver.ConfigurationMode Property

[Visual Basic]
Public Shared ReadOnly Property ConfigurationMode As Boolean
[C#]
public static bool ConfigurationMode {get;}

See Also

ScreenSaver Class | ScreenSaver Members | Genghis.Windows.Forms Namespace


ScreenSaver.IgnoreMouseMove Property

[Visual Basic]
Protected Property IgnoreMouseMove As Boolean
[C#]
protected bool IgnoreMouseMove {get; set;}

See Also

ScreenSaver Class | ScreenSaver Members | Genghis.Windows.Forms Namespace


ScreenSaver Methods

The methods of the ScreenSaver class are listed below. For a complete list of ScreenSaver class members, see the ScreenSaver Members topic.

Public Instance Methods

Activate (inherited from Form) | Select the method name to go to the Microsoft documentation.
AddOwnedForm (inherited from Form) | Select the method name to go to the Microsoft documentation.
BeginInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
BeginInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
BringToFront (inherited from Control) | Select the method name to go to the Microsoft documentation.
Close (inherited from Form) | Select the method name to go to the Microsoft documentation.
Contains (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateGraphics (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
DoDragDrop (inherited from Control) | Select the method name to go to the Microsoft documentation.
EndInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
FindForm (inherited from Control) | Select the method name to go to the Microsoft documentation.
Focus (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetChildAtPoint (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetContainerControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetNextControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
Hide (inherited from Control) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
LayoutMdi (inherited from Form) | Select the method name to go to the Microsoft documentation.
PerformLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
PerformLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
PointToClient (inherited from Control) | Select the method name to go to the Microsoft documentation.
PointToScreen (inherited from Control) | Select the method name to go to the Microsoft documentation.
PreProcessMessage (inherited from Control) | Select the method name to go to the Microsoft documentation.
RectangleToClient (inherited from Control) | Select the method name to go to the Microsoft documentation.
RectangleToScreen (inherited from Control) | Select the method name to go to the Microsoft documentation.
Refresh (inherited from Control) | Select the method name to go to the Microsoft documentation.
RemoveOwnedForm (inherited from Form) | Select the method name to go to the Microsoft documentation.
ResetBackColor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetBindings (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetCursor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetFont (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetForeColor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetImeMode (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetRightToLeft (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetText (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResumeLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResumeLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
Scale (inherited from Control) | Select the method name to go to the Microsoft documentation.
Scale (inherited from Control) | Select the method name to go to the Microsoft documentation.
ScrollControlIntoView (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
Select (inherited from Control) | Select the method name to go to the Microsoft documentation.
SelectNextControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
SendToBack (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetAutoScrollMargin (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
SetBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetDesktopBounds (inherited from Form) | Select the method name to go to the Microsoft documentation.
SetDesktopLocation (inherited from Form) | Select the method name to go to the Microsoft documentation.
Show (inherited from Control) | Select the method name to go to the Microsoft documentation.
ShowDialog (inherited from Form) | Select the method name to go to the Microsoft documentation.
ShowDialog (inherited from Form) | Select the method name to go to the Microsoft documentation.
SuspendLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Form) | Select the method name to go to the Microsoft documentation.
Update (inherited from Control) | Select the method name to go to the Microsoft documentation.
Validate (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Select the method name to go to the Microsoft documentation.
ActivateMdiChild (inherited from Form) | Select the method name to go to the Microsoft documentation.
AdjustFormScrollbars (inherited from Form) | Select the method name to go to the Microsoft documentation.
ApplyAutoScaling (inherited from Form) | Select the method name to go to the Microsoft documentation.
CenterToParent (inherited from Form) | Select the method name to go to the Microsoft documentation.
CenterToScreen (inherited from Form) | Select the method name to go to the Microsoft documentation.
CreateAccessibilityInstance (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateControlsInstance (inherited from Form) | Select the method name to go to the Microsoft documentation.
CreateHandle (inherited from Form) | Select the method name to go to the Microsoft documentation.
DefWndProc (inherited from Form) | Select the method name to go to the Microsoft documentation.
DestroyHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetScrollState (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetStyle (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetTopLevel (inherited from Control) | Select the method name to go to the Microsoft documentation.
InitLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeGotFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeLostFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeOnClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokePaint (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokePaintBackground (inherited from Control) | Select the method name to go to the Microsoft documentation.
IsInputChar (inherited from Control) | Select the method name to go to the Microsoft documentation.
IsInputKey (inherited from Control) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
NotifyInvalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnActivated (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnBackColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBackgroundImageChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBindingContextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnCausesValidationChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnChangeUICues (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnClick |
OnClosed |
OnClosing (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnContextMenuChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnControlAdded (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnControlRemoved (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
OnCreateControl (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnCursorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDeactivate (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnDockChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDoubleClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragDrop (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragOver (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnEnabledChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnFontChanged (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnForeColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnGiveFeedback (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnGotFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnHandleCreated (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnHandleDestroyed (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnHelpRequested (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnImeModeChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnInputLanguageChanged (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnInputLanguageChanging (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnInvalidated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnKeyDown |
OnKeyPress (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnKeyUp (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLayout (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
OnLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLoad |
OnLocationChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLostFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMaximizedBoundsChanged (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnMaximumSizeChanged (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnMdiChildActivate (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnMenuComplete (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnMenuStart (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnMinimumSizeChanged (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnMouseDown (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseHover (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseMove |
OnMouseUp (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseWheel (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
OnMove (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnNotifyMessage (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnPaint (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnPaintBackground (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBackColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBackgroundImageChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBindingContextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentEnabledChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentFontChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentForeColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentRightToLeftChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentVisibleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnQueryContinueDrag (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnResize (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnRightToLeftChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnSizeChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnStyleChanged (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnSystemColorsChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTabIndexChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTabStopChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTextChanged (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnValidated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnValidating (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnVisibleChanged (inherited from Form) | Select the method name to go to the Microsoft documentation.
ProcessCmdKey (inherited from Form) | Select the method name to go to the Microsoft documentation.
ProcessDialogChar (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
ProcessDialogKey (inherited from Form) | Select the method name to go to the Microsoft documentation.
ProcessKeyEventArgs (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessKeyPreview (inherited from Form) | Select the method name to go to the Microsoft documentation.
ProcessMnemonic (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
ProcessTabKey (inherited from Form) | Select the method name to go to the Microsoft documentation.
RaiseDragEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseKeyEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseMouseEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaisePaintEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RecreateHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetMouseEventArgs (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateContent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateHorizontal (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateLeftRight (inherited from Control) | Select the method name to go to the Microsoft documentation.
ScaleCore (inherited from Form) | Select the method name to go to the Microsoft documentation.
Select (inherited from Form) | Select the method name to go to the Microsoft documentation.
SetBoundsCore (inherited from Form) | Select the method name to go to the Microsoft documentation.
SetClientSizeCore (inherited from Form) | Select the method name to go to the Microsoft documentation.
SetDisplayRectLocation (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
SetScrollState (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
SetStyle (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetTopLevel (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetVisibleCore (inherited from Form) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateDefaultButton (inherited from Form) | Select the method name to go to the Microsoft documentation.
UpdateStyles (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateZOrder (inherited from Control) | Select the method name to go to the Microsoft documentation.
WndProc (inherited from Form) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Advise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Close (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleWindow.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.DoVerb (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Draw (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Draw (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.EnableModeless (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.EnumAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.EnumVerbs (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Freeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Freeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.FreezeEvents (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.GetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersist.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetClientSite (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetClipboardData (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetColorSet (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.GetColorSet (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.GetContentExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.GetControlInfo (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetMiscStatus (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetMoniker (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.GetSizeMax (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetUserClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetUserType (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleWindow.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.HandsOffStorage (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.InitFromData (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.InPlaceDeactivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.IsDirty (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.IsDirty (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.IsUpToDate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.OleUpdate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.OnAmbientPropertyChange (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.OnDocWindowActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.OnFrameWindowActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.OnMnemonic (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.QuickActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.ReactivateAndUndo (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.ResizeBorder (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.SaveCompleted (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.SetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.SetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetClientSite (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetColorScheme (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.SetContentExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetHostNames (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetMoniker (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.SetObjectRects (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.TranslateAccelerator (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.UIDeactivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Unadvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Unfreeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Unfreeze (inherited from Control) | Select the method name to go to the Microsoft documentation.

See Also

ScreenSaver Class | Genghis.Windows.Forms Namespace


ScreenSaver.Dispose Method (Boolean)

[Visual Basic]
Overrides Overloads Protected Sub Dispose( _
   ByVal disposing As Boolean _
)
[C#]
protected override void Dispose(
   bool disposing
);

See Also

ScreenSaver Class | ScreenSaver Members | Genghis.Windows.Forms Namespace | ScreenSaver.Dispose Overload List


ScreenSaver.OnClick Method

[Visual Basic]
Overrides Protected Sub OnClick( _
   ByVal ea As System.EventArgs _
)
[C#]
protected override void OnClick(
   EventArgs ea
);

See Also

ScreenSaver Class | ScreenSaver Members | Genghis.Windows.Forms Namespace


ScreenSaver.OnClosed Method

[Visual Basic]
Overrides Protected Sub OnClosed( _
   ByVal ea As System.EventArgs _
)
[C#]
protected override void OnClosed(
   EventArgs ea
);

See Also

ScreenSaver Class | ScreenSaver Members | Genghis.Windows.Forms Namespace


ScreenSaver.OnKeyDown Method

[Visual Basic]
Overrides Protected Sub OnKeyDown( _
   ByVal ea As System.Windows.Forms.KeyEventArgs _
)
[C#]
protected override void OnKeyDown(
   KeyEventArgs ea
);

See Also

ScreenSaver Class | ScreenSaver Members | Genghis.Windows.Forms Namespace


ScreenSaver.OnLoad Method

[Visual Basic]
Overrides Protected Sub OnLoad( _
   ByVal ea As System.EventArgs _
)
[C#]
protected override void OnLoad(
   EventArgs ea
);

See Also

ScreenSaver Class | ScreenSaver Members | Genghis.Windows.Forms Namespace


ScreenSaver.OnMouseMove Method

[Visual Basic]
Overrides Protected Sub OnMouseMove( _
   ByVal ea As System.Windows.Forms.MouseEventArgs _
)
[C#]
protected override void OnMouseMove(
   MouseEventArgs ea
);

See Also

ScreenSaver Class | ScreenSaver Members | Genghis.Windows.Forms Namespace


ValidationCompareOperator Enumeration

Specifies the validation comparison operators used by the CompareValidator control.

[Visual Basic]
Public Enum ValidationCompareOperator
[C#]
public enum ValidationCompareOperator

Remarks

The ValidationCompareOperator enumeration represents the comparison operations that can be performed by the CompareValidator control.

Members

Member Name | Description
DataTypeCheck | A comparison for data type only.
Equal | A comparison for equality.
GreaterThan | A comparison for greater than.
GreaterThanEqual | A comparison for greater than or equal.
LessThan | A comparison for less than.
LessThanEqual | A comparison for less than or equal.
NotEqual | A comparison for non-equality.

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

Genghis.Windows.Forms Namespace


ValidationControlConverter Class

Provides a type converter to convert object references to and from other representations.

For a list of all members of this type, see ValidationControlConverter Members.

System.Object
TypeConverter
ReferenceConverter
ValidationControlConverter

[Visual Basic]
Public Class ValidationControlConverter
   Inherits ReferenceConverter
[C#]
public class ValidationControlConverter : ReferenceConverter

Remarks

This TypeConverter is designed and used by each of the validation controls to determine which controls can be selected for the ControlToValidate and ControlToCompare properties. The only controls that can be used are:

  • TextBoxes
  • ListBoxes
  • ComboBoxes

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

ValidationControlConverter Members | Genghis.Windows.Forms Namespace


ValidationControlConverter Members

Public Instance Constructors

ValidationControlConverter Constructor Initializes a new instance of the ValidationControlConverter component.

Public Instance Methods

CanConvertFrom (inherited from ReferenceConverter) | Select the method name to go to the Microsoft documentation.
CanConvertFrom (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
CanConvertTo (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
CanConvertTo (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFrom (inherited from ReferenceConverter) | Select the method name to go to the Microsoft documentation.
ConvertFrom (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFromInvariantString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFromInvariantString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFromString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFromString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFromString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertTo (inherited from ReferenceConverter) | Select the method name to go to the Microsoft documentation.
ConvertTo (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertToInvariantString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertToInvariantString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertToString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertToString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertToString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
CreateInstance (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
CreateInstance (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetCreateInstanceSupported (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetCreateInstanceSupported (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetProperties (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetProperties (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetProperties (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetPropertiesSupported (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetPropertiesSupported (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetStandardValues (inherited from ReferenceConverter) | Select the method name to go to the Microsoft documentation.
GetStandardValues (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetStandardValuesExclusive (inherited from ReferenceConverter) | Select the method name to go to the Microsoft documentation.
GetStandardValuesExclusive (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetStandardValuesSupported (inherited from ReferenceConverter) | Select the method name to go to the Microsoft documentation.
GetStandardValuesSupported (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsValid (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
IsValid (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetConvertFromException (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetConvertToException (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
IsValueAllowed | Returns a value indicating whether a particular value can be added to the standard values collection of the base ReferenceConverter class.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
SortProperties (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.

See Also

ValidationControlConverter Class | Genghis.Windows.Forms Namespace


ValidationControlConverter Constructor

Initializes a new instance of the ValidationControlConverter component.

[Visual Basic]
Public Sub New( _
   ByVal type As System.Type _
)
[C#]
public ValidationControlConverter(
   Type type
);

See Also

ValidationControlConverter Class | ValidationControlConverter Members | Genghis.Windows.Forms Namespace


ValidationControlConverter Methods

The methods of the ValidationControlConverter class are listed below. For a complete list of ValidationControlConverter class members, see the ValidationControlConverter Members topic.

Public Instance Methods

CanConvertFrom (inherited from ReferenceConverter) | Select the method name to go to the Microsoft documentation.
CanConvertFrom (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
CanConvertTo (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
CanConvertTo (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFrom (inherited from ReferenceConverter) | Select the method name to go to the Microsoft documentation.
ConvertFrom (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFromInvariantString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFromInvariantString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFromString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFromString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertFromString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertTo (inherited from ReferenceConverter) | Select the method name to go to the Microsoft documentation.
ConvertTo (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertToInvariantString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertToInvariantString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertToString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertToString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ConvertToString (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
CreateInstance (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
CreateInstance (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetCreateInstanceSupported (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetCreateInstanceSupported (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetProperties (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetProperties (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetProperties (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetPropertiesSupported (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetPropertiesSupported (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetStandardValues (inherited from ReferenceConverter) | Select the method name to go to the Microsoft documentation.
GetStandardValues (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetStandardValuesExclusive (inherited from ReferenceConverter) | Select the method name to go to the Microsoft documentation.
GetStandardValuesExclusive (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetStandardValuesSupported (inherited from ReferenceConverter) | Select the method name to go to the Microsoft documentation.
GetStandardValuesSupported (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
IsValid (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
IsValid (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetConvertFromException (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
GetConvertToException (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.
IsValueAllowed | Returns a value indicating whether a particular value can be added to the standard values collection of the base ReferenceConverter class.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
SortProperties (inherited from TypeConverter) | Select the method name to go to the Microsoft documentation.

See Also

ValidationControlConverter Class | Genghis.Windows.Forms Namespace


ValidationControlConverter.IsValueAllowed Method

Returns a value indicating whether a particular value can be added to the standard values collection of the base ReferenceConverter class.

[Visual Basic]
Overrides Protected Function IsValueAllowed( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal value As Object _
) As Boolean
[C#]
protected override bool IsValueAllowed(
   ITypeDescriptorContext context,
   object value
);

Remarks

The only values allowed include the following WinForm controls:

  • TextBoxes
  • ListBoxes
  • ComboBoxes

See Also

ValidationControlConverter Class | ValidationControlConverter Members | Genghis.Windows.Forms Namespace


ValidationDataType Enumeration

Specifies the validation data types used by the CompareValidator and RangeValidator controls.

[Visual Basic]
Public Enum ValidationDataType
[C#]
public enum ValidationDataType

Remarks

The ValidationDataType enumeration represents the different data types that the CompareValidator and RangeValidator controls can validate. When you specify a data type for validation control, if the input control being validated passes validation, the value of the input control can parsed to the specified data type.

Members

Member Name | Description
Currency | A monetary data type. The value is treated as a System.Decimal. However, currency and grouping symbols are still allowed.
Date | A date data type. Only numeric dates are allowed. The time portion cannot be specified.
Double | A double precision floating point number data type. The value is treated as a System.Double.
Integer | A 32-bit signed integer data type. The value is treated as a System.Int32.
String | A string data type. The value is treated as a System.String.

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

Genghis.Windows.Forms Namespace


WindowSerializer Class

A class to automatically serialize/deserialize the state of a form.

For a list of all members of this type, see WindowSerializer Members.

System.Object
MarshalByRefObject
Component
WindowSerializer

[Visual Basic]
Public Class WindowSerializer
   Inherits Component
   Implements IComponent, IDisposable
[C#]
public class WindowSerializer : Component, IComponent, IDisposable

Example

The sample below will persist the state of the MainWindow form.

            class MainWindow : Form {
                WindowSerializer windowSerializer;
                public MainWindow() {
                    windowSerializer = new WindowSerializer(this);
                }
            }

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

WindowSerializer Members | Genghis.Windows.Forms Namespace


WindowSerializer Members

Public Instance Constructors

WindowSerializer Overloaded. Initialize a new instance of the WindowSerializer class.

Public Instance Properties

Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Form | Gets or sets the form which is to have it's state persisted.
FormName | Gets or sets the name of the form.
Site (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.

Public Instance Methods

CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Component) | Select the method name to go to the Microsoft documentation.

Public Instance Events

LoadStateEvent
SaveStateEvent

Protected Instance Properties

DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

WindowSerializer Class | Genghis.Windows.Forms Namespace


WindowSerializer Constructor

Genghis Class Library

WindowSerializer

Constructs an empty WindowSerializer. If the Form property is not set, then this class will do nothing.

Overload List

Constructs an empty WindowSerializer. If the Form property is not set, then this class will do nothing.

public WindowSerializer();

Constructs WindowSerializer with a form.

public WindowSerializer(Form);

See Also

WindowSerializer Class | WindowSerializer Members | Genghis.Windows.Forms Namespace


WindowSerializer Constructor ()

Constructs an empty WindowSerializer. If the Form property is not set, then this class will do nothing.

[Visual Basic]
Overloads Public Sub New()
[C#]
public WindowSerializer();

See Also

WindowSerializer Class | WindowSerializer Members | Genghis.Windows.Forms Namespace | WindowSerializer Constructor Overload List


WindowSerializer Constructor (Form)

Constructs WindowSerializer with a form.

[Visual Basic]
Overloads Public Sub New( _
   ByVal form As System.Windows.Forms.Form _
)
[C#]
public WindowSerializer(
   Form form
);

Parameters

form
The form whose state is to be persisted.

See Also

WindowSerializer Class | WindowSerializer Members | Genghis.Windows.Forms Namespace | WindowSerializer Constructor Overload List


WindowSerializer Properties

The properties of the WindowSerializer class are listed below. For a complete list of WindowSerializer class members, see the WindowSerializer Members topic.

Public Instance Properties

Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Form | Gets or sets the form which is to have it's state persisted.
FormName | Gets or sets the name of the form.
Site (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.

See Also

WindowSerializer Class | Genghis.Windows.Forms Namespace


WindowSerializer.Form Property

Gets or sets the form which is to have it's state persisted.

[Visual Basic]
Public Property Form As System.Windows.Forms.Form
[C#]
public System.Windows.Forms.Form Form {get; set;}

Property Value

The form which is to have it's state persisted.

Remarks

If the WindowSerializer is used inside Visual Studio in a Windows Forms designer, Form is automatically set to the control that contains the WindowSerializer. For example, if you place a WindowSerializer on a designer for Form1 (which inherits from Form), the Form property of WindowSerializer is set to the instance of Form1.

See Also

WindowSerializer Class | WindowSerializer Members | Genghis.Windows.Forms Namespace


WindowSerializer.FormName Property

Gets or sets the name of the form.

[Visual Basic]
Public Property FormName As String
[C#]
public string FormName {get; set;}

Property Value

The name of the form.

Remarks

The name of the form should be unique and unchanging.

The default name is the full class name of the Form.

See Also

WindowSerializer Class | WindowSerializer Members | Genghis.Windows.Forms Namespace


WindowSerializer Events

The events of the WindowSerializer class are listed below. For a complete list of WindowSerializer class members, see the WindowSerializer Members topic.

Public Instance Events

LoadStateEvent
SaveStateEvent

See Also

WindowSerializer Class | Genghis.Windows.Forms Namespace


WindowSerializer.LoadStateEvent Event

[Visual Basic]
Public LoadStateEvent As Genghis.Windows.Forms.WindowSerializer.WindowSerializerDelegate
[C#]
public WindowSerializerDelegate LoadStateEvent;

See Also

WindowSerializer Class | WindowSerializer Members | Genghis.Windows.Forms Namespace


WindowSerializer.SaveStateEvent Event

[Visual Basic]
Public SaveStateEvent As Genghis.Windows.Forms.WindowSerializer.WindowSerializerDelegate
[C#]
public WindowSerializerDelegate SaveStateEvent;

See Also

WindowSerializer Class | WindowSerializer Members | Genghis.Windows.Forms Namespace


WindowSerializerDelegate Delegate

[Visual Basic]
Public Delegate Sub WindowSerializerDelegate( _
   ByVal sender As Object, _
   ByVal preferences As Genghis.Preferences _
)
[C#]
public delegate void WindowSerializerDelegate(
   object sender,
   Preferences preferences
);

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

Genghis.Windows.Forms Namespace


WindowsFormsNotInitializedException Class

Represents an exception that can be thrown by the HandleCollector, when registering handle types has been attempted before windows forms has initiated, and registered it's own types

For a list of all members of this type, see WindowsFormsNotInitializedException Members.

System.Object
Exception
ApplicationException
WindowsFormsNotInitializedException

[Visual Basic]
Public Class WindowsFormsNotInitializedException
   Inherits ApplicationException
   Implements ISerializable
[C#]
public class WindowsFormsNotInitializedException : ApplicationException, ISerializable

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

WindowsFormsNotInitializedException Members | Genghis.Windows.Forms Namespace


WindowsFormsNotInitializedException Members

Public Instance Constructors

WindowsFormsNotInitializedException Constructor Constructs a new WindowsFormsNotInitializedException

Public Instance Properties

HelpLink (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
InnerException (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
Message (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
Source (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
StackTrace (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.
TargetSite (inherited from System.Exception) | Select the method name to go to the Microsoft documentation.

Public Instance Methods

Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetBaseException (inherited from Exception) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetObjectData (inherited from Exception) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Exception) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

HResult (inherited from System.Exception) Select the method name to go to the Microsoft documentation.

Protected Instance Methods

Finalize (inherited from Object) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.

See Also

WindowsFormsNotInitializedException Class | Genghis.Windows.Forms Namespace


WindowsFormsNotInitializedException Constructor

Constructs a new WindowsFormsNotInitializedException

[Visual Basic]
Public Sub New()
[C#]
public WindowsFormsNotInitializedException();

See Also

WindowsFormsNotInitializedException Class | WindowsFormsNotInitializedException Members | Genghis.Windows.Forms Namespace


WizardPage Class

A User Control that provides a base class to derive from to create standard looking wizard pages. It supports a top pane that contains a title and description of a page.

For a list of all members of this type, see WizardPage Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
UserControl
WizardPage

[Visual Basic]
Public Class WizardPage
   Inherits UserControl
   Implements IComponent, IDisposable, IOleControl, IOleObject, IOleInPlaceObject, IOleInPlaceActiveObject, IOleWindow, IViewObject, IViewObject2, IPersist, IPersistStreamInit, IPersistPropertyBag, IPersistStorage, IQuickActivate, ISynchronizeInvoke, IWin32Window, IContainerControl
[C#]
public class WizardPage : UserControl, IComponent, IDisposable, IOleControl, IOleObject, IOleInPlaceObject, IOleInPlaceActiveObject, IOleWindow, IViewObject, IViewObject2, IPersist, IPersistStreamInit, IPersistPropertyBag, IPersistStorage, IQuickActivate, ISynchronizeInvoke, IWin32Window, IContainerControl

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

WizardPage Members | Genghis.Windows.Forms Namespace


WizardPage Members

Public Instance Constructors

WizardPage Overloaded. Initialize a new instance of the WizardPage class.

Public Instance Properties

AccessibilityObject (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleDefaultActionDescription (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleDescription (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleRole (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ActiveControl (inherited from System.Windows.Forms.ContainerControl) | Select the method name to go to the Microsoft documentation.
AllowDrop (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Anchor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AutoScroll (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
AutoScrollMargin (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
AutoScrollMinSize (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
AutoScrollPosition (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
BackColor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
BackgroundImage (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
BindingContext (inherited from System.Windows.Forms.ContainerControl) | Select the method name to go to the Microsoft documentation.
Bottom (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Bounds (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CanFocus (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CanSelect (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Capture (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CausesValidation (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ClientRectangle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ClientSize (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CompanyName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ContainsFocus (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ContextMenu (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Controls (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Created (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Cursor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DataBindings (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DisplayRectangle (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
Disposing (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Dock (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DockPadding (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
Enabled (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Focused (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Font (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ForeColor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Handle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
HasChildren (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Height (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ImeMode (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
InvokeRequired (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsAccessible (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsDisposed (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsHandleCreated (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Left (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Location (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Name (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
PageDescription | Sets the description of the page shown within the header of the page.
PageTitle | Sets the title of the page shown within the header of the page.
Parent (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ParentForm (inherited from System.Windows.Forms.ContainerControl) | Select the method name to go to the Microsoft documentation.
ProductName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ProductVersion (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RecreatingHandle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Region (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Right (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RightToLeft (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Site (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Size (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TabIndex (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TabStop (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Tag (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Text (inherited from System.Windows.Forms.UserControl) | Select the method name to go to the Microsoft documentation.
Top (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TopLevelControl (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Visible (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Width (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
WindowTarget (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
WizardSheet | The current WizardSheet that the WizardPage is shown within.

Public Instance Methods

BeginInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
BeginInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
BringToFront (inherited from Control) | Select the method name to go to the Microsoft documentation.
Contains (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateGraphics (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
DoDragDrop (inherited from Control) | Select the method name to go to the Microsoft documentation.
EndInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
FindForm (inherited from Control) | Select the method name to go to the Microsoft documentation.
Focus (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetChildAtPoint (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetContainerControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetNextControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
Hide (inherited from Control) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
PerformLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
PerformLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
PointToClient (inherited from Control) | Select the method name to go to the Microsoft documentation.
PointToScreen (inherited from Control) | Select the method name to go to the Microsoft documentation.
PreProcessMessage (inherited from Control) | Select the method name to go to the Microsoft documentation.
RectangleToClient (inherited from Control) | Select the method name to go to the Microsoft documentation.
RectangleToScreen (inherited from Control) | Select the method name to go to the Microsoft documentation.
Refresh (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetBackColor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetBindings (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetCursor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetFont (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetForeColor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetImeMode (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetRightToLeft (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetText (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResumeLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResumeLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
Scale (inherited from Control) | Select the method name to go to the Microsoft documentation.
Scale (inherited from Control) | Select the method name to go to the Microsoft documentation.
ScrollControlIntoView (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
Select (inherited from Control) | Select the method name to go to the Microsoft documentation.
SelectNextControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
SendToBack (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetAutoScrollMargin (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
SetBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
Show (inherited from Control) | Select the method name to go to the Microsoft documentation.
SuspendLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Component) | Select the method name to go to the Microsoft documentation.
Update (inherited from Control) | Select the method name to go to the Microsoft documentation.
Validate (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

CreateParams (inherited from System.Windows.Forms.ContainerControl) | Select the method name to go to the Microsoft documentation.
DefaultImeMode (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DefaultSize (inherited from System.Windows.Forms.UserControl) | Select the method name to go to the Microsoft documentation.
DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
FontHeight (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
HScroll (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
RenderRightToLeft (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ResizeRedraw (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowFocusCues (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowKeyboardCues (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
VScroll (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Select the method name to go to the Microsoft documentation.
AdjustFormScrollbars (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
CreateAccessibilityInstance (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateControlsInstance (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
DefWndProc (inherited from Control) | Select the method name to go to the Microsoft documentation.
DestroyHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetScrollState (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetStyle (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetTopLevel (inherited from Control) | Select the method name to go to the Microsoft documentation.
InitLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeGotFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeLostFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeOnClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokePaint (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokePaintBackground (inherited from Control) | Select the method name to go to the Microsoft documentation.
IsInputChar (inherited from Control) | Select the method name to go to the Microsoft documentation.
IsInputKey (inherited from Control) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
NotifyInvalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBackColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBackgroundImageChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBindingContextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnCausesValidationChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnChangeUICues (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnContextMenuChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnControlAdded (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnControlRemoved (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
OnCreateControl (inherited from UserControl) | Select the method name to go to the Microsoft documentation.
OnCursorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDockChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDoubleClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragDrop (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragOver (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnEnabledChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnFontChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnForeColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnGiveFeedback (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnGotFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnHandleCreated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnHandleDestroyed (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnHelpRequested (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnImeModeChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnInvalidated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnKeyDown (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnKeyPress (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnKeyUp (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLayout (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
OnLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLoad (inherited from UserControl) | Select the method name to go to the Microsoft documentation.
OnLocationChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLostFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseDown (inherited from UserControl) | Select the method name to go to the Microsoft documentation.
OnMouseEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseHover (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseMove (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseUp (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseWheel (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
OnMove (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnNotifyMessage (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnPaint (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnPaintBackground (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBackColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBackgroundImageChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBindingContextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentEnabledChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentFontChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentForeColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentRightToLeftChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentVisibleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnQueryContinueDrag (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnResize (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnRightToLeftChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnSizeChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnStyleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnSystemColorsChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTabIndexChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTabStopChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnValidated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnValidating (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnVisibleChanged (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
ProcessCmdKey (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessDialogChar (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
ProcessDialogKey (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
ProcessKeyEventArgs (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessKeyPreview (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessMnemonic (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
ProcessTabKey (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
RaiseDragEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseKeyEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseMouseEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaisePaintEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RecreateHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetMouseEventArgs (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateContent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateHorizontal (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateLeftRight (inherited from Control) | Select the method name to go to the Microsoft documentation.
ScaleCore (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
Select (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
SetBoundsCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetClientSizeCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetDisplayRectLocation (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
SetScrollState (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
SetStyle (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetTopLevel (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetVisibleCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateDefaultButton (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
UpdateStyles (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateZOrder (inherited from Control) | Select the method name to go to the Microsoft documentation.
WndProc (inherited from UserControl) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Advise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Close (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleWindow.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.DoVerb (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Draw (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Draw (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.EnableModeless (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.EnumAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.EnumVerbs (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Freeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Freeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.FreezeEvents (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.GetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersist.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetClientSite (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetClipboardData (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetColorSet (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.GetColorSet (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.GetContentExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.GetControlInfo (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetMiscStatus (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetMoniker (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.GetSizeMax (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetUserClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetUserType (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleWindow.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.HandsOffStorage (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.InitFromData (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.InPlaceDeactivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.IsDirty (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.IsDirty (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.IsUpToDate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.OleUpdate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.OnAmbientPropertyChange (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.OnDocWindowActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.OnFrameWindowActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.OnMnemonic (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.QuickActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.ReactivateAndUndo (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.ResizeBorder (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.SaveCompleted (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.SetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.SetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetClientSite (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetColorScheme (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.SetContentExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetHostNames (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetMoniker (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.SetObjectRects (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.TranslateAccelerator (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.UIDeactivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Unadvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Unfreeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Unfreeze (inherited from Control) | Select the method name to go to the Microsoft documentation.

See Also

WizardPage Class | Genghis.Windows.Forms Namespace


WizardPage Constructor

Genghis Class Library

WizardPage

The default constructor.

Overload List

The default constructor.

public WizardPage();

Creates a new wizard page, specifying the title and description.

public WizardPage(string,string);

See Also

WizardPage Class | WizardPage Members | Genghis.Windows.Forms Namespace


WizardPage Constructor ()

The default constructor.

[Visual Basic]
Overloads Public Sub New()
[C#]
public WizardPage();

See Also

WizardPage Class | WizardPage Members | Genghis.Windows.Forms Namespace | WizardPage Constructor Overload List


WizardPage Constructor (String, String)

Creates a new wizard page, specifying the title and description.

[Visual Basic]
Overloads Public Sub New( _
   ByVal title As String, _
   ByVal description As String _
)
[C#]
public WizardPage(
   string title,
   string description
);

Parameters

title
The Title to be shown in the top pane of the page.
description
The description to be shown in the top pane of the page.

See Also

WizardPage Class | WizardPage Members | Genghis.Windows.Forms Namespace | WizardPage Constructor Overload List


WizardPage Properties

The properties of the WizardPage class are listed below. For a complete list of WizardPage class members, see the WizardPage Members topic.

Public Instance Properties

AccessibilityObject (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleDefaultActionDescription (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleDescription (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleRole (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ActiveControl (inherited from System.Windows.Forms.ContainerControl) | Select the method name to go to the Microsoft documentation.
AllowDrop (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Anchor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AutoScroll (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
AutoScrollMargin (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
AutoScrollMinSize (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
AutoScrollPosition (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
BackColor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
BackgroundImage (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
BindingContext (inherited from System.Windows.Forms.ContainerControl) | Select the method name to go to the Microsoft documentation.
Bottom (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Bounds (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CanFocus (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CanSelect (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Capture (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CausesValidation (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ClientRectangle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ClientSize (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CompanyName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ContainsFocus (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ContextMenu (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Controls (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Created (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Cursor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DataBindings (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DisplayRectangle (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
Disposing (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Dock (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DockPadding (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
Enabled (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Focused (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Font (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ForeColor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Handle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
HasChildren (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Height (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ImeMode (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
InvokeRequired (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsAccessible (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsDisposed (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsHandleCreated (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Left (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Location (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Name (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
PageDescription | Sets the description of the page shown within the header of the page.
PageTitle | Sets the title of the page shown within the header of the page.
Parent (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ParentForm (inherited from System.Windows.Forms.ContainerControl) | Select the method name to go to the Microsoft documentation.
ProductName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ProductVersion (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RecreatingHandle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Region (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Right (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RightToLeft (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Site (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Size (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TabIndex (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TabStop (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Tag (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Text (inherited from System.Windows.Forms.UserControl) | Select the method name to go to the Microsoft documentation.
Top (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TopLevelControl (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Visible (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Width (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
WindowTarget (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
WizardSheet | The current WizardSheet that the WizardPage is shown within.

Protected Instance Properties

CreateParams (inherited from System.Windows.Forms.ContainerControl) | Select the method name to go to the Microsoft documentation.
DefaultImeMode (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DefaultSize (inherited from System.Windows.Forms.UserControl) | Select the method name to go to the Microsoft documentation.
DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
FontHeight (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
HScroll (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
RenderRightToLeft (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ResizeRedraw (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowFocusCues (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowKeyboardCues (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
VScroll (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.

See Also

WizardPage Class | Genghis.Windows.Forms Namespace


WizardPage.PageDescription Property

Sets the description of the page shown within the header of the page.

[Visual Basic]
Public Property PageDescription As String
[C#]
public string PageDescription {set;}

See Also

WizardPage Class | WizardPage Members | Genghis.Windows.Forms Namespace


WizardPage.PageTitle Property

Sets the title of the page shown within the header of the page.

[Visual Basic]
Public Property PageTitle As String
[C#]
public string PageTitle {set;}

See Also

WizardPage Class | WizardPage Members | Genghis.Windows.Forms Namespace


WizardPage.WizardSheet Property

The current WizardSheet that the WizardPage is shown within.

[Visual Basic]
Public ReadOnly Property WizardSheet As Genghis.Windows.Forms.WizardSheet
[C#]
public WizardSheet WizardSheet {get;}

Property Value

A reference to the WizardSheet

See Also

WizardPage Class | WizardPage Members | Genghis.Windows.Forms Namespace


WizardPage Methods

The methods of the WizardPage class are listed below. For a complete list of WizardPage class members, see the WizardPage Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
BeginInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
BringToFront (inherited from Control) | Select the method name to go to the Microsoft documentation.
Contains (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateGraphics (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
DoDragDrop (inherited from Control) | Select the method name to go to the Microsoft documentation.
EndInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
FindForm (inherited from Control) | Select the method name to go to the Microsoft documentation.
Focus (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetChildAtPoint (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetContainerControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetNextControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
Hide (inherited from Control) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
PerformLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
PerformLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
PointToClient (inherited from Control) | Select the method name to go to the Microsoft documentation.
PointToScreen (inherited from Control) | Select the method name to go to the Microsoft documentation.
PreProcessMessage (inherited from Control) | Select the method name to go to the Microsoft documentation.
RectangleToClient (inherited from Control) | Select the method name to go to the Microsoft documentation.
RectangleToScreen (inherited from Control) | Select the method name to go to the Microsoft documentation.
Refresh (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetBackColor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetBindings (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetCursor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetFont (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetForeColor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetImeMode (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetRightToLeft (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetText (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResumeLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResumeLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
Scale (inherited from Control) | Select the method name to go to the Microsoft documentation.
Scale (inherited from Control) | Select the method name to go to the Microsoft documentation.
ScrollControlIntoView (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
Select (inherited from Control) | Select the method name to go to the Microsoft documentation.
SelectNextControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
SendToBack (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetAutoScrollMargin (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
SetBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
Show (inherited from Control) | Select the method name to go to the Microsoft documentation.
SuspendLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Component) | Select the method name to go to the Microsoft documentation.
Update (inherited from Control) | Select the method name to go to the Microsoft documentation.
Validate (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Select the method name to go to the Microsoft documentation.
AdjustFormScrollbars (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
CreateAccessibilityInstance (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateControlsInstance (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
DefWndProc (inherited from Control) | Select the method name to go to the Microsoft documentation.
DestroyHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetScrollState (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetStyle (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetTopLevel (inherited from Control) | Select the method name to go to the Microsoft documentation.
InitLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeGotFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeLostFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeOnClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokePaint (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokePaintBackground (inherited from Control) | Select the method name to go to the Microsoft documentation.
IsInputChar (inherited from Control) | Select the method name to go to the Microsoft documentation.
IsInputKey (inherited from Control) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
NotifyInvalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBackColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBackgroundImageChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBindingContextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnCausesValidationChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnChangeUICues (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnContextMenuChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnControlAdded (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnControlRemoved (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
OnCreateControl (inherited from UserControl) | Select the method name to go to the Microsoft documentation.
OnCursorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDockChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDoubleClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragDrop (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragOver (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnEnabledChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnFontChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnForeColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnGiveFeedback (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnGotFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnHandleCreated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnHandleDestroyed (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnHelpRequested (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnImeModeChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnInvalidated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnKeyDown (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnKeyPress (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnKeyUp (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLayout (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
OnLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLoad (inherited from UserControl) | Select the method name to go to the Microsoft documentation.
OnLocationChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLostFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseDown (inherited from UserControl) | Select the method name to go to the Microsoft documentation.
OnMouseEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseHover (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseMove (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseUp (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseWheel (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
OnMove (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnNotifyMessage (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnPaint (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnPaintBackground (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBackColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBackgroundImageChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBindingContextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentEnabledChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentFontChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentForeColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentRightToLeftChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentVisibleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnQueryContinueDrag (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnResize (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnRightToLeftChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnSizeChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnStyleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnSystemColorsChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTabIndexChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTabStopChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnValidated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnValidating (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnVisibleChanged (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
ProcessCmdKey (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessDialogChar (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
ProcessDialogKey (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
ProcessKeyEventArgs (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessKeyPreview (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessMnemonic (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
ProcessTabKey (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
RaiseDragEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseKeyEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseMouseEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaisePaintEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RecreateHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetMouseEventArgs (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateContent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateHorizontal (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateLeftRight (inherited from Control) | Select the method name to go to the Microsoft documentation.
ScaleCore (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
Select (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
SetBoundsCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetClientSizeCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetDisplayRectLocation (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
SetScrollState (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
SetStyle (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetTopLevel (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetVisibleCore (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateDefaultButton (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
UpdateStyles (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateZOrder (inherited from Control) | Select the method name to go to the Microsoft documentation.
WndProc (inherited from UserControl) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Advise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Close (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleWindow.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.DoVerb (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Draw (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Draw (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.EnableModeless (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.EnumAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.EnumVerbs (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Freeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Freeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.FreezeEvents (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.GetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersist.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetClientSite (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetClipboardData (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetColorSet (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.GetColorSet (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.GetContentExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.GetControlInfo (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetMiscStatus (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetMoniker (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.GetSizeMax (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetUserClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetUserType (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleWindow.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.HandsOffStorage (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.InitFromData (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.InPlaceDeactivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.IsDirty (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.IsDirty (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.IsUpToDate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.OleUpdate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.OnAmbientPropertyChange (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.OnDocWindowActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.OnFrameWindowActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.OnMnemonic (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.QuickActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.ReactivateAndUndo (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.ResizeBorder (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.SaveCompleted (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.SetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.SetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetClientSite (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetColorScheme (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.SetContentExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetHostNames (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetMoniker (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.SetObjectRects (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.TranslateAccelerator (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.UIDeactivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Unadvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Unfreeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Unfreeze (inherited from Control) | Select the method name to go to the Microsoft documentation.

See Also

WizardPage Class | Genghis.Windows.Forms Namespace


WizardPage.Dispose Method (Boolean)

Clean up any resources being used.

[Visual Basic]
Overrides Overloads Protected Sub Dispose( _
   ByVal disposing As Boolean _
)
[C#]
protected override void Dispose(
   bool disposing
);

See Also

WizardPage Class | WizardPage Members | Genghis.Windows.Forms Namespace | WizardPage.Dispose Overload List


WizardSheet Class

Frame to hold WizardPages for a Wizard-like User Interface.

For a list of all members of this type, see WizardSheet Members.

System.Object
MarshalByRefObject
Component
Control
ScrollableControl
ContainerControl
Form
WizardSheet

[Visual Basic]
Public Class WizardSheet
   Inherits Form
   Implements IComponent, IDisposable, IOleControl, IOleObject, IOleInPlaceObject, IOleInPlaceActiveObject, IOleWindow, IViewObject, IViewObject2, IPersist, IPersistStreamInit, IPersistPropertyBag, IPersistStorage, IQuickActivate, ISynchronizeInvoke, IWin32Window, IContainerControl
[C#]
public class WizardSheet : Form, IComponent, IDisposable, IOleControl, IOleObject, IOleInPlaceObject, IOleInPlaceActiveObject, IOleWindow, IViewObject, IViewObject2, IPersist, IPersistStreamInit, IPersistPropertyBag, IPersistStorage, IQuickActivate, ISynchronizeInvoke, IWin32Window, IContainerControl

Example

Typical usage case:

            WizardSheet sht = new WizardSheet();
            sht.Add(new WizardPage());
            sht.ShowDialog();

Requirements

Namespace: Genghis.Windows.Forms Namespace

Assembly: Genghis.dll

See Also

WizardSheet Members | Genghis.Windows.Forms Namespace


WizardSheet Members

Public Instance Constructors

WizardSheet Overloaded. Initialize a new instance of the WizardSheet class.

Public Instance Properties

AcceptButton (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
AccessibilityObject (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleDefaultActionDescription (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleDescription (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleRole (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ActiveControl (inherited from System.Windows.Forms.ContainerControl) | Select the method name to go to the Microsoft documentation.
ActiveMdiChild (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
AllowDrop (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AllowTransparency (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Anchor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AutoScale (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
AutoScaleBaseSize (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
AutoScroll (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
AutoScrollMargin (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
AutoScrollMinSize (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
AutoScrollPosition (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
BackColor (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
BackgroundImage (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
BindingContext (inherited from System.Windows.Forms.ContainerControl) | Select the method name to go to the Microsoft documentation.
Bottom (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Bounds (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CancelButton (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
CanFocus (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CanSelect (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Capture (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CausesValidation (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ClientRectangle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ClientSize (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
CompanyName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ContainsFocus (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ContextMenu (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ControlBox (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Controls (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Created (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CurrentGroup | The current group of wizard pages shown in the wizard.
Cursor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DataBindings (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DesktopBounds (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
DesktopLocation (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
DialogResult (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
DisplayRectangle (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
Disposing (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Dock (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DockPadding (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
Enabled (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
EnableFinishButton | Enables or disables the Finish button. Usually called from the pages of the Wizard Page to ensure that some pages are viewed.
Focused (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Font (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ForeColor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
FormBorderStyle (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Handle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
HasChildren (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Height (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
HelpButton (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Icon (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
ImeMode (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
InvokeRequired (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsAccessible (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsDisposed (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsHandleCreated (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsMdiChild (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
IsMdiContainer (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
IsRestrictedWindow (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
KeyPreview (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Left (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Location (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
MaximizeBox (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
MaximumSize (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
MdiChildren (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
MdiParent (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Menu (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
MergedMenu (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
MinimizeBox (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
MinimumSize (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Modal (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Name (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Opacity (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
OwnedForms (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Owner (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
PageCount | The number of pages in the current group.
Parent (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ParentForm (inherited from System.Windows.Forms.ContainerControl) | Select the method name to go to the Microsoft documentation.
ProductName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ProductVersion (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RecreatingHandle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Region (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Right (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RightToLeft (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowHelpButton | Shows or hides the help button.
ShowInTaskbar (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Site (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Size (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
SizeGripStyle (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
StartPosition (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
TabIndex (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
TabStop (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Tag (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Text | The text for the titlebar of the wizard.
Top (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TopLevel (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
TopLevelControl (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TopMost (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
TransparencyKey (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Visible (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Width (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
WindowState (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
WindowTarget (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.

Public Instance Methods

Activate (inherited from Form) | Select the method name to go to the Microsoft documentation.
AddOwnedForm (inherited from Form) | Select the method name to go to the Microsoft documentation.
AddPage | Overloaded. Adds a page to the Wizard, specifying the groups in which this new page will belong.
BeginInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
BeginInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
BringToFront (inherited from Control) | Select the method name to go to the Microsoft documentation.
Close (inherited from Form) | Select the method name to go to the Microsoft documentation.
Contains (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateGraphics (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
DoDragDrop (inherited from Control) | Select the method name to go to the Microsoft documentation.
EndInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
FindForm (inherited from Control) | Select the method name to go to the Microsoft documentation.
Focus (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetChildAtPoint (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetContainerControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetNextControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetPage | Gets the page in the current group by ordinal number.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
Hide (inherited from Control) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
LayoutMdi (inherited from Form) | Select the method name to go to the Microsoft documentation.
PerformLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
PerformLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
PointToClient (inherited from Control) | Select the method name to go to the Microsoft documentation.
PointToScreen (inherited from Control) | Select the method name to go to the Microsoft documentation.
PreProcessMessage (inherited from Control) | Select the method name to go to the Microsoft documentation.
RectangleToClient (inherited from Control) | Select the method name to go to the Microsoft documentation.
RectangleToScreen (inherited from Control) | Select the method name to go to the Microsoft documentation.
Refresh (inherited from Control) | Select the method name to go to the Microsoft documentation.
RemoveOwnedForm (inherited from Form) | Select the method name to go to the Microsoft documentation.
ResetBackColor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetBindings (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetCursor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetFont (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetForeColor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetImeMode (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetRightToLeft (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetText (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResumeLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResumeLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
Scale (inherited from Control) | Select the method name to go to the Microsoft documentation.
Scale (inherited from Control) | Select the method name to go to the Microsoft documentation.
ScrollControlIntoView (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
Select (inherited from Control) | Select the method name to go to the Microsoft documentation.
SelectNextControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
SendToBack (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetAutoScrollMargin (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
SetBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetDesktopBounds (inherited from Form) | Select the method name to go to the Microsoft documentation.
SetDesktopLocation (inherited from Form) | Select the method name to go to the Microsoft documentation.
Show (inherited from Control) | Select the method name to go to the Microsoft documentation.
ShowDialog (inherited from Form) | Select the method name to go to the Microsoft documentation.
ShowDialog (inherited from Form) | Select the method name to go to the Microsoft documentation.
SuspendLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Form) | Select the method name to go to the Microsoft documentation.
Update (inherited from Control) | Select the method name to go to the Microsoft documentation.
Validate (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.

Protected Instance Fields

BottomPanel
pagePanel

Protected Instance Properties

CreateParams (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
DefaultImeMode (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
DefaultSize (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
FontHeight (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
HScroll (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
MaximizedBounds (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
RenderRightToLeft (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ResizeRedraw (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowFocusCues (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowKeyboardCues (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
VScroll (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Select the method name to go to the Microsoft documentation.
ActivateMdiChild (inherited from Form) | Select the method name to go to the Microsoft documentation.
AdjustFormScrollbars (inherited from Form) | Select the method name to go to the Microsoft documentation.
ApplyAutoScaling (inherited from Form) | Select the method name to go to the Microsoft documentation.
CenterToParent (inherited from Form) | Select the method name to go to the Microsoft documentation.
CenterToScreen (inherited from Form) | Select the method name to go to the Microsoft documentation.
CreateAccessibilityInstance (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateControlsInstance (inherited from Form) | Select the method name to go to the Microsoft documentation.
CreateHandle (inherited from Form) | Select the method name to go to the Microsoft documentation.
DefWndProc (inherited from Form) | Select the method name to go to the Microsoft documentation.
DestroyHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Form) | Select the method name to go to the Microsoft documentation.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetScrollState (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetStyle (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetTopLevel (inherited from Control) | Select the method name to go to the Microsoft documentation.
InitLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeGotFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeLostFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeOnClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokePaint (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokePaintBackground (inherited from Control) | Select the method name to go to the Microsoft documentation.
IsInputChar (inherited from Control) | Select the method name to go to the Microsoft documentation.
IsInputKey (inherited from Control) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
NotifyInvalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnActivated (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnBackColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBackgroundImageChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBindingContextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnCausesValidationChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnChangeUICues (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnClosed (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnClosing (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnContextMenuChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnControlAdded (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnControlRemoved (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
OnCreateControl (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnCursorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDeactivate (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnDockChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDoubleClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragDrop (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragOver (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnEnabledChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnFontChanged (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnForeColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnGiveFeedback (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnGotFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnHandleCreated (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnHandleDestroyed (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnHelp | Virtual method called with the help button is pressed. The default behavior is to do nothing.
OnHelpRequested (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnImeModeChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnInputLanguageChanged (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnInputLanguageChanging (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnInvalidated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnKeyDown (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnKeyPress (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnKeyUp (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLayout (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
OnLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLoad (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnLocationChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLostFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMaximizedBoundsChanged (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnMaximumSizeChanged (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnMdiChildActivate (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnMenuComplete (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnMenuStart (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnMinimumSizeChanged (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnMouseDown (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseHover (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseMove (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseUp (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseWheel (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
OnMove (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnNotifyMessage (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnPaint (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnPaintBackground (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBackColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBackgroundImageChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBindingContextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentEnabledChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentFontChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentForeColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentRightToLeftChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentVisibleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnQueryContinueDrag (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnResize (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnRightToLeftChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnSizeChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnStyleChanged (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnSystemColorsChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTabIndexChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTabStopChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTextChanged (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnValidated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnValidating (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnVisibleChanged (inherited from Form) | Select the method name to go to the Microsoft documentation.
ProcessCmdKey (inherited from Form) | Select the method name to go to the Microsoft documentation.
ProcessDialogChar (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
ProcessDialogKey (inherited from Form) | Select the method name to go to the Microsoft documentation.
ProcessKeyEventArgs (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessKeyPreview (inherited from Form) | Select the method name to go to the Microsoft documentation.
ProcessMnemonic (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
ProcessTabKey (inherited from Form) | Select the method name to go to the Microsoft documentation.
RaiseDragEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseKeyEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseMouseEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaisePaintEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RecreateHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetMouseEventArgs (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResizeDialog | resizes the dialog based on the pages in the current group.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateContent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateHorizontal (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateLeftRight (inherited from Control) | Select the method name to go to the Microsoft documentation.
ScaleCore (inherited from Form) | Select the method name to go to the Microsoft documentation.
Select (inherited from Form) | Select the method name to go to the Microsoft documentation.
SetActiveButtons | Enables/Disables next/prev buttons based on the pages
SetBoundsCore (inherited from Form) | Select the method name to go to the Microsoft documentation.
SetClientSizeCore (inherited from Form) | Select the method name to go to the Microsoft documentation.
SetDisplayRectLocation (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
SetScrollState (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
SetStyle (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetTopLevel (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetVisibleCore (inherited from Form) | Select the method name to go to the Microsoft documentation.
ShowPage | Shows the current page in the wizard.
ShowTitleBar | Shows the title of the page and the page numbers on the TitleBar
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateDefaultButton (inherited from Form) | Select the method name to go to the Microsoft documentation.
UpdateStyles (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateZOrder (inherited from Control) | Select the method name to go to the Microsoft documentation.
WndProc (inherited from Form) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Advise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Close (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleWindow.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.DoVerb (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Draw (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Draw (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.EnableModeless (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.EnumAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.EnumVerbs (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Freeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Freeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.FreezeEvents (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.GetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersist.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetClientSite (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetClipboardData (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetColorSet (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.GetColorSet (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.GetContentExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.GetControlInfo (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetMiscStatus (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetMoniker (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.GetSizeMax (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetUserClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetUserType (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleWindow.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.HandsOffStorage (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.InitFromData (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.InPlaceDeactivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.IsDirty (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.IsDirty (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.IsUpToDate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.OleUpdate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.OnAmbientPropertyChange (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.OnDocWindowActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.OnFrameWindowActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.OnMnemonic (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.QuickActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.ReactivateAndUndo (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.ResizeBorder (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.SaveCompleted (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.SetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.SetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetClientSite (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetColorScheme (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.SetContentExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetHostNames (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetMoniker (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.SetObjectRects (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.TranslateAccelerator (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.UIDeactivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Unadvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Unfreeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Unfreeze (inherited from Control) | Select the method name to go to the Microsoft documentation.

See Also

WizardSheet Class | Genghis.Windows.Forms Namespace


WizardSheet Constructor

Genghis Class Library

WizardSheet

Default Constructor

Overload List

Default Constructor

public WizardSheet();

Constructs a new Wizard Sheet specifying the name of the wizard (for the Titlebar).

public WizardSheet(string);

See Also

WizardSheet Class | WizardSheet Members | Genghis.Windows.Forms Namespace


WizardSheet Constructor ()

Default Constructor

[Visual Basic]
Overloads Public Sub New()
[C#]
public WizardSheet();

Example

To create a new WizardSheet object without specifying the dialog title:

            Wizard sheet = new WizardSheet();

See Also

WizardSheet Class | WizardSheet Members | Genghis.Windows.Forms Namespace | WizardSheet Constructor Overload List


WizardSheet Constructor (String)

Constructs a new Wizard Sheet specifying the name of the wizard (for the Titlebar).

[Visual Basic]
Overloads Public Sub New( _
   ByVal titleBarText As String _
)
[C#]
public WizardSheet(
   string titleBarText
);

Parameters

titleBarText
Text for the Titlebar

Example

To create a new WizardSheet object while specifying the dialog title:

            Wizard sheet = new WizardSheet("My Wizard");

See Also

WizardSheet Class | WizardSheet Members | Genghis.Windows.Forms Namespace | WizardSheet Constructor Overload List


WizardSheet Fields

The fields of the WizardSheet class are listed below. For a complete list of WizardSheet class members, see the WizardSheet Members topic.

Protected Instance Fields

BottomPanel
pagePanel

See Also

WizardSheet Class | Genghis.Windows.Forms Namespace


WizardSheet.BottomPanel Field

[Visual Basic]
Protected BottomPanel As System.Windows.Forms.Panel
[C#]
protected Panel BottomPanel;

See Also

WizardSheet Class | WizardSheet Members | Genghis.Windows.Forms Namespace


WizardSheet.pagePanel Field

[Visual Basic]
Protected pagePanel As System.Windows.Forms.Panel
[C#]
protected Panel pagePanel;

See Also

WizardSheet Class | WizardSheet Members | Genghis.Windows.Forms Namespace


WizardSheet Properties

The properties of the WizardSheet class are listed below. For a complete list of WizardSheet class members, see the WizardSheet Members topic.

Public Instance Properties

AcceptButton (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
AccessibilityObject (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleDefaultActionDescription (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleDescription (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AccessibleRole (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ActiveControl (inherited from System.Windows.Forms.ContainerControl) | Select the method name to go to the Microsoft documentation.
ActiveMdiChild (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
AllowDrop (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AllowTransparency (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Anchor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
AutoScale (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
AutoScaleBaseSize (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
AutoScroll (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
AutoScrollMargin (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
AutoScrollMinSize (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
AutoScrollPosition (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
BackColor (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
BackgroundImage (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
BindingContext (inherited from System.Windows.Forms.ContainerControl) | Select the method name to go to the Microsoft documentation.
Bottom (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Bounds (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CancelButton (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
CanFocus (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CanSelect (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Capture (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CausesValidation (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ClientRectangle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ClientSize (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
CompanyName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Container (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
ContainsFocus (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ContextMenu (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ControlBox (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Controls (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Created (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
CurrentGroup | The current group of wizard pages shown in the wizard.
Cursor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DataBindings (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DesktopBounds (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
DesktopLocation (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
DialogResult (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
DisplayRectangle (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
Disposing (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Dock (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
DockPadding (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
Enabled (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
EnableFinishButton | Enables or disables the Finish button. Usually called from the pages of the Wizard Page to ensure that some pages are viewed.
Focused (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Font (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ForeColor (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
FormBorderStyle (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Handle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
HasChildren (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Height (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
HelpButton (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Icon (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
ImeMode (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
InvokeRequired (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsAccessible (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsDisposed (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsHandleCreated (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
IsMdiChild (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
IsMdiContainer (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
IsRestrictedWindow (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
KeyPreview (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Left (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Location (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
MaximizeBox (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
MaximumSize (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
MdiChildren (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
MdiParent (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Menu (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
MergedMenu (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
MinimizeBox (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
MinimumSize (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Modal (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Name (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Opacity (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
OwnedForms (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Owner (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
PageCount | The number of pages in the current group.
Parent (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ParentForm (inherited from System.Windows.Forms.ContainerControl) | Select the method name to go to the Microsoft documentation.
ProductName (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ProductVersion (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RecreatingHandle (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Region (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Right (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
RightToLeft (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowHelpButton | Shows or hides the help button.
ShowInTaskbar (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Site (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Size (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
SizeGripStyle (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
StartPosition (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
TabIndex (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
TabStop (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Tag (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Text | The text for the titlebar of the wizard.
Top (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TopLevel (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
TopLevelControl (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
TopMost (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
TransparencyKey (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
Visible (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
Width (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
WindowState (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
WindowTarget (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

CreateParams (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
DefaultImeMode (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
DefaultSize (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
DesignMode (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
Events (inherited from System.ComponentModel.Component) | Select the method name to go to the Microsoft documentation.
FontHeight (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
HScroll (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.
MaximizedBounds (inherited from System.Windows.Forms.Form) | Select the method name to go to the Microsoft documentation.
RenderRightToLeft (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ResizeRedraw (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowFocusCues (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
ShowKeyboardCues (inherited from System.Windows.Forms.Control) | Select the method name to go to the Microsoft documentation.
VScroll (inherited from System.Windows.Forms.ScrollableControl) | Select the method name to go to the Microsoft documentation.

See Also

WizardSheet Class | Genghis.Windows.Forms Namespace


WizardSheet.CurrentGroup Property

The current group of wizard pages shown in the wizard.

[Visual Basic]
Overridable Public Property CurrentGroup As String
[C#]
public string CurrentGroup {virtual get; virtual set;}

Property Value

A string that matches groups that you specified while adding wizard pages.

See Also

WizardSheet Class | WizardSheet Members | Genghis.Windows.Forms Namespace


WizardSheet.EnableFinishButton Property

Enables or disables the Finish button. Usually called from the pages of the Wizard Page to ensure that some pages are viewed.

[Visual Basic]
Public Property EnableFinishButton As Boolean
[C#]
public bool EnableFinishButton {get; set;}

See Also

WizardSheet Class | WizardSheet Members | Genghis.Windows.Forms Namespace


WizardSheet.PageCount Property

The number of pages in the current group.

[Visual Basic]
Public ReadOnly Property PageCount As Integer
[C#]
public int PageCount {get;}

See Also

WizardSheet Class | WizardSheet Members | Genghis.Windows.Forms Namespace


WizardSheet.ShowHelpButton Property

Shows or hides the help button.

[Visual Basic]
Public Property ShowHelpButton As Boolean
[C#]
public bool ShowHelpButton {get; set;}

See Also

WizardSheet Class | WizardSheet Members | Genghis.Windows.Forms Namespace


WizardSheet.Text Property

The text for the titlebar of the wizard.

[Visual Basic]
Public Property Text As String
[C#]
public string Text {get; set;}

See Also

WizardSheet Class | WizardSheet Members | Genghis.Windows.Forms Namespace


WizardSheet Methods

The methods of the WizardSheet class are listed below. For a complete list of WizardSheet class members, see the WizardSheet Members topic.

Public Instance Methods

Activate (inherited from Form) | Select the method name to go to the Microsoft documentation.
AddOwnedForm (inherited from Form) | Select the method name to go to the Microsoft documentation.
AddPage | Overloaded. Adds a page to the Wizard, specifying the groups in which this new page will belong.
BeginInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
BeginInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
BringToFront (inherited from Control) | Select the method name to go to the Microsoft documentation.
Close (inherited from Form) | Select the method name to go to the Microsoft documentation.
Contains (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateGraphics (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateObjRef (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Component) | Select the method name to go to the Microsoft documentation.
DoDragDrop (inherited from Control) | Select the method name to go to the Microsoft documentation.
EndInvoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
FindForm (inherited from Control) | Select the method name to go to the Microsoft documentation.
Focus (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetChildAtPoint (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetContainerControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
GetNextControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetPage | Gets the page in the current group by ordinal number.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
Hide (inherited from Control) | Select the method name to go to the Microsoft documentation.
InitializeLifetimeService (inherited from MarshalByRefObject) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
Invoke (inherited from Control) | Select the method name to go to the Microsoft documentation.
LayoutMdi (inherited from Form) | Select the method name to go to the Microsoft documentation.
PerformLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
PerformLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
PointToClient (inherited from Control) | Select the method name to go to the Microsoft documentation.
PointToScreen (inherited from Control) | Select the method name to go to the Microsoft documentation.
PreProcessMessage (inherited from Control) | Select the method name to go to the Microsoft documentation.
RectangleToClient (inherited from Control) | Select the method name to go to the Microsoft documentation.
RectangleToScreen (inherited from Control) | Select the method name to go to the Microsoft documentation.
Refresh (inherited from Control) | Select the method name to go to the Microsoft documentation.
RemoveOwnedForm (inherited from Form) | Select the method name to go to the Microsoft documentation.
ResetBackColor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetBindings (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetCursor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetFont (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetForeColor (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetImeMode (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetRightToLeft (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetText (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResumeLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResumeLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
Scale (inherited from Control) | Select the method name to go to the Microsoft documentation.
Scale (inherited from Control) | Select the method name to go to the Microsoft documentation.
ScrollControlIntoView (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
Select (inherited from Control) | Select the method name to go to the Microsoft documentation.
SelectNextControl (inherited from Control) | Select the method name to go to the Microsoft documentation.
SendToBack (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetAutoScrollMargin (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
SetBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetDesktopBounds (inherited from Form) | Select the method name to go to the Microsoft documentation.
SetDesktopLocation (inherited from Form) | Select the method name to go to the Microsoft documentation.
Show (inherited from Control) | Select the method name to go to the Microsoft documentation.
ShowDialog (inherited from Form) | Select the method name to go to the Microsoft documentation.
ShowDialog (inherited from Form) | Select the method name to go to the Microsoft documentation.
SuspendLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Form) | Select the method name to go to the Microsoft documentation.
Update (inherited from Control) | Select the method name to go to the Microsoft documentation.
Validate (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Select the method name to go to the Microsoft documentation.
ActivateMdiChild (inherited from Form) | Select the method name to go to the Microsoft documentation.
AdjustFormScrollbars (inherited from Form) | Select the method name to go to the Microsoft documentation.
ApplyAutoScaling (inherited from Form) | Select the method name to go to the Microsoft documentation.
CenterToParent (inherited from Form) | Select the method name to go to the Microsoft documentation.
CenterToScreen (inherited from Form) | Select the method name to go to the Microsoft documentation.
CreateAccessibilityInstance (inherited from Control) | Select the method name to go to the Microsoft documentation.
CreateControlsInstance (inherited from Form) | Select the method name to go to the Microsoft documentation.
CreateHandle (inherited from Form) | Select the method name to go to the Microsoft documentation.
DefWndProc (inherited from Form) | Select the method name to go to the Microsoft documentation.
DestroyHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from Form) | Select the method name to go to the Microsoft documentation.
Finalize (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetScrollState (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
GetService (inherited from Component) | Select the method name to go to the Microsoft documentation.
GetStyle (inherited from Control) | Select the method name to go to the Microsoft documentation.
GetTopLevel (inherited from Control) | Select the method name to go to the Microsoft documentation.
InitLayout (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeGotFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeLostFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokeOnClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokePaint (inherited from Control) | Select the method name to go to the Microsoft documentation.
InvokePaintBackground (inherited from Control) | Select the method name to go to the Microsoft documentation.
IsInputChar (inherited from Control) | Select the method name to go to the Microsoft documentation.
IsInputKey (inherited from Control) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
NotifyInvalidate (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnActivated (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnBackColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBackgroundImageChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnBindingContextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnCausesValidationChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnChangeUICues (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnClosed (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnClosing (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnContextMenuChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnControlAdded (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnControlRemoved (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
OnCreateControl (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnCursorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDeactivate (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnDockChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDoubleClick (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragDrop (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnDragOver (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnEnabledChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnFontChanged (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnForeColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnGiveFeedback (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnGotFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnHandleCreated (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnHandleDestroyed (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnHelp | Virtual method called with the help button is pressed. The default behavior is to do nothing.
OnHelpRequested (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnImeModeChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnInputLanguageChanged (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnInputLanguageChanging (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnInvalidated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnKeyDown (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnKeyPress (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnKeyUp (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLayout (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
OnLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLoad (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnLocationChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnLostFocus (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMaximizedBoundsChanged (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnMaximumSizeChanged (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnMdiChildActivate (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnMenuComplete (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnMenuStart (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnMinimumSizeChanged (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnMouseDown (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseEnter (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseHover (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseLeave (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseMove (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseUp (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnMouseWheel (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
OnMove (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnNotifyMessage (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnPaint (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnPaintBackground (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBackColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBackgroundImageChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentBindingContextChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentEnabledChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentFontChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentForeColorChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentRightToLeftChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnParentVisibleChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnQueryContinueDrag (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnResize (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnRightToLeftChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnSizeChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnStyleChanged (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnSystemColorsChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTabIndexChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTabStopChanged (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnTextChanged (inherited from Form) | Select the method name to go to the Microsoft documentation.
OnValidated (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnValidating (inherited from Control) | Select the method name to go to the Microsoft documentation.
OnVisibleChanged (inherited from Form) | Select the method name to go to the Microsoft documentation.
ProcessCmdKey (inherited from Form) | Select the method name to go to the Microsoft documentation.
ProcessDialogChar (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
ProcessDialogKey (inherited from Form) | Select the method name to go to the Microsoft documentation.
ProcessKeyEventArgs (inherited from Control) | Select the method name to go to the Microsoft documentation.
ProcessKeyPreview (inherited from Form) | Select the method name to go to the Microsoft documentation.
ProcessMnemonic (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
ProcessTabKey (inherited from Form) | Select the method name to go to the Microsoft documentation.
RaiseDragEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseKeyEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaiseMouseEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RaisePaintEvent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RecreateHandle (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResetMouseEventArgs (inherited from Control) | Select the method name to go to the Microsoft documentation.
ResizeDialog | resizes the dialog based on the pages in the current group.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateAlignment (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateContent (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateHorizontal (inherited from Control) | Select the method name to go to the Microsoft documentation.
RtlTranslateLeftRight (inherited from Control) | Select the method name to go to the Microsoft documentation.
ScaleCore (inherited from Form) | Select the method name to go to the Microsoft documentation.
Select (inherited from Form) | Select the method name to go to the Microsoft documentation.
SetActiveButtons | Enables/Disables next/prev buttons based on the pages
SetBoundsCore (inherited from Form) | Select the method name to go to the Microsoft documentation.
SetClientSizeCore (inherited from Form) | Select the method name to go to the Microsoft documentation.
SetDisplayRectLocation (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
SetScrollState (inherited from ScrollableControl) | Select the method name to go to the Microsoft documentation.
SetStyle (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetTopLevel (inherited from Control) | Select the method name to go to the Microsoft documentation.
SetVisibleCore (inherited from Form) | Select the method name to go to the Microsoft documentation.
ShowPage | Shows the current page in the wizard.
ShowTitleBar | Shows the title of the page and the page numbers on the TitleBar
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateBounds (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateDefaultButton (inherited from Form) | Select the method name to go to the Microsoft documentation.
UpdateStyles (inherited from Control) | Select the method name to go to the Microsoft documentation.
UpdateZOrder (inherited from Control) | Select the method name to go to the Microsoft documentation.
WndProc (inherited from Form) | Select the method name to go to the Microsoft documentation.

Protected Internal Instance Methods

ProcessKeyMessage (inherited from Control) Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

IContainerControl.ActivateControl (inherited from ContainerControl) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Advise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Close (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleWindow.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.ContextSensitiveHelp (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.DoVerb (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Draw (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Draw (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.EnableModeless (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.EnumAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.EnumVerbs (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Freeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Freeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.FreezeEvents (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.GetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersist.GetClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetClientSite (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetClipboardData (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetColorSet (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.GetColorSet (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.GetContentExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.GetControlInfo (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.GetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetMiscStatus (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetMoniker (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.GetSizeMax (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetUserClassID (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.GetUserType (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleWindow.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.GetWindow (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.HandsOffStorage (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.InitFromData (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.InitNew (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.InPlaceDeactivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.IsDirty (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.IsDirty (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.IsUpToDate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.Load (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.OleUpdate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.OnAmbientPropertyChange (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.OnDocWindowActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.OnFrameWindowActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleControl.OnMnemonic (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.QuickActivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.ReactivateAndUndo (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.ResizeBorder (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStreamInit.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistPropertyBag.Save (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IPersistStorage.SaveCompleted (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.SetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.SetAdvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetClientSite (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetColorScheme (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IQuickActivate.SetContentExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetExtent (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetHostNames (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.SetMoniker (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.SetObjectRects (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceActiveObject.TranslateAccelerator (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleInPlaceObject.UIDeactivate (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IOleObject.Unadvise (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject2.Unfreeze (inherited from Control) | Select the method name to go to the Microsoft documentation.
UnsafeNativeMethods+IViewObject.Unfreeze (inherited from Control) | Select the method name to go to the Microsoft documentation.

See Also

WizardSheet Class | Genghis.Windows.Forms Namespace


AddPage Method

Genghis Class Library

WizardSheet.AddPage

Adds a new page

Overload List

Adds a page to the Wizard, specifying the groups in which this new page will belong.

public virtual void AddPage(Control,string[]);

Adds a page to the Wizard, specifying the specific group to add it to.

public virtual void AddPage(Control,string);

Add a page to the default group.

public virtual void AddPage(Control);

Adds a new Page, assigning it to multiple groups.

public virtual void AddPage(WizardPage,string[]);

Adds a new Page, assigning it to a single group.

public virtual void AddPage(WizardPage,string);

Adds a new page

public virtual void AddPage(WizardPage);

See Also

WizardSheet Class | WizardSheet Members | Genghis.Windows.Forms Namespace


WizardSheet.AddPage Method (WizardPage)

Adds a new page

[Visual Basic]
Overridable Overloads Public Sub AddPage( _
   ByVal page As Genghis.Windows.Forms.WizardPage _
)
[C#]
public virtual void AddPage(
   WizardPage page
);

Parameters

page
The WizardPage object to add to the collection of pages.

See Also

WizardSheet Class | WizardSheet Members | Genghis.Windows.Forms Namespace | WizardSheet.AddPage Overload List


WizardSheet.AddPage Method (WizardPage, String)

Adds a new Page, assigning it to a single group.

[Visual Basic]
Overridable Overloads Public Sub AddPage( _
   ByVal page As Genghis.Windows.Forms.WizardPage, _
   ByVal group As String _
)
[C#]
public virtual void AddPage(
   WizardPage page,
   string group
);

Parameters

page
The WizardPage object to add to the collection of pages.
group
The name of the group to add this page to.

See Also

WizardSheet Class | WizardSheet Members | Genghis.Windows.Forms Namespace | WizardSheet.AddPage Overload List


WizardSheet.AddPage Method (WizardPage, String[])

Adds a new Page, assigning it to multiple groups.

[Visual Basic]
Overridable Overloads Public Sub AddPage( _
   ByVal page As Genghis.Windows.Forms.WizardPage, _
   ByVal groups As String() _
)
[C#]
public virtual void AddPage(
   WizardPage page,
   string[] groups
);

Parameters

page
The WizardPage object to add to the collection of pages.
groups
An array of strings specifying which groups to add the pages to.

See Also

WizardSheet Class | WizardSheet Members | Genghis.Windows.Forms Namespace | WizardSheet.AddPage Overload List


WizardSheet.AddPage Method (Control)

Add a page to the default group.

[Visual Basic]
Overridable Overloads Public Sub AddPage( _
   ByVal page As System.Windows.Forms.Control _
)
[C#]
public virtual void AddPage(
   Control page
);

Parameters

page
The Control object to add to the collection of pages.

See Also

WizardSheet Class | WizardSheet Members | Genghis.Windows.Forms Namespace | WizardSheet.AddPage Overload List


WizardSheet.AddPage Method (Control, String)

Adds a page to the Wizard, specifying the specific group to add it to.

[Visual Basic]
Overridable Overloads Public Sub AddPage( _
   ByVal page As System.Windows.Forms.Control, _
   ByVal group As String _
)
[C#]
public virtual void AddPage(
   Control page,
   string group
);

Parameters

page
The Control object to add to the collection of pages.
group
The name of the group to add this page to.

See Also

WizardSheet Class | WizardSheet Members | Genghis.Windows.Forms Namespace | WizardSheet.AddPage Overload List


WizardSheet.AddPage Method (Control, String[])

Adds a page to the Wizard, specifying the groups in which this new page will belong.

[Visual Basic]
Overridable Overloads Public Sub AddPage( _
   ByVal page As System.Windows.Forms.Control, _
   ByVal groups As String() _
)
[C#]
public virtual void AddPage(
   Control page,
   string[] groups
);

Parameters

page
The Control object to add to the collection of pages.
groups
An array of strings specifying which groups to add the pages to.

See Also

WizardSheet Class | WizardSheet Members | Genghis.Windows.Forms Namespace | WizardSheet.AddPage Overload List


WizardSheet.GetPage Method

Gets the page in the current group by ordinal number.

[Visual Basic]
Public Function GetPage( _
   ByVal item As Integer _
) As System.Windows.Forms.Control
[C#]
public Control GetPage(
   int item
);

Parameters

item
The zero-based index to a page in the current group.

See Also

WizardSheet Class | WizardSheet Members | Genghis.Windows.Forms Namespace


WizardSheet.OnHelp Method

Virtual method called with the help button is pressed. The default behavior is to do nothing.

[Visual Basic]
Overridable Protected Sub OnHelp()
[C#]
protected virtual void OnHelp();

See Also

WizardSheet Class | WizardSheet Members | Genghis.Windows.Forms Namespace


WizardSheet.ResizeDialog Method

resizes the dialog based on the pages in the current group.

[Visual Basic]
Overridable Protected Sub ResizeDialog()
[C#]
protected virtual void ResizeDialog();

See Also

WizardSheet Class | WizardSheet Members | Genghis.Windows.Forms Namespace


WizardSheet.SetActiveButtons Method

Enables/Disables next/prev buttons based on the pages

[Visual Basic]
Overridable Protected Sub SetActiveButtons()
[C#]
protected virtual void SetActiveButtons();

See Also

WizardSheet Class | WizardSheet Members | Genghis.Windows.Forms Namespace


WizardSheet.ShowPage Method

Shows the current page in the wizard.

[Visual Basic]
Overridable Protected Sub ShowPage()
[C#]
protected virtual void ShowPage();

See Also

WizardSheet Class | WizardSheet Members | Genghis.Windows.Forms Namespace


WizardSheet.ShowTitleBar Method

Shows the title of the page and the page numbers on the TitleBar

[Visual Basic]
Overridable Protected Sub ShowTitleBar()
[C#]
protected virtual void ShowTitleBar();

See Also

WizardSheet Class | WizardSheet Members | Genghis.Windows.Forms Namespace


Genghis.Windows.Forms.Design

Genghis Class Library

Genghis.Windows.Forms.Design Namespace

Namespace hierarchy

Classes

Class | Description
ContainerStatusBarDesigner |


ContainerStatusBarDesigner Class

For a list of all members of this type, see ContainerStatusBarDesigner Members.

System.Object
ComponentDesigner
ControlDesigner
ParentControlDesigner
ContainerStatusBarDesigner

[Visual Basic]
Public Class ContainerStatusBarDesigner
   Inherits ParentControlDesigner
   Implements IDesigner, IDisposable, IDesignerFilter, ISelectionUIHandler, IOleDragClient
[C#]
public class ContainerStatusBarDesigner : ParentControlDesigner, IDesigner, IDisposable, IDesignerFilter, ISelectionUIHandler, IOleDragClient

Requirements

Namespace: Genghis.Windows.Forms.Design Namespace

Assembly: Genghis.dll

See Also

ContainerStatusBarDesigner Members | Genghis.Windows.Forms.Design Namespace


ContainerStatusBarDesigner Members

Public Instance Constructors

ContainerStatusBarDesigner Constructor

Public Instance Properties

AccessibilityObject (inherited from System.Windows.Forms.Design.ControlDesigner) | Select the method name to go to the Microsoft documentation.
AssociatedComponents (inherited from System.Windows.Forms.Design.ControlDesigner) | Select the method name to go to the Microsoft documentation.
Component (inherited from System.ComponentModel.Design.ComponentDesigner) | Select the method name to go to the Microsoft documentation.
ContainerStatusBar | A reference to the ContainerStatusBar being designed.
Control (inherited from System.Windows.Forms.Design.ControlDesigner) | Select the method name to go to the Microsoft documentation.
SelectionRules (inherited from System.Windows.Forms.Design.ControlDesigner) | Select the method name to go to the Microsoft documentation.
Verbs (inherited from System.ComponentModel.Design.ComponentDesigner) | Select the method name to go to the Microsoft documentation.

Public Instance Methods

CanBeParentedTo (inherited from ControlDesigner) | Select the method name to go to the Microsoft documentation.
CanParent (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
CanParent (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
DoDefaultAction (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
Initialize | Prepares the designer to view, edit, and design ContainerStatusBar
InitializeNonDefault (inherited from ControlDesigner) | Select the method name to go to the Microsoft documentation.
OnSetComponentDefaults (inherited from ControlDesigner) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Fields

accessibilityObj

Protected Instance Properties

DefaultControlLocation (inherited from System.Windows.Forms.Design.ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
DrawGrid (inherited from System.Windows.Forms.Design.ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
EnableDragRect (inherited from System.Windows.Forms.Design.ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
GridSize (inherited from System.Windows.Forms.Design.ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
InheritanceAttribute (inherited from System.ComponentModel.Design.ComponentDesigner) | Select the method name to go to the Microsoft documentation.
Inherited (inherited from System.ComponentModel.Design.ComponentDesigner) | Select the method name to go to the Microsoft documentation.
ShadowProperties (inherited from System.ComponentModel.Design.ComponentDesigner) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

BaseWndProc (inherited from ControlDesigner) | Select the method name to go to the Microsoft documentation.
CreateTool (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
CreateTool (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
CreateTool (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
CreateToolCore |
DefWndProc (inherited from ControlDesigner) | Select the method name to go to the Microsoft documentation.
DisplayError (inherited from ControlDesigner) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
EnableDragDrop (inherited from ControlDesigner) | Select the method name to go to the Microsoft documentation.
Finalize (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
GetControl (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
GetHitTest (inherited from ControlDesigner) | Select the method name to go to the Microsoft documentation.
GetService (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
GetUpdatedRect (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
HookChildControls (inherited from ControlDesigner) | Select the method name to go to the Microsoft documentation.
InvokeGetInheritanceAttribute (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
OnContextMenu (inherited from ControlDesigner) | Select the method name to go to the Microsoft documentation.
OnCreateHandle (inherited from ControlDesigner) | Select the method name to go to the Microsoft documentation.
OnDragDrop | Attempts to host the control on the panel on which it was dropped.
OnDragEnter (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
OnDragLeave (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
OnDragOver (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
OnGiveFeedback (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
OnMouseDragBegin (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
OnMouseDragEnd (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
OnMouseDragMove (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
OnMouseEnter (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
OnMouseHover (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
OnMouseLeave (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
OnPaintAdornments (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
OnSetCursor (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
PostFilterAttributes (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
PostFilterEvents (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
PostFilterProperties (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
PreFilterAttributes (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
PreFilterEvents (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
PreFilterProperties (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
RaiseComponentChanged (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
RaiseComponentChanging (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
UnhookChildControls (inherited from ControlDesigner) | Select the method name to go to the Microsoft documentation.
WndProc (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

IOleDragClient.AddComponent (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
ISelectionUIHandler.BeginDrag (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
ISelectionUIHandler.DragMoved (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
ISelectionUIHandler.EndDrag (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
ISelectionUIHandler.GetComponentBounds (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
ISelectionUIHandler.GetComponentRules (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
IOleDragClient.GetControlForComponent (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
IOleDragClient.GetDesignerControl (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
ISelectionUIHandler.GetSelectionClipRect (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
IOleDragClient.IsDropOk (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
ISelectionUIHandler.OleDragDrop (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
ISelectionUIHandler.OleDragEnter (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
ISelectionUIHandler.OleDragLeave (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
ISelectionUIHandler.OleDragOver (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
ISelectionUIHandler.OnSelectionDoubleClick (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
IDesignerFilter.PostFilterAttributes (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
IDesignerFilter.PostFilterEvents (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
IDesignerFilter.PostFilterProperties (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
IDesignerFilter.PreFilterAttributes (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
IDesignerFilter.PreFilterEvents (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
IDesignerFilter.PreFilterProperties (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
ISelectionUIHandler.QueryBeginDrag (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
ISelectionUIHandler.ShowContextMenu (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.

See Also

ContainerStatusBarDesigner Class | Genghis.Windows.Forms.Design Namespace


ContainerStatusBarDesigner Constructor

[Visual Basic]
Public Sub New()
[C#]
public ContainerStatusBarDesigner();

See Also

ContainerStatusBarDesigner Class | ContainerStatusBarDesigner Members | Genghis.Windows.Forms.Design Namespace


ContainerStatusBarDesigner Fields

The fields of the ContainerStatusBarDesigner class are listed below. For a complete list of ContainerStatusBarDesigner class members, see the ContainerStatusBarDesigner Members topic.

Protected Instance Fields

accessibilityObj

See Also

ContainerStatusBarDesigner Class | Genghis.Windows.Forms.Design Namespace


ContainerStatusBarDesigner.accessibilityObj Field

[Visual Basic]
Protected accessibilityObj As System.Windows.Forms.AccessibleObject
[C#]
protected AccessibleObject accessibilityObj;

See Also

ContainerStatusBarDesigner Class | ContainerStatusBarDesigner Members | Genghis.Windows.Forms.Design Namespace


ContainerStatusBarDesigner Properties

The properties of the ContainerStatusBarDesigner class are listed below. For a complete list of ContainerStatusBarDesigner class members, see the ContainerStatusBarDesigner Members topic.

Public Instance Properties

AccessibilityObject (inherited from System.Windows.Forms.Design.ControlDesigner) | Select the method name to go to the Microsoft documentation.
AssociatedComponents (inherited from System.Windows.Forms.Design.ControlDesigner) | Select the method name to go to the Microsoft documentation.
Component (inherited from System.ComponentModel.Design.ComponentDesigner) | Select the method name to go to the Microsoft documentation.
ContainerStatusBar | A reference to the ContainerStatusBar being designed.
Control (inherited from System.Windows.Forms.Design.ControlDesigner) | Select the method name to go to the Microsoft documentation.
SelectionRules (inherited from System.Windows.Forms.Design.ControlDesigner) | Select the method name to go to the Microsoft documentation.
Verbs (inherited from System.ComponentModel.Design.ComponentDesigner) | Select the method name to go to the Microsoft documentation.

Protected Instance Properties

DefaultControlLocation (inherited from System.Windows.Forms.Design.ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
DrawGrid (inherited from System.Windows.Forms.Design.ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
EnableDragRect (inherited from System.Windows.Forms.Design.ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
GridSize (inherited from System.Windows.Forms.Design.ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
InheritanceAttribute (inherited from System.ComponentModel.Design.ComponentDesigner) | Select the method name to go to the Microsoft documentation.
Inherited (inherited from System.ComponentModel.Design.ComponentDesigner) | Select the method name to go to the Microsoft documentation.
ShadowProperties (inherited from System.ComponentModel.Design.ComponentDesigner) | Select the method name to go to the Microsoft documentation.

See Also

ContainerStatusBarDesigner Class | Genghis.Windows.Forms.Design Namespace


ContainerStatusBarDesigner.ContainerStatusBar Property

A reference to the ContainerStatusBar being designed.

[Visual Basic]
Public ReadOnly Property ContainerStatusBar As Genghis.Windows.Forms.ContainerStatusBar
[C#]
public Genghis.Windows.Forms.ContainerStatusBar ContainerStatusBar {get;}

See Also

ContainerStatusBarDesigner Class | ContainerStatusBarDesigner Members | Genghis.Windows.Forms.Design Namespace


ContainerStatusBarDesigner Methods

The methods of the ContainerStatusBarDesigner class are listed below. For a complete list of ContainerStatusBarDesigner class members, see the ContainerStatusBarDesigner Members topic.

Public Instance Methods

CanBeParentedTo (inherited from ControlDesigner) | Select the method name to go to the Microsoft documentation.
CanParent (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
CanParent (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
DoDefaultAction (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
Equals (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetHashCode (inherited from Object) | Select the method name to go to the Microsoft documentation.
GetType (inherited from Object) | Select the method name to go to the Microsoft documentation.
Initialize | Prepares the designer to view, edit, and design ContainerStatusBar
InitializeNonDefault (inherited from ControlDesigner) | Select the method name to go to the Microsoft documentation.
OnSetComponentDefaults (inherited from ControlDesigner) | Select the method name to go to the Microsoft documentation.
ToString (inherited from Object) | Select the method name to go to the Microsoft documentation.

Protected Instance Methods

BaseWndProc (inherited from ControlDesigner) | Select the method name to go to the Microsoft documentation.
CreateTool (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
CreateTool (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
CreateTool (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
CreateToolCore |
DefWndProc (inherited from ControlDesigner) | Select the method name to go to the Microsoft documentation.
DisplayError (inherited from ControlDesigner) | Select the method name to go to the Microsoft documentation.
Dispose (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
EnableDragDrop (inherited from ControlDesigner) | Select the method name to go to the Microsoft documentation.
Finalize (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
GetControl (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
GetHitTest (inherited from ControlDesigner) | Select the method name to go to the Microsoft documentation.
GetService (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
GetUpdatedRect (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
HookChildControls (inherited from ControlDesigner) | Select the method name to go to the Microsoft documentation.
InvokeGetInheritanceAttribute (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
MemberwiseClone (inherited from Object) | Select the method name to go to the Microsoft documentation.
OnContextMenu (inherited from ControlDesigner) | Select the method name to go to the Microsoft documentation.
OnCreateHandle (inherited from ControlDesigner) | Select the method name to go to the Microsoft documentation.
OnDragDrop | Attempts to host the control on the panel on which it was dropped.
OnDragEnter (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
OnDragLeave (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
OnDragOver (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
OnGiveFeedback (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
OnMouseDragBegin (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
OnMouseDragEnd (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
OnMouseDragMove (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
OnMouseEnter (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
OnMouseHover (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
OnMouseLeave (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
OnPaintAdornments (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
OnSetCursor (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
PostFilterAttributes (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
PostFilterEvents (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
PostFilterProperties (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
PreFilterAttributes (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
PreFilterEvents (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
PreFilterProperties (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
RaiseComponentChanged (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
RaiseComponentChanging (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
UnhookChildControls (inherited from ControlDesigner) | Select the method name to go to the Microsoft documentation.
WndProc (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.

Explicit Interface Implementations

IOleDragClient.AddComponent (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
ISelectionUIHandler.BeginDrag (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
ISelectionUIHandler.DragMoved (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
ISelectionUIHandler.EndDrag (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
ISelectionUIHandler.GetComponentBounds (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
ISelectionUIHandler.GetComponentRules (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
IOleDragClient.GetControlForComponent (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
IOleDragClient.GetDesignerControl (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
ISelectionUIHandler.GetSelectionClipRect (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
IOleDragClient.IsDropOk (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
ISelectionUIHandler.OleDragDrop (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
ISelectionUIHandler.OleDragEnter (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
ISelectionUIHandler.OleDragLeave (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
ISelectionUIHandler.OleDragOver (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
ISelectionUIHandler.OnSelectionDoubleClick (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
IDesignerFilter.PostFilterAttributes (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
IDesignerFilter.PostFilterEvents (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
IDesignerFilter.PostFilterProperties (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
IDesignerFilter.PreFilterAttributes (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
IDesignerFilter.PreFilterEvents (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
IDesignerFilter.PreFilterProperties (inherited from ComponentDesigner) | Select the method name to go to the Microsoft documentation.
ISelectionUIHandler.QueryBeginDrag (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.
ISelectionUIHandler.ShowContextMenu (inherited from ParentControlDesigner) | Select the method name to go to the Microsoft documentation.

See Also

ContainerStatusBarDesigner Class | Genghis.Windows.Forms.Design Namespace


ContainerStatusBarDesigner.CreateToolCore Method

[Visual Basic]
Overrides Protected Function CreateToolCore( _
   ByVal tool As System.Drawing.Design.ToolboxItem, _
   ByVal x As Integer, _
   ByVal y As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal hasLocation As Boolean, _
   ByVal hasSize As Boolean _
) As System.ComponentModel.IComponent()
[C#]
protected override IComponent[] CreateToolCore(
   ToolboxItem tool,
   int x,
   int y,
   int width,
   int height,
   bool hasLocation,
   bool hasSize
);

See Also

ContainerStatusBarDesigner Class | ContainerStatusBarDesigner Members | Genghis.Windows.Forms.Design Namespace


ContainerStatusBarDesigner.Initialize Method

Prepares the designer to view, edit, and design ContainerStatusBar

[Visual Basic]
Overrides Public Sub Initialize( _
   ByVal component As System.ComponentModel.IComponent _
)
[C#]
public override void Initialize(
   IComponent component
);

Parameters

component
The component being designed. This should be a ContainerStatusBar, but no checks are made for this. if this designer is used on another control, not inherited from ContainerStatusBar, it will crash.

See Also

ContainerStatusBarDesigner Class | ContainerStatusBarDesigner Members | Genghis.Windows.Forms.Design Namespace


ContainerStatusBarDesigner.OnDragDrop Method

Attempts to host the control on the panel on which it was dropped.

[Visual Basic]
Overrides Protected Sub OnDragDrop( _
   ByVal e As System.Windows.Forms.DragEventArgs _
)
[C#]
protected override void OnDragDrop(
   DragEventArgs e
);

Parameters

e

See Also

ContainerStatusBarDesigner Class | ContainerStatusBarDesigner Members | Genghis.Windows.Forms.Design Namespace


Genghis.DiagnosticsHierarchy

Genghis Class Library

Genghis.Diagnostics Hierarchy

System.Object
-TraceEx


Genghis.WebHierarchy

Genghis Class Library

Genghis.Web Hierarchy

System.Object
-WebCommandLineHelper


Genghis.Win32Hierarchy

Genghis Class Library

Genghis.Win32 Hierarchy

System.Object
-MappedDriveMap
-MappedDriveMapEnumerator
-MappedDrives
-ManagementSystemProperties
-NetworkConnectionCollection
-NetworkConnectionEnumerator
-ManagementSystemProperties
-ShareCollection
-ShareEnumerator
-ShareMap
-ShareMapEnumerator
-SystemShares
-TypeConverter
-WMIValueTypeConverter
-ReferenceConverter
-ValidationControlConverter
-WMIValueTypeConverter

Interfaces

Win32NetworkConnectionList.IWin32NetworkConnectionListEnumerator
Win32ShareList.IWin32ShareListEnumerator


Genghis.Windows.Forms.DesignHierarchy

Genghis Class Library

Genghis.Windows.Forms.Design Hierarchy

System.Object
-ComponentDesigner
-ControlDesigner
-ParentControlDesigner
-ContainerStatusBarDesigner


Genghis.Windows.FormsHierarchy

Genghis Class Library

Genghis.Windows.Forms Hierarchy

System.Object
-BaseValidatorCollection
-StatusBarPanelCollection
-CursorChanger
-Exception
-ApplicationException
-UsageException
-HandleTypeNotRegisteredException
-WindowsFormsNotInitializedException
-FindReplace
-FormValidatorCollection
-HandleCollector
-RegisteredHandleType
-ListViewSorter
-MarshalByRefObject
-Component
-BaseValidator
-BaseCompareValidator
-CompareValidator
-RangeValidator
-RegularExpressionValidator
-RequiredFieldValidator
-Control
-GroupBox
-HeaderGroupBox
-ListControl
-ComboBox
-CompletionCombo
-ImageCombo
-ScrollableControl
-ContainerControl
-Form
-ScreenSaver
-WizardSheet
-UserControl
-WizardPage
-StatusBar
-ContainerStatusBar
-TreeView
-CustomStateTreeView
-FileDocument
-FindReplaceDialog
-FormValidator
-Menu
-MenuItem
-MRUMenuItem
-MRU
-StatusBarPanel
-ContainerStatusBarPanel
-WindowSerializer
-MRUStringCollectionEnumerator
-TypeConverter
-WMIValueTypeConverter
-ReferenceConverter
-ValidationControlConverter
-WMIValueTypeConverter
-UITypeEditor
-FolderNameEditor
-FolderNameDialog

Interfaces

BaseValidatorCollection.IBaseValidatorCollectionEnumerator
FormValidatorCollection.IFormValidatorCollectionEnumerator


GenghisHierarchy

Genghis Class Library

Genghis Hierarchy

System.Object
-Attribute
-ParserUsageAttribute
-UsageAttribute
-FlagUsageAttribute
-NoUsageAttribute
-ValueUsageAttribute
-UsageAttribute
-FlagUsageAttribute
-NoUsageAttribute
-ValueUsageAttribute
-CommandLineParser
-CurrentDir
-MemberInfoUsage
-EventArgs
-PathResolverEventArgs
-Exception
-ApplicationException
-UsageException
-HandleTypeNotRegisteredException
-WindowsFormsNotInitializedException
-PathList
-PathResolver
-Preferences
-ResolvedPathList
-ResolvedPathListEnumerator

Interfaces

IPathResolver
IPublicDictionary
IResolvedPathList
PathList.IPathListEnumerator